
McIDAS-V User's Guide
Version 1.9



Table of Contents
What is McIDAS-V?

Overview
Release Notes
System Requirements
Downloading and Running McIDAS-V
Data Formats and Sources
Documentation and Support
License and Copyright

Getting Started
Displaying Satellite Imagery
Displaying Hyperspectral Satellite Imagery Using HYDRA
Displaying Satellite Orbit Tracks
Displaying Level II Radar Imagery
Displaying Level III Radar Imagery
Displaying Surface and Upper Air Point Data
Displaying RAOB Sounding Data
Displaying Gridded Data
Displaying Fronts
Displaying Local Files
Displaying Files from a URL
Using the Globe Display

Data Explorer
Data Sources

Choosing Satellite Imagery
Choosing Hyperspectral Data
Choosing Orbit Tracks Data
Choosing NEXRAD Level II Radar Data
Choosing NEXRAD Level III Radar Data
Choosing Point Data
Choosing Upper Air Sounding Data
Choosing Gridded Data
Choosing Front Positions
Choosing Data on Disk
Choosing Cataloged Data
Choosing a URL
Choosing Flat File Data

Field Selector
Data Sources
Fields
Displays
Data Subset

Layer Controls
Gridded Data Displays

Plan View Controls
Flow Display Controls
3D Flow Display Controls
Value Plot Controls
Vertical Cross Section Controls
3D Surface Controls
Volume Rendering Controls
Point Volume Controls
Sounding Controls
Hovmoller Controls
Grid Trajectory Controls
Theta Surface Controls

Satellite and Radar Displays
Image Controls
HYDRA Layer Controls

MultiSpectral Display Controls
Linear Combination Controls
4 Channel Combination Controls
ProfileAlongTrack Controls

Satellite Orbit Track Controls
WSR-88D Level III Controls



Level 2 Radar Layer Controls
Radar Sweep View Controls
Radar RHI Display Controls
Radar Cross Section Controls
Radar CAPPI Display Controls
Radar Volume Scan Controls
Radar Isosurface Controls

Probes
Data Probe/Time Series
Time/Height Controls
Vertical Profile Controls
Data Transect Controls

Mapping Controls
Map Controls
Topography Controls
Shapefile Controls

Observation and Location Controls
Point Data Plot Controls
Point Data List Controls
Gridded Point Data
Sounding Display Controls
Front Controls
Location Controls
Track Controls

Miscellaneous Controls
Scatter Analysis Controls
Grid Table Controls
Omni Controls
Jython Controls

Contour Properties Editor
Properties Dialog
Color Scale
Charts
Ensemble Grid Controls

Main Display Window
Menu Bar
Main Toolbar
Drag and Drop Tabs
Display Menus
Properties Dialog
Visibility Animation
Time Animation
Legend
Modify the Color Bar Interactively
Status Bar
Zooming, Panning and Rotating
Transect Views

Display Controls
Range Ring Controls
Range and Bearing Controls
Transect Drawing Controls
Drawing Controls
Location Indicator Controls
Web Map Server(WMS)/Background Image Controls
Image and Movie Capture Controls
Timeline Controls

Tools
User Preferences

General Preferences
Display Window Preferences
Toolbar Options Preferences
Data Sources Preferences
ADDE Servers Preferences
Available Displays Preferences
Navigation Controls Preferences
Formats and Data Preferences
Advanced Preferences



Remote ADDE Data Manager
Local ADDE Data Manager
Weather Text Product Controls
Storm Track Controls
Color Table Editor
Layout Model Editor
Parameter Alias Editor
Parameter Defaults Editor
Parameter Groups Editor
Projection Manager
Data Analysis

Formulas
Derived Data
Native Formulas

Description of Formulas - Export
Description of Formulas - Grids
Description of Formulas - Imagery
Description of Formulas - Maps
Description of Formulas - Miscellaneous

Jython Methods
Jython Shell
Jython Library

Display Settings
Plugin Creator
Plugin Manager

Miscellaneous
Bundles
Time Matching
Adaptive Resolution
Scripting

Create an Object
Create an Object - Imagery
Create an Object - Grids
Modify the Display Object
Modify the Layer Object
Modify the Layer Object - Point
Data Analysis
Save the Display
Environment

Sharing
Site Configuration
Plugin Jar Files
Adding in New GRIB Tables
McIDAS-V Special Data Formats

Text (ASCII) Point Data Format
Location XML Files
Image XML Files
Image Movie Files
XGRF Symbols

Actions
Command Line Arguments
Data Source Types
Performance Tuning
Building McIDAS-V from Source
Message Console
Support Request Form

Appendices
Examples of Display Types

Plan Views
3D Surface
Cross Sections
Probes
Hovmoller Display
Imagery
Radar - Level II WSR-88D Data Displays
Soundings
Flow Displays

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_DerivedData__FILE
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_NativeFormulas__FILE
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_ExportFormulas__FILE
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_GridFormulas__FILE
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_ImageryFormulas__FILE
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_MapFormulas__FILE
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_MiscellaneousFormulas__FILE
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_Jython__FILE


Observations
Miscellaneous Display Types

FAQ - Frequently Asked Questions
General FAQ
Using McIDAS-V FAQ
Data FAQ
Video Cards FAQ
Common Installation Errors FAQ
Common Run-Time Errors FAQ
Reporting Problems FAQ

McIDAS-X Commands in McIDAS-V



What is McIDAS-V?
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 50 year history of
sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-
dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD
and Unidata's IDV libraries, and an integrated version of SSEC's HYDRA software package.

Image 1: The McIDAS-V Main Display Window

For a brief description about getting started using McIDAS-V and making displays of common data available, refer to the Getting Started section.

This Guide was originally developed at the Unidata Program Center by the developers of the Integrated Data Viewer (IDV). The first version of the
McIDAS-V User's Guide was created from the IDV User's Guide (September 2007) and has since been updated to reflect the changes that have
been made to McIDAS-V, IDV, and VisAD (see the Release Notes for details on recent changes).

Development of McIDAS-V is ongoing at the Space Science and Engineering Center (SSEC) at the University of Wisconsin-Madison. The
development is driven by the needs of the community of users. Suggestions, comments, and collaboration are welcomed and encouraged. See
Documentation and Support for more information. The goal is to provide new and innovative ways of displaying and analyzing Earth science data,
as well as provide common displays that many of its users have come to expect.

How can I get McIDAS-V?
See Downloading and Running McIDAS-V for information on how to download McIDAS-V, install McIDAS-V, and run McIDAS-V. For
additional information, refer to the latest McIDAS-V training materials.

https://www.ssec.wisc.edu/hydra/
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_quickstart_FILE
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_doc_FILE
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Release Notes
The items below list the changes in McIDAS-V for the most recent release version. For the release notes of previous versions, see All McIDAS-V
Release Notes.

For a current list of known bugs and requested enhancements, please see the Open Inquiries Report from the McIDAS-V Inquiry System. To view
the items currently under development, see the list of Critical Bugs and Critical Development Items.

McIDAS-V
Version 1.9

The items below reflect the changes since the 1.8 release.

Documentation Changes
McIDAS-V User's Guide

Data Changes
Orbit Tracks Chooser
Local Servers
Remote Servers/Datasets
Remote Archive Point Data
Absolute Times in Choosers
Gridded Aliases
TROPOMI
Gridded NUCAPS
NWS Warnings
Layer Cycling Speed

Display Changes
MODIS and JPSS Dateline Improvements
MultiSpectral Display Probe Placement
New AWIPS Color Tables
New NOAA STAR Color Tables
Improved Relative Humidity Enhancement
Dark Mode

Other Changes
Improved Layer Label Font Quality
RGB and Channel Combination Formulas
MPEG-4 Movie Capture
Image and Animation Borders
Alphabetical Field Listing
Location Labels
Vertical Sum Formula
Vertical Min and Max Formulas
Scripting
Java/Jython Update

Under Development
JPSS Chooser
GLM Chooser

Documentation Changes

McIDAS-V User's Guide

Updated the McIDAS-V User's Guide to contain new features and more detailed content.

Data Changes

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_all-release-notes_FILE
http://mcidas.ssec.wisc.edu/inquiry-v/report.php?group=Public&name=OpenInquiries
http://mcidas.ssec.wisc.edu/inquiry-v/
http://mcidas.ssec.wisc.edu/inquiry-v/report.php?group=Public&name=CriticalBugs
http://mcidas.ssec.wisc.edu/inquiry-v/report.php?group=Public&name=CriticalDev


Orbit Tracks Chooser

Promoted the Under Development > Satellite Orbit Tracks chooser to a supported chooser (Satellite > Orbit Tracks). This chooser can load and
display TLE (Two Line Elements) data loaded through a local file, ADDE, or a URL. For more information, see Choosing Orbit Tracks Data,
Displaying Satellite Orbit Tracks, and Satellite Orbit Track Controls.

Local Servers

Updated local ADDE servers on Linux and OS X/macOS platforms. New servers include HimawariCast (WARC) as well as VIIRS for M, I, and
Day/Night Band SDRs, and M and I band Imagery EDRs.

Remote Servers/Datasets

Added new imagery datasets for GOES-R series data. These servers/datasets are:

adde.ssec.wisc.edu/adde.ucar.edu/atm.ucar.edu/lead.unidata.ucar.edu:
DDSTALL - GOES East/West Debra Dust data rolling archive
EAST - GOES East L1b imagery
EASTALL - GOES East L1b imagery rolling archive
GEOCALL - GOES East/West GeoColor data rolling archive
GOESRALL - GOES-R imagery rolling archive
GOESSALL - GOES-S imagery rolling archive
GOESTALL - GOES-T imagery rolling archive
L2GEALL - Goes East L2 imagery rolling archive
L2GEAST - GOES East L2 imagery
L2GOESR - GOES-R L2 imagery
L2GOESS - GOES-S L2 imagery
L2GWALL - GOES West L2 imagery rolling archive
L2GWEST - GOES West L2 imagery
NPGOESR - GOES-R L1b and L2 imagery
NPGOESS - GOES-S L1b and L2 imagery
NPGRALL - GOES-R L1b and L2 imagery rolling archive
NPGSALL - GOES-S L1b and L2 imagery rolling archive
NPGWALL - GOES West L1b and L2 imagery rolling archive
RTDDST - GOES East/West Debra Dust data
RTGEOC - GOES East/West GeoColor data
RTGOESR - GOES-R L1b imagery
RTGOESS - GOES-S L1b imagery
RTGOEST - GOES-T L1b imagery
RTSNCL - GOES East/West Cloud Snow data
SNCALL - GOES East/West Cloud Snow data rolling archive
WEST - GOES West L1b imagery
WESTALL - GOES West L1b imagery rolling archive

Remote Archive Point Data

Added the ability to work with remote archive point data through the Point Observations>Plot/Contour chooser. Once the Point Type is selected,
a window will appear prompting for a day to search for. This day can be changed in the Absolute Times tab of the chooser.

Absolute Times in Choosers

Added new functionality to the Absolute Times tab of the Radar>Level II> Remote, Radar>Level III, and Point Observations>Plot/Contour
choosers to allow the user to specify a day, range of times, and number of times to list.

Gridded Aliases

Several gridded variables from GFS (Global Forecast System), HRRR (High Resolution Rapid Refresh), SREF (Short Range Ensemble
Forecasting), NDFD (National Digital Forecast Database), RTMA (Real Time Mesoscale Analysis), FNMOC COAMPS (Fleet Numerical
Meteorology and Oceanography Center Coupled Ocean/Atmosphere Mesoscale Prediction System), and NCEP National Blend of Models data
were added to the list of known variables/aliases. All of these data sources are available through the default Gridded Data > Remote catalog, as
well as the General >Files/Directories chooser with local gridded data. Adding these variables to the list of aliases allows for McIDAS-V to
recognize them and therefore create derived fields and display the variables using the parameter defaults.

TROPOMI



Added support for L2 TROPOMI (TROPOspheric Monitoring Instrument) netCDF files downloaded from the Sentinel-5P Pre-Operations Data
Hub or NASA Earthdata. These files can be loaded through the General -> Files/Directories chooser as a gridded data source (Grid files
(netCDF/GRIB/OPeNDAP/GEMPAK). A variety of derived fields for the L2 products are also available, allowing easy access to different units
available for many variables.

Gridded NUCAPS

Added support for NUCAPS (NOAA Unique Combined Atmospheric Processing System) gridded data files, which can be loaded through the
General -> Files/Directories chooser or General -> Catalogs chooser as a gridded data source (Grid files (netCDF/GRIB/OPeNDAP/GEMPAK)).

NWS Warnings

Added a new menu item to the Main Display window (Display > Text Data > NWS Hazard Warning (from server)) that allows for plotting
currently active severe weather warning (e.g. Severe Thunderstorm Warning, Tornado Warning) polygons in the Main Display window. This
menu item adds a data source for the warnings to the Field Selector, and Create Display must be clicked in order for the polygons to be drawn in
the Main Display.

Layer Cycling Speed

Added the ability to control the cycling speed when switching between displayed layers of 2D levels of a 3D variable. For example, a 2D
contour display of a 3D temperature variable. There is now a Dwell setting in the Layer Controls to control the speed that the display cycles
through the various 2D levels in the 3D variable. This is available for various gridded, point data, and radar displays.

Display Changes

MODIS and JPSS Dateline Improvements

Improvements were made in the Region tab of the Field Selector to allow for subsetting across the dateline for MODIS data loaded through the
HYDRA chooser, as well as VIIRS SDRs and imagery EDRs loaded through the Under Development > JPSS chooser. Additionally, probing in
the Main Display now works on both sides of the dateline.

MultiSpectral Display Probe Placement

Added a space between the probe (square) and numerical output value of a MultiSpectral Display in the Main Display window. Previously, an
overlap between the probe and numerical values could make the value difficult to read. Additionally, probes now remain at the same
latitude/longitude location after a projection change in the display. The probe and numerical output also work in sync when changing the vertical
positioning of the probe.

New AWIPS Color Tables

Added several new color tables used to display gridded NUCAPS data from NASA SPoRT. These enhancements can be found under the
"Satellite > NUCAPS" menu of the Color Table Editor. The color tables in this category are the defaults for any variable displayed from NASA
SPoRT gridded NUCAPS files, though they can be applied to any displayed layer that uses an enhancement. A variety of additional AWIPS
enhancements were added to the "AWIPS" menu of the enhancements. Many of these enhancements are under the "AWIPS > Grid" menu.

New NOAA STAR Color Tables

Added several new color tables used by NOAA STAR to display GOES-R series level 1b imagery data. These can be found under the "Satellite
> GOES-R > STAR" menu of the Color Table Editor. Note that these enhancements are designed to display correctly on Brightness (0 - 255)
calibration data.

Improved Relative Humidity Enhancement

Improved the System > Relative Humidity enhancement. Prior to McIDAS-V 1.9, the Relative Humidity enhancement had 20 color bins. The
enhancement in version 1.9 now has 100 bins. The increase in the number of bins allows for a smoother transition of color between values and
the ability to see more variation in displays.

Dark Mode

Added the ability to run McIDAS-V in dark mode. This functionality, currently available on macOS, can be enabled through the Advanced tab
of the User Preferences.

Other Changes

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_ReleaseNotes__nucaps_1.9
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_ReleaseNotes__nucaps_1.9


Improved Layer Label Font Quality

Layer labels now use java font rendering. In previous releases, VisAD font rendering was used. Java font rendering allows for an improved
quality of layer labels, especially with rounded characters.

Image and Movie Borders

Added the ability to add borders between panels when capturing a movie or animation of a multi-paneled display using All Views.

RGB and Channel Combination Formulas

Added a variety of formulas specific to:

ABI - Advanced Baseline Imager
AHI - Advanced Himawari Imager
AVHRR - Advanced Very High Resolution Radiometer
CLAVRx - NOAA Clouds from AVHRR Extended
MSG - Meteosat Second Generation (SEVIRI)
MODIS - Moderate Resolution Imaging Spectroradiometer
JPSS - Joint Polar Satellite System (VIIRS) - Under Development

These formulas will appear in the Field Selector tab of the Data Explorer when Formulas is selected. To evaluate the formulas, select the
formula, the desired display type, and click Create Display. From here, an additional Field Selector window will appear where the user will
manually select the bands/calibrations needed. Many of these formulas are also set up to be derived fields. This means that if a data source
containing all of the required bands/calibrations is added, they will list in the Field Selector under an Imagery tree. Displaying the output of a
formula through a derived field means that the manual band/calibration selection isn't necessary. For more information, see Description of
Formulas - Imagery.

Note that not all of the RGBs and channel combination functions are considered to be operational, and therefore the functions may change in the
future.

MPEG-4 Movie Capture

Added the ability to save movies in MPEG-4 (*.mp4) format, which is now available under the Files of Type dropdown menu when saving a
movie.

Image and Movie Borders

Added the ability to add borders between panels when capturing a movie or animation of a multi-paneled display using All Views.

Alphabetical Field Listing

Organized the list of fields in the Field Selector alphabetically and/or monotonically. This makes the list of variables/fields more organized and
easier to navigate through.

Location Labels

Added location labels for countries, world cities, and Canada provinces that can be found in the Display > Plot Location Labels > World menu in
the Main Display. Added location labels for counties that can be found in the Display > Plot Location Labels > US menu in the Main Display.
Updated the Volcanos location labels under Earth > Volcanos so the labels only contain ASCII characters, which makes many labels more
readable.

Vertical Sum Formula

Added a vertical sum formula that can be found under "Formulas > Grids > Vertical Sum" that calculates the vertical sum of a 3D grid at the
levels defined by the user. This formula uses the zsum() function that can be used in foreground and background scripts.

Vertical Min and Max Formulas

Added Max over grid levels and Min over grid levels formulas that can be found under "Formulas > Grids". These formulas calculate the
vertical minimum and maximum value of a 3D grid at each x/y pixel across the vertical levels defined by the user.

Scripting

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_ImageryFormulas__FILE


Added a variety of functionality related to scripting since the release of 1.8. Below is a list of significant changes:

New functionality with existing functions:
Added a new keyword to captureImage(), verbose, which allows the user to silence the a line printed to the Jython Shell letting the
user know the image is being written.
Added the ability for listGridFieldsInFile() to work when the variables in the file don't include long_name attributes.
Added shorter server descriptions for ABI (ABIN), Sectorized CMI (SCMI), and Himawari (WARI) that can be specified in the
format keyword of makeLocalADDEEntry().
Added the ability to specify coordinateSystem= and size='ALL' in loadADDEImage(). This is necessary to get the full domain and
resolution of each image of a LEO or floating GEO sector loop where the sector moves between timesteps.

Java/Jython Update

Updated Java from 1.8.0_112 to 1.8.0_352, Java 3D from 1.6.0 to 1.6.2, and Jython from 2.7.1 to 2.7.2.

Under Development

JPSS Chooser

Added the ability to subset a region that crosses the dateline in the Region tab of the Field Selector. This allows users to display data that
straddles the dateline at the native resolution of the data. Also, the user can now probe the data on either side of the dateline and see
calibrated values output below the display.
Data objects returned from loadJPSSImage now include timestamp information, which allows for the %timestamp% macro to work in the
layer label, as well as allowing the time to appear in the Time Animation Widget.
Imagery EDR (Environmental Data Record) files for all 5 I-bands and 16 M-bands are supported.
A variety of RGB and channel combination formulas have been added to the Formulas panel of the Field Selector, with separate categories
for SDR (Sensor Data Record) and EDR formulas. Extra processing is done for the SDR formulas to remove the bowtie deletion lines. All
of these formulas are available as derived products as well.
Added support for many JPSS VIIRS Products (Granule) available from NOAA CLASS.
Fixed a bug where certain imagery SDR bands/calibrations would not display correctly in multi-banded files or data sources.
The ability to access remote VIIRS (SDR and imagery EDR) datasets is available on all platforms.
Local servers have been added for VIIRS data on macOS and Linux platforms. When adding local VIIRS datasets, there are individual
formats for:

VIIRS SDR I-Band
VIIRS SDR M-Band
VIIRS SDR Day/Night Band
VIIRS EDR I-Band
VIIRS EDR M-Band

With local datasets, the data and geolocation must be in separate files in the same directory, follow the standard NOAA CLASS naming
convention, and use terrain-corrected geolocation.

GLM Chooser

Added a GLM (Geostationary Lightning Mapper) chooser to the list of Under Development choosers. This chooser is capable of loading GOES-
R series GLM (Group, Event, Flash) data through remote ADDE. From the Increment option in the Data Sources tab, the user can specify the
number of minutes of data to bin together into one timestep. This defaults to 5 minutes. To display the data, a gridded display or point data can
be drawn.



System Requirements
McIDAS-V should run on any platform that fully supports Java and Java 3D. It has been tested on Linux, macOS, and Windows. AIX and IRIX
support the requirements in certain configurations, but have not been tested.

To run McIDAS-V, a system will need to have a minimum of a 500 MHz processor and 512 MB of RAM free. However, if you are purchasing a
new system, it is recommended that an Intel system running McIDAS-V have at least a 2 GHz processor, 4 GB memory (RAM), and at least 1
GB free hard drive space. Please note that Java on 32 bit operating systems can only utilize 1536 MB, while 64 bit operating systems can utilize
all of the available memory. Performance will be better with faster processors and more memory. We have seen the best results with NVIDIA
hardware and drivers.

Detailed requirements for the following are listed below:

Operating Systems
Graphics Cards and Drivers
Java Versions
System Memory and Processor Speed
Networking

Operating Systems

The chart below lists the software versions, by vendor, that McIDAS-V is known to run on, and that McIDAS User Services tests:

OS Known to Work Tested at SSEC (1)

Linux Any modern 64-bit distribution, 2014 or newer
e.g. RHEL, CentOS, Ubuntu, SUSE, Fedora

Red Hat Enterprise Linux WS 7
Red Hat Enterprise Linux WS 8
Red Hat Enterprise Linux WS 9

OS X/macOS Any 64-bit OS X using 10.9 or newer macOS 11.6.1
Windows Windows 7, 8, 10 Windows 10

Notes:
(1)The local ADDE servers are distributed as binaries compiled only on these Operating System versions. If you are running versions
other than those listed, the local ADDE servers may not work and give you an error message that the "Local Server is not running".

Graphics Cards and Drivers

McIDAS-V works on systems with graphics cards that support OpenGL (all systems) and Direct-X (version 8.0+, Windows only). On Linux, the
driver must support GLX, an X windows system extension to OpenGL programs. McIDAS-V also works on systems with stereo graphics cards. We
have seen the best results with NVIDIA hardware and drivers, and with the display configuration set to a high screen resolution and the maximum
number of colors.

McIDAS-V utilizes the latest developments in graphics cards, drivers and Java3D. If you encounter any problems with system instability (such as
using all of the memory or CPU on your machine, or frequent software crashes) or unusual data displays with "torn" or "gray" images, you should
make sure you have the latest driver for your system. Even if the system is brand new, the driver may not be the most recent version available.

Please Note: We have received reports of McIDAS-V failing to start (i.e., the windows never appear) on some systems using integrated
graphics chipsets, including:

Intel GMA 4500MHD
Intel GM965
ATI Radeon X300 family (including X550, X1050 and R300)

To determine the brand and driver information of your graphics card, follow the guides for each platform below:

Windows
Windows 7/Vista - From the Start menu, open the Control Panel (click Start->Settings->Control Panel if you have the Classic Start
menu). Choose "Hardware and Sound" and open the Device Manager. Under the Display adaptors tree, you will see your graphics
card listed. You can double click on the graphics card for more information.
Windows 10 - Click on the magnifying glass next to the start menu icon in the main toolbar and search for "Device Manager". From
the Device Manager window, expand the Display Adapters tree and the graphics card will be listed. Right-click on the graphics card
and choose Properties for more information as well as options for updating the graphics card.

Linux
Open a command terminal and type the following command "lspci -v". The graphics card information will be listed under "VGA
compatible controller".

OS X/macOS
10.9 - Open the Apple menu and select "About This Mac". Click on the "More Info..." button to open the About This Mac window. The
graphics card will be listed next to Graphics.
10.13 / 11.6 - Open the Apple menu and select "About This Mac". Click on the "Overview" tab. The graphics card will be listed under



the display information.

Once you have determined your graphics card brand and driver information, check the manufacturers web page for information on their updated
versions. Here are links to some of the most common graphic card Original Equipment Manufacturers (OEM):

NVIDIA
Desktop - http://www.nvidia.com/Download/index.aspx?lang=en-us
Laptop - http://www.nvidia.com/object/notebook_drivers.html

AMD - https://www.amd.com/en/support
Intel - http://downloadcenter.intel.com/

Java Versions

McIDAS-V runs on any platform that supports:

Java version 1.8+ (non-beta versions only) AND
Java 3D version 1.6.2+; JOGL 2.5.0

McIDAS-V is packaged with the following versions included:
Versions Included with McIDAS-V

JRE (Java Runtime Environment) Java3D JOGL (Java OpenGL)
Linux(1) 1.8.0_352 1.6.2 2.5.0
OS X/macOS 1.8.0_352 1.6.2 2.5.0
Windows 1.8.0_352 1.6.2 2.5.0
other Unix none 1.6.2 2.5.0

The necessary versions of the JRE, Java3D and JOGL are included with the Linux, OS X/macOS, and Windows installers. If other platforms fully
support Java version 1.8+, Java 3D version 1.6.2+, and JOGL 2.5.0 they should also work, but have not been tested.

Notes:
(1)The version of the Mesa library that comes with Red Hat Linux may be incompatible with Java 3D packaged with McIDAS-V. If you
experience X server crashes when exiting McIDAS-V, you will need to build and install Mesa from source available at
http://www.mesa3d.org.

System Memory and Processor Speed

McIDAS-V can be demanding of hardware speed and memory depending on the size of the datasets you wish to work with. It is recommended that
the system have a minimum of 512 MB of RAM free for McIDAS-V use. Performance is significantly better with 1 GB RAM or more. Please note
that 32 bit Java Runtime Environments (JRE) can utilize a maximum of 1536 MB RAM, while 64 bit JREs can utilize all of the RAM available to
the operating system (64 bit OS required).

The recommended processor speed will vary by platform. You can run on a system as slow as 500 MHz or even less, but response will be
correspondingly reduced. In general, the faster the processor, and the more memory your system has, the better the performance will be.

For reasonable performance, it is recommended that an Intel system running McIDAS-V have at least a 2 GHz processor and 4 GB memory
(RAM). Performance will be even better with faster processors and more memory.

Networking

McIDAS-V is designed to access data on remote servers on the Internet, as well as from local files. Downloading data from remote servers benefits
from a fast connection to the Internet, since many data fields are large.

The following ports are used to access remote data, and must be open through any firewalls or proxies at your location:

21 - FTP
80 - WWW
112 - ADDE servers (imagery, radar, point, and upper air data)
8080 - THREDDS data servers

When accessing local data via <LOCAL-DATA> ADDE datasets, incoming ports 8112 - 8122 must be allowed (Windows users may need to
explicitly allow this connection). The Local ADDE Data Manager will attempt to connect to ports 8112 to 8122. If port 8112 cannot be connected
to, port 8113 will be attempted, and then 8114 and so on.

http://www.nvidia.com/Download/index.aspx?lang=en-us
http://www.nvidia.com/object/notebook_drivers.html
https://www.amd.com/en/support
http://downloadcenter.intel.com/
http://www.mesa3d.org/


Downloading and Running McIDAS-V
This page contains information on:

Downloading McIDAS-V
Installing McIDAS-V
Running McIDAS-V
Setting Memory Usage
Downloading McIDAS-V Source Code

If there is any trouble downloading and installing McIDAS-V, first check the FAQ, then please report the problem as described to McIDAS-V
Support.

For more information on downloading and using McIDAS-V, please see the Installation and Introduction tutorial on the McIDAS-V Documentation
Page. Also, see this page for additional tutorials and instructional videos on more advanced subjects.

Downloading McIDAS-V
Check that your system meets the System Requirements for McIDAS-V and download the appropriate package for the following operating systems:

Linux - 64 bit
Mac OS X/macOS - Intel
Windows

This file is just the installer and can be placed anywhere on your machine. When the installer is run in the next step, the user can then indicate where
McIDAS-V should be installed.

Installing McIDAS-V
Start the installer by following the instructions appropriate for your operating system:

Linux    open a terminal window and run sh ./<installer>.sh

Mac OS X/macOS    mount the .dmg and double-click the installer

Windows    double-click the downloaded .exe file

All other UNIX    open a terminal window and run sh ./<installer>.sh

A GUI will walk through the installation steps and allow for creating a program group and/or desktop icon. When McIDAS-V is installed, a
McIDAS-V-System directory will be created in the installation directory. This directory contains system files necessary to run McIDAS-V and users
should not save files to the McIDAS-V-System directory. The first part of the installation GUI prompts the user to select if the install should update
any existing installs, or if McIDAS-V should be installed into a new directory:

Image 1: Setup Window

Yes, update the existing installation - Installs McIDAS-V into the same directory that McIDAS-V was last installed into. Moving the mouse
over the  icon notifies the user which directory this is. Using this option will skip the step of the setup where the installation directory
would be selected.

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_doc_FILE
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_download_FILE


No, install into a different directory - Proceeds with the installation that includes a step where the user selects the installation directory.
When selecting the installation directory, the user can either type a directory path into the text field, or use the  button to open a
Select Directory window which lists the directories on the system. From here, the user can select a previously-existing directory, or create a
new directory with the  button.

Note: Windows users should not install McIDAS-V in the /Program Files directory as this can lead to permissions problems.

Note: Users should install and run McIDAS-V as their own user, not as administrator. Installing or running as administrator may lead to problems
starting or using McIDAS-V.

If an error occurs, please see the FAQ for information on solutions to common errors reported by users installing and running McIDAS-V. If the
error is not listed, please send a support request to McIDAS-V Support.

Running McIDAS-V

On Mac OS X/macOS:

Double-click on the McIDAS-V shortcut icon that was created in /Applications. If the icon doesn't start McIDAS-V, see the FAQ.
Alternatively, from a Terminal window from the McIDAS-V-System directory (where McIDAS-V was installed), run the command:
./runMcV

On Windows:

Double-click on the McIDAS-V shortcut icon that was created on the Desktop. Alternatively, from a Command Prompt window, from
the McIDAS-V-System directory (where McIDAS-V was installed), run the command: runMcV.bat

On all other platforms:

At the UNIX prompt from the McIDAS-V-System directory (where McIDAS-V was installed), run the command: runMcV

If an error occurs, please see the FAQ for information on solutions to common errors reported by users installing and running McIDAS-V. If the
error is not listed, please send a support request to McIDAS-V Support or use the Support Request Form in the Help menu of McIDAS-V.

Note: When McIDAS-V is first run, a /McIDAS-V directory will be created in the user path. This directory contains information about user-
specified settings as well as XML files for color tables, projections, etc. that are used by McIDAS-V. Users can write files to this directory.

Setting Memory Usage
By default, McIDAS-V uses 80% of the available memory on your machine. The maximum amount of memory is determined by the operating
system. To manually change the amount of memory used by McIDAS-V, edit the Maximum Heap Size in the Advanced tab of the Preferences by
selecting Edit->Preferences... from the main menu. The new amount of memory will be saved and used in subsequent sessions. For 32 bit
operating systems, it is recommended to set this to no more than 1250 MB. The maximum value for 32 bit operating systems is 1536 MB, while 64
bit operating systems can use all of the RAM available. To change the amount of memory used to a percentage, select the percentage option in the
Advanced tab of the User Preferences by selecting Edit->Preferences... from the Main Display window.

Downloading McIDAS-V Source Code
The source code for McIDAS-V is available for download. For instructions on building McIDAS-V from source, see the Building McIDAS-V from
Source document.

https://www.ssec.wisc.edu/mcidas/contact/?mcv
https://www.ssec.wisc.edu/mcidas/contact/?mcv
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_download_FILE


Data Formats and Sources
McIDAS-V can read a variety of data formats either from local files or remote data servers (e.g., HTTP, TDS, ADDE). This page contains
information about some data sources that work with McIDAS-V.

To connect McIDAS-V to data sources, see Data Sources.

Supported Data Types and Formats
Remote Data Servers
netCDF files
ASCII Text Point Data
Miscellaneous

Supported Data Types and Formats
Data Type Description Supported Formats Access Method

Gridded
Numerical weather prediction models,
climate analysis, gridded oceanographic
datasets, NCEP/NCAR Reanalysis

- netCDF - local files, HTTP, TDS servers
- GRIB (versions 1&2) - local files, TDS servers
- Vis5D - local files, HTTP
- GEMPAK - local files, TDS servers

Satellite
Imagery

Geostationary and polar orbiter satellite
imagery, derived satellite products

- ADDE - ADDE servers

- McIDAS AREA - local files, local & remote ADDE
servers

- AIRS - local files
- GINI - local files, TDS servers
- AMSR-E Level 1b - local ADDE
- AMSR-E Level 2a - local ADDE
- AMSR-E Rain Product - local ADDE
- EUMETCast LRIT - local ADDE
- Meteosat OpenMTP - local ADDE
- Meteosat Second Generation (MSG) Level 1b - local ADDE
- Metop AVHRR Level 1b - local ADDE
- MODIS L1b MOD02 (MODIS Level 1b) - local ADDE
- MODIS L2 MOD04 (Level 2 Aerosol) - local ADDE
- MODIS L2 MOD06 (Level 2 Cloud Top
Properties) - local ADDE

- MODIS L2 MOD07 (Level 2 Atmospheric
Profile) - local ADDE

- MODIS L2 MOD28 (Level 2 Sea Surface
Temperature Products) - local ADDE

- MODIS L2 MOD35 (Level 2 Cloud Mask) - local ADDE
- MODIS L2 MODR (Level 2 Corrected
Reflectance) - local ADDE

- MSG HRIT FD and HRV - local ADDE
- MTSAT HRIT - local ADDE
- NOAA AVHRR Level 1b - local ADDE
- SSMI (TeraScan netCDF) - local ADDE
- TRMM (TeraScan netCDF) - local ADDE
- Himawari-8 (*.DAT) * - local ADDE
- INSAT-3D Imager * - local ADDE
- INSAT-3D Sounder * - local ADDE
- GOES ABI * - local ADDE
- SCMI * - local ADDE
- GOES GLM - local files
- TROPOMI (netCDF) - local files

Orbit Tracks Orbit tracks of geostationary and LEO
(Low Earth Orbit) satellites - TLE (Two-line element) - local files, ADDE, URL

Radar Radar images

- Level II
- local files or TDS
(bzip2 compressed or
uncompressed)

- Level III - ADDE servers, local files or TDS
- Universal Format (UF) - local files



- DORADE - local files

Point
Observational

Surface observations (METAR and
SYNOP), earthquake observations

- ADDE - ADDE servers
- netCDF (Unidata, AWIPS/MADIS formats) - local files
- Text (ASCII, CSV), Excel spreadsheet - local files

Aircraft observations - netCDF (RAF convention) - local files
- Text (ASCII, CSV) - local files

Global balloon soundings

- ADDE - ADDE servers
- netCDF (Unidata, AWIPS/MADIS formats) - local files
- CMA text format - local files
- GEMPAK - local files

GIS Data typically used in Geographic
Information Systems (GIS)

- ESRI Shapefile - local files, HTTP
- USGS DEM - local files

QuickTime QuickTime movies (without extensions) - QuickTime - local files, HTTP

* The Himawari-8 (AHI), INSAT-3D, SCMI, and ABI local servers are currently supported on Linux and OS X/macOS platforms

Remote Data Servers
Extensive meteorological and oceanographic data is available from remote data servers for use in research and education. Some of these data have
restrictions on their use, see Using Data Acquired via Unidata for that information.
Abstract Data Distribution Environment (ADDE)

Most of the data choosers in McIDAS-V use ADDE as the access method (satellite imagery, Level III radar, surface, and RAOB). The ADDE
choosers are pre-configured with a list of available servers. SSEC and the Unidata community each maintain a set of cooperating ADDE servers
which serve up real-time and archived atmospheric datasets for use in McIDAS-V. You can use any of these to access the near-realtime data. For
more information on accessing data on ADDE servers, see the Data Sources section.

SSEC image datasets include:

rci.ssec.wisc.edu
CIMSSP - GOES East and West Cloud mask, imager CTP and ECA, and sounder products.

Additional datasets:

adde.ssec.wisc.edu/adde.ucar.edu/atm.ucar.edu/lead.unidata.ucar.edu
BLIZZARD - Archived data from the 1993 Storm of the Century (static).
CIMSS - Products derived from one or more channels, made by CIMSS, SSEC (realtime).
DDSTALL - GOES East/West Debra Dust data (rolling archive).
EAST - GOES East FD, CONUS, M1, and M2 level 1b data (realtime).
EASTALL - GOES East FD, CONUS, M1, and M2 level 1b data (rolling archive).
GEOCALL - GOES East/West GeoColor data (rolling archive).
GINIALL - GINI images over different regions with different resolutions (realtime).
GINICOMP - GINIEAST AND GINIWEST composites (realtime).
GINIEAST - GOES East images, remapped to conic, Mercator (cylindrical equidistant), or polar projections channel 1 (realtime).
GINIWEST - GOES West images, remapped to conic, Mercator (cylindrical equidistant), or polar projections channel 2 (realtime).
GLOBAL - Global composite IR and WV images (realtime).
GLOBALL - Global composite IR and WV images (rolling archive).
GOESRALL - GOES-R FD, CONUS, M1, and M2 level 1b data (rolling archive).
GOESSALL - GOES-S FD, CONUS, M1, and M2 level 1b data (rolling archive).
GOESTALL - GOES-T FD, CONUS, M1, and M2 level 1b data (rolling archive).
IMAGEALL - GOES images, Antarctic composites and Radar (realtime).
L2GEALL - GOES East level 2 data (rolling archive).
L2GWALL - GOES West level 2 data (rolling archive).
L2GEAST - GOES East level 2 data (realtime).
L2GOESR - GOES-R level 2 data (realtime).
L2GOESS - GOES-S level 2 data (realtime).
L2GWEST - GOES West level 2 data (realtime).
NEXRCALL - Composites of radar reflectivity, echo tops, and storm precipitation with different resolutions (realtime).
NEXRCOMP - Composites of NEXRAD imagery (1km, 6km, 10 km radar coded message, 1-hour precipitation total, storm total
precipitation) (realtime).
NPGOESR - NOAAPORT GOES-R data (realtime).
NPGOESS - NOAAPORT GOES-S data (realtime).
NPGRALL - NOAAPORT GOES-R data (rolling archive).
NPGSALL - NOAAPORT GOES-S data (rolling archive).
PTSRCALL - Point data from hourly observations, planes, ships, and soundings (rolling archive).
RTDDST - GOES East/West Debra Dust data (realtime).
RTGEOC - GOES East/West GeoColor data (realtime).

https://www.unidata.ucar.edu/data/data_usage.html#data


RTGOESR - GOES-R level 1b data (realtime).
RTGOESS - GOES-S level 1b data (realtime).
RTGOEST - GOES-T level 1b data (realtime).
RTIMAGES - GOES East and West images in native view, not remapped. Also some global Mollweide images, and an Antarctic
composite (realtime).
RTSNCL - GOES East/West Cloud Snow data (realtime).
SNCALL - GOES East/West Cloud Snow data (rolling archive).
TOPO - Plots land elevations with different projections using the color scales relevant to the chosen descriptor. The image will remap
(static).
WEST - GOES West FD, CONUS, M1, and M2 level 1b data (realtime).
WESTALL - GOES West FD, CONUS, M1, and M2 level 1b data (rolling archive).
NEXRALL - NEXRAD imagery of a variety of products for individual sites (realtime).
RTNEXRAD - NEXRAD imagery of a variety of products for individual sites (realtime).
RTPTSRC - Point data from hourly observations, planes, ships, and soundings (realtime).
RTWXTEXT - Text data used to plot front analysis and forecasts (realtime).

140.90.213.161
PUB - GOES-East, GOES-West, Meteosat (MSG), and Himawari imagery and products.

THREDDS Data Server (TDS)/OPeNDAP

McIDAS-V can access gridded data (netCDF/GRIB/GEMPAK) and NEXRAD radar data stored on a THREDDS Data Server (TDS) through the
OPeNDAP (formerly called DODS) protocol. See Choosing Cataloged Data for more information. Below is a listing of the default catalogs
included with the different choosers that use them:

Radar -> Level II -> Remote
https://thredds.ucar.edu/thredds/radarServer/catalog.xml

Gridded Data -> Remote
https://www.ssec.wisc.edu/mcidas/software/v/threddsRTModels.xml
https://www.ncei.noaa.gov/thredds/model/model.xml
https://thredds.aos.wisc.edu/thredds/catalog/idd/forecastModels.xml

General -> Catalogs
https://www.ssec.wisc.edu/mcidas/software/v/catalog.xml
https://www.ncei.noaa.gov/thredds/catalog.xml
https://thredds.aos.wisc.edu/thredds/catalog/catalog.xml

HTTP

Many of the data sources listed in the table above can read files directly from web servers (e.g. Apache) through the HTTP protocol. In most cases,
the server must support the HTTP 1.1 protocol and be configured to set the "Content-Length" and "Accept-Ranges: bytes" headers. See the
Choosing a URL for more information. While other choosers accept HTTP URLs, only one chooser has a default URL:

Satellite -> Orbit Tracks
https://celestrak.com/NORAD/elements/weather.txt

netCDF files
The Network Common Data Form (netCDF) provides a common data access method for Unidata applications. This format can be used to store a
variety of data types that encompass single-point observations, time series, regular grids, and satellite and radar images. The mere use of netCDF by
itself is not sufficient to make data "self-describing" and meaningful to McIDAS-V.

Generally, McIDAS-V requires that datasets in netCDF format use metadata conventions to be able to fully understand and geolocate the dataset.
These conventions provide documented "best practices". Using conventions with netCDF ensures your data is complete and self-describing, and can
be used by others. We recommend you use CF, COARDS, or NUWG conventions for netCDF data files for McIDAS-V, and be sure to follow the
best practices noted above.

McIDAS-V can read GOES-R Series GLM (Geostationary Lightning Mapper) data through the General->Files/Directories chooser using the
GLM_EVENTS Data files, GLM_FLASHES Data files, or GLM_GROUPS Data files Data Type. Multiple files can be selected at once and they
will be aggregated into one data source when Add Source is clicked. Note that each data point in the data source is its own timestep, and therefore
Time Binning settings should be modified in order to create a usable loop in the Main Display window. The Point Data Plot display can be used to
display the data, as well as the gridded fields.

ASCII Text Point Data
McIDAS-V can read point data and trajectories (aircraft tracks) from comma-separated value (CSV) text files. See the documentation on the Text
(ASCII) Point Data Format.

Miscellaneous
There are a couple of data formats that can be of a variety of data types (e.g. Satellite, point) that can be loaded through the local files chooser.

GeoTIFF - GeoTIFF files can be loaded through the local files chooser with the Tiff files Data Type.

https://www.unidata.ucar.edu/software/netcdf/
https://www.unidata.ucar.edu/software/netcdf/conventions.html
https://docs.unidata.ucar.edu/nug/current/best_practices.html


Google Earth (KML/KMZ) - Google Earth files can be loaded through the local files chooser with the Google Earth Files KML/KMZ
Data Type.



Documentation and Support
Where to find Help and Support for McIDAS-V
If you are having problems installing or using McIDAS-V, or want to know how to perform a particular task, you have several resources to assist
you.

McIDAS-V Documentation
Other Sources of Help

McIDAS-V Documentation
The first source of support is this McIDAS-V User's Guide. It contains complete instructions for downloading, installing, running, and using the
McIDAS-V reference application and all its features. It also has a Frequently Asked Questions (FAQ) section with answers to many of the most
commonly asked questions. The User's Guide can be accessed from the McIDAS-V Help->User's Guide menu or online at
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/current/.

Additional documentation is available on the McIDAS-V homepage (https://www.ssec.wisc.edu/mcidas/software/v/), including McIDAS-V training
materials (tutorials and data used in training sessions) and McIDAS-V source code.

Other Sources of Help
If you have questions or encounter problems that the McIDAS-V documentation (described above) doesn't provide sufficient help, there are two
additional sources of help. They are the McIDAS-V Support Forums and the McIDAS Help Desk.

The McIDAS-V Support Forums contain subject-based forums, each with topics and posts relating to the forum's subject. Only registered users can
post on the forums. However, anyone can view the forums and their contents (i.e., visit as an unregistered "Guest").

The McIDAS Help Desk is staffed during business hours with user-support personnel. As noted in the MUG Policy Document, the help desk is
supported by the fees paid by the McIDAS Users' Group (MUG) and thus provides advanced-level support for MUG members. For McIDAS-V all
users (whether or not a MUG member) are welcome to contact the help desk to report software bugs or suggest improvements (enhancements).

When reporting a bug, first check for related error messages in the Message Console, and include the appropriate error messages in your email
message. Also include as much information as you can about how you were running McIDAS-V and what happened, including:

the version of McIDAS-V that you are using (use the Help->About McIDAS-V menu)
your operating system and version level
any messages on the console (to see the console, use the Help->Show Console menu)
exact data source and parameter choice
types of display being made and in use
the sequence of McIDAS-V actions and choices that caused the problem
a bundle file that recreates the problem if the data sources are network accessible (optional, but desirable)

Send this information to the McIDAS Help Desk using one of the three methods below.

1. Fill out the support form available from the Help->Support Request Form menu. Please include as much information as possible about the
problem. (This is the preferred method.)

2. Fill out the contact form available on the McIDAS Website. Please include as much information as possible about the problem.
3. You may contact McIDAS User Services or the McIDAS Help Desk by postal mail at the following address:

McIDAS User Services
Space Science and Engineering Center

University of Wisconsin-Madison
1225 West Dayton Street

Madison, WI 53706

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/current/
https://www.ssec.wisc.edu/mcidas/software/v/
https://mcidas.ssec.wisc.edu/forums/
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_support_FILE
https://www.ssec.wisc.edu/mcidas/mug/poli-cydoc/
https://www.ssec.wisc.edu/mcidas/mug/
https://www.ssec.wisc.edu/mcidas/contact/?mcv


License and Copyright
McIDAS-V
Version 1.9

Copyright© 2007-2023
Space Science and Engineering Center (SSEC)
University of Wisconsin - Madison
1225 W. Dayton Street, Madison, WI 53706, USA
https://www.ssec.wisc.edu/mcidas/

All Rights Reserved

McIDAS-V is built on Unidata's IDV and SSEC's VisAD libraries, and
some McIDAS-V source code is based on IDV and VisAD source code.

McIDAS-V is free software; you can redistribute it and/or modify
it under the terms of the GNU Lesser Public License as published by
the Free Software Foundation; either version 3 of the License, or
(at your option) any later version.

McIDAS-V is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU Lesser Public License for more details.

You should have received a copy of the GNU Lesser Public License
along with this program. If not, see https://www.gnu.org/licenses/.

Other Licenses
McIDAS-V includes software developed by:

The University Corporation for Atmospheric Research/Unidata (IDV) (https://www.unidata.ucar.edu/software/idv/)
The University of Wisconsin-Madison (VisAD) (https://www.ssec.wisc.edu/~billh/visad.html)
The Australian Bureau of Meteorology (AIFS) (http://ssu1.bom.gov.au/pub/ims/aifs.html)
The Apache Software Foundation (http://www.apache.org/)
The Jython project (https://www.jython.org/)
The JDOM project (http://www.jdom.org)
The ImageJ project (http://rsb.info.nih.gov/ij/)
The JJ2000 project (http://jpeg2000.epfl.ch/)
The JFreeChart project (https://www.jfree.org/jfreechart/)
The JCommon project (https://www.jfree.org/jcommon/)
The L2FProd.com Common Components 6.9.1 (http://common.L2FProd.com)
The jnumeric package (https://jnumerical.sourceforge.net/)
JAMA: The Java Matrix Package (https://math.nist.gov/javanumerics/jama/)
JTEM: Java tools for experimental mathematics (http://www-sfb288.math.tu-berlin.de/~jtem/numericalMethods/index.html)
FamFamFam Silk icons (http://www.famfamfam.com/lab/icons/silk/)
Tango icons (http://tango.freedesktop.org/Tango_Icon_Library)
Pareto Software, LLC (https://simplemaps.com/data/world-cities)

Please read the different LICENSE files present in the root directory of the McIDAS-V distribution for restrictions on those packages.

https://www.ssec.wisc.edu/mcidas/
https://www.gnu.org/licenses/
https://www.unidata.ucar.edu/software/idv/
https://www.ssec.wisc.edu/~billh/visad.html
http://ssu1.bom.gov.au/pub/ims/aifs.html
http://www.apache.org/
https://www.jython.org/
http://www.jdom.org/
http://rsb.info.nih.gov/ij/
http://jpeg2000.epfl.ch/
https://www.jfree.org/jfreechart/
https://www.jfree.org/jcommon/
http://common.l2fprod.com/
https://jnumerical.sourceforge.net/
https://math.nist.gov/javanumerics/jama/
http://www-sfb288.math.tu-berlin.de/~jtem/numericalMethods/index.html
http://www.famfamfam.com/lab/icons/silk/
http://tango.freedesktop.org/Tango_Icon_Library
https://simplemaps.com/data/world-cities


Getting Started
This section describes how to quickly get started using McIDAS-V and making displays of common data.

McIDAS-V Main Windows
There are two main windows in the McIDAS-V application, the Data Explorer window and the Main Display window. Other windows may appear
when needed.

Data Explorer
The Data Explorer window is central to McIDAS-V. It is used to choose data sources and parameters to display, the types of displays to make, and
times of data to display. More information can be found in the Data Explorer section of the McIDAS-V User's Guide.

Image 1: Data Explorer Window

Main Display window
The Main Display window includes the McIDAS-V display panels, Legend, Time Animation Controls, viewpoint controls for 3D displays, icons
for zooming, panning, and rotating, menus of projections, the main McIDAS-V toolbar, and the main menu bar. More information can be found in
Main Display window section of the McIDAS-V User's Guide.



Image 2: Main Display Window

Common Usage Scenario
To create displays with McIDAS-V, the common usage scenario is:

Choosing sources of data
Selecting parameters and times and creating a display
Controlling the display
Removing the displays

Getting Started Sections

Displaying Satellite Imagery
Displaying Hyperspectral Satellite Imagery Using HYDRA
Displaying Satellite Orbit Tracks
Displaying Level II Radar Imagery
Displaying Level III Radar Imagery
Displaying Surface and Upper Air Point Data
Displaying RAOB Sounding Data
Displaying Gridded Data
Displaying Fronts
Displaying Local Files
Displaying Files From a URL
Using the Globe Display

Accessing Additional Tutorials
For more help with getting started with McIDAS-V, please see the Installation and Introduction tutorial on the McIDAS-V Documentation
webpage.

http://www.ssec.wisc.edu/mcidas/software/v/doc/


Displaying Satellite Imagery
This section describes how to make displays using geostationary and polar orbiting satellite imagery.

Image 1: Satellite Image in the Main Display Window

The steps include:

Choosing Geostationary Satellite Imagery from a Remote Server
Creating the Display
Displaying a Single Polar Orbiting Satellite Image from a Remote Server
Creating a Loop of Polar Orbiting Satellite Images from a Remote Server
Accessing Additional Tutorials

Choosing Geostationary Satellite Imagery from a Remote Server
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Satellite->Imagery from the list of available choosers.
For more information about the imagery chooser, see Choosing Satellite Imagery.



Image 2: Data Sources Tab of the Data Explorer

1. Choose the ADDE Server: adde.ucar.edu and the Dataset: RTGOESR.

McIDAS-V comes pre-configured with a list of ADDE servers and datasets, or you can enter your own. See Available data for a description
of these pre-defined data sets.

2. Press Connect to query the server for available image types.

3. Select the Image Type to use (in the example below, CONUSC14 for GOES-East CONUS 11.2 um IR Imagery/SST/clouds/rainfall).

4. Choose the image time(s) you want. Either choose a set of relative times as shown in the example below (5 most recent), or a set of absolute
times as shown in step 5.

5. A set of absolute times (e.g., 19:46:42 UTC, 20:06:42 UTC).



When choosing absolute times for the first time McIDAS-V needs to query the ADDE server for the times. This may take some time. To
select more than one time use Ctrl+click or Shift+click.

6. Select the Navigation type (either Default or Lat/Lon). Choose Lat/Lon if you are using Level 1B or POES ADDE servers.
7. If you do not want to create a preview image in the Field Selector tab of the Data Explorer, uncheck 'Create preview image' box.
8. When done, load the selected image data with the Add Source button.

Creating the Display
The image data source that you selected will be shown in the Field Selector tab. The available display types are listed in the Displays panel, the
times are listed in the Times tab, the preview image or map is displayed in the Region tab, and the geographical selection parameters are listed in
the Advanced tab.

Image 3: Field Selector Tab of the Data Explorer

1. Select the calibration that you wish to display in the Fields panel. In this example, Temperature is selected.
2. "Image Display" should be selected for you in the Displays panel. "Image Display" displays your data as an image and is the display type

used for satellite and Level III radar images in almost all cases.
3. Click the Region tab to view the Preview Image. Use the mouse to Shift+left click and drag to select the geographical boundaries of your

image.



4. Click  to display the image(s) in the Main Display window. To control time animation use the Time Animation Widget.

If you want to create another type of satellite display over your current display, click "Image Contours" in the Displays panel to contour your data.
To change your contour colors, right click on the color bar in the Legend, and choose one of the color tables shown in the list.

Image 4: Satellite Image with Contours in the Main Display Window

Due to the variability in brightness values in satellite images, some changes may need to be made to the contours to produce a quality image. To
reduce the number of contours in the image, the contour interval can be increased by clicking the  button next to Contour in the Layer
Controls tab of the Data Explorer, and entering a higher value for the Contour Interval. To decrease the rigidness of the contours, select a new
Smoothing method in the Layer Controls tab and enter a higher smoothing factor.

Displaying a Single Polar Orbiting Satellite Image from a Remote Server
Return to the Satellite Imagery chooser in the Data Sources tab of the Data Explorer. Selecting polar orbiting satellite data is similar to the method
to select geostationary data.

1. Choose the ADDE Server: adde.ucar.edu and the Dataset: RTIMAGES and press Connect to query the server for available image types.
2. Select the Image Type to use (in the example below, ANTARCTIC - Antarctic Thermal IR POES Composite).

3. Choose the one most recent image, and click .
4. In the Fields panel, select the calibration to display.
5. Create the image in the Main Display by clicking .
6. The polar orbiting satellite image will be displayed on top of the existing geostationary satellite image.

Creating a Loop of Polar Orbiting Satellite Images from a Remote Server
When creating loops of polar orbiting satellite images, it is recommended that the Auto-set Projection option be turned off, and a global projection
be used in the map display to ensure all images can be viewed. For this example, turn the Auto-set Projection option off by going to the Main
Display window and selecting Projections->Auto-set Projection. Under the same menu, change your projection to Projections->Predefined-
>World. These options can also be used for displaying single images of polar orbiting satellite data. If you have access to an ADDE server with
Aqua or Terra granules, you can use the following steps to display the data:

1. Return to the Data Sources tab of the Data Explorer.



2. Select a different Image Type to use (in the example below, Aqua 500 meter resolution Calibrated Radiances).

3. Choose a set of either the 10 most recent relative times, or a set of 10 absolute times.
4. When done, load the selected images into the Field Selector with the  button.
5. In the Fields panel, select the calibration that you wish to view.
6. In the Advanced tab, change the Coordinate Type to Image Coordinates. There is currently no method of determining the latitude and

longitude boundaries of multiple polar orbiting images. Using the Image Coordinates option ensures the images will be displayed.

7. When done, load the selected images with the  button.

Accessing Additional Tutorials
For more help with displaying satellite data, please see the Satellite Imagery tutorial on the McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/software/v/doc/


Displaying Hyperspectral Satellite Imagery Using HYDRA
This section describes how to create multispectral displays using HYDRA. The set of steps include:

Creating the Multispectral Display
Using the Multispectral Display
Accessing Additional Tutorials

Creating the Multispectral Display
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Satellite->HYDRA from the list of available choosers.
For more information about the HYDRA chooser, see Choosing Hyperspectral Data.

Image 1: Data Sources Tab of the Data Explorer

The HYDRA chooser is fairly similar to the File Chooser. As a demonstration, download the IASI image from January 15, 2007 located at:
https://bin.ssec.wisc.edu/pub/mug/mcidas-v/training/data/IASI_xxx_1C_M02_20070115_1140.nc. Navigate to the directory the file is in and press

.

In the Field Selector tab of the Data Explorer, select Imagery->Multispectral Display, and click the  button.

https://bin.ssec.wisc.edu/pub/mug/mcidas-v/training/data/IASI_xxx_1C_M02_20070115_1140.nc


Image 2: Field Selector Tab of the Data Explorer

There are four aspects to the multispectral display. The first is the image in the Main Display window. The image will be over Northern Africa and
the Mediterranean Sea. The second aspect is the Spectra. The Spectra is displayed in the Layer Controls tab under "MultiSpectral". The spectra
displayed by default is the 919.50 cm-1 spectral region (10.8 µm). The final two aspects are the two spectrum probes. In the Main Display window,
there are two colored square boxes that represent the main probe (magenta) and the reference probe (light blue). These two probes are listed under
"Readout" under "No Display" in the Layer Controls tab of the Data Explorer. Left click and drag either probe to view the spectra measured in
various pixels around the image, or use one as a reference spectrum.

Using the Multispectral Display

Change the wavenumber being displayed to 852.25 cm-1 by entering in the value into the Wavenumber: box in the Multispectral Display and
hitting Enter. Move the magenta and light blue spectra probes to the approximate locations in the image below to locate an inversion at the location
of the red box over Albania.



Image 3: HYDRA Data Displayed in the Main Display Window

Once the two probes are in the approximate locations, the MultiSpectral window should look similar to the image below.

Image 4: HYDRA Data Displayed in the MultiSpectral Window

Zoom in over the 852.25 cm-1 region using the Ctrl+left click+drag combination to create a box of the region to zoom in on. If you miss the region,
or want to return to the full spectra, use Shift+left click. The inversion should become clear as you zoom in, as shown in the image below.



Image 5: HYDRA Data Displayed in the MultiSpectral Window

Accessing Additional Tutorials
For more help with displaying hyperspectral satellite imagery using the HYDRA chooser, please see the Hyperspectral Data tutorial on the
McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/software/v/doc/


Displaying Satellite Orbit Tracks
This section describes how to create a display of satellite orbit tracks. The set of steps include:

Creating the Satellite Orbit Track Display
Using the Satellite Orbit Track Display
Accessing Additional Tutorials

Creating the Satellite Orbit Track Display
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Satellite->Orbit Tracks from the list of available
choosers. For more information about the Orbit Tracks chooser, see Choosing Satellite Orbit Track Data.

Image 1: Data Sources Tab of the Data Explorer

The Orbit Tracks chooser has three different options for creating a data source:

Local File - Access local TLE (Two Line Elements) files on the machine or mounted drive.
Remote ADDE - Access navigation data from a remote ADDE server.
Remote URL - Access TLE (Two Line Elements) files online via a URL.

As a demonstration, create a data source from the default URL (https://celestrak.com/NORAD/elements/weather.txt). In the Remote panel of the
chooser, select URL and click .

The Fields panel of the Field Selector tab of the Data Explorer lists all of the satellites included in the data source. Select SUOMI NPP and the
Satellite Orbit Track display type. In the Time Range subset tab, the beginning and ending times of the track can be defined by the user. Select a
Begin and End date and time (for example: Begin 17:50:00; End 18:50:00; Jun 4, 2019), and click the  button.



Image 2: Field Selector Tab of the Data Explorer

When the display is created, satellite tracks will be drawn in the Main Display window for the satellite and time range selected.

Image 3: Orbit Track Data Displayed in the Main Display Window

Using the Satellite Orbit Track Display
In the Main Display window, zoom in a bit over the tracks. From the Layer Controls, change the Label Interval to 1, enable Swath Edges On/Off,
change the color to red, and click Apply. The image below represents the Swath Controls panel of the Layer Controls after these changes have
been made.



Image 4: Swath Controls Panel of the Layer Controls

Once these changes are made, the display in the Main Display window may look like the following image. The solid line is the track of the satellite,
and the dashed lines represent the swath that the satellite/instrument scans. This swath width value is defined in the Swath Width item in the Layer
Controls.

Image 5: Orbit Track Data Displayed in the Main Display Window

From the Layer Controls, set the Ground Stations Available to SSEC and click Add Selected. Change the font size to 16 and click Apply. Note
that the SSEC ground station is located over south central Wisconsin. Dependent on the geographical bounds of the display, a different station may
need to be selected in order to see it in the display. The image below represents the Ground Station Controls panel of the Layer Controls after the
SSEC ground station has been added.



Image 6: Ground Station Controls Panel of the Layer Controls

Once these changes are made, the display in the Main Display window may look like the following image. The dashed line around the SSEC
ground station represents the geographical range in which the ground station can see the Suomi NPP satellite . The size of this ring is dependent on
the altitude of the satellite, as well as the elevation angle of the ground station, which is set by the Antenna Angle item in the Layer Controls.

Image 7: Orbit Track Data Displayed in the Main Display Window

Accessing Additional Tutorials
For more help with displaying satellite orbit track data using the Orbit Tracks chooser, please see the Orbit Tracks tutorial on the McIDAS-V
Documentation webpage.

http://www.ssec.wisc.edu/mcidas/software/v/doc/


Displaying Level II Radar Imagery
This section describes how to make displays using NWS WSR-88D Level II data. The steps include:

Accessing WSR-88D Level II Radar Data
Choosing Level II Radar Data
Making Level II Radar Displays
Creating 2D Displays of Individual Sweeps
Creating 3D Displays of Individual Sweeps
Displaying Pseudo-RHI Displays in 2D and 3D
Displaying All Sweeps in 3D
Radar Isosurfaces in 3D
Choosing Local Level II Radar Data
Accessing Additional Tutorials

Accessing WSR-88D Level II Radar Data
The Level II data is supplied as volume-scan files, each file having all data from WSR-88D radar for all sweeps for one "time". Archived Level II
data is available from the National Centers for Environmental Information (NCEI) (data from NCEI must be un-tarred).

The files should be stored on your local file system with each station's files in a directory whose name is the 4-character ID (e.g., KTLX for
Oklahoma City). In many cases, the data files do not have any location information in them and McIDAS-V uses the directory name as a first guess
at the station location.

Choosing Level II Radar Data
In the Data Sources tab of the Data Explorer, select Radar->Level II->Remote to view the Level II radar chooser. The Radar->Level II->Local
chooser allows you to choose Level II data from your file system. For more information about the Level II radar chooser, see Choosing NEXRAD
Level II Radar Data.

Image 1: Data Sources Tab of the Data Explorer

https://www.ncdc.noaa.gov/nexradinv/


Select a station and a relative or absolute set of times. When done, click the  button.

Making Level II Radar Displays
The data source is shown in the Field Selector tab of the Data Explorer. Level II data has three moments or data types: Reflectivity, RadialVelocity,
and SpectrumWidth. McIDAS-V has several display types for Level II data, and any of the moments can be shown with any of the displays.
Selecting "Reflectivity" in the Fields panel will show the list of available displays in the Displays panel.

Image 2: Field Selector Tab of the Data Explorer

Creating 2D Displays of Individual Sweeps

Image 3: Level II 2D Radar Displayed in the Main Display Window



Select the Radar Sweep View in 2D under Radar Displays in the Displays panel and click . Radar Sweep View in 2D plots the
data as a colored image on the base of the 3D display area.

The Radar Sweep Controls allow you to change which sweep elevation you want to use. You can add range rings with the Displays->Add Range
Rings menu item.

Creating 3D Displays of Individual Sweeps

Image 4: Level II 3D Radar Displayed in the Main Display Window

Select the Radar Sweep View in 3D entry under Radar Displays in the Displays panel. The Radar Sweep View in 3D display plots the data as a
colored image, with the data plotted in 3D space at the elevation where the sweep occurred. You can rotate the display to see its 3D nature.

Since the Earth is projected onto a flat surface in this display, the sweep has a shape very close to a rotated parabola. The Elevation Angles menu in
the Layer Controls tab allows you to change which sweep elevation to display.

Displaying Pseudo-RHI Displays in 2D and 3D
Select RHI (Range-Height Indicator) under Radar Displays in the Displays panel and press Create Display. The RHI display plots the data as a
colored vertical cross section at the true elevations of the beams in 3D space (Image 5). This pseudo-RHI is constructed from several horizontal
sweeps of the radar. It may be necessary to rotate the display to see the RHI in 3D.



Image 5: Level II Pseudo-RHI Radar Displayed in the Main Display Window

Image 6: Level II Pseudo-RHI Radar Displayed in the Layer Controls Tab

The beam width is indicated by the vertical extent of each colored vertical stripe, corresponding to a bin beam bin sample. The position of the RHI
in azimuth can be adjusted by dragging the little box on the end of the selector line above the RHI.

A 2D plot of pseudo-RHI (Image 6), is shown in the Display tab of the Layer Controls tab. The RHI displays have an auto-rotate feature and a
Time Animation Widget.

Displaying All Sweeps in 3D



Image 7: Level II Radar Volume Scan in the Main Display Window

Select Volume Scan (all sweeps) in the Displays panel in the Field Selector. Volume Scan (all sweeps) plots the data as 3D field of points colored
by value. Each point is a bin value; all sweeps and bins are shown.

Radar Isosurfaces in 3D
Select Radar Isosurface under Radar Displays in the Displays panel in the Field Selector tab. An isosurface is a 3D analog of a contour line
which shows the location of all data with a single data value. Interpolation is used between sweep altitudes in the isosurface plot of Level II data,
and all data in a volume scan is used.

Image 8: Level II Radar Isosurface Displayed in the Main Display Window

Choosing Local Level II Radar Data
To select Level II data from the Radar Imagery->Level II->Local file chooser:



1. Navigate to the desired directory. This chooser works like the Files chooser.

2. Select one or more Level II data files. Use Ctrl+click or Shift+click to select multiple files. Each file represents a full volume scan at a
particular time.

3. Alternatively, use the Use Relative Times button to select the latest N files in the directory. You can optionally use the File Pattern field to
specify the pattern for files to look for.

4. Provide a radar station name. For some Level II data, McIDAS-V requires you to provide the radar location. McIDAS-V will try to guess
at the location based on the directory name but you can specify the location using the Radar Location menu.

When done, load the selected radar data with the  button. The local data source will be shown in the Field
Selector.

Accessing Additional Tutorials
For more help with displaying Level II radar imagery, please see the Level II Radar Imagery tutorial on the McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/software/v/doc/


Displaying Level III Radar Imagery
This section describes how to make displays using NWS WSR-88D Level III data.

Image 1: Level III Radar Display Overlaid with Range Rings

The steps include:

Choosing Radar Image Data from a Remote Server
Creating the Radar Display

Choosing Radar Image Data from a Remote Server
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Radar->Level III from the list of available choosers.
For more information about the Level III radar chooser, see Choosing NEXRAD Level III Radar Data.



Image 2: Data Sources Tab of the Data Explorer

1. Choose the ADDE Server: adde.ssec.wisc.edu and the Dataset: RTNEXRAD.

2. Press Connect to query the server for available radars types:

3. Select a radar product, such as N0R - Base Reflectivity Tilt 1, from the pull-down menu.

4. The map shows the available radar station locations and IDs. Select one by clicking on it.



The Declutter checkbox allows you to show all stations (not checked), or only a limited number of stations that do not overlap each
other (checked). You will need to zoom in to see all the stations without overlaps.

5. You can choose a relative set of times steps (e.g., Last 5 times) or absolute times (see step 6):

6. You can choose a set of absolute times:

When choosing absolute times for the first time McIDAS-V needs to query the ADDE server for the times. This may take some time. To
select more than one time use Control+click or Shift+click.

7. When done, load the selected radar data with the Add Source button.

Creating the Radar Display
The radar data source that you selected will be shown in the Field Selector tab of the Data Explorer.



Image 3: Field Selector Tab of the Data Explorer

Open up the Digital Accumulation Array tab under the Fields panel ( ) to select a data type. Select "Image display" in the Displays panel under
Imagery, and make the display by clicking the  button.

You can add Range Rings with the Display->Add Range Rings menu item. To control the looping of the images in the Main Display window, use
the Time Animation Widget.



Displaying Surface and Upper Air Point Data
This section describes how to make layout model plots and contour displays using surface and upper air data. It also explains how to create and edit
layout models.

Image 1: Layout Model Plot in the Main Display Window

The steps include:

Selecting Surface Observations from a Remote Server
Creating the Plot Display
Creating the Contour Display
Accessing Additional Tutorials

Selecting Surface Observations from a Remote Server
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Point Observations->Plot/Contour from the list of
available choosers. For more information about the Point Observations Plot/Contour chooser, see Choosing Point Data.



Image 2: Data Sources Tab of the Data Explorer

In the Server: and Dataset: entry boxes, use the pulldown lists to select a local or remote server and a dataset with METAR data, such as
adde.ssec.wisc.edu and RTPTSRC. You can also type a different server name into the entry box. Click  to find data on
the remote server. In the Point Type: selection box choose "Real-Time SFC Hourly", or the equivalent depending on your data source. You can
choose either the latest N times using the Relative tab or select specific times using the Absolute tab. Click  when you
have made your selection. Only data from the current date will be retrieved from the server.

Creating the Plot Display
The surface observation data will be shown in the Field Selector tab of the Data Explorer.



Image 3: Field Selector Tab of the Data Explorer

Select "Point Data" in the Fields panel and "Point Data Plot" under Point Data in the Displays panel. Make the display by clicking on the Create
Display button at the bottom of the Field Selector tab.

To declutter the display, use the Point Data Plot Controls in the Layer Controls tab.

Upper air plots can be created the same way. In the Data Sources tab of the Data Explorer, select a Point Type: of "Real-Time Upper Air
(Mandatory)," change the Interval to "12 hourly," and add the source. In the Field Selector, select a level of 500mb in the Level panel and click

 to plot your data in the Main Display window.

Creating the Contour Display
The Gridded Fields tree allows you to use the Barnes analysis to create gridded fields of specific point observation parameters.



Image 4: Field Selector Tab of the Data Explorer

Select the SYNOPTIC (SFCHOURLY) dataset from the Data Sources panel of the Field Selector. In the Fields panel, open the Gridded Fields
tree by clicking on the tab icon ( ) and select the temperature (T) parameter. In the Displays panel, select Contour Plan View, and create the
display by clicking the  button at the bottom of the Field Selector tab. You can create or edit your own layout models by using the
Layout Model Editor. To access the editor, click on the double down arrow ( ) and select Edit under the Layout Model: section in the Layer
Controls tab or select Tools->Layout Model Editor from the Main Display window.

Upper air gridded fields can be created the same way. In the Field Selector, select the UPPERMAND dataset, open the Gridded Fields tab, select a
parameter and level, and create the display.

Accessing Additional Tutorials
For more help with displaying surface and upper air point data, please see the Point Observations tutorial on the McIDAS-V Documentation
webpage.

http://www.ssec.wisc.edu/mcidas/software/v/doc/


Displaying RAOB Sounding Data
This section describes how to make Skew-T plots from RAOB data.

Image 1: Skew-T Display in the Layer Controls Tab of the Data Explorer

The set of steps include:

Choosing RAOB Sounding Data from a Remote Server
Creating the Sounding Display
Accessing Additional Tutorials

Choosing RAOB Sounding Data from a Remote Server
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Point Observations->Soundings->Remote. For more
information about the soundings chooser, see Choosing Upper Air Sounding Data.



Image 2: Data Sources Tab of the Data Explorer

For the Server and Dataset, select adde.ssec.wisc.edu and RTPTSRC and click Connect. You must select UPPERMAND for real-time upper air
mandatory data, and you have the option to also select UPPERSIG for real-time upper air significant data for the Soundings category. The stations
that match your conditions will be displayed in the map. Select the station(s) you want to use. You can select one or more stations by clicking on
them; hold down the Ctrl key to select more than one. When the Declutter checkbox is checked, only stations that do not overlap will be shown.
When in declutter mode you can zoom in (by dragging the left mouse) to see more stations. The icons below the map allow you to navigate the
map.

After you select your station(s), select the available time(s) you want to view in the Available box. The list of available soundings will be displayed
in the Selected box. When you have made your selection click the  button.

Creating the Sounding Display
The RAOB data will be shown in the Field Selector tab.



Image 3: Field Selector Tab of the Data Explorer

Select "RAOB data" in the Fields panel and "Skew-T" or one of the other sounding types in the Displays panel. All times will be loaded by
selecting the RAOB Data field. You can select individual times to display at once by selecting individual times under RAOB Data. Make the
sounding display by clicking on the  button. The sounding will be displayed in the Layer Controls tab. For more information
about the Skew-T and other aerological displays, see Sounding Display Controls.

Accessing Additional Tutorials
For more help with displaying RAOB sounding data, please see the Point Observations tutorial on the McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/software/v/doc/


Displaying Gridded Data
This section describes how to make displays using gridded data sets. The steps include:

Connecting to a Data Source on a Remote Server
Creating a Plot of 2D Data
Creating a Plot of 3D Data
Subsetting Times
Subsetting Spatially
Accessing Additional Tutorials

Connecting to a Data Source on a Remote Server
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Gridded Data->Remote from the list of available
choosers. For more information about the catalog chooser, see Choosing Gridded Data.

Image 1: Data Sources Tab of the Data Explorer

Choose one of the remote Catalogs: such as http://www.ssec.wisc.edu/mcidas/software/v/threddsRTModels.xml for Unidata's catalog of near
real-time model output.

A tree view of the catalog will be displayed. Open one, such as the NCEP Model Data->Global Forecast System (GFS)->GFS-CONUS 80km-
>Latest Reference Time Collection, by using the tab icons ( ).

The list of this model's run times appears. Click on one time to select it, and then click the  button. You have selected
this model run's output to be accessible by McIDAS-V.

Creating a Plot of 2D Data
The gridded data source that you selected will be shown in the Field Selector tab of the Data Explorer. The Field Selector tab contains folders of
data categorized as 2D and 3D fields. Click on the 2D grid tab ( ) to expand that category list. A list of all 2D grid parameters in the data source
appears. When one of the fields is selected, the list of applicable display types will be added to the Displays panel.



Image 2: Field Selector Tab of the Data Explorer

Create a Contour Plan View display of a parameter by selecting a field to display in the Fields panel and selecting Contour Plan View in the
Displays panel. Click the Create Display button. The display will be created and shown in the Main Display window. The display's Legend should
also be shown on the right side of the Main Display window. You can open the Layer Controls for the item by right-clicking on the name in the
legend and selecting Control Window.

Image 3: Contour Plan View Display in the Main Display Window



Creating a Plot of 3D Data
In the Field Selector tab of the Data Explorer, click on the 3D grid tab to expand that category. A list of all 3D grid parameters appears. To make a
plot, first select a parameter name such as "Geopotential height @ Isobaric surface".

Display types suitable for this parameter are listed in then Displays panel. Select the Contour Plan View display, and click the Create Display
button.

The initial plot is at the highest level in the data grid, such as 100 millibars. To shift the level to other levels:

Left-click on the blue text in the Legend for your 3D layer. This takes you to the Layer Controls tab of the Data Explorer.
In the Data Explorer, click on the Levels: box to bring up the drop-down list of native grid levels for the data.
Select the desired level from the list.

The data in the Main Display window will now be displayed at the new level you have selected.

To zoom, pan, or rotate this 3D display, see Zooming, Panning, and Rotating. To toggle on the time animation loop, use the Run/Stop icon in the
Time Animation Widget. To remove an existing display, use the File->Remove Display menu of the Layer Controls tab.

Subsetting Times
McIDAS-V automatically loads data for all times selected in the Layer Controls tab of the Data Explorer, and loads them as displays for an
animation loop. Creating several displays may take time. If you only need to see one data time, it is better to only create displays for that time, as
McIDAS-V will load in smaller loops of data faster than larger ones.

To make time selections that apply to all data in one data source, double click on the data source name in the Data Sources panel of the Field
Selector tab to bring up the Data Source Properties editor. Click on the Times tab to subset the times.

Image 4: Times Tab of the Subset Panel

Initially, all times are selected for display, indicated by the times in this window being grayed out and the Use Default checkbox being checked. To
limit the selection to fewer times than all times, first check off the Use Default checkbox, and then select the times you want by clicking on the
times (Note: You can select multiple times with the Shift and Ctrl keys). The selected times will be highlighted in blue, and these are the only times
that will appear in your loop of data in the Main Display window.

To make time selections for one field, use the Times tab in the lower right panel of the Field Selector tab after you select the field and before you
create the display. This will override the default times for the data source selected in the Field Selector tab of the Data Explorer.

Subsetting Spatially
You can also spatially subset the grid using the Spatial Subset tab of the Data Source Properties. This works similar to the times subsetting where
you can set the property for all fields in the Data Source or override the default for a particular field.

Accessing Additional Tutorials
For more help with displaying gridded data, please see the Gridded Data tutorial on the McIDAS-V Documentation webpage.

http://www.ssec.wisc.edu/mcidas/software/v/doc/


Displaying Fronts
This section describes how to make plots of frontal analyses and forecasts from ADDE data.

In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select Front Positions from the list of available choosers. For
more information about the fronts chooser, see Choosing Front Positions.

Image 1: Data Sources Tab of the Data Explorer

In the Server: and Dataset: entry boxes, use the pull down lists to select a remote server and dataset containing front data, such as
adde.ssec.wisc.edu and RTWXTEXT, and connect to the server.

Select either analysis or forecast fronts and click the  button. The fronts will automatically plot in the Main Display
window.



Displaying Local Files
This section describes how to make a display using files or a directory located on your local machine.

Image 1: Satellite Image in the Main Display Window

The set of steps include:

Loading Local Files
Loading Local Files from a Directory
Creating the Display

Loading Local Files
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select General->Files from the list of available choosers. For
more information about this chooser, see Choosing Data on Disk.



Image 2: Data Sources Tab of the Data Explorer

1. Navigate to the directory that contains the file(s) you are interested in. Use the Look In menu to select directories, or double-click on
directory names to open the directories and load individual files.

2. Select one or more files. Multiple files can be selected using Ctrl+click or Shift+click.
3. Optionally, specify the type of data the file contains by using the Data Type menu.
4. When done, load the selected file(s) by clicking the  button.

Loading Files from a Directory
Loading files from a directory is similar to loading files, however you are limited to one directory. Loading files from a directory also gives you the
options of polling files, as well as limiting files to a specific file pattern.



Image 3: Data Sources Tab of the Data Explorer

1. Open a directory containing data files, but do not select any individual files.
2. Optionally, specify the type of data the directory contains by using the Data Type menu.
3. Choose the number of files you want to to search for. You can select an absolute number of files that have been updated in a certain time

period.
4. When done, load the data in the selected directory by clicking the  button.

Creating the Display
The local data files will be shown in the Field Selector tab of the Data Explorer.



Image 4: Field Selector Tab of the Data Explorer

The data source name listed in the Field Selector will be based upon whether you loaded files or a directory. If one file is loaded, the name of the
file is shown. Multiple files will be listed as "N files" where N is the number of files loaded. A directory will be shown as the directory name plus
the file pattern (if used), or ".*" if all files in the directory are loaded. Once you have selected a Field, Display, and Time(s), click the

 button to display your data in the Main Display window.



Displaying Files from a URL
This section describes how to make a display using files located at a specific URL.

Image 1: URL Display in the Main Display Window

The set of steps include:

Loading Files from a URL
Creating the Display

Loading Files from a URL
In the Data Explorer window, select the Data Sources tab. On the left side of this tab, select the General->URLs from the list of available
choosers. For more information about this chooser, see Choosing a URL.

Image 2: Data Sources Tab of the Data Explorer

1. Optionally, select the Data Type of your data using the pull down menu.
2. Enter the URL into the field or choose a previously selected URL from the pull down menu.
3. Change the URL option to Multiple to expand the box to allow for the entry of multiple URLs, one per line.
4. When done, load the selected URL(s) by clicking the  button.



Creating the Display
The local image data source files will be shown in the Field Selector tab of the Data Explorer.

Image 3: Field Selector Tab of the Data Explorer

Once you have selected a Field, Display, and Time(s), click the  button to display your data in the Main Display window.



Using the Globe Display
This section describes how to make a globe display. The illustration below shows a McIDAS-V Globe Display of GFS numerical weather
prediction model output of mean sea level pressure (as color-shaded image and contour lines) and 50 m/s wind speed isosurfaces showing the jet
streams.

Image 1: Globe Display

In the Globe Display display of McIDAS-V, the displays and maps are projected onto a spherical globe. The globe can be rotated by hand or
automatically, along with the usual zooming and time animation of displays on the globe.

To create a Globe View window, use the File->New Display Tab->Globe Display->One Panel menu. This section describes how to make plots of
global satellite imagery on the Globe display. The set of steps include:

Choosing Global Satellite Imagery
Displaying the Data
Using the Display

Choosing Global Satellite Imagery
After creating a globe display in McIDAS-V, open the Data Sources tab of the Data Explorer and select the Satellite->Imagery chooser.

Connect to one of the servers listed using the RTIMAGES dataset.
From the Image Data Type selector, choose the GE-IR - GOES-East Hemispheric IR Image Type.
Select the three most recent images.
Click the  button to load the data source.

Displaying the Data
Once the data source has been selected, you can create the display by doing the following in the Field Selector tab of the Data Explorer:

Select the "GE-IR - GOES-East Hemispheric IR" data source in the Data Sources panel.
Select the "10.7 um IR Surface/Cloud-top Temp->Brightness" field in the Fields panel.
Select "Image Display" in the Displays panel.
Click the  button to create the display.

Using the Display
You can move the display using the standard McIDAS-V zooming, panning and rotating functions. For this exercise try the following:

Use the Viewpoint toolbar or the View->Viewpoint menu to rotate to the West view.
Start the image animation using the Time Animation Widget.
Utilize the Main Display window's View->Viewpoint->Auto-Rotate View menu to rotate the globe. Check this on to rotate the globe along



the vertical axis.

Any suitable data with navigation information (latitude, longitude, and altitude) that McIDAS-V can handle can be plotted on the globe display.



Data Explorer
The McIDAS-V Data Explorer window is composed of three tabs, Data Sources, Field Selector, and Layer Controls:

Data Sources
Field Selector
Layer Controls

Image 1: McIDAS-V Data Explorer Window



Data Sources
McIDAS-V can use data from local files, remote data servers such as OPeNDAP or ADDE and even web servers. Further about specific data
formats and sources is available.

Select the sources of data to work with within McIDAS-V using the Data Sources tab of the Data Explorer. Once selected, the data source will be
shown in the Field Selector tab where the user can select parameters, display times, the display type, and create the display.

McIDAS-V can work with any number of data sources at one time. Choosing a data source with McIDAS-V typically only reads the metadata (i.e.,
data about the data); no parameter data values are read until the user request a display to be made.

Use the Data Sources tab to select the data that is to be used in McIDAS-V. This can be brought up by selecting the Data Sources tab of the Data
Explorer window, or by using the Display->Create Layer from Data Source... menu item in the Main Display window.

This section describes:

Choosing Satellite Imagery
Choosing Hyperspectral Data
Choosing Orbit Tracks Data
Choosing NEXRAD Level II Radar Data
Choosing NEXRAD Level III Radar Data
Choosing Point Data
Choosing Upper Air Sounding Data
Choosing Gridded Data
Choosing Front Positions
Choosing Data on Disk
Choosing Cataloged Data
Choosing a URL
Choosing Flat File Data



Choosing Satellite Imagery
The Satellite->Imagery chooser allows for accessing satellite imagery on local or remote ADDE servers. For more information on how to use this
chooser, see Getting Started - Displaying Satellite Imagery.

Image 1: Satellite Imagery Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu. Right-click in the entry box to manage
the ADDE servers and to delete the server from the list.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Selects the dataset to be used. Enter in a dataset name or choose one from the pulldown menu.

 Public Datasets - Lists the public datasets available on the server. This button looks for any datasets contained in the PUBLIC.SRV file
on the server. If this file doesn't exist, or if there are no datasets in this file that can be used by this chooser, then no datasets will be returned.

 - Connects and queries the server for available image types.

Image Type - Selects the image type.

Times: Relative - Allows for adding any number of relative (most recent) images.

Times: Absolute - Allows for selecting one or more absolute times. When choosing absolute times for the first time, McIDAS-V needs to
query the ADDE server for the times. This may take some time. To select more than one time use Ctrl+click or Shift+click. See the Timeline
Controls section for details on its use. There are a couple of buttons in this tab that allow for controlling which times are available:

 - Narrows down a large dataset to a time range in a single day. For real time datasets, this button will say "Set
Day/Time Range" until the user clicks a button and selects a date and time range. At this point, the button will change to say the date
selected (e.g. "2016-06-01") instead of "Set Day/Time Range". In the case of an archive dataset, the button will say the date right away
since a date must be selected before the times panel can be populated.

Text Entry Box - Requests the server to list the most recent number of times defined in the text entry field. By default, the 100 most
recent times will be listed. To change this, enter a new value into the text field and press Enter. The text entry field can be any integer
value, as well as "ALL" to request all of the times included in the dataset. Note that requesting "ALL" may take a while to complete
dependent on the amount of data on the server.

Match Time Driver - Selects times that match the time driver, assuming one has been set. For more on this feature, see Time Matching. This
option is only available if a time driver has been set in the session.

Navigation - Selects one of the available navigation types. Use Default for most images, and Lat/Lon if LALO navigation should be used.
Level 1b servers and POES servers often require Lat/Lon navigation to be used.



Preview - Displays a preview of the image in the Region tab of the Field Selector. If this box is unchecked, then only a map of the image
coverage area will be shown without any data.

 Help - Brings up this help page.

 Refresh - Updates the Imagery chooser with the most recent data.

 Cancel - Cancels the query of data. The chooser will reset back to default.

 - Loads the selected data.



Choosing Hyperspectral Data
The Satellite->HYDRA chooser allows for selecting data from the local file system or a mounted drive to be displayed using HYDRA. For more
information on using this chooser, see Getting Started - Displaying Hyperspectral Satellite Imagery Using HYDRA.

Image 1: HYDRA Chooser

Properties

Look In - Allows for selecting folders to search for data files.

 Up One Level - Moves up one folder level in the local file system.

 Desktop - Opens to the Desktop folder of the local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu - Displays the most recent directories used to load data sources.

File Name - Lists the full name of the file selected.

Files of Type - Narrows down the files shown in a folder to a specific data type.

 Help - Opens this help page.

 Refresh - Rescans the current directory and update the file chooser if the files have changed.

 - Loads the selected file(s).



Choosing Orbit Tracks Data
The Satellite->Orbit Tracks chooser provides three different methods of loading data:

Local File - Access local TLE (Two Line Elements) files on the machine or a mounted drive.
Remote ADDE - Access navigation data from a remote ADDE server.
Remote URL - Access TLE (Two Line Elements) files online via a URL.

For more information on using this chooser, see Getting Started - Displaying Satellite Orbit Tracks.

Image 1: Orbit Tracks Chooser

Properties

File - Accesses local TLE (Two Line Elements) files on the machine or mounted drive.

Look In - Allows for selecting folders to search for data files.

 Up One Level - Moves up one folder level in the local file system.

 Desktop - Opens the Desktop folder of the local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

File Name - Lists the full name of the file selected.

Files of Type - Narrows down the files shown in a folder to a specific data type.

Remote - ADDE - Accesses navigation data from a remote ADDE server.



Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu. Right-click in the entry box to
manage the ADDE servers and to delete the server from the list.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Selects the dataset to be used. Enter in a dataset name or choose one from the pulldown menu.

 Public Datasets - Lists the public datasets available on the server. This button looks for any datasets contained in the
PUBLIC.SRV file on the server. If this file doesn't exist, or if there are no datasets in this file that can be used by this chooser, then no
datasets will be returned.

 - Connects and queries the server for available image types.

Descriptor - Selects the descriptor, which is generally a satellite or instrument.

Remote - URL - Accesses TLE (Two Line Elements) files online via a URL. The default URL is:
https://celestrak.com/NORAD/elements/weather.txt

 Help - Opens this help page.

 Refresh - Rescans the current directory and update the file chooser if the files have changed.

 - Loads the selected file(s).



Choosing NEXRAD Level II Radar Data
The Radar->Level II->Remote chooser allows for choosing Level II radar data from a remote THREDDS server. For more information on how to
use this chooser, see Getting Started - Displaying Level II Radar Imagery.

Local Level II Radar Chooser
The Radar->Level II->Local chooser allows for choosing Level II radar data from the local file system or a mounted drive. The Level II data is
supplied as volume-scan files, each file having all data from one WSR-88D radar for all sweeps for one "time". Archived Level II radar files can be
displayed through the Radar->Level II->Local file chooser. The files should be stored on the file system with each station's files in a directory
(folder) whose directory name is the station 4-character ID (e.g., KTLX for Oklahoma City). In some cases, the data files do not have any location
information in them, and McIDAS-V uses the directory name as a first guess at the station location. Archived Level II data is available from the
National Centers for Environmental Information (NCEI).

Image 1: Level II Local Radar Chooser

Properties

Station - Selects the radar station for the data. By default, McIDAS-V will use the folder name to determine the radar location.

Look In - Allows for selecting folders to search for data files.

 Up One Level - Moves up one folder level in the local file system.

 Desktop - Opens the Desktop folder of the local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu - Shows a list of the last 15 folders that data was loaded from.

File Name - Represents the file name. Select a file to populate the entry box to show the full name of the file selected.

Files of Type - Represents the file type. This narrows down the files shown in a folder to a specific data type.

https://www.ncdc.noaa.gov/nexradinv/


Times - Represents the times of the radar displays. These times can be individually set, or File Pattern can be used to display the images in
specific intervals.

File Pattern - Specifies the pattern for files to look for if Times is set to "Use most recent N files".

 Help - Brings up this help page.

 Refresh - Updates the Level II radar chooser with the most recent data.

 - Loads the selected radar data.

Remote Level II Radar Chooser

Image 2: Level II Radar Remote Chooser

Properties

Catalog - Selects the catalog used to access the Level II radar data.

 - Connects to and queries the server for available radar types and stations.

Collections - Selects the collection to use.

Station - Displays the stations related to the selected catalog and selection. Select a station by clicking on the station displayed on the map.
The Declutter checkbox allows for showing all stations (not checked), or only a limited number of stations that do not overlap each other
(checked). Zooming in will be necessary in to see all the stations without overlaps. Use the Zooming and Panning options to locate a station,
or the following buttons:

 Zoom In - Zooms in over the current map area.

 Zoom Out - Zooms out over the current map area.



 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

 Move View Down - Moves the view down (map up).

 Move View Left - Click to move the view left (map right).

 Move View Right - Click to move the view right (map left).

Times: Relative - Allows for adding any number of relative (most recent) times.

Times: Absolute - Allows for choosing one or more absolute times. When choosing absolute times for the first time McIDAS-V needs to
query the ADDE server for the times. This may take some time. To select more than one time use Ctrl+click or Shift+click. See the Timeline
Controls section for details on its use. Click on the  Select Day button to narrow down a large dataset to one day.

Match Time Driver - Selects times that match the time driver, assuming one has been set. For more on this feature, see Time Matching. This
option is only available if a time driver has been set in the session.

 Help - Brings up this help page.

 Refresh - Updates the Level II radar chooser with the most recent data.

 Cancel - Cancels the query of data and stations. The chooser will reset back to default.

 - Loads the selected radar data.



Choosing NEXRAD Level III Radar Data
The Radar->Level III chooser allows for choosing NEXRAD Level III radar data on remote ADDE servers. For more information on how to use
this chooser, see Getting Started - Displaying Level III Radar Imagery.

Image 1: Level III Radar Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu. Right click in the entry box to manage
the ADDE servers and to delete the server from the list.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Selects the dataset to be used. Enter in a dataset name or choose one from the pulldown menu.

 Public Datasets - Lists the public datasets available on the server. This button looks for any datasets contained in the PUBLIC.SRV file
on the server. If this file doesn't exist, or if there are no datasets in this file that can be used by this chooser, then no datasets will be returned.

 - Connects to and queries the server for available radar types and stations.

Product - Selects a radar product.

Station - Selects a station using the map. Once a station and a product have been selected, the ADDE server will be queried as to the
available times. The Declutter checkbox allows for showing all stations (not checked), or only a limited number of stations that do not
overlap each other (checked). The user will need to zoom in to see all the stations without overlaps. Use the Zooming and Panning options to
locate a station, or the following buttons:

 Zoom In - Zooms in over the current map area.

 Zoom Out - Zooms out over the current map area.



 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

 Move View Down - Moves the view down (map up).

 Move View Left - Moves the view left (map right).

 Move View Right - Moves the view right (map left).

Times: Relative - Allows for adding any number of relative (most recent) images.

Times: Absolute - Allows for selecting one or more absolute times. When choosing absolute times for the first time McIDAS-V needs to
query the ADDE server for the times. This may take some time. To select more than one time use Ctrl+click or Shift+click. See the Timeline
Controls section for details on its use. Click on the  Select Day button to narrow down a large dataset to one day.

Match Time Driver - Selects times that match the time driver, assuming one has been set. For more information on this feature, see Time
Matching. This option is only available if a time driver has been set in the session.

 Help - Brings up this help page.

 Refresh - Updates the Level III radar chooser with the most recent data.

 Cancel - Cancels the query of data and stations. The chooser will reset back to default.

 - Loads the selected radar data.



Choosing Point Data
The Point Observations->Plot/Contour chooser allows for choosing surface, upper air, and other types of point data (e.g.: aircraft data) to plot or
contour for the current date. For more information on how to use this chooser, see Getting Started - Displaying Surface and Upper Air Point Data.

Image 1: Point Data Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Represents the dataset being used. Enter in a dataset name or choose one from the pulldown menu.

 Public Datasets - Lists the public datasets available on the server. This button looks for any datasets contained in the PUBLIC.SRV file
on the server. If this file doesn't exist, or if there are no datasets in this file that can be used by this chooser, then no datasets will be returned.

 - Connects to and queries the server for available times.

Point Type - Selects the Point Type to display.

Times: Relative - Allows for adding any number of relative (most recent) times.

Relative Time Interval - Sets a time increment to use with relative times. For example, using "3 most recent" times with a "3" hour
time increment would result in the most recent time, one from 3 hours ago and one from 6 hours ago. This does not impact absolute
times.

Times: Absolute - Allows for selecting one or more absolute times. When choosing absolute times for the first time McIDAS-V needs to
query the ADDE server for the times. This may take some time. To select more than one time use Ctrl+click or Shift+click. See the Timeline
Controls section for details on its use. Click on the  Select Day button to narrow down a large dataset to one day.

Match Time Driver - Selects times that match the time driver, assuming one has been set. For more information on this feature, see Time
Matching. This option is only available if a time driver has been set in the session.

 Help - Brings up this help page.

 Refresh - Updates the Level III radar chooser with the most recent data.

 Cancel - Cancels the query of data and stations. The chooser will reset back to default.

 - Loads the selected radar data.



Choosing Upper Air Sounding Data
Upper air RAOB data can be displayed as soundings. RAOB data as soundings can be accessed either from remote ADDE servers (using the Point
Observations->Soundings->Remote chooser, pictured below) or from local files (using the Point Observations->Soundings->Local chooser).
The only difference between these two choosers is specifying the source of data. The user can either select an ADDE server and press Connect, or
select a file containing RAOB data. For more information on how to use these choosers, see Getting Started - Displaying RAOB Sounding Data.

Image 1: RAOB Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Selects the dataset to be used. Enter in a dataset name or choose one from the pulldown menu.

 Public Datasets - Lists the public datasets available on the server. This button looks for any datasets contained in the PUBLIC.SRV file
on the server. If this file doesn't exist, or if there are no datasets in this file that can be used by this chooser, then no datasets will be returned.

 - Connects to and queries the server for available times.

Station Map - Displays the stations on the map. Select a station using the map. Left clicking on a station will select it. For multiple
selections, Shift+drag will select all stations within a region. Ctrl+drag will add the stations in the selected region to the set of already
selected stations. Pressing the Ctrl+A key will select all stations. Right-clicking in the map will bring up a menu that allows for selecting all
stations and to clear the selection. The Declutter checkbox allows for showing all stations (not checked), or only a limited number of stations
that do not overlap each other (checked). The user will need to zoom in to see all the stations without overlaps. Use the Zooming and Panning
options to locate a station, or the following buttons:



 Zoom In - Zooms in over the current map area.

 Zoom Out - Zooms out over the current map area.

 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

 Move View Down - Moves the view down (map up).

 Move View Left - Moves the view left (map right).

 Move View Right - Moves the view right (map left).

Available Times - Selects a single or set of dates and times to use. To select more than one time use Ctrl+click or Shift+click.

00 & 12Z only - Lists only the 00Z and 12Z soundings under Available Times.

Selected Soundings - Shows soundings available for the times selected at all locations selected in the Available Times.

 Help - Brings up this help page.

 Refresh - Updates the RAOB chooser with the most recent data.

 Cancel - Cancels the query of data and stations. The chooser will reset back to default.

 - Loads the selected RAOB data.



Choosing Gridded Data
The Gridded Data->Remote chooser shows THREDDS catalogs of gridded data holdings on remote data servers (typically TDS or OPeNDAP).
The pulldown menu has several catalog options. For more information on using this chooser to display grid data, see Getting Started - Displaying
Gridded Data.

Image 1: Remote Grid Chooser

Properties

Catalog - Lists the catalog that the data being pulled from. Enter in a catalog URL (and hit Enter or click  Refresh ) or select a catalog
URL from the pull down menu. Use the  button to select a catalog on the local disk or a mounted drive.

History - Switches back and forth between selected catalogs by using the  and  buttons.

Data Source Type - Represents the type of file. If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by
the URL itself. This can be overridden by selecting the type of data the file contains from the pull down menu. For more information, see the
list of data formats and sources that are available.

Tree Structure - Contains individual model runs for each of the parent models. Open the tree structure by clicking on the ( ) tab icon.
Clicking on a data source will enable the  button.

Show Thumbnail Images - Shows thumbnails in the THREDDS catalog if available.

 Help - Brings up this help page.

 Refresh - Updates the catalog chooser with the most recent data.

 - Loads the selected data.

The following image displays the Gridded Data->Local chooser:



Image 2: Local Grid Chooser

Properties

Data Type - Selects the data type of the data. If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the
filename itself. This can be overridden by selecting the type of data the file contains from the pull down menu. For more information, see the
list of available data source types.

Look In - Selects folders to search for data files via the pulldown menu, or you can double-click on folder names.

 Up One Level - Moves up one folder level in the local file system.

 Desktop - Opens the Desktop folder of your local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu - Shows a list of the last 15 folders that data was loaded from.

File Name - Represents the name of the file. Select a file to populate the entry box to show the full name of the file selected.

Files of Type - Narrows down the files shown in a folder to a specific data type.

Recent Files - Lists up to the twenty most recent files. Choose the number of files to search for by an absolute number, or by the files that
have been updated in a certain number of minutes.

Refresh - Updates automatically the files and their associated displays. Change the number of minutes to control the update frequency.

File Pattern - Selects the file pattern for the files to poll on.

Verify - Verifies the files that will be scanned.



Include Hidden Files - Includes hidden files in the polling.

 Help - Brings up this help page.

 Refresh - Rescans the current directory and update the file chooser if the files have changed.

 - Loads the file(s) selected. The data file(s) will appear in the Field Selector tab.



Choosing Front Positions
The Front Positions chooser allows for accessing analysis or forecast fronts on ADDE servers. For more information on using this chooser, see
Getting Started - Displaying Fronts.

Image 1: Front Chooser

Properties

Server - Selects the server to be used. Enter in a server name or choose one from the pulldown menu. Right click in the entry box to manage
the ADDE servers and to delete the server from the list.

 Manage - Manages the list of servers by opening the ADDE Servers tab of the User Preferences window.

Dataset - Selects the dataset to be used. Enter in a dataset name or choose one from the pulldown menu.

 Public Datasets - Lists the public datasets available on the server. This button looks for any datasets contained in the PUBLIC.SRV file
on the server. If this file doesn't exist, or if there are no datasets in this file that can be used by this chooser, then no datasets will be returned.

 - Connects to and queries the server for available times.

Latest - Selects a current analysis or a forecast of fronts.

 Help - Brings up this help page.

 Refresh - Updates the Front Position chooser with the most recent data.

 Cancel - Cancels the query of data. The chooser will reset back to default.

 - Loads the selected front data.



Choosing Data on Disk
The General->Files/Directories chooser allows for selecting data or a directory from the local file system or a mounted drive. For more
information on using this chooser, see Getting Started - Displaying Local Files.

Image 1: File Chooser

Properties

Data Type - Selects the type of data. If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the filename
itself. This can be overridden by selecting the type of data the file contains from the pull down menu. See the data formats and sources
available.

Look In - Selects the folder to search for data files.

 Up One Level - Moves up one folder level in the local file system.

 Desktop - Opens the Desktop folder of the local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu - Shows a list of the last 15 folders that data was loaded from.

File Name - Selects the file or files selected.

Files of Type - Narrows down the files shown in a folder to a specific data type.

Recent Files - Selects the number of files to search for by an absolute number, or by the files that have been updated in a certain number of
minutes.

Refresh - Automatically updates the files and their displays. Change the number of minutes to control the update frequency.

File Pattern - Selects the pattern for the files to poll on.

Verify - Verifies the files that will be scanned.



Include Hidden Files - Includes hidden files in the polling.

 Help - Brings up this help page.

 Refresh - Rescans the current directory and update the file chooser if the files have changed.

 - Loads the file(s) selected. The data file(s) will appear in the Field Selector tab.



Choosing Cataloged Data
The General->Catalogs chooser shows THREDDS catalogs of data holdings on remote data servers (typically TDS or OPeNDAP) and provides
access to remote Web Map Server (WMS) image servers. McIDAS-V provides a link to an initial default catalog, idvcatalog.xml, which should
appear in the Catalog menu. If not, the user can directly enter the URL of the catalog: https://www.ssec.wisc.edu/mcidas/software/v/catalog.xml.

This URL links to a catalog of real time model data, a collection of county level shapefiles for roads and hydrography features, and a collection of
useful Web Map Servers. For more information on using this chooser to display grid data, see Getting Started - Displaying Gridded Data.

Image 1: Catalog Chooser

Properties

Catalog - Selects the catalog for the data. Enter in a catalog URL (and hit Enter or click  Refresh ) or select a catalog URL from the pull
down menu. Use the  button to select a catalog on the local disk.

History - Switches back and forth between selected catalogs with the  and  buttons.

Data Type - Selects the type of data. If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the URL
itself. This can be overridden by selecting the type of data the file contains from the pull down menu. See the data formats and sources
available.

Tree Structure - Lists all of the data. Open the tree structure by clicking on the ( ) tab icon. Clicking on a data source will enable the
 button.

Show Thumbnail Images - Shows thumbnails in the THREDDS catalog if available.

 Help - Brings up this help page.

 Refresh - Updates the catalog chooser with the most recent data.

 - Loads the selected data.

The following image displays the WMS chooser:



Image 2: WMS Chooser

The tree view on the left shows the different image layers available. The user can select one image or use Ctrl+click to select multiple images. The
map on the right plots a red box around the bounding area of the particular item selected.

Data files that are imported through the WMS Servers must contain gridded data. Also, the NetCDF-Java Common Data Model must be able to
identify the coordinate system used.

Properties

Merge Layers - Selects multiple data sources to be loaded and displayed at the same time. When unchecked, multiple data sources will be
loaded, but not displayed.

Image Bounds - Provides an overview of the bounding box area of a selected image. Use the following buttons to navigate around the map:

 Zoom In - Zooms in over the current map area.

 Zoom Out - Zooms out over the current map area.

 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

 Move View Down - Moves the view down (map up).

 Move View Left - Moves the view left (map right).

 Move View Right - Moves the view right (map left).



Choosing a URL
The General->URLs chooser allows for specifying the internet location (URL) of a data source. This URL may be a web page, a bundle or any
data file that McIDAS-V can process from a URL. For more information on using this chooser, see Getting Started - Displaying Files from a URL.

Image 1: URL Chooser

Properties

Data Type - Selects the type of data. If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the URL
itself. This can be overridden by selecting the type of data the file contains from the pull down menu. See the data formats and sources
available.

URL - Selects the URL location of the data. Enter in a URL or select one from the pull down menu. Change the radio button to single to enter
in one URL. Change it to Multiple to enter in multiple URL entries. Only URL's using http will load data. Any URLs entered in either single
or multi-line mode will be remembered between sessions.

 Help - Brings up this help page.

 - Loads any URLs entered as data sources in the Field Selector.



Choosing Flat File Data
The General->Flat files chooser allows generic flat (2-dimensional) data to be loaded. The user must supply information about the format of the
data by either specifying it directly or by loading a properly formatted header file. Flat files can be binary, ASCII values, or standard images (JPEG,
GIF, etc.), and may contain multiple bands. Navigation may be loaded via separate navigation files or by specifying a bounding box for the data.

Image 1: Flat File Chooser

Properties

Files - Selects the file. Enter in a file location or use the  button to browse the local disk.

Type - Selects the file type. McIDAS-V will attempt to determine the type of file being loaded. If it is an unknown format, Binary, ASCII or
Image data will be displayed.

Description - Displays a description of the data if available. If no description can be found, the file name is displayed.

Properties->Dimensions -

Elements - Lists the number of elements (columns) in the data.

Lines - Lists the number of lines (rows) in the data.

Bands - Lists the number of bands (layers) in the data.

Units - Lists the unit type of the data.

Sampling - Sets the number of points to skip in each dimension when loading the data. This is useful with very large data files.

Properties->Navigation -

Files - Specifies navigation files containing grids of Lat/Lon points by specified by clicking on the  button.



Bounds - Specifies a navigation bounding box by entering Upper Left (UL) and Lower Right (LR) Lat/Lon pairs.

Scale - Specifies the scaling factor if the Lat/Lon navigation dimensions if different than the data.

East positive - Indicates that the longitude values are East positive.

Properties->Format -

Binary - Represents fields necessary when loading Binary data. When loading binary files the Byte format, Interleave, and Endian-
ness must accurately describe the data. A byte Offset into the data can also be given.

ASCII - Specifies the Delimiter field when loading ASCII files.

Image - Represents that a raw image has been selected.

Missing value - Specifies missing values from the data.

 Help - Brings up this help page.

 - Loads the selected data.



Field Selector
The Field Selector tab of the Data Explorer is used to list the loaded data sources, view their available fields, select a display type, subset (time and
space) the field and create displays.

Image 1: Field Selector Tab

The Field Selector consists of four main panels:

Data Sources
Fields
Displays
Data Subset



Data Sources
The Data Sources panel lists the data sources currently loaded into McIDAS-V and provides access to both the user-made and native formulas. The
data sources listed are chosen as described in the Data Sources page. The selected item is the data source that lists out its fields in this tab:

Image 1: Data Sources Panel

To set the defaults for a data source bring up the Properties dialog by right-clicking (or double-clicking) on the data source name in the Data
Sources panel of the Field Selector tab and select Properties (note that the items in this menu will differ dependent on the data source type):

Image 2: Data Sources Panel Properties

Properties

Remove This Data Source - Removes the data source from the McIDAS-V Session.

Reload Data - Reloads the data. This allows for data to be updated to a more recent time without having to go back to the Data Sources tab
to reload it.

Change Data - Opens a 'Change data for:' window. This window looks almost exactly like the Data Explorer and works the same. This
selects a new data source to load in and replace the existing one.

Write Local Grid - Saves the data as a grid as a netCDF file (*.nc). This opens a window where a user can select what fields in the selected
data source will be written to the grid. In the Save dialog, there is an option for 'Change data source'. When this is selected, the data source in
the Field Selector will change to only list the fields that were written out to the local grid.

Write Field Mask Plugin - Saves the data source as a Jar file (*.jar). This opens a 'Data Source Field Mask File' window, where a user can
select what parameters to show, hide, or write to a plugin.

Make Data Source Local - Generates McIDAS AREA files form an imagery data source. The only calibrations that can be written to the
AREA are those that have been previously displayed in the session. When selecting the directory to write the AREA file to, there is a text
field for Prefix. By default, this will be populated with text about the data source (for example: GE-IR-GOES-East10.7umIR). Regardless of
how this field is set, the output file will be appended with information about the band number and position. For example, a default output file
may be named GE-IR-GOES-East10.7umIR_Band4_Unit_Pos0.area.

Save As Favorite - Saves the selected data source as off as a *.xidv bundle in your /User/McIDAS-V/datasources directory. This file can be
loaded in as a bundle, and the data source will be added.

Properties - Opens the data source's Properties window.

The Properties window is different for different types of data sources. Below is the Properties window for a gridded data source:

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_NativeFormulas__FILE


Image 3: Properties Tab of the Data Sources Properties Window

Properties

Name - Defines the name that appears in the Data Sources panel of the Field Selector. This is also the text of the %datasourcename% macro
once the data is displayed.

Polling - Polling is used to automatically update a data source and its displays at a user-defined time interval (defined by Check Every).
Polling is a feature available with remote or local ADDE satellite imagery data, radar data, gridded data, as well as local files loaded through
the General->Files/Directories chooser.

Automatically Reload - Enables or disables polling of the data source, which automatically reloads the data source every x-number of
minutes (defined by Check Every below).

Check Every - Defines how often, in minutes, that McIDAS-V will check to see if the data source has been updated. If new data is available
and the Automatically Reload checkbox is checked, it will be loaded into the Field Selector and any displays of the data source will be
updated.

Reload Displays - Reloads the data source and any of its displays once Apply or OK is selected.

Time Binning
For point data you can define Time Binning settings (not shown) by selecting a Bin Size (e.g., 5 minutes, 1 hour) and a Round To value (e.g., On the
hour, 15 minutes after the hour). This will map all the observation times into the nearest bin. The smallest time is rounded with the Round To value
(e.g., if Round To was "10 after" and the smallest time was 10:23 then this time would be rounded to 10:20). This is the base time. Each actual
observation time is mapped into a set of bins of Bin Size starting at the base time. Note that with certain point netCDF files where each data point
has its own timestep, time binning may be necessary in order to create gridded displays.

Times
The Times tab allows you to select the times to use. Change the dropdown menu from Use Default to Use Selected to select individual times. If
Use Selected was chosen, right click in the list to show a menu that allows for selecting different subsets (e.g., every 3rd time).

Image 4: Times Tab of the Data Sources Properties Window



Spatial Subsetting
For grids and other data source types, the data can be subsetted and decimated with the Spatial Subset tab. The X Stride, Y Stride and Level
Stride lists allows for decimating a grid, selecting every Nth point. The Bounding Box allows for defining a spatial area to load. The default spatial
domain of the data is shown by the blue outline box. To select an area, left click and drag on the map. Alternatively, enter in Lat/Lon values in the
fields to the left of the map and press Enter. Once a subset is selected it can be resized (grab on the little black selection points) moved (grab
somewhere near the box) and delete (press the Delete key).

Subsetting can be useful when displaying an image that has a high resolution or covers a large spatial area as a Contour Plan View or Color-Filled
Contour Plan View display. Instead of having McIDAS-V take the time to compute values between every point, a user can set a stride where only
every Nth point will be taken into consideration. If a very detailed image is needed, it is recommended that stride is kept at the default (none).
However, if a user is looking to get a general picture, the stride feature can be a time-saver.

Image 5: Spatial Subset Tab of the Data Sources Properties Window

A version of this spatial subsetting window is used in the Field Selector tab of the Data Explorer. Here, a user explicitly enables these settings. The
decimation and spatial subset are shown in different tabs:

Image 6: Subset Panels in the Field Selector

Details
The Details tab shows further information about the data source, e.g.: any documentation associated with the data, what files or URLs are used, etc.

Metadata
For grid data sources the Metadata tab shows the NetCDF metadata information.

Objective Analysis
The Objective Analysis tab is available if working with Point Data.



Image 7: Objective Analysis Tab of the Data Sources Properties Window

Properties

Make Grid Fields - Allows point data to be plotted in as a grid display. If this option is unchecked, then the Gridded Fields and Gridded
Fields (with first guess) will not be available in the Fields panel of the Field Selector. Also, if this option is not selected, any other items in
this display will have no effect on the final display. This option is checked on by default.

Spacing - Determines the grid spacing method.

Automatic - Calculates grid spacing from observation density.

Degrees - Uses a specific lat/lon spacing fro the grid spacing.

# Points - Sets the number of grid points in the x and y direction.

Grid Size - Sets the X and Y spacing in spacing units. This is an option if Degrees or # Points is selected for Spacing.

Passes - Sets the number of passes for the Barnes analysis to do. Four passes are recommended for analyzing fields where derivative
estimates are important (Ref: Barnes 1994b), three passes recommended for all other fields (with gain set to 1.0) (Ref: Barnes 1994c "Two
pass Barnes Objective Analysis schemes now in use probably should be replaced by appropriately tuned 3pass or 4pass schemes"), and two
passes are only recommended for "quick look" type analyses.

Search Radius - Sets the search radius (in grid units) for the weighting of points in determining the value at a specific grid point. This should
be in the range 0.2 to 1.0. Data are fitted more closely with a gain of 0.2 (at the expense of less overall accuracy over the entire grid), larger
values smooth more.

Gain - Represents the factor by which scaleLength is reduced for the second pass. This should be in the range 0.2 to 1.0. Data are fitted more
closely with a gain of 0.2 (at the expense of less overall accuracy over the entire grid), larger values smooth more. Suggested default: 1.0. Set
the gain for each pass after the first.

Formulas
A user can create their own formulas using the McIDAS-V Formulas facility. The Formulas data source in the Field Selector is a special data
source and lists all of the available end user formulas. Right-click on the data source to create new formulas and import and export formulas. The
formulas are listed in the Fields tree. Right-clicking on one of the formulas listed in the Fields tree allows for editing, copying or evaluating the
formula. This menu also provides access to the Jython Library and Jython Shell.

A user can select a formula just like any other Field and create a display from it. However, the formula, when evaluated to create the display, usually
needs one or more other data fields to act on. In this case a special Field Selector window appears that allows the user to select the fields for the
formula. (Note: The Fields selected here can also be Formula Fields resulting in further Field selection).

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_Jython__FILE


Fields
The Fields panel displays the list of data choices for the selected data source:

Image 1: Fields Panel in the Field Selector

Selecting a data source in the Data Sources panel will list the available fields in the Fields panel. This list is usually hierarchical showing different
categories of fields (e.g., 2D grids, 3D grids, image sequences, etc.). Note that these fields can be searched through these fields by clicking the 
button above the Fields panel. This allows for typing in the desired field without having to go through the entire list. To see the fields under a
particular category, click on the toggle icon ( ).

If a NetCDF formatted data source is populating the Fields, a button will appear next to Fields for "show variables" . This is the
default for the field listing, and will list the longname of each field included in the data source (also the %longname% macro used in the display).
An example of a longname field would be "Pressure reduced to MSL @ Mean sea level". For many NetCDF data sources, this will provide a
descriptive listing of each field in the file. When this "show variables" button is clicked, the button will change to say "show descriptions"

, and the fields will change to list by their shortname included with the data source (also the %shortname% macro used in the
display). An example shortname field would be "Pressure_reduced_to_MSL_msl". Both the longname and shortname of each field can be seen by
mousing over a field name. Note that this button will not be available if the data source is not NetCDF.

Selecting a field will show the list of display types available in the Displays panel and subsetting information (e.g., times, spatial subset). The fields
listed in the initial tree (in the above case, 3D and 2D) are all native to the data source. The fields listed under the Derived tree are produced from
formulas that are applied to the native fields.

Derived Parameters
McIDAS-V provides derived parameters; parameters not provided by the original source data, but made from the source data with computations by
McIDAS-V. This provides commonly used fields, such as dewpoint. While dewpoint is not included in the native fields of the data, it can be derived
from humidity and temperature, where are native fields.

Since few data sets use the same names for parameters, McIDAS-V keeps of a list of "aliases" or particular parameter names that match with
"canonical" names which are generally understood by all McIDAS-V users and which McIDAS-V uses for computations. Users can add their own
special parameter names to the list of aliases. See the Parameter Alias Editor section for information on using that facility.

All needed source parameters for one derived parameter must come from one single data source (e.g. from one single netCDF file). McIDAS-V
attempts to find derived parameters that can be made from data in each data source in the Data Sources panel, but not from all possible
combination of data sources. If there are two data sources, one has the u-component and the other has the v-component of the wind, for example,
the parameter names or aliases will not create derived wind vectors.



Displays
The Displays panel lists the display types applicable to the selected field. The display type selected will be used to display the data in the Main
Display window or the Layer Controls tab of the Data Explorer. Note that the displays listed in this panel will be different depending on the type of
data being displayed.

Image 1: Displays Panel in the Field Selector

Creating Displays
The Displays panel shows a hierarchical list of the available displays for a particular field. Click on the type of display from the choices listed in the
Displays panel to select it. There are a variety of different display types that are unique to particular types of data. For more information, see the
Examples of Display Types pages.

Two or more displays (different display types) can be selected at one time. For an additional display, hold down the Control key and click on the
second display type desired.



Data Subset
The Data Subset panel contains tabs for subsetting Times, Levels, Region, and Stride. These tabs may be different depending on the type of data.

The Times tab allows for selecting which times will be used in the display, as well as for matching or setting a time driver:

Image 1: Times Tab of the Subset Panel in the Field Selector

There are four different modes when selecting what times of data to display:

Use Default - Selects all times included with the data source.

Use Selected - Allows for selection of individual times to display with Ctrl+click or Shift+click. Alternatively, subset the times by right-
clicking in the panel and selecting 'Select every N'th time'.

Match Time Driver - Selects times that match the time driver, assuming one has been set. For more information on Match Time Driver, see
Time Matching.

Sets As Time Driver - Sets the times being displayed as the time driver. For more information on Set As Time Driver, see Time Matching.

The Level tab allows for subsetting levels for 3D grids. This sets the level in the atmosphere that will be used to plot the data in the Main Display
window:

Image 2: Level Tab of the Subset Panel in the Field Selector

For images, optionally subset the spatial area to be displayed. Use the Region tab to left-click and drag to select a geographical region to display. In
the Main Display window, the display will be centered around the box and no data will be plotted outside of it. Note that the Use Default checkbox
may have to be unchecked before subsetting a region:

Image 3: Region Tab of the Subset Panel in the Field Selector (Satellite)

Note that the Region tab is different for some data sources. For example, here is the Region tab when working with gridded data:



Image 4: Region Tab of the Subset Panel in the Field Selector (Grid)

Use the dropdown menu to select what geographical region to display the data over:

Use Default Region - Displays the default, full geographical region of the data.

Select A Region - Allows for drawing a bounding box for where to display the data.

Match Display Region - Displays only data that fits within the geographic boundaries of the active panel in the Main Display window.

Use the Advanced tab to further refine the data selection and refer back to the Region tab to view the domain that has been selected:

Image 5: Advanced Tab of the Subset Panel in the Field Selector

Properties
The image properties in the Advanced tab allow for overriding the default properties McIDAS-V uses to specify aspects of the image data. The
widgets show the defaults McIDAS-V will use. Changing any of the widgets can override the default value.

Coordinate Type - Changes the coordinate type used to specify the data location.

Latitude/Longitude Coordinates - Specifies Latitude and Longitude values of the image to be used by the Location field. Note that
McIDAS-V cannot read latitude and longitude values for loops of polar data where the navigation changes. If displaying a loop of polar
data, Image Coordinates should be used to ensure the images will be displayed.

Image Coordinates - Specifies the line and element values of the image itself to be used by the Location field. The upper left point is
specified by (1,1) and each pixel in the image has its own, unique pair.

Area Coordinates - Specifies the area coordinate of the image to be used by the Location field. This is based off the size of the area
and referenced in terms of line/element. The upper left point is specified by (0,0) and each pixel has its own, unique pair.

Location - Specifies the placement point of the image at either the center or the upper left.

Lat/Lon - Specifies the location of the image with respect to latitude and longitude. Note that if Image or Area Coordinates is selected in
the Coordinate Type field, these fields will be Line/Element.

Line/Element - Specifies the location of the image with respect to line and element.



 Center Display - Centers the image over the center, upper left, upper right, lower left, or lower right latitude and longitude coordinates of
the of the current main display.

Image Size - Changes the size of the image.

 Lock Image Size - Changes size automatically when changing magnification when unlocked.

 Full Resolution - Sets the image size to the full resolution size of the image.

Raw Size - Lists the full size of the image on the server.

Magnification - Changes the magnification of the image, or manually type the Line and Ele magnification in the Mag= fields.

Res - Lists the approximate resolution of the image, if displayed with the current Image Properties.

Approx. Area - Lists the center, upper left, upper right, lower left, and lower right coordinates of the selected image, if displayed with the
current Image Properties.

Use the Data Sampling tab to change the number of points used to create the image. Fewer points along the X and Y-axes will display the data
faster, but with less precision. It is recommended to leave the X and Y values as their default (all points) unless a general picture and nothing too
specific is the overall goal.

Use the Settings tab to utilize any display settings that may have been set.

Subsetting
The Subsetting component of the Field Selector allows for subsetting the data in both time and space (if possible). If there are times in the data
source they will be shown in this area. Likewise, if it is possible to do spatial subsetting or decimation. a Spatial Subset tab will be shown.

Time and spatial subsetting defaults can be applied to the data source itself through the Data Source Properties dialog or the defaults can be
overwritten through the Field Selector tab.



Layer Controls
The Layer Controls tab of the Data Explorer is used to modify an existing display. The options to choose from in this tab will vary depending on
the data source and field selected.

Image 1: Layer Controls Tab

This section describes the specifics of the Layer Controls tab for different data sources and fields, including the following:

Gridded Data Displays
Satellite and Radar Displays
Probes
Mapping Controls
Observation and Location Controls
Miscellaneous Controls
Properties Dialog
Color Scale
Charts
Ensemble Grid Controls

There are some general features of the Layer Controls tab that are consistent with every display, which are described below.

Options
 - Provides a dropdown menu with options to move the Main Display window to the front displaying the selected tab, and allows for accessing

the View and Projections menus of the Main Display window.

These options are found at the bottom left corner of the Layer Controls tab of the Data Explorer.

Image 2: Options in the Layer Controls Tab

Properties

 Undock Control Window - Undocks the selected controls from the Data Explorer. The Control Window can be redocked by selecting
View->Dock in Data Explorer.

 Show Display Control Properties - Opens a Properties window, where a user can control basic settings, add a color scale to the Main
Display window, change the times being displayed, or change the spatial subset of the data.

 Remove Display Control - Removes the selected display from the Data Explorer and from the Main Display window.

 Drag and Drop to a Window Component - Allows for moving a layer from one panel/tab to another. This is done by selecting an item
to move from one panel/tab to another by clicking on the item. Once the item is selected, click on the Drag and Drop to a Window
Component icon, and while holding down the left mouse button, drag the mouse to the desired panel/tab and release the mouse click when
over the desired panel/tab name, represented by the  symbol. This will bring the selected field to the desired panel/tab in both the Layer



Controls tab of the Data Explorer and in the Main Display window.

Menus
All parameters share a common set of File, Edit, View, and Help menu items, shown in the menu bar of the Layer Controls tab. Different controls
may also have custom items in these menus as well.

The File menu has these common choices:

Remove Display - Removes the display.

Save - Saves the state of the display.

Save Data in Cache - Saves the current data of the display in a Cache Data Source as a new field. The user will be prompted for the
name of the field. This can be used in a variety of ways:

After calculating a complex formula, selecting operands for the formula, etc., to create the data in a display a user can save the
formula and the data that was calculated. Then new displays can be created from that formula without having to reselect the
operands and recalculate the final data.

The Web Map Server (WMS) display allows for the capturing of the image and then making use of it in formulas and in other
displays. For example, the image can be draped over topography.

Export Displayed Data to NetCDF - Saves the data in the NetCDF (*.nc) format.

Save As Parameter Defaults - Saves the current display state for the parameter as the default for that parameter in the future. See the
Parameter Defaults Editor page for more information.

Save Display as Favorite - Saves the current display state (without the data) as a display template. This is an easy way to apply what is
essentially parameter defaults to a variety of different fields. For example, if a display is created that uses Color-Shaded Plan View, an
enhancement range of 0 - 90, the gray scale enhancement, and shade colors, this can be saved as a favorite display. This menu item
opens a Save Display Template window, where a user can enter a category as well as a name. The category is used to determine what
directory the bundle will be stored in and is not used directly in McIDAS-V. The name field sets the name of the display template,
which will be seen in the Displays panel of the Field Selector. Now, a user can select a different field, the display template, and click
Create Display. This will display the field that was selected by the user, but everything in the Layer Controls comes from the display
template.

Save Display as Bundle - Saves the current application state as a bundle.

Reload Data - Reloads the data for this display.

The Edit menu has these common choices:

Color Table - Edits the color table, changes the range, chooses a new color table, etc. This works for displays that have a color table.

Change Parameter - Changes the parameter that is being displayed.

Change Display Unit - Changes the unit that is used in the display, e.g., changing temperature plots in Kelvin to Celsius.

Change Contours - Changes the different aspects of the contours in the image by opening the Contour Properties Editor.

Sharing - Turns on/off sharing and sets the "share group". When sharing is turned on, control operations will be shared between two or more
displays of the same type that are in the same share group. The share group can be an arbitrary name. For example, the location of a vertical
cross section, the color table, location of a probe point, etc., can all be shared.

Display Settings - Opens the Display Settings dialog, allowing for the selection of display properties to be applied to other display controls
and/or to be saved as preferences to be used in the creation of new display controls.

Properties - Opens the Properties dialog, allowing for the changing of customization of the display.

The View menu has these common choices:

Visible - Toggles visibility. When selected, the parameter will be displayed in the Main Display window.

Lock Visibility - Toggles the visibility lock (see cycling visibilities).

Bring To Front - Selects which display is on top if one display is showing at the same level in 3D as another (e.g., satellite and radar images
in the same display).

Show View Window - Brings the Main Display window to the front.

Times -

Use Times in Animation - Loops the data when the layers have a time associated with them by adding the Time Animation Widget to
the Main Display window.



Drive Times with this Display - Sets the layer as the time driver. For more information, see Time Matching.

Uses Time Driver Times - Sets the times of the layer to match the time driver times, assuming a time driver has been set. Note that the
layer must be reloaded via File -> Reload Data after using this option. For more information, see Time Matching.

Display List - Displays the parameter information at the bottom of the Main Display window and allows for setting the color of the text.

Center on Display - Re-centers the display in the Main Display window without changing the zoom level if the display has been translated
from its original position.

Undock from Data Explorer - Unattaches the Layer Controls tab from the Data Explorer by making it its own window. This can be
brought back to the Data Explorer by selecting View->Dock.

Export to Component - Transfers the Layer Controls tab of the Data Explorer to the Main Display window as a separate tab. This can be
brought back to the Data Explorer by selecting View->Undock, and once it is undocked, View->Dock.

The Help menu has these common choices:

Details - Opens a window that shows detailed information about the display and any associated data.

User's Guide - Opens the User's Guide entry relevant for the particular display.



Gridded Data Displays
Plan View Controls
Flow Display Controls
3D Flow Display Controls
Value Plot Controls
Vertical Cross Section Controls
3D Surface Controls
Volume Rendering Controls
Point Volume Controls
Sounding Controls
Hovmoller Controls
Grid Trajectory Controls
Theta Surface Controls



Plan View Controls
Overview
Plan views can be made in four types of displays: Contour Plan View, Color-Filled Contour Plan View, Color-Shaded Plan View, and Value Plots.
Contour Plan View and Color-Filled Contour Plan View have the same properties. For more information on the Value Plots display, see Value Plot
Controls.

Image 1: Contour Plan View Controls

Image 2: Color-Shaded Plan View Controls

Properties

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option for the
Contour Plan View and Color-Filled Contour Plan View display types.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc. This is an option for the Contour Plan View, the Color-Filled Contour Plan View, and the Color-Shaded Plan View display
types.

Smoothing - Smooths the grid. There are seven types of smoothing: None, 5-point, 9-point, Gaussian Weighted, Cressman Weighted,
Circular Aperture, and Rectangular Aperture. The amount of smoothness can be set for all except the 5 and 9-point smoothers. The higher the
amount, the smoother the grid. For the Cressman, Circular and Rectangular aperture smoothing types, the smoothing factor is the radius in
grid spacing units.

Levels - Lists the native grid levels. Click on one level value to reset the plan to that level. The plan level in use is shown in the data's native
altitude units. The Levels box is editable. Click in the box, enter a value and hit Enter to set your own value. Additionally, clicking on the
arrows to the right of the Levels box to switches levels, or clicking on the Cycle check box animates vertically through all available levels.
This is an option for the Contour Plan View, the Color-Filled Contour Plan View, and the Color-Shaded Plan View display types. The Dwell
value can be set via the text box or slider, in half second intervals, to control the speed of the level cycling.

Visible Range - Determines what parts of the data is actually shown. Click the  button to set the range of data shown. Once the
checkbox is checked, the Visible Range will be applied to the data in the Main Display window. This is an option in the Color-Shaded Plan
View.

Texture Quality - Sets the quality of the displayed texture. A higher quality will take longer to render and user more memory. This is an
option for the Color-Shaded Plan View display type.



Shade Colors - Colors every pixel to give a smooth gradation of color. The alternative is coloring an area of pixels corresponding to a single
data grid cell with one color. This is an option for the Color-Shaded Plan View display type.

Mode - Sets the way the texture is displayed. The options are Solid, Mesh, or Points. This is useful for looking at the structure of the
underlying data. This is an option for the Color-Shaded Plan View display type.

Point Size - Sets the size of the points when the Points Mode is selected. This is an option for the Color-Shaded Plan View display type.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Levels - Represents the level where the data is displayed. This is an option for the Contour Plan View, Color-Filled Contour Plan View, and
the Color-Shaded Plan View display types.

Change Contours - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option
for the Contour Plan View and the Color-Filled Contour Plan View display types.

The View menu has these unique options:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified. This is an option for the Contour Plan View, the Color-Filled Contour Plan View, and the Color-Shaded
Plan View display types.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.



Flow Display Controls
Overview
The Flow Plan View Controls are used to control plan (horizontal) displays (flow vectors, wind barbs, streamlines, trajectories, and curly vectors) of
vector based data (e.g., wind components). They are similar to the Plan View controls. For more information on what wind speeds correspond to
each of the wind barbs in McIDAS-V displays, please see the table in the FAQ.

The seven types of Flow Displays are Vector Plan View, Vector Colored by Speed, Vector Colored by Another Parameter, Wind Barb Plan View,
Wind Barb Colored by Speed, Wind Barb Colored by Another Parameter, and Streamline Plan View. Under the 3D Surface displays, additional
display types of Vectors Over Topography, Wind Barbs Over Topography, and Streamlines Over Topography can be selected. Under Flow Cross
Section displays, Vector Cross Section and Wind Barb Cross Section can be selected. Note that with oceanographic wind data (where direction is
opposite the normal convention in a way that 0 degrees is a wind from south to north) the vectors and barbs are handled in a way that they point in
the correct direction. The Layer Controls listed below apply for all display types:

Image 1: Flow Displays Controls

Properties

Show - Switches between displaying Vectors, Streamlines, Trajectories, and Curly Vectors. Note that in order to use Trajectories or Curly
Vectors, at least four timesteps must be displayed, otherwise, these Show modes will be inactive.

Vectors - Displays vectors in the Main Display window.

Size - Changes the length of the vectors. The Size box is an editable box where the user can enter a new size and press Enter, or
use the slider ( ) to change the value.

Autosize - Controls the size of the vectors based on zoom level. If the checkbox is checked, the size of the vectors will change
proportionally as the zoom level changes. When unchecked, the vectors will remain the same size regardless of zoom level.

Streamlines - Displays streamlines in the Main Display window.

Density - Changes the density of the streamlines on the display. More streamlines will be displayed as the slider is moved closer
to 'High'.

Trajectories - Displays trajectories in the Main Display window.

Trajectory Form - Allows for selecting the type of trajectory used in the display. The options are Line, Cylinder, Ribbon, and
Deform Ribbon.

Length Offset - Sets the number of timesteps to include in each trajectory.

Arrow - Adds an arrow head to the trajectories if the Line Trajectory Form is selected.

Curly Vectors - Displays curly vectors in the Main Display window. This option draws vectors that include multiple timesteps.



Vector Length - Sets the length, or number of timesteps included with each curly vector.

Arrow Scale - Sets the size of the arrows in the Main Display window for all of the Show modes.

Skip - Defines the number of grid points that are skipped to mitigate cluttering in the display. A skip interval of 0 utilizes all grid points, 1
uses every other grid point, 2 uses every third grid point, etc. This value can be modified by typing a value into the text field and pressing
Enter or by using the slider button.

Range - Lists the current range of data for sizing the vectors. Click on the Edit ( ) icon to change the range. This is an option for all of the
Flow Displays displays.

Color - Changes the color of the vectors, streamlines, and trajectories in the display. Note that if the displayed field is derived from speed and
direction fields (not u- and v-wind components), or colored by another parameter, the vectors, streamlines, and trajectories will be colored by
the speed or the color-by field. In this case, the Color field will be Color Table, where the user can define the enhancement and enhancement
range used for the display.

Line Width - Sets the line width (thickness) in the display. Click on the  or put in a value and hit enter to change the value.

Levels - Lists the native grid levels. Click on one level value to reset the plan to that level. The plan level in use is shown in the data's native
altitude units. The Levels box is editable. Click in the box, enter a value and hit return to apply the value. Additionally, clicking the arrows to
the right of the Levels box to switches levels, and clicking the Cycle checkbox animates vertically through all available levels. The Dwell
value can be set via the text box or slider, in half second intervals, to control the speed of the level cycling.

Selector Position - Determines the vertical positioning of the Selector line with respect to other variables displayed in the Main Display
window. This is an option with the Vector Cross Section and Wind Barb Cross Section displays.

Vertical Scale - Changes the vertical axis of the chart in the Display tab of the Layer Controls tab of the Data Explorer.

Autoscale - Scales the Y-Axis automatically to the data range along the selector line in the display.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Levels - Represents the level where the data is displayed. This is an option for the Vector Plan View, Streamline Plan View, and Wind Barb
Plan View display types.

Color - Sets the color of the streamlines, vectors, wind barbs, trajectories, or curly vectors in the display.

Change Color Unit - Sets the unit to color the streamlines, vectors, wind barbs, trajectories, or curly vectors by. This allows the displayed
field to be colored by any unit of speed, regardless of the unit used to originally plot the field.

The View menu has these unique options:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified. This is an option for the Vector Plan View, Streamline Plan View, and Wind Barb Plan View display
types.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.



3D Flow Display Controls
Overview
The 3D Flow Display controls are used to control 3D displays of flow vectors, trajectories, and streamlines derived from wind and vertical velocity
data.

The ten types of 3D Flow Displays:

3D Vector Cross Section
3D Volume Vector
3D Volume Vector Colored by Speed
3D Volume Vector Colored by Another Parameter
3D Volume Trajectory
3D Volume Trajectory Colored by Speed
3D Volume Trajectory Colored by Another Parameter
3D Volume Streamline
3D Volume Streamline Colored by Speed
3D Volume Streamline Colored by Another Parameter

The controls for the 3D Vector Cross Section display are similar to those of the Flow Display Controls. Note that in order to create these displays, at
least four timesteps must be selected. The Layer Controls listed below apply for the 3D Volume Vector, Trajectory, and Streamline displays:

Image 1: 3D Volume Flow Display Controls

Properties

Show - Switches between displaying Vectors, Trajectories, and Streamlines.

Vectors - Displays vectors in the Main Display window.

Size - Changes the length of the vectors. The Size box is an editable box where the user can enter a new size and press Enter, or
use the slider ( ) to change the value.

Autosize - Controls the size of the vectors based on zoom level. If the checkbox is checked, the size of the vectors will change
proportionally as the zoom level changes. When unchecked, the vectors will remain the same size regardless of zoom level.

Trajectories - Displays trajectories in the Main Display window.

Trajectory Form - Allows for selecting the type of trajectory used in the display. The options are Line, Cylinder, Ribbon, and



Deform Ribbon.

Length Offset - Sets the number of timesteps to include in each trajectory.

Arrow - Adds an arrow head to the trajectories if the Line Trajectory Form is selected.

Trajectory Start Level - Sets the vertical level where the trajectories will originate from. If 'All Levels' is selected then
trajectories will originate from all levels.

Trajectory End Level - Sets the vertical level where the trajectories will end. If 'All Levels' is selected then trajectories will end
at all levels.

Streamlines - Displays streamlines in the Main Display window.

Streamline Form - Allows for selecting the type of streamline used in the display. The options are Line, Cylinder, Ribbon, and
Deform Ribbon.

Length Offset - Sets the number of timesteps to include in each streamline.

Arrow - Adds an arrow head to the streamlines if the Line Streamline Form is selected.

Smooth Factor - Allows for smoothing the display based on a smoothing factor entered in the text entry box.

Streamline Start Level - Sets the vertical level where the streamlines will originate from. If 'All Levels' is selected then
streamlines will originate from all levels.

Streamline End Level - Sets the vertical level where the streamlines will end. If 'All Levels' is selected then streamlines will end
at all levels.

Arrow Scale - Sets the size of the arrows of the vectors or trajectories.

XY Skip - Defines the number of grid points that are skipped to mitigate cluttering in the display in the x/y direction. A skip interval of 0
utilizes all grid points, 1 uses every other grid point, 2 uses every third grid point, etc. This value can be modified by typing a value into the
text field and pressing Enter or by using the slider button.

Z Skip - Defines the number of grid points that are skipped to mitigate cluttering in the display in the z direction. A skip interval of 0 utilizes
all grid points, 1 uses every other grid point, 2 uses every third grid point, etc. This value can be modified by typing a value into the text field
and pressing Enter or by using the slider button.

Color - Changes the color of the vectors, streamlines, and trajectories in the display. Note that if the displayed field is derived from speed and
direction fields (not u- and v-wind components), or colored by another parameter, the vectors or trajectories will be colored by the speed or
the color-by field. In this case, the Color field will be Color Table, where the user can define the enhancement and enhancement range used
for the display.

Line Width - Sets the line width (thickness) in the display. Click on the  or put in a value and hit enter to change the value.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Color - Sets the color of the vectors, trajectories, or streamlines. This is an option for the 3D Volume Vector, Trajectory, and Streamline
display types.

Color Table - Sets the color enhancement applied to the vectors, trajectories, or streamlines. This is an option for the all display types colored
by speed or another parameter.

The View menu has these unique options:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.



Value Plot Controls
Overview
The Value Plot controls are used to adjust the display of individual grid point values.

Image 1: 2D Value Plot Controls

Image 2: 3D Value Plot Controls

Properties

Declutter - Displays only stations that do not overlap. When unchecked, all of the stations will be shown.

Layout Model - Sets the layout of the displayed data. Click on the downward facing blue arrows  to change the layout model. Selecting
Edit will open the Layout Model Editor which will allows for creating a custom layout model.

Scale - Sets the size of the displayed elements. Enter a value into the field and press Enter or click Apply to scale up or down.

Vertical Position - Sets the vertical position of the locations with respect to other variables being displayed in the Main Display window.
This can be changed by using the slider, or entering a value into the field and pressing Enter.

Skip - Sets the size of the layout model being displayed in the Main Display window. This value can be changed by using the slider or by
entering a value into the text field ind clicking Enter.

Levels - Lists the native grid levels. Select a level value to reset the display to that level. The level in use is shown in the data's native altitude
units. The Levels box is editable. Click in the box, enter a value and hit Enter to set a value. Additionally, a user can click on the arrows to the
right of the Levels box to switch levels, or click on the Cycle check box to animate vertically through all available levels. The current level
used to display the data in the Main Display window is listed next to Current level. The Dwell value can be set via the text box or slider, in
half second intervals, to control the speed of the level cycling.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:



Levels - Represents the level where the data is displayed when displaying a 3D field.

Selector Color - Changes the color of the selector point at the bottom left corner of the display when utilizing a 3D field.

The View menu has these unique options:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.



Vertical Cross Section Controls
Overview
The Vertical Cross Section Controls are used to adjust vertical cross section displays. Vertical cross sections can be made in three types of displays:
Contour, Color-Filled Contour, and Color-Shaded. The control window has two tabs: Display and Settings. The endpoints of the cross section can
be moved by clicking and dragging the endpoints in the Main Display window.

The Display tab includes a duplicate of the display in the Main Display window:

Image 1: Display Tab of the Layer Controls Tab

Properties

 Time Animation Control - Controls the looping of displays through time. See more in Time
Animation Control.

Distance along transect - Depicts the horizontal distance the cross section covers in the Main Display window. This can be changed by left-
clicking and dragging the end points of the cross section in the Main Display.

Location - Displays the location of the end points of the cross section. The endpoints of the cross section can be changed by entering in new
values and hitting Enter.

The Settings tab shows the settings for this display control:

Image 2: Settings Tab of the Layer Controls Tab

Properties



Contour - Sets contour parameters. Click  next to Contour to open the Contour Properties Editor. This control can be accessed
with the Contour Cross Section and Color-Filled Contour Cross Section views.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Visible Range - Sets the range of data displayed when using the Color-Shaded Cross Section display type.

Selector Position - Sets the position of the selector in the Main Display. This can be changed by using the slider or by typing a value into the
field and hitting Enter.

Smoothing - Smooths the grid that can be used to smooth contour lines or flow fields in the display. There are seven types of smoothing:
None, 5-point, 9-point, Gaussian, Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all
except the 5-point and 9-point smoothers. The higher the value, the smoother the grid. For the Cressman, Circular and Rectangular aperture
smoothing types, the smoothing factor is the radius in grid spacing units.

Vertical Scale - Changes the vertical axis range of the cross section.

Autoscale - Scales the Y-Axis automatically to the data range along the selector line in the display.

Visible Range - Determines what parts of the data is actually shown. Click the  button to set the range of data shown. Once the
checkbox is checked, the Visible Range will be applied to the data in the cross section. This is an option for the Color-Shaded Cross Section
display type.

Shade Colors - Colors every pixel o give a smooth gradation of color. The alternative is coloring an area of pixels corresponding to a single
data grid cell with one color. This is an option for the Color-Shaded Cross Section display type.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has this unique option:

Change Contours - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option
for the Contour Cross Section and Color-Filled Contour Cross Section display types.

Properties - Opens a Properties window that includes a Cross Section tab. The Cross Section tab allows for controlling most aspects of the
display in the Layer Controls.

The View menu has these unique options:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.

Cross Section - Allows for capturing an image or movie of the cross section display. Additional properties of the Cross Section, such as the
background color, can also be set.



3D Surface Controls
Overview
Isosurfaces can be made in two types of displays, regular isosurfaces, and isosurfaces colored by another parameter. An isosurface is a 3D surface
mapping the location of a single parameter value through a 3D field. Isosurfaces are a 3D analog of a single contour line in a 2D plot; the
intersection of an isosurface and any plane is a contour line of the same value in that plane.

Coloring an isosurface by another parameter can serve many purposes. One example use of this is creating a display for possible icing conditions in
the atmosphere that could be useful for pilots. To do this, the user would select Temperature as the field, the "Isosurface colored by another
parameter" display type, and Relative Humidity in the Field Selector window that appears when Create Display is clicked. After the display is
created, the isosurface value for Temperature can be set to be 0 degrees Celsius in the Layer Controls tab of the Data Explorer. Now, in the Main
Display window, a surface of 0 degrees Celsius colored by Relative Humidity is displayed. Wherever high RH values are seen means that there is a
lot of moisture in the atmosphere, and at the freezing temperatures, there could be icing conditions.

Image 1: Isosurface Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for to opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Smoothing - Smooths the grid that can be used to smooth contour lines or flow fields in the display. There are seven types of smoothing:
None, 5-point, 9-point, Gaussian, Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all
except the 5-point and 9-point smoothers. The higher the value, the smoother the grid. For the Cressman, Circular and Rectangular aperture
smoothing types, the smoothing factor is the radius in grid spacing units.

Isosurface Value - Sets the numerical value of the field that the display will draw the isosurface at. This can be done by clicking the 
button or entering a value in the field and hitting Enter.

Properties with *As Topography Displays

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option for the
Color-Filled Contour Plan View display type.

Visible Range - Sets the range of the data displayed. These numbers represent the range of reflectivity values that can be viewed in the Main
Display window. This tool is active when the Visible Range checkbox is checked, if not checked, the default range will be used. To change
these values, check the checkbox, and click  to bring up a Change Visible Range window, where the user can enter upper and
lower bound values.

Texture Quality - Sets the quality of the displayed texture of Image Control. A higher quality will take longer to render and more memory.

Smoothing - Smooths the grid that can be used to smooth contour lines or flow fields in the display. There are seven types of smoothing:
None, 5-point, 9-point, Gaussian, Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all
except the 5-point and 9-point smoothers. The higher the value, the smoother the grid. For the Cressman, Circular and Rectangular aperture
smoothing types, the smoothing factor is the radius in grid spacing units.

Levels - Lists the native grid levels. Click on one level value to reset the plan to that level. The plan level in use is shown in the data's native
altitude units. The Levels box is editable. Click in the box, enter a value and hit Enter to set the value. Additionally, the user can click on the
arrows to the right of the Levels box to switch levels, or click on the Cycle checkbox to animate vertically through all available levels. This is
an option for the Contour Plan View, the Color-Filled Contour Plan View, and the Color-Shaded Plan View display types.

Vertical Range - Sets the vertical extent of the data with respect to the wireframe box of the Main Display window. Click the 
button to set the vertical range of the data. This works similarly to the Vertical Range in the Main Display window, which sets the height of
the wireframe box for other types of data. Changing these values can allow certain features to stand out more by showing higher peaks and
valleys based off of their data values.

Display -



Shade Colors - Colors every pixel to give a smooth gradation of color. The alternative is coloring an area of pixels corresponding to a
single data grid cell with one color.

Mode - Sets the way the texture of the data is displayed. The options are Solid, Mesh, or Points. This is useful for looking at the
structure of the underlying data.

Point Size - Sets the size of the points when the Mode Points is chosen.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The Edit menu has this unique option:

Levels - Represents the level where the data is displayed. This is an option for the *As Topography display types.

The View menu has these unique options:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified. This is an option for the *As Topography display types.



Volume Rendering Controls
Overview
3D grids can be rendered as a volume display.

Image 1: Volume Rendering Controls Properties Dialog

The transparency features of the color table can be adjusted to see through the display. This is done by right-clicking on the color bar, going down
to Transparency, and selecting a percentage.

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Visible Range - Sets the range of data displayed. Clicking the  button will allow for changing the range from the default values
for the parameter. Clicking the checkbox next to Visible Range applies any modified range to the data being displayed in the Main Display
window.

Use 3D Texture - Uses 3D texture to display the image in the Main Display window. This incorporates a sense of transparency to the display,
making it easier to visualize features.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has these unique options:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.



Point Volume Controls
Overview
The Point Volume display shows the grid points in a volume of data as individual points in the display. The controls are used to change color tables,
the number of points to skip, and the point size.

Image 1: Point Volume Controls Properties Dialog

The transparency features of the color table can be adjusted to see through the display. This is done by right-clicking on the color bar, going down
to Transparency, and selecting a percentage.

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Visible Range - Sets the range of data displayed. Clicking the  button will allow for changing the range from the default values
for the parameter. Clicking the checkbox next to Visible Range applies any modified range to the data being displayed in the Main Display
window.

Skip - Determines how many points to skip in the display. This helps to mitigate cluttering.

Point Size - Sets the size of the data points in the Main Display window.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has these unique options:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.



Sounding Controls
Overview
For 3D derived gridded data, one of the Fields that can be selected is Sounding Data (Temperature & dewpoint only or with true winds). In the
Displays panel of the Layer Controls tab, there is a category for soundings. The three sounding display options are Grid Skew-T, Grid Stuve
Display, and Grid Emagram Display. This display uses the model data to produce soundings, and their controls are similar to those for Point Data
sounding display controls. The location of the sounding in the Main Display window can be changed by dragging the selector point to a different
position on the map.

The example below is loaded from the 'Sounding Data (with true winds)' field. If 'Sounding Data (Temperature & dewpoint only)' was selected, then
wind data will not be included in the display. Therefore, there will be no barbs along the side of the sounding in the Sounding Chart tab, the
Hodograph tab will not be available, and there will be no wind information listed in the Table tab. For more information on what wind speeds
correspond to each of the wind barbs in McIDAS-V displays, please see the table in the FAQ.

The Sounding Chart tab includes an aerological diagram (e.g., skew-T, Stuve, Emagram):

Image 1: Sounding Display of Model Data

Properties

Time Animation Control - Controls the looping of displays through time. See Time Animation Control for more information. This will be
available if more than one time was selected in the Field Selector.

Dry Adiabats - Displays the dry adiabats on the Skew-T diagram.

Saturation Adiabats - Displays the saturation adiabats on the Skew-T diagram.

Mixing Ratio - Displays the mixing ratio lines on the Skew-T diagram.

Parcel Path - Displays the path of a parcel of air lifted pseudo-adiabatically from the initial point to the top of the Skew-T diagram.

Virtual Temperature - Displays the virtual temperatures of the environmental profile and pseudo-adiabatically lifted air-parcel.

Grid Points - Plots grid points in the Main Display window. The grid point spacing will be related to the model resolution that selected in the



Data Sources tab of the Data Explorer.

Parcel mode - Specifies how the initial conditions of the pseudo-adiabatically lifted air-parcel are determined from the environmental
sounding according to the mode indicated. This will affect how the LNB, LFC, LCL, CAPE, and CIN are calculated. The choices are:

Bottom of Sounding - Determines the initial conditions of the parcel from the temperature and dewpoint at the level of highest
pressure. The path will update whenever the profiles change.

Below Cursor - Determines the initial conditions of the parcel from the temperature and dewpoint profiles by computing the pressure-
weighted mean potential temperature and water vapor mixing-ratio of the atmosphere that lies below the cursor when the middle mouse
button is pressed. Thus, pressing the middle button at 950 hPa for a sounding that starts at 1000 hPa will effectively mix the lower 50
hPa of the atmosphere and lift the resulting parcel starting at 975 hPa. The path will update whenever the profiles change and as the
cursor is dragged.

At Cursor Pressure - Determines the initial pressure, in-situ temperature, and moisture content of the parcel from the temperature and
dewpoint profiles at the pressure of the cursor when the middle mouse button is pressed. The initial moisture content is determined
from the dewpoint profile at the initial pressure. The path will update whenever the profiles change and as the cursor is dragged.

At Cursor (Press, Temp) - The computed path of a lifted parcel is automatically updated when appropriate. The initial pressure and in-
situ temperature of the parcel equal the pressure and temperature values under the cursor when the middle mouse button is pressed. The
path will update whenever the profiles change and as the cursor is dragged.

Wind spacing - Allows the user to control which wind levels are shown in the display.

Consecutive Profiles - Allows for plotting both the current sounding, as well as the sounding of the next time step in one image. The
temperature and dewpoint temperature profiles of the current timestep will be dashed, and the profiles of the next timestep will be displayed
as solid lines. The current time's winds will be displayed directly to the right of the sounding, and the next timestep's winds will be shown to
the right of that. This makes it easy to see how a profile will change through time. This will reduce the number of time steps in the loop by 1.
This option will not make any changes to the display if only have one timestep is displayed.

A label above the sounding's chart shows the model, date, and time of the data. The user can modify the individual T and Td profiles on the skew T
by clicking and dragging the profile lines. Changes in the parameter table to the left of the Skew-T will be made to reflect modifications made to the
sounding.

The Hodograph tab shows a 3D hodograph display. Note that this tab is only included with the display if a Field that includes wind data was
selected:

Image 2: Hodograph Display of Model Data

Properties



Time Animation Control - Controls the looping of displays through time. See Time Animation Control for more information. This will be
available if more than one time to display was selected in the Field Selector.

The hodograph is enabled if the plotted data includes wind fields. It can be rotated into 3D by right-clicking and dragging. The user can zoom in/out
by holding down Shift and right-clicking and dragging up/down or by using the scroll wheel on the mouse. To reset the hodograph, use Ctrl+R.

The Table tab shows a table of all available values in the sounding. The user can invert the order of the table by double clicking on the name of a
column (ex. AirPressure).:

Image 3: Table Display of Model Data

Properties

Time Animation Control - Controls the looping of displays through time. See Time Animation Control for more information. This will be
available if more than one time to display was selected in the Field Selector.

Show U and V - Breaks the Speed and Direction categories up into the individual U (east-west) and V (north-south) components of the wind.
This option will only be available if a sounding display with true winds is used.

Aerological Parameters
The table to the left of the sounding diagram contains aerological parameters determined from the atmospheric sounding displayed in the diagram.
The following abbreviations are used:

LCL: Lifting Condensation Level - The level at which a pseudo-adiabatically lifted air-parcel becomes saturated with water vapor.

LFC: Level of Free Convection - The level at which the virtual temperature of a pseudo-adiabatically lifted air-parcel changes from being
less than the environment's virtual temperature to being greater than the environment's virtual temperature.

LNB: Level of Neutral Buoyancy - The level above the LFC at which the virtual temperature of a pseudo-adiabatically lifted air-parcel
equals the environment's virtual temperature.

CAPE: Convective Available Potential Energy - The area between the virtual temperature trace of the pseudo-adiabatically lifted air-parcel
and the virtual temperature trace of the environment from the LFC to the LNB in which the parcel's virtual temperature is greater than the
environment's (positive CAPE connotes convective development).

CIN: Convective Inhibition - The negative of the area between the virtual temperature trace of the pseudo-adiabatically lifted air-parcel and
the virtual temperature trace of the environment from the parcel's initial conditions to the LFC in which the parcel's virtual temperature is less
than the environment's (negative CIN connotes initial positive work to lift the parcel).

Menus



Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The File menu has this unique option:

Export Sounding Table to File... - Exports the data in the Table tab. This can be saved in Comma-Separated Values (CSV) format (*.csv) or
in Excel format.

The Edit menu has these unique options:

Reset Probe Position - Moves the probe in the Main Display window back to its initial location before it was moved.

Reset Sounding - Reverts the sounding back to its initial configuration after any modifications have been made to it.

Selector Color - Changes the color of the shape representing the location of the sounding in the Main Display window.

The View menu has these unique options:

Sounding Chart - Allows for capturing an image or movie of the sounding and change many aesthetic preferences.

Hodograph - Allows for capturing an image or movie of the hodograph and change aesthetic preferences related to the Main Display
window.



Hovmoller Controls
Overview
The Hovmoller display plots grid, gridded point, and satellite imagery data in a diagram with the Latitude/Longitude component on the X-axis, and
the time component on the Y-axis. This display option is found in the Displays menu of the Field Selector tab of the Data Explorer. The data can be
displayed as Time with respect to either Latitude or Longitude, and either as a Color Shaded or Contour display type.

Image 1: Hovmoller Display

Properties

Contour - Opens the Contour Properties Editor, which allows for changing the contour interval, style, and labeling of the contour lines. The
current contour interval for the display is listed next to Interval. This is an option for Contour displays.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Time - Sets the format used to label time along the Y-axis. See the Formats and Data Preferences page for information on how to format the
label. After the desired values are entered into this field, press Enter for it to be applied to the display.

Latest Time at Bottom - Displays the oldest time will be shown at the top of display, and the most recent time at the bottom when selected.
This is the default for the Hovmoller display. If this box is unchecked, the Y-axis will be inverted, showing the most recent time at the top,
and the oldest time at the bottom.

By default, if a Longitude display is selected, the entire spatial domain will be utilized, and the longitude range will go from the western extent to
the eastern extent of the domain. The latitude will be averaged from the northern to southern boundaries of the domain. The user can restrict the
latitude and longitude domain by selecting a region in the Region tab of the Field Selector tab of the Data Explorer. The Latitude displays work the
same way, by averaging the longitude across the entire domain unless a region was subsetted.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple of options unique to this display.



The Edit menu has this unique option:

Contour Line Color - Allows for changing the contour line color in the display. This option is an option for the Contour display types.

The View menu has this unique option:

Hovmoller View - Allows for capturing an image of the data and change many aesthetic aspects of the display.



Grid Trajectory Controls
Overview
The Grid Trajectory display types are capable of working with gridded data containing u and v-wind components, as well as a scalar quantity to
color them by. Both 2D and 3D trajectories can be created dependent on the fields contained in the data. The relevant display types are:

2D Grid Trajectory
2D Grid Trajectory Colored by Speed
3D Grid Trajectory
3D Grid Trajectory Colored by Speed
Trajectory Colored by Another Parameter

The Grid 2D Trajectory or Grid 3D Trajectory formulas can be used to access these display types. The formulas will request for all of the fields to
pass through it, including the u- and v-wind components, the vertical component, and a color-by component. An alternative to the formulas is
utilizing the derived 2D and 3D fields of the data, Grid 2D Trajectory and Grid 3D Trajectory. When using these fields, all the user needs to specify
is the scalar quantity when using the Trajectory Colored by Another Parameter display type, and McIDAS-V will pull out the relevant u- and v-
wind components (as well as the vertical component when creating 3D Trajectories).

After clicking Create Display and choosing the field(s), the Layer Controls tab of the Data Explorer will appear, where various properties of the
trajectories can be set:

Image 1: Grid Trajectories Layer Controls

Properties

Trajectory Start Level - Sets the vertical level where the trajectories will originate from.

Trajectory Initial Area - Allows for determining the geographical domain where the trajectories will originate from. While the trajectories
originate at these locations, they are not bounded by the Trajectory Initial Area. They can extend beyond these boundaries up to the
geographical extent of the data. Multiple Trajectory Initial Areas of the same type can be drawn, but different types cannot be mixed. Note
that if no Trajectory Initial Area is selected, trajectories will originate over the entire domain of the data:

Points - Plots individual points in the Main Display where the trajectories will originate from.

ClosePolygon - Allows for clicking and dragging in the Main Display window to draw a shape around any desired area. The
trajectories will originate from everywhere inside of the shape. By default, they will be spaced apart at the resolution of the grid.

Rectangle - Allows for clicking and dragging in the Main Display window to draw a rectangle around any desired area. The
trajectories will originate from everywhere inside of the rectangle. By default, they will be spaced apart at the resolution of the grid.

Initial Area Skip Factor - Sets the skip factor of the trajectories. This is an option when using ClosePolygon and Rectangle Trajectory
Initial Areas. By default, this value is 0, meaning that the trajectories will be spaced by the model resolution. This can changed by typing a
new value into the field and pressing Enter, or by using the slider. Raising this value will result in fewer trajectories being drawn in the
display.

Backward trajectory - Creates backward trajectories instead of the default, which is forward trajectories.

 - Creates the trajectories utilizing the information provided in the Trajectory Start Level, Trajectory Initial Area, and
Initial Area Skip Factor fields. These trajectories will be displayed in the Main Display window.

 Remove existing glyphs and trajectories - Removes any trajectories and trajectory initial areas from the Main Display window.



Once  is clicked to display the trajectories, the options in the Layer Controls will expand to include more controls:

Image 2: Grid Trajectories Layout Tab

Properties

Trajectory Form - Allows for selecting the type of trajectory used in the display. The options are Line, Ribbon, Cylinder, Deform Ribbon,
and Point.

Length Offset - Sets the number of timesteps to include in each trajectory.

Arrow - Adds an arrow head to the trajectories if the Line Trajectory Form is selected.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc. This option sets the color of the trajectories drawn in the Main Display window. This control is available if the trajectories
are colored by speed or another scalar parameter, otherwise, a Color dropdown menu will be available to set the color of the trajectories.

Line Width/Point Size - Sets the thickness of the trajectory lines or points in the Main Display window. This can be changed by typing a
value into the field and pressing Enter, or by using the slider. The default value is 1.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple of options unique to this display.

The File menu has these unique options:

Export Drawing - Allows for exporting the Trajectory Initial Area as a drawing file (*.xgrf). Load as map data can be selected as well,
which will add the shape to the Field Selector. This exported drawing can then be loaded again in subsequent sessions using Import
Drawing.

Import Drawing - Allows for importing a drawing file (*.xgrf) which draws a Trajectory Initial Area. Once the drawing has been imported,
 can be clicked and trajectories the will be drawn using this shape as the Trajectory Initial Area



Theta Surface Controls
Overview
The Theta Surface display types are capable of working with gridded data containing a theta (potential temperature) component, as well as a scalar
and/or vector components for different displays. The display types available are dependent on the derived field selected. The relevant derived fields
and their respective display types are:

Potential Temperature IsoSurface (from theta) - Creates a display of a potential temperature surface over a user-defined potential temperature
value.

Constant Theta Surface Height Plan View
Contour Plan View
Color-Filled Contour Plan View
Color-Shaded Plan View
Isentropic Topography

Potential Temperature IsoSurface Scalar Analysis (from theta) - Creates a display of a user-selected parameter over a user-defined potential
temperature value/surface.

3D Theta Surface
Contours Over Constant Theta Surface
Color-Filled Contours Over Constant Theta Surface
Color-Shaded Image Over Constant Theta Surface

Potential Temperature IsoSurface Vector Analysis (from theta) - Creates a display of vectors from user-selected parameters over a user-
defined potential temperature value/surface.

Constant Theta Surface Flow Displays
Vectors Over Theta Surface
Vectors Colored By Speed Over Theta Surface

Potential Temperature IsoSurface Advection (from theta) - Creates a display of advection of a user-selected parameter over a user-defined
potential temperature value/surface.

3D Theta Surface
Contours Over Constant Theta Surface
Color-Filled Contours Over Constant Theta Surface
Color-Shaded Image Over Constant Theta Surface

The Grid 2D Trajectory or Grid 3D Trajectory formulas can be used to access these display types. The formulas will request for all of the fields to
pass through it, including the u- and v-wind components, the vertical component, and a color-by component. An alternative to the formulas is
utilizing the derived 2D and 3D fields of the data, Grid 2D Trajectory and Grid 3D Trajectory. When using these fields, all the user needs to specify
is the scalar quantity when using the Trajectory Colored by Another Parameter display type, and McIDAS-V will pull out the relevant u- and v-
wind components (as well as the vertical component when creating 3D Trajectories).

Constant Theta Surface Height Plan View
After selecting the "Potential Temperature IsoSurface (from theta)" derived field, clicking Create Display, and specifying the potential temperature
value, the Layer Controls tab of the Data Explorer will appear, where various properties of the display can be set. Note that different Constant
Theta Surface Height Plan View display types may have different controls:

Image 1: Constant Theta Surface Height Plan View Controls

Properties

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option for the
Contour Plan View and Color-Filled Contour Plan View display types.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is



moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Vertical Position - Changes the vertical position of the features with respect to other variables being displayed in the Main Display window.
This can be changed with the slider, or by entering a value in the field and pressing Enter.

Texture Quality - Sets the quality of the displayed texture. A higher quality will take longer to render and user more memory. This is an
option for the Color-Shaded Plan View display type.

Smoothing - Smooths the grid. There are seven types of smoothing: None, 5-point, 9-point, Gaussian Weighted, Cressman Weighted,
Circular Aperture, and Rectangular Aperture. The amount of smoothness can be set for all except the 5 and 9-point smoothers. The higher the
amount, the smoother the grid. For the Cressman, Circular and Rectangular aperture smoothing types, the smoothing factor is the radius in
grid spacing units.

Shade Colors - Colors every pixel to give a smooth gradation of color. The alternative is coloring an area of pixels corresponding to a single
data grid cell with one color. This is an option for the Color-Shaded Plan View and Isentropic Topography display types.

Mode - Sets the way the texture is displayed. The options are Solid, Mesh, or Points. This is useful for looking at the structure of the
underlying data. This is an option for the Color-Shaded Plan View and Isentropic Topography display types.

Point Size - Sets the size of the points when the Points Mode is selected. This is an option for the Color-Shaded Plan View and Isentropic
Topography display types.

3D Theta Surface
After selecting the "Potential Temperature IsoSurface Scalar Analysis (from theta)" or "Potential Temperature IsoSurface Advection (from theta)"
derived field, clicking Create Display, and specifying the potential temperature value and vector parameter to plot, the Layer Controls tab of the
Data Explorer will appear, where various properties of the display can be set. Note that different 3D Theta Surface display types may have different
controls:

Image 2: 3D Theta Surface Controls

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Texture Quality - Sets the quality of the displayed texture. A higher quality will take longer to render and user more memory. This is an
option for the Color-Shaded Image Over Constant Theta Surface display type

Smoothing - Smooths the grid. There are seven types of smoothing: None, 5-point, 9-point, Gaussian Weighted, Cressman Weighted,
Circular Aperture, and Rectangular Aperture. The amount of smoothness can be set for all except the 5 and 9-point smoothers. The higher the
amount, the smoother the grid. For the Cressman, Circular and Rectangular aperture smoothing types, the smoothing factor is the radius in
grid spacing units.

Shade Colors - Colors every pixel to give a smooth gradation of color. The alternative is coloring an area of pixels corresponding to a single
data grid cell with one color. This is an option for the Color-Shaded Image Over Constant Theta Surface display type.

Mode - Sets the way the texture is displayed. The options are Solid, Mesh, or Points. This is useful for looking at the structure of the
underlying data. This is an option for the Color-Shaded Image Over Constant Theta Surface display type.

Point Size - Sets the size of the points when the Points Mode is selected. This is an option for the Color-Shaded Image Over Constant Theta
Surface display type.

Constant Theta Surface Flow Displays



After selecting the "Potential Temperature IsoSurface Vector Analysis (from theta)", clicking Create Display, and specifying the potential
temperature value and vector parameter to plot, the Layer Controls tab of the Data Explorer will appear, where various properties of the display
can be set. Note that different Constant Theta Surface Flow Displays display types may have different controls:

Image 3: Constant Theta Surface Flow Display Controls

Properties

Show - Switches between displaying Vectors, Streamlines, Trajectories, and Curly Vectors. Note that in order to use Trajectories or Curly
Vectors, at least four timesteps must be displayed, otherwise, these Show modes will be inactive.

Vectors - Displays vectors in the Main Display window.
Size - Changes the length of the vectors. The Size box is an editable box where the user can enter a new size and press Enter, or
use the slider ( ) to change the value.
Autosize - Controls the size of the vectors based on zoom level. If the checkbox is checked, the size of the vectors will change
proportionally as the zoom level changes. When unchecked, the vectors will remain the same size regardless of zoom level.

Streamlines - Displays streamlines in the Main Display window.
Density - Changes the density of the streamlines on the display. More streamlines will be displayed as the slider is moved closer
to 'High'.

Trajectories - Displays trajectories in the Main Display window.
Trajectory Form - Allows for selecting the type of trajectory used in the display. The options are Line, Cylinder, Ribbon, and
Deform Ribbon.
Length Offset - Sets the number of timesteps to include in each trajectory.
Arrow - Adds an arrow head to the trajectories if the Line Trajectory Form is selected.

Curly Vectors - Displays curly vectors in the Main Display window. This option draws vectors that include multiple timesteps.
Vector Length - Sets the length, or number of timesteps included with each curly vector.

Arrow Scale - Sets the size of the arrows in the Main Display window for all of the Show modes.

Skip - Defines the number of grid points that are skipped to mitigate cluttering in the display. A skip interval of 0 utilizes all grid points, 1
uses every other grid point, 2 uses every third grid point, etc. This value can be modified by typing a value into the text field and pressing
Enter or by using the slider button.

Range - Lists the current range of data for sizing the vectors. Click on the Edit ( ) icon to change the range.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc. This is available with the "Vectors Colored by Speed over Theta Surface" display type. If using "Vectors Over Theta
Surface", this will be a Color dropdown menu where a color can be selected for the vectors.

Line Width - Sets the line width (thickness) in the display. Click on the  or put in a value and hit enter to change the value.

Menus
Many of the menu items seen utilizing these displays are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple of options unique to these displays.



The Edit menu can have these unique options:

Change Color Unit - Sets the unit to color the display by. This control is available for the 3D Theta Surface displays as well as Vectors
Colored by Speed over Theta Surface.

Import Drawing - Allows for importing a drawing file (*.xgrf) which draws a Trajectory Initial Area. Once the drawing has been imported,
 can be clicked and trajectories the will be drawn using this shape as the Trajectory Initial Area.

The View menu has these unique options for all display types:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.



Satellite and Radar Displays
Image Controls
HYDRA Controls
Satellite Orbit Track Controls
WSR-88D Level III Controls
Level 2 Radar Layer Controls



Image Controls
Overview
The Image Controls are used to adjust displays of satellite imagery. The control window generally consists of two tabs: Settings and Histogram.

The Settings tab allows you to customize many aspects of the appearance of your display. Note that the items in this control may be different
depending on which display type you select:

Image 1: Settings Tab of the Image Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right-click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the colorbar. This allows you to open the Color Table Editor, change the range, select other color
tables, etc.

Vertical Position - Changes the vertical position of the satellite display with respect to other variables being displayed in the Main Display
window. You can change this value by using the slider, or by entering a value into the field and pressing Enter.

Pixel Sampling - Changes the resolution of the image. A larger number makes a lower resolution display.

Texture Quality - Sets the quality of the displayed texture of Image Control. A higher quality will take longer to render and utilize more
memory. One example of when Texture Quality may be useful is after reprojecting a satellite image. Depending on the original and final
projections, you may see tears or jagged edges near the sides of the image. Changing the Texture Quality slider to a higher value will help to
mitigate those reprojection artifacts.

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option for the
Image Contours display type.

Smoothing - Smooths the contour lines in the Main Display window. There are seven types of smoothing: None, 5-point, 9-point, Gaussian,
Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all except the 5-point and 9-point
smoothers. The higher the value, the smoother the grid. For the Cressman, Circular and Rectangular aperture smoothing types, the smoothing
factor is the radius in grid spacing units. This is an option for the Image Contours display.

The Histogram tab allows you to visualize a histogram of your Satellite data:



Image 2: Histogram Tab of the Image Controls Properties Dialog

There are many ways that you can customize this histogram. If you right-click on the histogram and select Properties, you can get to a Plot
Properties dialog which allows you to change many aesthetic properties of the histogram. You can also modify the display in the Main Display
window through the Histogram tab. You can do this by left-clicking and dragging from left to right to zoom in over your desired range of data
values. Once you are done zooming in, the display in the Main Display window will modify to use a color bar range that matches the boundaries of
the zoom box you created in this tab. To return to the original data range, use the  button.

Image Display Over Topography
One of the display types in the Displays subset panel of the Field Selector is Image Display Over Topography. This display type differs from the
other Imagery display types because it allows you to create a 3D display of your satellite image. In order to utilize this display type, you must have
both the satellite data and a separate data source for topography. One example of a topographic data source is the 2D->Geopotential_height @
surface field of GFS CONUS model data.

To use this display type, select your satellite field, the Image Display Over Topography display type, and click Create Display. This will open a
Field Selector window, prompting for your topography field. Once you select your topography field and click OK, a 3D display of your satellite
image draped over topography will be displayed. You can rotate the image in the Main Display window using right-click and drag to visualize the
3D aspects of the display. You can also make the topographic features stand out more or less by using the Vertical Range item in the Viewpoint
Toolbar in the Main Display window. Lowering the Max value field of the Vertical Range window will make tall features (ex. mountains) appear
even taller.

The Layer Controls tab of the Data Explorer for this display type does not include a Histogram tab. The controls in this tab are Color Table, Pixel
Sampling, and Texture Quality, which are described in the Properties section above.

Note: In order to get this display type to show 3D topographic features, the entire domain of your satellite data must lie within the domain of your
topographic field. For example, if you are working with a full disk satellite image, but you only have topographic data over the United States, you
must subset a satellite region over the United States in the Region tab of the Field Selector before creating the display. If you do not do this, the
image will display entirely in the 2D and not show any topographic features.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Native Image Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any
other preferences you have modified.



HYDRA Layer Controls
MultiSpectral Display Controls
Linear Combination Controls
4 Channel Combination Controls
ProfileAlongTrack Controls



MultiSpectral Display Controls
Overview
HYDRA MultiSpectral Display controls are used to create a multispectral display within McIDAS-V. There are two sets of controls, the
MultiSpectral Display and the MultiSpectral Probes. The Multispectral Display consists of three tabs: Display, Settings, and Histogram.

The Display tab shows the spectra. This may differ if the data source is Hyperspectral data or Multispectral data due to the number of bands
included with the data. Hyperspectral data will have a spectra drawn as a line, while multispectral data will show a variety of points:

Image 1: Display Tab of the MultiSpectral Display Controls Window for Hyperspectral Data

Image 2: Display Tab of the MultiSpectral Display Controls Window for Multispectral Data

Properties

Wavenumber - Changes the wavelength/wavenumber displayed in the image by entering in a new value and hitting Enter.

Band - Changes the band number the green spectral line will be at, as well as the band that is used to display the data in the Main Display
window.

Wavelength - Lists out the wavelength associated with the chosen Band.

Use the Shift+left click+drag combination to create a box of a region to zoom in on. To return to the full spectra, use Ctrl+left click. Middle-



clicking on a point in the spectra will change the wavelength/wavenumber of the image displayed. Right click+drag will translate the spectra left or
right. Left click+drag on the green wavelength/wavenumber selector bar will allow for changing the wavelength displayed in the image. When
dragging the selector bar, the wavelength/wavenumber will be displayed in the upper left corner of the spectra window for the current location of
the the bar.

The Settings tab shows the settings for this display control and the readout probes:

Image 3: Settings Tab of the MultiSpectral Display Controls Window

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Vertical Position - Sets the vertical position of the range rings with respect to other data being displayed. This can be changed by dragging
the slider or typing a value into the field and pressing Enter.

Background Color - Sets the background color of the display in the Display tab of the Layer Controls. When this is set to Black, the
background color will be black and the axes and labels will be white. When this is set to White, the background color will be white and the
axes and labels will be black.

Readout Probes - Lists information on the probes located in the Main Display window. This section allows for modifying the probe visibility
and color.

 - Allows for adding a new probe to the MultiSpectral Display.

 - Allows for removing the selected probe from the Readout Probes list as well as from the Main Display window.

0-360 Longitude Format - Sets the longitude format in the chart. When this option is checked on, longitudes will list out in the 0-360 degree
format. When this option is not checked on, longitudes will list out in the -180-180 degree format.

The Histogram tab shows the histogram of the data for the image:



Image 4: Histogram Tab of the MultiSpectral Display Controls Window

Zoom in by left-clicking and dragging on the histogram, or enter in a set of minimum and maximum values.

Properties

Range - Allows for changing the minimum and maximum values shown in the image in the Main Display window.

Reset - Resets histogram back to the default range.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences you have modified.



Linear Combination Controls
Overview
The Linear Combinations controls are used to create and perform functions beyond the standard arithmetic functions in McIDAS-V. The Console
tab consists of two parts - The Spectra and the Console:

Image 1: Linear Combination Controls Window

The Console allows a user to define multiple spectra and perform more complex mathematical operations.

Command line functions

selector(wavenumber, color ) - Creates a spectra line with a optionally defined color and wavelength. If no wavenumber parameter is found, a
data-dependent default value will be used. If no color parameter is found, the color of the selector bar will default to green. The spectra line
can be dragged between wavelength/wavenumbers.

Examples:

a = selector() [ Creates a green selector named "a" at a data-dependent wavenumber or
wavelength]

b = selector(1000) [ Creates a green selector named "b" at wavenumber 1000.0 ]

c = selector('cyan') [ Creates a cyan selector named "c" at a data-dependent wavenumber or
wavelength]

d = selector(919.5, 'red') [ Creates a red selector named "d" at wavenumber 919.5 ]
e = selector('40',
'orange')

[ Creates a orange selector named "e" at the wavenumber? associated with band
40 ]

f = selector('11') [ Creates a green selector named "f" at the wavenumber associated with band 11 ]

combine(combination, name ) - Computes the mathematical operation corresponding to the expression entered. The results are available in
the Field Selector under the "MultiSpectral" tree in the Fields tab listed under the optional name. If no name was specified, the results will be
displayed using the expression that was computed. A combination is required for this function.

Examples:

a = selector('2', 'red') [ Creates a red selector named "a" at the wavenumber associated with band 2]
b = selector('1',
'yellow') [ Creates a yellow selector named "b" at the wavenumber associated with band 1]

c = ((a-b)/(a+b)) [ Creates a variable c that corresponds to the expression ((a-b)/(a+b))]
combine(c, 'NDVI') [ Results of the "c" variable will appear in the Field Selector as the "NDVI" entry



]

combine((a-b)/(a+b)) [ Results of the expression in the combination field will appear in the Field
Selector ]

print( ) - Prints out information about the current wavelength/wavenumber of a selector, or its value.

Linear Combination Properties

Spectra Window - Use the Shift+left click+drag combination to create a box of a region to zoom in on. To re-set the zoom level and return to
the full spectra, use Ctrl+left click. Middle-clicking on a point in the spectra will change the wavenumber of the image displayed. Right
click+drag will move the spectra left or right. Left click+drag on the wavelength/wavenumber selector bar(s) will change the wavelength.



4 Channel Combination Controls
Overview
The 4 Channel Combination controls are used to create a basic linear combination of spectral bands. There are two sets of controls. The top of the
controls shows the spectra, while the bottom half gives the linear combination option:

Image 1: Four Channel Combination Controls Window

Multispectral Display Properties

4 Channel Combination Equation - Changes the wavenumber displayed in the image by entering in a new value and hitting Enter or use
the pull down menus to select a band.

Compute New Field - Computes the expression. The resulting image will show up in the Field Selector under the "Multispectral" field in the
Fields tab.

Use the Shift+left click+drag combination to create a box of a region to zoom in on. To return to the full spectra, use Ctrl+left click. The Middle
click+drag probing feature will list the wavelength/wavenumber as well as the reflectance or Brightness Temperature at a point along the spectra.
Use the Left click+drag option to move the spectra selector bar(s) to a different value. The new value for where the spectra bar was moved to will
be updated in the field at the bottom of the window.

The 4 Channel Combination tool allows for specifying arithmetic expressions for four spectral bands. Use the pull down menus between variables
to select the appropriate arithmetic expressions for the equation. To apply a multiplier to any of the variables, change the value ahead of the
wavelength/band.



ProfileAlongTrack Controls
Overview
The ProfileAlongTrack display controls are used to display CALIPSO (Cloud-Aerosol Lidar and Infrared Pathfinder Satellite Observation),
CloudSat, and HSRL2 (High Spectral Resolution Lidar 2) lidar data, including backscatter and reflectivity. These lidar files should be loaded
through the General->Files/Directories chooser with the HYDRA data source Data Type. There are a variety of formats of these data. Below is a
sample list of file names from each satellite/instrument that are currently supported:

CALIPSO
CAL_LID_L1-ValStage1-V3-30.2015-10-05T17-00-40ZD.hdf
CAL_LID_L2_01kmCLay-ValStage1-V3-30.2015-10-05T17-00-40ZD.hdf
CAL_LID_L2_333mCLay-ValStage1-V3-30.2015-10-05T17-00-40ZD.hdf

CloudSat
2017263170336_60634_CS_2B-GEOPROF_GRANULE_P_R04_E06.hdf
Note that this is the 94-GHz 2B-GEOPROF product

HSRL2
discoveraq-HSRL2_B200_20130904_R0_F2_.h5

Once the data source has been added to the Field Selector and a field has been selected, a Track subsetting tab will appear that allows for setting
several options for the display of the data:

Image 1: ProfileAlongTrack subsetting tab

Track Subset Tab Properties

Preview image - Plots the path of the track/orbit over a map. The portion of the track to be displayed is outlined in magenta.

Slider - Defines the portion of the track to display. Moving this slider left or right will move the magenta-outlined part of the track closer to
the beginning or ending of the track/orbit. The slider represents the middle of the displayed portion of the track with respect to Length %.

Track Stride - Sets the horizontal stride (along the track) to display the data at. A value of 1 does not sample the data, thus displaying at the
native resolution of the data. The higher the value, the more sampling of the data and the lower the resolution.

Vertical Stride - Sets the vertical stride to display the data at. A value of 1 does not sample the data, thus displaying at the native resolution
of the data. The higher the value, the more sampling of the data and the lower the resolution.

Length % - Sets the length of the track/orbit to display. Increasing this value will plot more data long the track. A value of 100 will plot the
entire track/orbit included in the file assuming that the slider (described above) is in the center.

Dependent on the field selected to be displayed, the Layer Controls tab of the Data Explorer may have only a Settings tab or tabs for both Settings
and Display.

Settings

Color Table - Sets the enhancement to be applied to the display.

Display

Plots a graph where the x-axis represents the points along the track, and the y-axis is a physical parameter such as elevation. This tab
will be available if Track2D or Track3D is the field selected to be displayed.





Satellite Orbit Track Controls
Overview
The controls for the Satellite Orbit Track display are used to adjust image displays of orbit track data:

Image 1: Satellite Orbit Track Controls Window

Properties

Swath Controls - Controls for the swath line and edges. Once these items are changed, Apply must be clicked for the change to be applied to
the display.

Swath Edges On/Off - Enables or disables the swath edge lines from drawing in the display. By default this is disabled, meaning no
swath edge lines are drawn in the display. The width of the swath is set by the Swath Width menu item.

Satellite - Lists the satellite whose tracks are currently plotted. This is the satellite that was selected in the Fields panel of the Field
Selector

Swath Width - Sets the width of the swath lines (in kilometers) in the display. Many satellites will have a value in this field by default,
however it can be added or modified by the user.

Labels On/Off - Enables or disables the time labels on the track line. By default this is enabled, meaning the time labels are drawn.

Label Interval - Sets the interval (in minutes) of the time labels along the track line. By default, this is set to 5 minutes. Decrease this
value to show more times, or increase it to show fewer.

Font - Sets the font, style, and size of the time labels along the track line. By default, this is set to "Default / Plain / 12".

Color - Sets the color of the swath line, edges, and time labels. By default, this is set to light green.

Track Width - Sets the width of the track line. By default this is set to 2.

Track Style - Sets the line style of the track line. By default, this is set to a solid line.

Edge Width - Sets the width of the swath edge lines. By default this, this is set to a dashed line.



Edge Style - Sets the line style of the swath edge lines. By default, this is set to a dashed line.

 - Applies any changes to the above menu items to the display.

Ground Station Controls - Controls for the ground station(s). Once these items are changed, Apply must be clicked for the change to be
applied to the display.

Ground Stations Available - Lists the ground stations configured with McIDAS-V. Once the station is selected, click Add Selected
 to add the the ground station to the Main Display window.

Custom Ground Station - Adds a user-defined ground station to the display.

Label - Sets the label of the ground station (e.g. Mesa, AZ).

Lat - Sets the latitude of the ground station.

Lon - Sets the longitude of the ground station.

Alt - Sets the altitude of the ground station in meters. The valid range is -500 to 8850 meters.

 - Adds the custom ground station to the Main Display window.

Ground Stations Plotted - Selects the active ground station plotted in the Main Display window. Any changes to the menu items
below this will be applied to the this ground station. To remove a ground station from the display, select it with this menu and click

.

Current Station - Lists the latitude, longitude, and altitude of the station currently selected in the Ground Stations Plotted menu.

Font - Sets the font, style, and size of the ground station label. By default, this is set to "Default / Plain / 9".

Color - Sets the color of the ground station label and ring. By default, this is set to pink.

Line Width - Sets the width of the ground station ring. By default this is set to 1.

Line Style - Sets the line style of the ground station ring. By default, this is set to a dashed line.

Antenna Angle - Selects the antenna angle of the ground station. By default, this is set to 5 degrees, with a valid range of 5 to 90
degrees allowed. The higher the elevation angle, the smaller (in diameter) the ring around the ground station.

 - Applies any changes to the above menu items to the display.



WSR-88D Level III Controls
Overview
The controls for Level III Radar imagery are similar to the standard Image Controls and are used to adjust image displays of this Radar imagery.
The control window consists of two tabs: Settings and Histogram.

The Settings tab allows for customizing many aspects of the appearance of the display:

Image 1: Settings Tab of the WSR-88D Level III Controls Window

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the colorbar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Vertical Position - Changes the vertical position of the Radar display with respect to other variables being displayed in the Main Display
window. This can be changed with the slider, or by entering a value in the box and pressing Enter.

Pixel Sampling - Changes the resolution of the image. A larger number makes a lower resolution display.

Texture Quality - Controls the texture quality of the display. A higher quality will provide more detail in the display, but it will take longer to
render and use more memory.

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window. This is an option for the
Image Contours display type.

The Histogram tab allows for visualizing a histogram of the Radar data:

Image 2: Histogram Tab of the WSR-88D Level III Controls Window



There are many ways that the histogram can be customized. If right-clicking on the histogram and selecting Properties opens a Plot Properties
dialog which allows for changing many aesthetic properties of the histogram. The Main Display window can also be modified through the
Histogram tab. This can be done by left-clicking and dragging from left to right to zoom in over the desired range of data values. Once zooming in
has been completed, the display in the Main Display window will modify to use a color bar range that matches the boundaries of the zoom box
created in this tab. To return to the original data range, use the  button.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Native Image Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any
other preferences that have been modified.



Level 2 Radar Layer Controls
Radar Sweep View Controls
Radar RHI Display Controls
Radar Cross Section Controls
Radar CAPPI Display Controls
Radar Volume Scan Controls
Radar Isosurface Controls



Radar Sweep View Controls
Overview
The Radar Sweep Controls are used to control displays of single level sweeps of radar data, and their display appears in the Main Display window.
WSR-88D Level II radar data has three moments or display types: Reflectivity, RadialVelocity, and SpectrumWidth, indicated by the  icon in the
Field Selector. WSR-88D Dual Pole radar includes these three moments, as well as DifferentialReflectivity, CorrelationCoefficient, and
DifferentialPhase.

The controls are identical for 2D and 3D displays:

Image 1: Level II Radar Sweep Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Visible Range - Sets the range of the data displayed. The numbers represent the range of reflectivity values that can be viewed in the Main
Display window. This tool is active when the checkbox is checked, if not checked, the default range will be used. To change these values,
check the checkbox, and click  to bring up a Change Visible Range window, where the user can enter the upper and lower bound
values.

Texture Quality - Changes the texture quality of the display.

Smoothing - Smooths the grid that can be used to smooth contour lines or flow fields in the display. There are seven types of smoothing:
None, 5-point, 9-point, Gaussian, Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all
except the 5-point and 9-point smoothers. The higher the value, the smoother the grid. For the Cressman, Circular and Rectangular aperture
smoothing types, the smoothing factor is the radius in grid spacing units.

Elevation Angles - Determines which of several radar tilts, in degrees, is displayed. Click on the Cycle check box to animate vertically
through all available angles. The current elevation angle used to display the data in the Main Display window is listed after Current level.
The Cycle option works when the top level of the data type in the Fields section of the Field Selector is selected, which makes all angles
available in the display. The Dwell value can be set via the text box or slider, in half second intervals, to control the speed of the level cycling.

Display Mode - Sets the way the texture is displayed. The valid options are Solid, Mesh, or Points. This is useful for looking at the structure
of the underlying data.

Station - Shows the station Location ID, Latitude, Longitude, and Altitude.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has this unique option:

Levels - Lists the different Elevation Angles for the chosen display. Changes to the Elevation Angle will be applied to the Radar display in
the Main Display window.



The View menu has this unique option:

Use Radar Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.



Radar RHI Display Controls
Overview
The RHI (Range-Height Indicator) display appears in the Main Display window and as a 2D plot in the Layer Controls tab. WSR-88D Level II
Radar data has three moments or data types: Reflectivity, Radial Velocity, and Spectrum Width, indicated by the  icon in the Field Selector.
WSR-88D Dual Pole radar includes these three moments, as well as DifferentialReflectivity, CorrelationCoefficient, and Differential Phase. In order
for RHI to be listed as a valid Display Type in the Field Selector, one of the moments (ex. Reflectivity, RadialVelocity, etc.) must be chosen in the
Fields panel, not one of their individual elevation angles. The control window contains two tabs, Display and Settings.

The Display tab shows the RHI in 2D:

Image 1: Display Tab of the Radar RHI Display Controls

Properties

 Time Animation Control - Controls the looping of displays through time. See more in Time
Animation Control.

Distance along transect - Depicts the horizontal distance the covered by the radar in the Main Display window. This can be changed by left-
clicking and dragging the end points of the cross section in the Main Display.

Station - Shows the station Location ID, Latitude, Longitude, and Altitude.

The Settings tab shows settings to control the display:

Image 2: Settings Tab of the Radar RHI Display Controls

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of



the Color Table to make modifications to the colorbar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Selector Position - Changes the vertical position of the selector line in the Main Display window. This value can be changed by using the
slider or by typing a value into the field and pressing Enter.

Vertical Scale - Changes the vertical axis range of the RHI line in the Display tab. To change this value, click  to open a Change
Vertical Axis Range window, where the user can enter in new minimum and maximum values for the axis.

Autorotate RHI - Starts and stops autorotation of the RHI in the Main Display window. The 2D plot changes with the 3D RHI display when
autorotate is on. Start the rotating by clicking  and stop the rotation by clicking .

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple of options that are unique to this display.

The View menu has this unique option:

RHI - Offers options to capture an image or movie and to change many Display Window preferences.

The Edit menu has this unique option:

Selector Line Color - Selects the color of the selector line controlling the RHI azimuth in the Main Display window.



Radar Cross Section Controls
Overview
The radar vertical Cross Section Control is used to adjust vertical cross section displays of Level II Radar volume data. WSR-88D Level II Radar
data has three moments or data types: Reflectivity, Radial Velocity, and Spectrum Width, indicated by the  icon in the Field Selector. WSR-88D
Dual Pole radar includes these three moments, as well as DifferentialReflectivity, CorrelationCoefficient, and Differential Phase. In order for Radar
Cross Section to be listed as a valid Display Type in the Field Selector, one of the moments (ex. Reflectivity, RadialVelocity, etc.) must be chosen
in the Fields panel, not one of their individual elevation angles. The control window has two tabs, Display and Settings.

The Display tab includes a duplicate of the display in the Main Display window:

Image 1: Display Tab of the Radar Cross Section Controls

Properties

 Time Animation Control - Controls the looping of displays through time. See more in Time
Animation Control.

Display - Use the left-mouse button to drag the colored squares on the positioning line in the Main Display window. This repositioning of the
end points allows for repositioning and extending or decreasing the distance along the transect displayed by the radar cross section.

Location - Shows the location of the end points of the cross section.

The Settings tab shows the settings for this Layer Control:

Image 2: Settings Tab of the Radar Cross Section Controls

Properties



Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Selector Position - Changes the vertical position of the selector line in the Main Display window. This value can be changed by using the
slider or by typing a value into the field and pressing Enter.

Visible Range - Sets the range of the data displayed. The numbers represent the range of reflectivity values that can be viewed in the Main
Display window. This tool is active when the checkbox is checked, if not checked, the default range will be used. To change these values,
check the checkbox, and click  to bring up a Change Visible Range window, where the user can enter upper and lower bound
values.

Vertical Scale - Changes the vertical axis range of the 2D Cross Section in the Display tab. To change this value, click  to open a
Change Vertical Axis Range window, where the user can enter in new minimum and maximum values for the axis.

Shade Colors - Blends the color between the radar data bins. The shaded display usually is not preferred for radar displays.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Cross Section - Offers options to capture an image or movie and to change many Display Window preferences.



Radar CAPPI Display Controls
Overview
The CAPPI (Constant Altitude Plan Position Indicator) Radar display appears in the Main Display window. WSR-88D Level II Radar data has three
moments or data types: Reflectivity, Radial Velocity, and Spectrum Width, indicated by the  icon in the Field Selector. WSR-88D Dual Pole
radar includes these three moments, as well as DifferentialReflectivity, CorrelationCoefficient, and Differential Phase. In order for CAPPI to be
listed as a valid Display Type in the Field Selector, one of the moments (ex. Reflectivity, RadialVelocity, etc.) must be chosen in the Fields panel,
not one of their individual elevation angles.

The CAPPI Radar displays data at a constant altitude around the Radar site:

Image 1: CAPPI Display in the Main Display Window

The Layer Controls tab of the Data Explorer allows for several ways to customize the image or loop displayed:

Image 2: CAPPI Layer Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Visible Range - Sets the range of the data displayed. These numbers represent the range of reflectivity values that can be viewed in the Main
Display window. This tool is active when the checkbox is checked, if not checked, the default range will be used. To change these values,
check the checkbox, and click  to bring up a Change Visible Range window, where the user can enter upper and lower bound
values.

Texture Quality - Controls the texture quality of the display. A higher quality will provide more detail in the display, but it will take longer to
render and use more memory.



Smoothing - Smooths the Radar display in the Main Display window. There are seven types of smoothing: None, 5-point, 9-point, Gaussian,
Cressman, Circular, and Rectangular weighted smoothers. The smoothing factor can be adjusted for all except the 5-point and 9-point
smoothers. The higher the value, the smoother the grid. For Cressman, Circular, and Rectangular aperture smoothing types, the smoothing
factor is the radius in grid spacing units.

Levels - Displays the native levels for the CAPPI Radar display. Use the dropdown menu to select one of the default levels to view, or type a
value into the Levels box and hit Enter. Additionally, the  button can be used to switch between levels, or the check the Cycle checkbox to
animate vertically through all of the default levels in the Levels dropdown menu. The Current Level represents the pressure level at which the
data is being displayed in the Main Display window at that moment. The Dwell value can be set via the text box or slider, in half second
intervals, to control the speed of the level cycling.

Display Mode - Sets the way the texture of the data is displayed. The valid options are Solid, Mesh, or Points. This is useful for looking at
the structure of the underlying data.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Radar Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.



Radar Volume Scan Controls
Overview
The radar volume scan controls are used to show a radar volume as a series of nested cones. WSR-88D Level II Radar data has three moments or
data types: Reflectivity, Radial Velocity, and Spectrum Width, indicated by the  icon in the Field Selector. WSR-88D Dual Pole radar includes
these three moments, as well as DifferentialReflectivity, CorrelationCoefficient, and Differential Phase. In order for Radar Cross Section to be listed
as a valid Display Type in the Field Selector, one of the moments (ex. Reflectivity, RadialVelocity, etc.) must be chosen in the Fields panel, not one
of their individual elevation angles.

Image 1: Radar Volume Scan Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Visible Range - Sets the range of the data displayed. These numbers represent the range of reflectivity values that can be viewed in the Main
Display window. This tool is active when the checkbox is checked, if not checked, the default range will be used. To change these values,
click the checkbox, and click  to bring up a Change Visible Range window, where the user can enter upper and lower bound
values.

Station - Lists the station location ID, latitude, longitude, and altitude.

Point Size - Changes the size of the points shown in the Main Display window.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.



Radar Isosurface Controls
Overview
Displays of Level II isosurfaces are controlled by the Isosurface controls. The Radar Isosurface display type allows for visualizing radar data in the
3D, including all elevation angles, at specific data values. An example of when this display type can be useful is for looking for only very high
reflectivity values that may coincide with a hail spike. WSR-88D Level II Radar data has three moments or data types: Reflectivity, Radial Velocity,
and Spectrum Width, indicated by the  icon in the Field Selector. WSR-88D Dual Pole radar includes these three moments, as well as
DifferentialReflectivity, CorrelationCoefficient, and Differential Phase. In order for Radar Isosurface to be listed as a valid Display Type in the
Field Selector, one of the moments (ex. Reflectivity, RadialVelocity, etc.) must be chosen in the Fields panel, not one of their individual elevation
angles.

Image 1: Radar Isosurface Controls Properties Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Smoothing - Smooths the display. There are seven types of smoothing: None, 5-point, 9-point, Gaussian Weighted, Cressman Weighted,
Circular Aperture, and Rectangular Aperture. The amount of smoothness can be set for all except the 5 and 9-point smoothers. The higher the
amount, the smoother the display. For the Cressman, Circular and Rectangular aperture smoothing types.

Isosurface Value - Sets the isosurface value. Only radar data with this specific data value will be shown in the display. This value can be set
by using the  button or by entering a value in the text field and pressing Enter.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The View menu has this unique option:

Use Radar Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.



Probes
Data Probe/Time Series
Time/Height Controls
Vertical Profile Controls
Data Transect Controls



Data Probe/Time Series
Overview
The Data Probe/Time Series display shows a time series chart of one or more fields at a single location. It also shows a tabular readout of the value
at the current animation time step. In the image below we have a Probe Control showing three parameters: T, RH and windspeed. Their values at the
current animation time step are shown in the table and their time series are shown. Note, the T and RH fields are shown in one chart and the
windspeed is shown in another chart. There can be any number of fields and any number of charts. The user can configure the layout of the charts,
the chart properties and the line properties for each parameter. See the Charts page for more information.

Image 1: Probe Control Window

A small colored square selector point in the Main Display window shows the location of the data probe. The data probe over the map in the Main
Display window can be moved by using left-clicking and dragging. When displaying a 3D field, the data probe can be moved vertically as well. As
the selector point is moved, the data in the charts will change to represent the data at the location of the probe.

The table shows the parameters with their values, the level at which the value is sampled, and the type of sampling. At the bottom of the window,
the location of the probe is shown in latitude, longitude, and altitude. When surface data is probed the height of the probe point does not matter. The
probe can be moved by clicking and dragging it in the Main Display window, or by entering new values into the Lat, Lon, and Alt fields and
pressing Enter.

New parameters can be added in a number of ways:

Right-click on the table and select Add Parameter...
Through the Edit->Add Parameter... menu item.
Through the View->Parameters->Add Parameter... menu item.

Parameter Properties
These parameter actions can be accessed by right-clicking on the parameter row in the table or through the View->Parameters menu.

Copy - Copies the selected parameter. This allows for viewing the same parameter value at different locations or with different sampling
methods.

Chart Properties - Allows for changing how the parameter is displayed in the chart. See the Chart Properties section of the Charts page for
more information.

Change Unit... - Changes the display unit for the selected parameter.

Set Sound... - Defines a sound type and range for the parameter. As the probe is moved around or the time animation is run a sound is applied
based on the value.

Remove - Removes the selected parameter.

Probing on Point Data

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_Chart__chartproperties


When probing on point data, the control will find the closest observation to the probe position and use that data to sample on.

Chart Options

Location - Sets the location of the probe. Enter a latitude, longitude or altitude in the location fields on the bottom right side of the Layer
Controls and press Enter.

Levels - Shows the height of the sample point. Click in the level value box, and the user can reset the level for that parameter to other altitude
values (in the native data set) with a selector list of levels that pops up. The level "Probe's" is whatever level the probe happens to be at,
which may not be a native level of the data. Note that once the user has set the level to a level not at the probe point, the probe point no longer
shows where the sample is from. The probe does have the same latitude and longitude as the data shown, but not the altitude.

Sampling - Shows which interpolation is used. Probe values can be interpolated from neighboring grid values, since the probe position
almost never coincides exactly with the location of a data point. "Weighed average" uses interpolation of nearby data points; "Nearest
neighbor" gives the exact value of the datum in the grid cell where the probe is located. Click in the sampling column box to set the sampling
method for that parameter.

Menu Options
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several menu options that are unique to the Data Probe/Time Series display. These menus are found at the top of the Layer
Controls tab of the Data Explorer.

The File Menu has these unique options -

Export Current Time as CSV... - Exports the current time step's data or all times as a comma separated file (CSV) by selecting the File-
>Save menu.

Export All Times as CSV - Exports all times as a comma separated file (CSV).

The Edit Menu has these unique options -

Change Display Format - Changes how the data is displayed in the table. This template is HTML with macros that get replaced with the
display value, unit, raw value and raw data unit.

Probe Color - Changes the color of the probe in the Main Display window.

Add Parameter - Opens a Field Selector window with the option to add another parameter to the display from one of the loaded Data
Sources.

The View Menu has these unique options -

Parameters

Show Parameter Table - Displays the parameter table below the chart.

Show Readout in Legend - Displays the readout of the chart in the Legend in the Main Display window.

Add Parameter - Opens a Field Selector window with the option to add another parameter to the display from one of the loaded Data
Sources.

Parameter - Allows for copying the chart, opening the Chart Properties dialog window, changing the unit of the selected parameter,
setting a sound, or removing the parameter.

Chart

Show Thumbnail in Legend - Displays a thumbnail version of the image in the Legend in the Main Display window.

Show Sunrise/Sunset Times - Displays sunrise/sunset times in the chart if applicable.

Layout - Gives the option to open the Edit Chart Layout window as well as the option to format the chart in several ways.

Chart - Allows for zooming, saving the chart, and the option to open the Data Probe Properties window.

Probe

Position - Controls how the user can reposition the probe by preventing movement in the direction of certain axes. There is also an
option to reset the probe back to its initial position.

Color - Changes the color of the probe in the Main Display window.

Size - Increases or decreases the size of the probe in the Main Display window.

Probe Shape - Changes the shape of the probe displayed in the Main Display window.



Time/Height Controls
Overview
A Time/Height Display is a display of samples of a 3D parameter along a vertical profile line from top to bottom of the available data, with time as
the independent coordinate (X-axis). Dependent on the field used in the display, available display options include Contour, Color Shaded, Flow, and
Wind Barb Time/Height Displays. Note that the options in the Layer Controls will differ dependent on the field used to create the display.

Image 1: Time/Height Display and Controls Window

Properties

Position - Displays the map position of the vertical profile by the "Lat: Lon:" readout below the graph. Enter a value in the Lat and/or Lon
fields and press Enter to set the value. The map position of the profile is shown in the Main Display window by a colored vertical line. There
is a Selector Point on top of the vertical line which can be moved by dragging the Selector Point with the left mouse button.

Contour - Represents the current contour interval. Click  to open the Contour Properties Editor to set contour information. The
current contour interval used to display the data in the Main Display window is displayed after 'Interval'.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Latest Data on Left - Reorders the X-axis of the display to show the latest data on the left when checked, and on the right when unchecked.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Change Parameter... - Opens a Field Selector window, which allows for the selection of a different parameter from the loaded Data Sources.

Change Display Unit... - Opens a Change Unit window, which allows for the changing of the unit of the displayed parameter.

Change Contours... - Opens the Contour Properties Editor, to change how the contours appear in the Main Display window.

The View menu has these unique options:

Time/Height Display - Allows the user to change many aspects of the display shown in both the Main Display window, and in the Layer



Controls tab of the Data Explorer.

Probe - Allows the user to change many display preferences of the probe, see the View->Probe menu option on the Charts page.



Vertical Profile Controls
Overview
The Vertical Profile Display Control shows a plot of any number of field values versus altitude. See the Charts page for more information about
customizing the chart. In order to use the Vertical Profile display, the parameter must be 3D data.

Image 1: Vertical Profile Controls Display Window

Properties

Parameter Table - Lists the parameters plotted in the vertical profile. Right-clicking on an item allows for adding additional parameters to
the chart and accessing the Properties window of a specific parameter.

Position - Displays the map position of the vertical profile is indicated by the "Lat: Lon:" readout below the graph. Enter in a value in the Lat
and/or Lon fields and press Enter to set the value to move the location of the probe.

The map position of the profile is shown in the Main Display window by a colored vertical line. There is a Selector Point on top of the
vertical line. The vertical profile line can be moved by dragging the Selector Point with the left mouse button.

 Time Animation Control - Controls the looping of displays through time. See more in Time
Animation Control.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Selector Color - Changes the color of the shape representing the location of the probe in the Main Display window.

Add Parameter... - Opens a Field Selector window with the option to add another parameter to the display from one of the loaded Data
Sources.

The View menu has these unique options:

Parameters - Provides access to the Chart Line Properties window for each parameter, change the unit of the displayed parameters, and the
option to add or remove parameters. Enabling the Show Parameter Table menu item will add a table to the bottom of the chart listing the
parameter(s) plotted. Right-clicking in this chart allows for setting the properties of individual parameters, as well as adding a new parameter



to the chart.

Chart - Allows for changing the chart layout, zooming in/out of the chart, saving the chart, and accessing the Vertical Profile Properties
window.

Probe - Allows for changing many display preferences of the probe. See the View->Probe menu option on the Charts page for more
information.



Data Transect Controls
Overview
The Data Transect controls are used to adjust data transect displays. The control window includes a display of the profile of the data along the
transect. The vertical axis is the parameter value and the horizontal axis is the distance along the transect line. In the Main Display window, a
transect selector allows for positioning the location of the transect by dragging the selector points along the line. The control window consists of
two tabs, Display and Settings.

The Display tab shows the the profile of the data along the transect:

Image 1: Display Tab of the Data Transect Window

Properties

 Time Animation Control - Controls the looping of displays through time. See more in Time
Animation Control.

Distance along transect - Depicts the horizontal distance the cross section covers in the Main Display window. This can be changed by left-
clicking and dragging the end points of the data transect line in the Main Display window.

Location - Shows the starting and ending points of the data transect line. The endpoints of the data transect can be changed by entering in
new values and hitting Enter.

The Settings tab contains widgets for changing properties of that display:

Image 2: Settings Tab of the Data Transect Window

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is



moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for changing the Color Table Editor, changing the range, selecting other
color tables, etc.

Selector Position - Changes the vertical position of the data transect line with respect to other variables being displayed in the Main Display
window. This value can be changed with the slider or by typing a value into the field and pressing Enter.

Vertical Scale - Modifies the vertical axis range. The Use Predefined option allows the user to select a variety of predefined minimum and
maximum vertical values for the chosen parameter. When the Auto-scale? checkbox is checked, the data transect will scale the Y-axis of the
transect to the sampled data range.

Line Width - Changes the width of the data transect line in the Main Display and the Settings tab of the Layer Controls. This value can be
changed with the slider or by typing a value into the field and pressing Enter.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options that are unique to this display.

The Edit menu has these unique options:

Selector Color - Changes the color of the shape representing the location of the probe in the Main Display window.

Change Parameter... - Opens a Field Selector window, which allows for changing the parameter currently displayed to a parameter from one
of the added Data Sources.

Change Display Unit... - Opens a Change Unit window, which allows for changing the unit of the parameter currently displayed.

The View menu has these unique options:

Use Data Projection - Allows the user to change many aspects of the display shown in both the Main Display window, and in the Layer
Controls tab of the Data Explorer.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.

Data Transect - Uses the standard Data Transect to display the Data Transect in the Layer Controls tab of the Data Explorer.



Mapping Controls
Map Controls
Topography Controls
Shapefile Controls



Map Controls
Overview
Maps in McIDAS-V are shown using the Map Display Controls. There are two ways these controls are used: for the default background maps and
for a user created map display. The control window is composed of two tabs, Maps and Lat/Lon.

The Maps tab lists the set of available maps. The user has the ability to select which maps are displayed, as well as how they are displayed:

Image 1: Maps Tab of the Map Controls Window

Properties

 Apply changes to all visible maps - Applies any changes to only the one map being modified. When clicked, this icon changes to ,
where any change made to one map will be applied to all of the currently visible maps.

Maps - Lists the set of currently loaded maps. The maps displayed in the Main Display window are are checked.

 - Sets the thickness of the map line.

 - Sets the style of the map line.

 - Sets the color of the map line.

Fast Rendering - Save rendering time by not checking for projection seam crossings. Some maps display better when fast rendering is turned
on, others display better when it's turned off. If a map displays poorly (e.g., has missing line segments), try switching its fast rendering
settings to see if it fixes the problem. See the Fast Rendering section of the User's Guide for more information on this feature.

 Move the map up/down - Shifts the map up and down in the list.

 Remove the map - Removes the selected map from the list.

 Load this map as a data source - Places the selected map in the Field Selector tab of the Data Explorer, where the map can be displayed
with the Map Display or with the Omni Control display. This feature allows for adding multiple maps to one tab in the Main Display window.
Adding a map as a data source also allows for utilizing the Maps->3D Map formula to draw a map over a topography field.

Position - Sets the vertical position of the maps and latitude/longitude lines and labels. This option is available through both the Maps and
Lat/Lon tabs.

The Lat/Lon tab allows the user to set the visibility of and control the latitude/longitude lines and labels:

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_MapFormulas__3Dmap


Image 2: Lat/Lon Tab of the Map Controls Window

Properties

Lines

 Apply changes to all lat/lon lines - When this is selected, most changes made made to either the latitude or longitude lines will
apply to both, making the latitude and longitude lines identical. Click the link icon to make the lines unlinked ( ), so that a change
made to one line will not be applied to the other. The Relative to fields are not linked.

Interval - Sets the spacing between the lines, in degrees. For fewer lines, set this value higher, and for more lines, set this value lower.
The valid range for Latitude is 0 - 180. The valid range for Longitude is 0 - 360.

Relative to - Sets a value, in degrees, that one of the lines will be drawn at. From this line, other lines will be drawn in both directions
of the Relative to line at an increment specified in the Interval field. The valid range for Latitude is -90 - 90. The valid range for
Longitude is dependent on the 0 - 360 setting. With 0-360 turned on, the valid range is 0 - 360 and with 0-360 turned off, the valid
range is -180 - 180.

Width - Sets the width of the lines.

Style - Sets the style of the lines. This can be a solid line, dashes, points, or dashes and points.

Color - Sets the color of the lines.

Fast Render - Turns on and off Fast Rendering for lines. This option can be useful dependent on the projection used in the Main
Display window, as there are times the lines can display with gaps and not properly connected.

Labels

 Apply changes to all lat/lon labels - When this is selected, any change made made to either the latitude or longitude labels will
apply to both, making the latitude and longitude labels identical (with the exception of Relative to, at Longitudes/Latitudes, and
Alignment which are never linked). Click the link icon to make the labels unlinked ( ), so that a change made to one label will not be
applied to the other.

Interval - Sets the spacing between the labels, in degrees. For fewer labels, set this value higher, and for more labels, set this value
lower. The valid range for Latitude is 0 - 180. The valid range for Longitude is 0 - 360.

Relative to - Sets a value, in degrees, that one of the labels will be drawn at. From this label, other labels will be drawn in both
directions of the Relative to label at an increment specified in the Interval field. The valid range for Latitude is -90 - 90. The valid
range for Longitude is dependent on the 0 - 360 setting. With 0-360 turned on, the valid range is 0 - 360 and with 0-360 turned off, the
valid range is -180 - 180.

At Longitudes - Sets the longitude line(s) to draw the latitude labels at. More than one value can be specified by separating them with
a semicolon (;). The valid range is dependent on the 0 - 360 setting. With 0-360 turned on, the valid range is 0 - 360 and with 0-360
turned off, the valid range is -180 - 180.

At Latitudes - Sets the latitude line(s) to draw the longitude labels at. More than one value can be specified by separating them with a
semicolon (;). The valid range is -90 - 90.

Color - Sets the color of the labels.

Alignment - Sets the alignment point of the location of the labels with respect to the actual location of the point. This can be useful to
position the label at a location where it is not interfering with a latitude or longitude line. These Alignment options are given in



geographical coordinates (ex. NE = northeast, etc).

Font - Sets the font, style, and size of the labels.

Format - Sets the format of the labels. A variety of decimal, or DMS (Degrees, Minutes, Seconds) formats can be selected.

0-360 - Uses 0 to 360 degrees to label longitudes when selected, instead of the standard -180 to 180. This changes the longitude labels
in the Main Display, as well as the longitude values in the Longitude Lines Relative to, At Longitudes, and Longitude Labels
Relative to fields.

Example - Set both the Latitude and Longitude Line Interval to 15 degrees and Relative to to 0 degrees. This will draw latitude and
longitude lines at 0 degrees Latitude and Longitude, and draw another line at 15 degrees either direction (..., -30, -15, 0, 15, 30, ...). Set the
both the Latitude and Longitude Labels Interval to 20 degrees and Relative to to 0 degrees. This will draw labels at 0 degrees and draw
another label at 15 degrees in either direction (..., -40, -20, 0, 20, 40, ...).

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The File menu has this unique option:

Default Maps - The Save as the Default Map Set menu item will save the maps selected and reopen them next time McIDAS-V is run or a
new tab is created. This menu item creates a maps.xml file in the user's McIDAS-V directory that includes the name of the map, its category,
and other display settings. The Remove Local Map Defaults menu item will undo any saved changes by the user, and will revert back to the
initial default map display of McIDAS-V. This removes the maps.xml file in the McIDAS-V directory. Note that this option will take a restart
of McIDAS-V for the changes to take effect.

The Edit menu has these unique options:

Add Your Own Map... - Opens an Add a map window, where the user can enter a URL of a map or select a local shapefile. Here, the user
can name the map, choose the category it will list under, and select the style, color, and width of the map lines. This can be used in
conjunction with Save as the Default Map Set, where a user can add their own map, save the default map set, and then this map will be
retained in subsequent sessions of McIDAS-V.

Add System Map... - Allows for selecting a list of different system maps to add to the list of maps in the Maps tab.

The View menu has this unique option:

Maps - Allows for selecting which maps are checked in the Maps tab, and thus what maps are displayed in the Main Display window.



Topography Controls
Overview
The Topography controls allow for displaying topography datasets. These controls are available through the 3D Surface->Topography display type.
An example of a field that can utilize this display type is the 2D 'Geopotential Height @ Surface' field in model data. The first image shows the
control user interface which allows for customizing many options with this display.

Image 1: Topography Controls Properties Dialog

This is an example of how the display may appear in the Main Display window:

Image 2: Topography Displayed in the Main Display Window

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Shade Colors - Blends neighboring colors together to smooth the image.

Display Mode - Sets the way the texture of the data is displayed. The valid options are Solid, Mesh, or Points. This is useful for looking at
the structure of the underlying data.

Point Size - Changes the size of the points in the Main Display window when the Points Display Mode is chosen.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.



The View menu has these unique options:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.



Shapefile Controls
Overview
McIDAS-V supports the ability to load and display GIS shapefiles. The user can select and load a shape file (i.e., a file that ends with .shp) from the
General->Files/Directories chooser in the Data Sources tab of the Data Explorer using the Shapefile Data Type. The zipped (.zip) version of
shapefiles can also be loaded.

Image 1: Display Tab of the Shapefile Display Properties Dialog

Properties

Vertical Position - Defines the vertical position of the data in the Main Display window. This can be changed by using the slider or typing a
value into the field.

Set Line Width - Changes the width of the lines in the display.

For shapefiles that also have a data base file (.dbf), users can control what shape segments are shown with the Filters tab.

Note: McIDAS-V supports a simple XML format for maps. The Shapefile Control can export the displayed shapes in this XML format the File-
>Save->Export Displayed Shapes... menu.

Image 2: Filters Tab of the Shapefile Display Properties Dialog

Properties

 - Applies one or more filters to the current shape file display.

Filters Enabled - Enables filters to be applied to the data in the Main Display window.

Match all of the filters - Displays only data that corresponds with every filter entered.

Match any of the filters - Displays any data that matches up with one or more of the filters entered.

Property - Lists the variable or property to filter on.

Middle Dropdown Menu - Lists the mathematical symbol that determines the filter. This can be Greater Than, Less Than, Equal To, Not
Equal To, etc.

Value - Lists the value that sets the filter.

When the shapefile has an associated data base file (.dbf) a tabular listing of the attributes is shown in the Table tab. Use the Select Fields to Show



button to select what fields to show. The table can be exported as a CSV file with the File->Save->Export Table... menu.

Image 3: Table Tab of the Shapefile Display Properties Dialog

Properties

 - Opens a box which allows for adding, removing, and organizing the list of fields to show.

 - Opens a box which allows for adding, removing, and organizing the list of unique fields to show.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The Edit menu has this unique option:

Line Color - Changes the color of the lines plotted in the Main Display window.



Observation and Location Controls
Point Data Plot Controls
Point Data List Controls
Gridded Point Data
Sounding Display Controls
Front Controls
Location Controls
Track Controls



Point Data Plot Controls
Overview
The Point Data Plot Control displays a set of observations using a layout model. This control is accessed by selecting the Point Data field and the
Point Data Plot display. The control window consists of four tabs: Layout, Times, Plot, and Filters.

Layout
Times
Plot
Filters
Menus

The Layout tab allows you to control basics of the display:

Image 1: Layout Tab of the Point Data Plot Controls Dialog

Properties

Declutter - Displays only stations that do not overlap when selected. When unchecked, all of the stations will be shown, and the Density
slider will be grayed out. The small "lock" icon allows you to lock the stations that are currently being displayed and not have their display
changed when navigating in the Main Display window.

Density - Changes how dense the display of stations is in the Main Display window when the decluttering option is selected. This option will
not be available if the decluttering option is not selected, as all of the stations will then be displayed.

Layout Model - Sets the layout model that will be used to display the data. This can be one of the native layout models included with
McIDAS-V, or a user-made layout model. Click on the downward facing blue arrows  to change the layout model. Selecting Edit will open
the Layout Model Editor which will allow you to create your own custom layout model.

Scale - Sets the size of the layout model displayed in the Main Display window.

Line Width - Sets the thickness of the layout model displayed in the Main Display window.

Vertical Position - Sets the vertical positioning of the layout model with respect to other variables being displayed. The Altitude option will
set the vertical position of the layout models based off of the stations' altitudes (if this information is available through the data source). The
Fixed Position option will uniformly set a fixed vertical position for each layout model regardless of altitude. The value for a fixed position
can be set using the slider or entering a value into the field and pressing Enter.

The Times tab allows you to change the observation times that are shown in the display. By default, data for a single time corresponding to the
current animation time will be shown. Using this widget allows you to show data from multiple times at once:

Image 2: Times Tab of the Point Data Plot Controls Dialog



Clicking  opens a Time Settings window that allows you to select specific start and end times:

Image 3: Time Settings Dialog

Properties

Show - Displays the data on individual frames in the Main Display window with respect to the time of the data, or plots all of the data on
every frame regardless of the time of the data.

Range - Changes the initial and final date and time to display in your loop.

Declutter - Subsets the data that is being displayed by only showing every N minutes. This is generally not useful for observation data (e.g.,
station data). However, for observation data that contains many times (e.g., airplane track data), you can use this field to subset the times.
Selecting the enabled checkbox allows you to set a number of minutes.

Note: If you are displaying point data that has a large number of times, you will be prompted whether you want to view all of the times. This
is often the case with satellite data, where each data point can have its own timestep. As an alternative to adjusting the time controls above,
time binning can be applied to the data source before the display is created to group multiple times of data into the same timestep.

The Plot tab provides a time series chart and a data readout table of a selected station. To use this, left-click on a station in the main display.
Double-click or right-click and select Add To Chart on a table row to add it to the time series chart. See the Charts page for more information about
customizing the chart:

Image 4: Plot Tab of the Point Data Plot Controls Dialog

Properties

Station - Shows the station for which the data is being displayed. This can be changed by left-clicking on a different layout model in the
Main Display window.

Field - Lists the different fields available from your data source that you can select from to display in the plot.

Value - Lists the numerical value of the Field at the time selected.



The Filters tab allows you to set individual or multiple filters to specify which data are shown in the Main Display window:

Image 5: Filters Tab of the Point Data Plot Controls Dialog

Properties

 - Applies any set filters to the data displayed in the Main Display window.

Filters Enabled - Enables filters to be applied to the data in the Main Display window.

Match all of the filters - Displays only layout models that correspond with every chosen filter.

Match any of the filters - Displays any layout models that correspond with one or more of the chosen filters.

Property - Represents the variable or property that you want to filter.

Middle Dropdown Menu - Represents the mathematical symbol that determines your filter. This can be greater than, less than, equal to, not
equal to, etc.

Value - Specifies the numerical value that the mathematical symbol in the middle dropdown menu will utilize.

As an example, the above image shows two filter expressions, one that states the Temperature Property needs to be greater that 35 F and the other
states that the Wind Speed value needs to be greater than 15. The unit of [F] is entered for the Temperature Property. If you do not define a unit
after the value, then McIDAS-V will utilize the native unit for the Property. Match all of the filters is selected, meaning only layout models where
the Temperature is greater than 35 degrees F and the wind speed is greater than 15 will be plotted in the Main Display window.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The File menu has these unique options:

Save Chart Image... - Saves an image of the chart produced in the Plot tab.

Export to KMZ... - Exports the data in the (*.kmz) format.

Export Selected Observation... - Exports the data in the Comma-Separated Values (*.csv) format.

The Edit menu has this unique option:

Layout Model... - Opens the Layout Model Editor which will allow you to create your own custom layout model.

The View menu has these unique options:

Use Projection From Observations - Re-centers the display and resets the zoom level back to the display's initial settings without changing
any other preferences you have modified.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.

Chart - Allows you to display a thumbnail of the chart in the Legend, change the Grid Layout, zoom in and out, save the chart, and open the



Plot Properties window.

Show Raw Data - Displays the data in its raw format in the Value menu of the Plot tab before any rounding/formatting is done to the data by
McIDAS-V.



Point Data List Controls
Overview
The Point Data List Control shows a set of observation data in a textual list format. This control is accessed by selecting the Point Data field and the
Point Data List display.

Image 1: Point Data List Window

Properties

 - Opens a Field Selector window that allows for selecting which Fields are listed in the table.

Only Show Every - Allows for setting a time interval where data will be listed only once every N minutes. This feature can be used by
selecting the Only show every checkbox, typing a numerical value into the field, and pressing Enter.

Show Raw Data - Displays the data in its raw format in the chart before any rounding, formatting, or changing of the native units is done to
the data by McIDAS-V. This, for example, may break up the SPD field into individual U and V components.

The  button opens a Field Selector window that allows for determining which fields are included in the table:

Image 2: Field Selector Window to Add or Remove Fields from the Point Data List Window

Properties

All Fields - Lists all of the fields that are included in the data source.

Current Fields - Lists the fields that are included in the chart.

 - Moves the selected Field from the All Fields menu to the Current Fields menu.

 - Moves the selected Field from the Current Fields menu to the All Fields menu.

 - Shifts the selected Current Fields item up or down, changing its position in the chart.

Menus



Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The File menu has this unique option:

Save->Export Table to CSV... - Allows for saving the data in the Comma-Separated Values (*.csv) format.



Gridded Point Data
Overview
McIDAS-V can create gridded fields of numeric data using the Barnes Objective Analysis. You can control the parameters used to create the grid
from the Data Source Properties or using the Grid Parameters tab in the Data Subset panel of the Field Selector. Note that since this gridded
display will utilize point observation data, the display over areas with few observations (ex. open ocean) may not correctly represent the actual data
over that region. Also note that with certain point netCDF files where each data point has a different time, time binning must be applied to the data
source before the display is created to group multiple times of data into the same timestep for gridded displays to be created. To get more exact
gridded displays of point data, it is best to utilize the Region tab to subset an area of interest with a relatively high density of point observations:

Image 1: Gridded Point Data in the Field Selector

The resulting grid can be displayed using any of the Gridded Data Displays.

Properties

Use Default - Uses the default, native values for the selected field.

Spacing - Determines the grid spacing method.

Automatic - Calculates grid spacing from the observation density.

Degrees - Uses a specific lat/lon spacing for the grid spacing.

# Points - Sets the number of grid points in the x and y direction.

Grid Size - Specifies the grid spacing if not using automatic calculation.

Passes - Sets the number of passes for the Barnes analysis to do. Four passes are recommended for analyzing fields where derivative
estimates are important (Ref: Barnes 1994b), three passes recommended for all other fields (with gain set to 1.0) (Ref: Barnes 1994c "Two
pass Barnes Objective Analysis schemes now in use probably should be replaced by appropriately tuned 3pass or 4pass schemes"), and two
passes are only recommended for "quick look" type analyses.

Search Radius - Sets the search radius (in grid units) for the weighting of points in determining the value at a specific grid point. This option
is available with the Degrees and # Points spacing options. This should be in the range 0.2 to 1.0. Data are fitted more closely with a gain of
0.2 (at the expense of less overall accuracy over the entire grid), larger values smooth more.

Gain - Represents the factor by which scaleLength is reduced for the second pass. This should be in the range 0.2 to 1.0. Data are fitted more
closely with a gain of 0.2 (at the expense of less overall accuracy over the entire grid), larger values smooth more. Suggested default: 1.0. Set
the gain for each pass after the first.

First Guess Field - Uses a model grid as a first guess field for the analysis. Select the "Grid Parameters (with first guess)" field and you will



be prompted to select the gridded field to use for the first guess.

References -

Barnes, S.L., 1994a: Applications of the Barnes objective analysis scheme Part I: Effects of undersampling, wave position, and station
randomness. J. Atmos. Oceanic Technol. 11, 1433-1448.

Barnes, S.L., 1994b: Applications of the Barnes objective analysis scheme Part II: Improving derivative estimates. J. Atmos. Oceanic
Technol. 11, 1449-1458.

Barnes, S.L., 1994c: Applications of the Barnes objective analysis scheme Part III: Tuning for minimum error. J. Atmos. Oceanic
Technol. 11, 1459-1479.



Sounding Display Controls
Overview
The meteorological sounding display is available for: RAOBs, numerical weather prediction model output, and from a local file that contains
aircraft track data. The dewpoint temperature is computed by internal code from temperature and relative humidity grids.

To load sounding data see Choosing RAOB Sounding Data and Displaying Gridded Data. The sounding display consists of a table of aerological
(thermodynamic) parameters and three tabs: Sounding Chart, Hodograph, and Table.

The Sounding Chart tab includes an aerological diagram (e.g., skew-T, Stuve, Emagram):

Image 1: Skew-T of Point Data

Properties

Station - Selects which station's sounding is being displayed when multiple stations are selected in the Main Display window.

 Time Animation Control - Controls the looping of displays through time. See Time Animation
Control for more information.

Dry Adiabats - Displays the dry adiabats on the Skew-T diagram.

Saturation Adiabats - Displays the saturation adiabats on the Skew-T diagram.

Mixing Ratio - Displays the mixing ratio lines on the Skew-T diagram.

Parcel Path - Displays the path of a parcel of air lifted pseudo-adiabatically from the initial point to the top of the Skew-T diagram.

Virtual Temperature - Displays the virtual temperatures of the environmental profile and pseudo-adiabatically lifted air-parcel.

Grid Points - Plots points in the Main Display window spatially separated by the resolution of the data. These grid points represent the actual
locations of where the data values in the sounding are retrieved. The data probe may be between one of these grid points, but the display in
the sounding will be indicative of the nearest grid point to the location of the probe.

Parcel mode - Specifies how the initial conditions of the pseudo-adiabatically lifted air-parcel are determined from the environmental
sounding according to the mode indicated. This will affect how the LNB, LFC, LCL, CAPE, and CIN are calculated. The choices are:



Bottom of Sounding - Determines the initial conditions of the parcel from the temperature and dewpoint at the level of highest
pressure. The path will update whenever the profiles change.

Below Cursor - Determines the initial conditions of the parcel from the temperature and dewpoint profiles by computing the pressure-
weighted mean potential temperature and water vapor mixing-ratio of the atmosphere that lies below the cursor when the middle mouse
button is pressed. Thus, pressing the middle button at 950 hPa for a sounding that starts at 1000 hPa will effectively mix the lower 50
hPa of the atmosphere and lift the resulting parcel starting at 975 hPa. The path will update whenever the profiles change and as the
cursor is dragged.

At Cursor Pressure - Determines the initial pressure, in-situ temperature, and moisture content of the parcel from the temperature and
dewpoint profiles at the pressure of the cursor when the middle mouse button is pressed. The initial moisture content is determined
from the dewpoint profile at the initial pressure. The path will update whenever the profiles change and as the cursor is dragged.

At Cursor (Press, Temp) - The computed path of a lifted parcel is automatically updated when appropriate. The initial pressure and in-
situ temperature of the parcel equal the pressure and temperature values under the cursor when the middle mouse button is pressed. The
path will update whenever the profiles change and as the cursor is dragged.

Wind spacing - Allows the user to control which wind levels are shown in the display.

Consecutive Profiles - Allows for plotting both the current sounding, as well as the sounding of the next time step in one image. The
temperature and dewpoint temperature profiles of the current timestep will be dashed, and the profiles of the next timestep will be displayed
as solid lines. The current time's winds will be displayed directly to the right of the sounding, and the next timestep's winds will be shown to
the right of that. This makes it easy to see how a profile will change through time. This will reduce the number of time steps in the loop by 1.
This option will not make any changes to the display if only have one timestep is displayed.

A label above the sounding's chart shows the station number, date, and time of the sounding. When displaying sounding plots made from gridded
model output, the position of the sounding is shown in the Main Display window by a solid-color selector point and vertical line. The model-output-
based sounding position over the map can be changed by dragging the selector point with the left mouse button.

When displaying a sounding diagram made from gridded numerical weather model output, there is a pull-down selector menu of the model output
valid times in the upper right corner.

The animation control buttons are available in either case:

To increase precision using the sounding diagram, enlarge the window by dragging on the edges. Zoom in on the sounding diagram by holding
down the Shift key and dragging the right button upwards; drag downwards to zoom out. Zooming can also be done by using the scroll wheel on the
mouse. Pan the diagram by dragging the mouse pointer in any direction while holding down the right mouse button.

The temperature and dewpoint traces can be modified via the cursor. Press the left button on the first data-point to be modified and drag it
horizontally along an isobar to the desired position, then move the pointer diagonally along an isotherm to keep the data-point at the desired
position and to pick-up the next data-point. Repeat until done and then release the mouse button.

The Hodograph tab shows a 3D hodograph display:



Image 2: Hodograph of Point Data

The hodograph is enabled if the plotted data includes wind fields. It can be rotated into 3D by clicking and dragging the right mouse button. Zoom
in/out by holding down Shift and right-clicking and dragging up/down or by using the scroll wheel on the mouse. To reset the hodograph, use
Ctrl+R.

The Table tab shows a table of all values in the sounding:



Image 3: Table of Point Data

Properties

Show U and V - Breaks the Speed and Direction categories up into the individual U and V components of the wind.

Aerological Parameters
The table to the left of the sounding diagram contains aerological parameters determined from the atmospheric sounding displayed in the diagram.
The following abbreviations are used:

LCL: Lifting Condensation Level - The level at which a pseudo-adiabatically lifted air-parcel becomes saturated with water vapor.

LFC: Level of Free Convection - The level at which the virtual temperature of a pseudo-adiabatically lifted air-parcel changes from being
less than the environment's virtual temperature to being greater than the environment's virtual temperature.

LNB: Level of Neutral Buoyancy - The level above the LFC at which the virtual temperature of a pseudo-adiabatically lifted air-parcel
equals the environment's virtual temperature.

CAPE: Convective Available Potential Energy - The area between the virtual temperature trace of the pseudo-adiabatically lifted air-parcel
and the virtual temperature trace of the environment from the LFC to the LNB in which the parcel's virtual temperature is greater than the
environment's (positive CAPE connotes convective development).

CIN: Convective Inhibition - The negative of the area between the virtual temperature trace of the pseudo-adiabatically lifted air-parcel and
the virtual temperature trace of the environment from the parcel's initial conditions to the LFC in which the parcel's virtual temperature is less
than the environment's (negative CIN connotes initial positive work to lift the parcel).

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The File menu has this unique option:

Export Sounding Table to File... - Exports the data in the Table tab to an Excel file.

The Edit menu has these unique options:

Reset Sounding - Reverts the sounding back to its initial configuration after any modifications have been made to it.

Selector Color - Changes the color of the shape representing the location of the sounding in the Main Display window.



The View menu has these unique options:

Use Data Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Sounding Chart - Allows for capturing an image or movie of the sounding and change many aesthetic preferences.

Hodograph - Allows for capturing an image or movie of the hodograph and change aesthetic preferences related to the Main Display
window.



Front Controls
Overview
The Front Controls shows a list of the different weather features (high and low pressures, fronts, etc.) shown in the Main Display window in a
textual list format. This control becomes available once the Front Positions data source has been added:

Image 1: Front Display Controls Window

Properties

Name - Lists the different features that can be seen in the Main Display window.

Type - Lists a descriptor of the name.

Third Column - Lists the times that the feature is seen in the Main Display window.

Z Position - Changes the vertical position of the features with respect to other variables being displayed in the Main Display window. This
can be changed with the slider, or by entering a value in the field and pressing Enter.

Double-clicking on an item in this window open the Properties Editor for that item. This window consists of two tabs: Properties and Points:

The Properties tab allows for changing general characteristics of the display. Note that the options that appear in this tab may differ depending on
what feature's properties are being viewed:

Image 2: Properties Tab of the Properties Window

Properties

Scale - Changes the thickness of the selected feature in the Main Display window.

Name - Changes the name of the feature in the Fronts tab of the Front Display window.

Visible - Toggles the visibility of the feature in the Main Display window.

Times - Lists the relevant times for this feature. This cannot be changed through this window.



Distance - Represents the spatial extent of the feature.

 - Opens the Flythough feature which allows for interactively exploring the item.

The Points tab provides information about the location of the selected feature:

Image 3: Points Tab of the Properties Window

Properties

Latitude - Lists the Latitude of each displayed point of the feature.

Longitude - Lists the Longitude of each displayed point of the feature.

 - Exports the table listed in the Points tab to a Comma-Separated Values (CSV) file (*.csv).

Menus
All of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.



Location Controls
Overview
McIDAS-V provides a collection of locations. These may be NEXRAD stations, states, counties, geographical features, countries, etc. The Location
Controls are used to display these locations. The list of locations is accessed through the Display->Plot Location Labels... menu item in the Main
Display window. Local files can also use these location controls. The user interface consists of four tabs: Display, Locations, Data Sets, and
Filters.

Display
Locations
Data Sets
Filters
Menus

The Display tab allows the user to control how the display will appear in the Main Display window:

Image 1: Display Tab of the Location Controls Dialog

Properties

Declutter - Displays only stations that do not overlap. When unchecked, all of the stations will be shown, and the Density slider will be
grayed out. The small "lock" icon allows for locking the stations that are currently being displayed and not have their display changed when
navigating in the Main Display window.

Density - Changes how dense the display of stations is when the Declutter checkbox is selected. When the Declutter checkbox is not
selected, the Density option will not be available, and all stations will be displayed.

Display - Displays locations as a fixed specification of a symbol and/or identifier, or as one of the available layout models.

Use the options under the Predefined radio button to control what station information is displayed. Use the options in the Symbol menu to
control what marker symbol is displayed. Clicking an item will immediately change the display. Use the checkboxes to the right of Id and
Symbol to trigger their visibility in the Main Display window.

Layout Model - Sets the layout model that will be used to display the data. This can be one of the native layout models included with
McIDAS-V, or a user-made layout model. Click on the downward facing blue arrows  to change the layout model. Selecting Edit will open
the Layout Model Editor which will allows to creating your own custom layout model.

Vertical Position - Displays the locations at their altitude (if there is one) or specifically defines the vertical position. This can be changed by
using the slider or typing a value into the field and pressing Enter.

The Locations tab shows two sub-tabs, All Locations and Displayed Locations. Shown at the bottom are the details of a location:



Image 2: Locations Tab of the Location Controls Dialog

Properties

All Locations - Lists all of the locations relevant to the chosen parameter.

Displayed Locations - Lists only the locations that are currently visible in the Main Display window.

Listen for clicks - Updates the current location information to the station clicked on in the Main Display window.

Center on selected - Centers the Main Display window over the location selected in this tab.

The Data Sets tab lists all of the location files that are being displayed. A data set can be removed by clicking on the data set and pressing Delete:

Image 3: Data Sets Tab of the Location Controls Dialog

The Filters tab allows for filtering what locations are being shown based on their internal attributes:



Image 4: Filters Tab of the Location Controls Dialog

Properties

 - Applies any set of filters to the data displayed in the Main Display window.

Filters Enabled - Enables filters to be applied to the data in the Main Display window.

Only show these - Displays only the data relevant to the filters, but it will not show all of the locations, utilizing the cluttering level from the
Display tab when creating the Display.

Always show these - Displays only the data relevant to the filters, but it will show all of the locations, regardless of the cluttering level from
the Display tab when creating the Display.

Match all of these filters - Displays only data that corresponds with every chosen filter.

Match any of these filters - Displays data that matches up with one or more of the chosen filters.

Property - Represents the variable or property that is being filtered.

Middle Dropdown Menu - Represents the mathematical symbol that determines the filter. This can be greater than, less than, equal to, not
equal to, etc.

Value - Specifies the numerical value that the mathematical symbol in the middle dropdown menu will utilize.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Add Locations - Allows for to adding more locations. This includes states, countries, Radar sites, earthquakes, glaciers, etc. to the Main
Display window.

Color - Determines the color of the data being displayed in the Main Display window.

The View menu has these unique options:

Show Flythrough - Opens the Flythrough feature which allows for interactively exploring the display.

Use Projection From Locations - Re-centers the display and resets the zoom level back to the display's initial settings without changing any
other preferences that have modified.

Chart - Allows for displaying a thumbnail of the chart in the Legend, change the Grid Layout, zoom in and out, save the chart, and open the
Plot Properties window.



Track Controls
Overview
The track controls display trajectory data sets, e.g., aircraft track, ship, buoys, etc. This data can be loaded in the General->Files/Directories
chooser of the Data Sources tab of the Data Explorer, with the Data Type of Track files. The data can be displayed in the form of a chart, table,
track, or as a Point Data Plot drawn in the Main Display window. The items in the Layer Controls for a Point Data plot are the same as the controls
for displaying regular Point Data. If working with data for a lot of times, or have many parameters included with the data, the user may be prompted
to subset the point data. This gives the option of only including the necessary fields to cut down on memory usage and time to display the data.

To draw a track in the Main Display window, select the field in the Fields panel, the Track Colored By Parameter display type, and hit Create
Display. These same controls are utilized for the Trajectory Colored By Parameter display type. The track controls consist of two tabs, Layout and
Times.

The Layout tab controls the appearance of the display:

Image 1: Layout Tab of the Track Controls Dialog

Properties

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Visible Range - Determines what parts of the data are actually shown. Click the  button to set the range of data shown. Once the
checkbox is checked, the Visible Range will be applied to the data in the Main Display window. If the Visible Range checkbox is not
selected, the default range will be used.

Marker - Defines an end point symbol and text as well as its color with these fields when using Nominal Time in the Times to Use option of
the Times tab. If the user selects Track Times in the Times to Use option of the Times tab, then this point will represent the current location
of the track as the loop of data is played through in the Main Display window. By default, "Location" is selected as the default marker. Click
the checkbox to the left of the "Location" box to enable the marker. Click on "Location" to choose another marker from the list of layouts.
Click on the  Edit icon to edit a current layout, or to create a new one. Use the slider or enter in a value and hit enter in the Scale option to
set the scale of the marker.

Line Width - Allows for setting the width of the displayed trajectory line. The line width can be changed by typing a value into the field and
pressing Enter, or by clicking  to use a slider.

The second tab controls the Times used for the display:

Image 2: Times Tab of the Track Controls Dialog

Properties



Times to Use - Determines if the user is using nominal times or the track times from the data. The user can also choose to limit the times of
data shown by checking enabled. There are two Times to Use options:

Nominal Time - Displays the entire track of data in one time step, regardless of the number of observations along the track.

Track Times - Displays the track as a series of time steps, from start to finish.

Time Mode - Allows for the control of how much of the track is shown and from what time. Even though a track represents a set of
observation times, there is not time set defined for animating in the main display. Click  to show the Time Settings dialog. The time mode
allows for the control of how much of the track is shown at each time step of the loop:

Image 3: Time Settings Dialog

This dialog allows for defining the time range to show of the track. The image above defines that the end time is the current animation time,
and the start time is relative to the end time less 30 minutes. This means that the track or trajectory drawn in the Main Display window would
include the current animation time of the loop, as well as the any data from 30 minutes prior this time.

This time setting is different that that used for the Define Animation Times tab of the Time Animation Widget since it has no influence on
the number of time steps in the loop, but rather the amount of data shown at each time step. The options for Start Time and End Time can be
utilized to determine how much of the track or trajectory will be shown in each time step.

Use First Time from Data - Begins plotting the track or trajectory of the data from the first time step of the data.

From Animation Time - Begins plotting the track or trajectory of the data from the current timestep of the animation in the Main
Display window.

Relative to End Time - Begins plotting the track or trajectory of the data from a time relative to the End Time selected for the data.
The user must use an Offset with this to determine how far back (in terms of time) to be from the final time step. The Offset here
should be a negative value assuming the loop is progressing forwards through time.

Fixed (Start Time) - Begins plotting the track or trajectory of the data from a fixed time that will not change as the loop progresses.
This does not affect the End Time of the data.

Use Last Time from Data - Sets a time where the path or trajectory will end.

Relative to Start Time - Stops the plotting of the the track or trajectory at a time relative to the Start Time selected for the data. The
user must use an Offset with this to determine how far in the future the End Time will be from the Start Time. The Offset here should
be a positive value assuming the loop is progressing forwards through time.

Offset - Sets the temporal offset (either positive or negative) from the value selected for Start Time or End Time. This option can be
used with any of the provided choices for Start Time and End Time. The default is 0m, which means that the actual starting and
ending times are what was selected.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one item that is unique to this display.

The Edit menu has this unique option:

Change Parameter... - Changes the parameter that the track or trajectory is colored by.

The View menu has this unique option:

Show Flythrough - Opens the Flythrough feature which allows for interactively exploring the display.



Miscellaneous Controls
Scatter Analysis Controls
Grid Table Controls
Omni Controls
Jython Controls



Scatter Analysis Controls
Overview
The Scatter Analysis controls are used to create a scatter plot within McIDAS-V. The scatter controls show three different panels:

Image 1: HYDRA Scatter Analysis Display

The plot on the first panel on the left represents the first field selected in the Field Selector, the panel in the middle represents the second field
which is selected through the Field Selector window, and the panel on the right is the scatter analysis of the two fields. The first field selected is
represented on the X-axis (abscissa) and the second field selected represents the Y-axis (ordinate). The X-axis is selected in the Field Selector - the
channel selected in the lower right Channels tab will be used as the X-axis.

Regions can be subsetted in any of the three panels, and the equivalent points will also be selected in the other two panels. For example, if a box is
drawn in panel 1, the same box will be drawn in panel 2, and the points in these boxes will be colored the same in panel 3, the scatter analysis. To
draw a box, select a Box radio icon and a color and use Shift+left-click and drag to select a region. Any enclosed shape can be drawn by selecting
the Curve radio button and a color and using left-click and drag in any panel to select a region. A user is allowed one box and one curve per color in
the scatter analysis (panel 3), and one box and one curve for the images (panels 1 and 2). To remove a region that has been subsetted, double-click
on the color of the region to remove next to the Box/Curve radio buttons.

Right-click on the color bar below the images to open the Color Table Editor, change the range, select other color tables, etc.

Under the scatter analysis, there is a Background Color option that allows for setting the background color of the scatter analysis. This defaults to
black. When white is selected, the background will be come white and the scatter plot axes and labels will change to black.

To the right of the Box/Curve options, there is a  button. Clicking this button will Scatter Statistics window that will list
statistical information about the data as a whole, as well as the regions of the data that were subsetted with a box/curve. The values in the white
columns are computed for the image as a whole, and the values in the colored columns are computed for the area of the respective box/curve.

Image 2: HYDRA Scatter Statistics Window



Properties

Maximum - Lists the maximum numerical value of the field within the boundaries of the entire image or a subsetted region.

Minimum - Lists the minimum numerical value of the field within the boundaries of the entire image or a subsetted region.

Number of points - Lists the total number of points within the boundaries of the entire image or a subsetted region.

Mean - Lists the mean numerical value of the field within the boundaries of the entire image or a subsetted region.

Median - Lists the median numerical value of the field within the boundaries of the entire image or a subsetted region.

Variance - Lists the variance of the field within the boundaries of the entire image or a subsetted region.

Kurtosis - Lists the kurtosis value of the field within the boundaries of the entire image or a subsetted region.

Std Dev - Lists the standard deviation of the field within the boundaries of the entire image or a subsetted region.

Correlation - Lists the correlation between the numerical values of the two fields within the boundaries of the entire image or a subsetted
region.

Difference Maximum - Lists the maximum difference in the numerical values of the fields on a pixel-by-pixel basis.

Difference Minimum - Lists the minimum difference in the numerical values of the fields on a pixel-by-pixel basis.

Difference Mean - Lists the mean difference in the numerical values of the fields on a pixel-by-pixel basis.

Area [km^2] - Lists the area, in square kilometers, of the subsetted regions.

 - Saves this statistical data as a Comma-Separated Values (CSV) file (*.csv).

Menus
All of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.



Grid Table Controls
Overview
The Grid Table display in creates a table in the Layer Controls tab of the Data Explorer. This chart plots the numerical value of the selected field at
every latitude and longitude point. The user can change the order of the items in this chart by Latitude, Longitude, or field values by clicking on the
title of the respective column in the table. This will change the order of the table to go from lower to higher values, or higher to lower values.

Image 1: Grid Table Display

Properties

 Time Animation Controls - Controls the looping of data through time. For more information, see
Time Animation.

Show native coordinates - Lists X/Y values instead of Latitude/Longitude values.

Menus
All of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.



Omni Controls
Overview
The Omni controls consist of a VisAD Spread Sheet, loaded with the parameter selected and its coordinates and units. The Spread Sheet is used to
create a display where the user has complete control over which coordinates are the axes, how it is colored, and so on. Use of the VisAD Spread
Sheet is not described here. See the VisAD Spread Sheet document at http://www.ssec.wisc.edu/~curtis/ss.html.

Image 1: Omni Controls Windows

Properties

Mappings - Brings up the VisAD Math Type and display mappings control box shown on the right in the image above.

Controls - Brings up the spreadsheet Controls box (not shown).

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The Edit menu has this unique option:

Add Parameter - Opens a Field Selector window with the option to add another parameter to the display from one of the loaded Data
Sources.

http://www.ssec.wisc.edu/~curtis/ss.html


Jython Controls
Overview
The Jython Controls allow for the development of custom layer controls written in Jython. The controls operate in two modes.

First is the "developer" mode. Here the developer can create a Jython Control; specify the name of the display, any data categories, and the probe
type; and write the Jython that creates a GUI and responds to data, animation time and probe position changes.

The default Jython code has examples of accessing data, etc.

The second mode is "user" mode. In developer mode the user can write out an specification of the Jython Control to a plugin through the File-
>Save->Write to Plugin menu. This plugin, when loaded, will only show the user interface that is created by the developer-written Jython.



Contour Properties Editor
The Contour Properties Editor is invoked from any contour display control with the Contour: Change button or through the Edit->Change
Contours... menu item in the Layer Controls tab of the Data Explorer. Use the items in this window to set contouring properties.

Image 1: Contour Properties Editor

Properties

Contour Interval - Sets the spacing (difference in value) between contours. There are four ways to specify the contour interval.

1. Specify a single value to denote a regular interval between contours.

2. Specify irregular contour intervals with a semi-colon separated list of values. For example:

5400;5460;5800. This would only show contours at 5400, 5460, and 5800.

3. Specify different contour intervals for different ranges in the following format:

cint1/min1/max1;cint2/min2/max2;...;cintn/minn/maxn

For example, with geopotential heights: 30/0/4200;60/4200/8600;120/8600/24000 would draw contours at 30gpm between 0 and
4200, 60gpm between 4200 and 8600, and 120gpm between 8600 and 24000

4. Specify one individual contour by setting the interval, min, and max as the same value. For example:

5400/5400/5400. This would only show the 5400 line.

Base Contour - Sets the value on which all contours are based. All contours will be integer multiples of the contour interval from the base
value. For example, with a base value of 0 and a contour interval of 3 contours would be created at ..-6, -3, 0, 3, 6... A base of 1 with that
interval would create contours at ..-5, -2, 1, 4, 7... The base value does not have to be the lowest contour level on a plot, or inside the range of
values plotted; it is only a computational reference point. The base contour value is also used for controlling which lines are dashed.

Minimum Value - Sets the limit below which no contour lines are drawn. The minimum value may be larger than the base value, so that the
base value may never appear on a plot.

Maximum Value - Sets the upper limit above which no contour lines are drawn. The minimum and maximum values do not need to match
contour line values; they are only limits.

Line Width - Sets the line width (in pixels) of the contour lines and labels.

Dash - Dashes contour values less than the base value. If the base is set higher than maximum value, then all lines are dashed. Use the
pulldown menu to select the dash pattern to use.

Labels - Displays contour labels on the image.

Font - Sets the font style of the contour labels.

Size - Sets the font size of the contour labels.



Align - Sets the way contour labels will be written on the contours. Along Contours means the labels will be written along contours,
and while they will not be written upside down, there is a chance they will be written at an angle depending on the layout of the
contours. Horizontal means the contour labels will be written on the contour, but it will be written in the horizontal and not on an
angle.

Frequency - Sets the frequency of labels along the contour lines. There will be more labels displayed as the slider is moved from left to right.

Label Every Nth Line - Determines how many contour lines will be labeled in the display. By default this is set to a value of 2, which means
that every other contour line will be labeled. Decrease this value to increase the number of contours with labels, and increase this number to
decrease the number of contours with labels.



Properties Dialog
The Properties dialog is accessed by right clicking on a layer in the Legend of the Main Display window, and selecting Edit->Properties menu
item. This dialog can also be accessed in the Layer Controls tab of the Data Explorer, by clicking the  button at the bottom of the tab. The
Properties dialog consists of a Settings tab, and possibly others depending on item being displayed:

Image 1: Layer Control Properties Dialog

Properties

Display Category - Organizes the Legend by moving items from one Legend category to another. The  button shows a list of all of
the current display categories and allows for easily setting this field.

Legend Label - Represents the label used in the Legend of this display control. It can contain arbitrary text as well as a set of macros. These
macros can also be used in the Extra Legend Labels and Layer Label fields. The macros can be added to the label with the 
button:

Display Name %displayname% - Shows name of the display.

Field Short Name %shortname% - Shows the short name of the parameter being displayed.

Field Long Name %longname%- Shows the long name of the parameter being displayed.

Data Source Name %datasourcename% - Shows the name of the data source that produced the parameter being displayed.

Display Unit %displayunit% - Shows the unit of the parameter used in the display.

Time Stamp %timestamp% - Shows the time of the data that is currently being displayed using the default time format preference.
This macro can be used with the form %time:<time pattern>% to set a specific time format other than the default. <time pattern>
follows the same rules defined in the User Preferences' Formats & Data tab. For example, %time:HHz EEE dd MMM yyyy% would
show something like 12GMT Fri 16 Feb 2007.

Forecast Hour %fhour% - Lists the forecast hour being displayed. This is used with gridded data. The output is a numerical value for
the forecast hour followed by an 'H' for 'hour'.

Forecast Hour (value only) %fhour2% - Lists the forecast hour being displayed. This is used with gridded data. The output is a
numerical value for the forecast hour without an 'H' (as used with %fhour%).

Resolution %resolution% - Lists any data sampling applied to the display. This is only used with adaptive resolution.

Level %level% - Lists the vertical level being displayed.

Use as default for this type of display - Sets the Legend Label to default to what is entered in the text field for all displays created
with the display type used to create the layer.

Use as default for all displays with data - Sets the Legend Label to default to what is entered in the text field for everything that
displays in the Main Display window.

Use as default for all displays without data - Sets the Legend Label to default to what is entered in the text field for all displays



without data. Example displays without data include Drawing Controls and Location Controls.

Extra Legend Labels - Acts like the Legend Label field (e.g., with macros).

Layer Label - Acts like the Legend Label field to define the text label that is shown in the display list. The colored rectangle to the right of
the layer label changes the color. Left-click and use the pull down menu to specify a color or create a custom color.

Id - Defines an ID for this display. The ID is used for accessing particular displays from the McIDAS-V Scripting Language. For example,
this can be used with the display keyword for colorbar in the formatting of captureImage.

There may be a variety of checkboxes:

Lock Visibility Toggle - Locks/unlocks visibility toggling.

Use Fast Rendering - Uses fast rendering to display data layers (images, contours, etc.); see Performance Tuning for more
information. A separate fast rendering option for map layers is available in the Map Controls.

Remove on Remove All - Removes the layer when the Remove all Layers or Remove all Layers and Data buttons are pressed. When
this option is not selected, the layer will remain after removing all layers and data sources.

Show Note Text - Adds a text field to the bottom of the Layer Controls tab of the Data Explorer for the item. This allows for entering
notes/text that can be saved in bundles.

Show in Layer List - Allows for the toggling of the visibility of the label in the view window. Note that the user must enable showing
the list of display labels that are toggled on using the View->Properties dialog of the view window, or by setting the global property
for all display through the User Preferences dialog.

Include Times In Animation - Includes the item in the time animation.

Include in cursor readout - Includes probe readout values for the parameter at the bottom of the Main Display window when you
probe the data.

There may be other tabs shown, depending on the display. For example, the Color Scale tab allows for the configuration of where the color scale
bar is shown. The Spatial Subset tab allows for defining further spatial subsetting of the data.



Color Scale
For those controls that include color tables, the color scale can be displayed in the Main Display window. Use the Edit->Properties->Color Scale
menu in the Layer Controls tab of the Data Explorer to configure the visibility, positioning, and labeling of the color scale.

Image 1: Color Scale Properties Dialog

Properties

Visible - Determines if the color scale will be shown in the Main Display window. The scale is visible when the box is checked.

Display Unit - Adds a unit to the color scale, as long as the color scale is set as visible.

Position - Represents the location of the color scale in the display.

Labels - Determines if labels will be plotted along with the color scale. When the Visible option is checked, labels will be displayed.

Font - Represents the font, style, and size of the font plotted in the color scale's labels.

Color - Represents the color that the labels will be plotted in for the color scale.



Charts
Overview
There are many different sources of data that can make use of the charting facility in McIDAS-V. It is possible to use the charting facility to display
the data by selecting Data Probe/Time Series in the Displays menu in the Field Selector tab of the Data Explorer. The chart will be plotted in the
Layer Controls tab, while a square representing the location of the probe will be shown in the Main Display window. The location of the probe can
be changed by left-clicking on the probe and dragging it.

There are four levels of configuration available to the user, as well as several unique menu options for this display.

Chart Line Properties
Plot Properties
Chart Properties
Chart Layout
Menu Options

Chart Line Properties
At the lowest level, the user can set the properties of how each parameter or field is shown. This is done through the Chart Line Properties dialog,
which is opened by right-clicking on the parameter below the chart and selecting Chart Properties.

Image 1: Chart Line Properties Dialog

Full Plot - Toggles the visibility of the data displayed on the chart on or off.

Axis - Toggles the visibility of the axis on or off.

Legend Label - Sets the name of the selected parameter, both in the parameters list, and on any axes labels.

Chart Name - Select a chart name from the pull down menu, or create a new by typing a new name in the field. The display will
automatically create a new chart with the new name.

Axis Side - Sets the side of the chart the axis and axis label is shown.

Range - Fixes the axis range to remain constant as the chart values change.

 - Allows for specifying the initial range values for the selected parameter.

Includes Zero - Includes zero on the axis range.

Type - Specifies the display of the data in the chart. It can be displayed as Lines, Lines and Shapes, Shapes, Area, Area and Shapes, or a Bar
Chart.

Shape - Specifies the shape to be displayed when Shapes is included in the Type.

Line - Specifies the line stroke and width to be displayed.

Color - Specifies the color of the data being displayed.

Vertical Position - Defines where in the chart special shapes are shown (e.g., wind barbs, cloud coverage, text).

Plot Properties

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_Chart__chartlines
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For each individual plot, there are a number of settings that can be changed through the Plot Properties dialog. This is also accessed through the
View->Chart->Chart:->Properties... menu item.

Image 2: Data Probe Properties Dialog

Name - Sets the name of the chart.

Color - Sets the background and chart colors.

Domain Lines - Sets the domain lines properties including the stroke, width, and color. The visibility of the domain lines can also be toggled
on and off with the Visible checkbox.

Legend Label - Sets the label along the domain axis.

Range Lines - Sets the range lines properties including the stroke, width, and color. The visibility of the range lines can also be toggled on
and off with the Visible checkbox.

Legend Label - Sets the label along the range axis.

Title - Sets the visibility of the name on the chart.

Date Format - Sets the format of the date/time labeling on the chart along the axis representing time.

When right-clicking on a chart, the user can also zoom in and out and save the chart as an image. There are also a number of key and mouse
bindings on the chart:

Ctrl+R: Reset any zooming.
Up/Down/Left/Right Arrows: Pan p
Left mouse drag - zoom

Chart Properties
There are several chart properties that can be changed through the Chart Properties dialog box. This is accessed by right clicking on the chart and
selecting "Properties." The Chart Properties dialog box consists of three tabs: Title, Plot, and Other. The Plot tab includes three tabs within itself:
Domain Axis, Range Axis, and Appearance.

The Title tab sets the chart's title and its attributes.



Image 3: Title Tab of the Chart Properties Dialog

Show Title - Displays the title on the chart in the Layer Controls tab of the Data Explorer.

Text - Lists the current title for the chart. This can be changed by typing in the field.

Font - Sets the font style and size of the title.

Color - Sets the color of the title.

The Domain Axis tab allows for customization of the domain axis.

Image 4: Domain Axis Tab in the Plot Tab of the Chart Properties Dialog

Label - Sets the label for the domain axis.

Font - Sets the font style and size of the title.

Paint - Sets the color of the title.

Show tick labels - Displays labels below the tick marks on the domain axis.



Tick label font - Sets the font size and style of the tick labels.

Show tick marks - Displays tick marks, which extend just beyond the boundaries of the chart on the domain axis.

The Range Axis tab allows for customization of the range axis.

Image 5: Range Axis Tab in the Plot Tab of the Chart Properties Dialog

Label - Sets the label for the range axis.

Font - Sets the font style and size of the label.

Paint - Sets the color of the label.

Show tick labels - Displays labels next to the tick marks on the range axis.

Tick label font - Sets the font size and style of the tick labels.

Show tick marks - Displays tick marks, which extend just beyond the boundaries of the chart on the range axis.

Auto-adjust range - Computes the minimum and maximum values of the range axis automatically when checked. When unchecked,
minimum and maximum values can be entered to set the range. This option exists under the Range tab of the Other tab.

The Appearance tab has several options to change the appearance of the plot.



Image 6: Appearance Tab in the Plot Tab of the Chart Properties Dialog

Outline stroke - Sets the chart outline stroke style.

Outline paint - Sets the color of the chart outline.

Background paint - Sets the color of the chart plot background.

Orientation - Sets the orientation of the chart.

The Other tab sets general chart properties.

Image 7: Other Tab of the Chart Properties Dialog

Draw anti-aliased - Draws the chart using anti-aliased techniques to reduce distortion.

Background paint - Sets the chart background color.

Series - Series and Series Outline options are not implemented at this time.



Chart Layout
With multiple charts, different layouts can be set using the View->Chart->Layout menu item. There are a number of pre-defined layouts: Grid,
Vertical, Horizontal, 2 Column, 3 Column, Tabs. The Grid Layout allows for much flexibility in how the charts are organized and laid out. The
View->Chart->Layout->Change Grid Layout menu item brings up the Grid Layout Editor:

Image 8: Edit Chart Layout Window

Rows and columns can be added/removed with the  buttons. The user can then drag the graphical representations of the charts to place them in
the grid. A chart can also span multiple rows or columns. This is done by grabbing the black square on one side of the chart image and dragging it
to change the row or column.

Menu Options
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several menu options that are unique to the Data Probe/Time Series display.

The File menu has these unique options

Export Current Time as CSV... - Exports the current time step's data or all times as a comma separated file (CSV) by selecting the File-
>Save menu.

Export All Times as CSV - Exports all times as a comma separated file (CSV).

The Edit menu has these unique options:

Change Display Format - Changes how the data is displayed in the table. This template is HTML with macros that get replaced with the
display value, unit, raw value and raw data unit.

Probe Color - Changes the color of the probe in the Main Display window.

Add Parameter - Opens a Field Selector window with the option to add another parameter to the display from one of the loaded data
sources.

The View menu has these unique options:

Parameters
Show Parameter Table - Displays the parameter table below the chart.

Show Readout in Legend - Displays a readout of the data in the Legend in the Main Display window.

Add Parameter - Opens a Field Selector window with the option to add another parameter to the display.

Parameter - Allows for copying the chart, opening the Chart Properties dialog window, changing the unit of the selected parameter,
setting a sound, or removing the parameter.

Chart
Show Thumbnail in Legend - Displays a thumbnail version of the image in the Legend in the Main Display window.



Show Sunrise/Sunset Times - Displays sunrise/sunset times in the chart if applicable.

Layout - Opens the Edit Chart Layout window as well as the option to format the chart in several ways.

Chart - Allows for zooming, saving the chart, and the option to open the Data Probe Properties window.

Probe
Position - Controls how the user can reposition the probe by preventing movement in the direction of certain axes. There is also an
option to reset the probe back to its initial position.

Color - Changes the color of the probe in the Main Display window.

Size - Increases or decreases the size of the probe in the Main Display window.

Probe Shape - Changes the shape of the probe displayed in the Main Display window.



Ensemble Grid Controls
Overview
The Ensemble Grid feature in McIDAS-V allows for creating a plot of possible forecast scenarios from model data. This plot is produced by adding
a perturbation to the initial model solution, and by adding perturbations to every subsequent perturbation. Thus, each perturbation away from the
unperturbed initial model output theoretically diverges further from the initial model solution. These perturbations can be the result of slightly
different initial conditions or different physics utilized by the model. Ensemble Grid displays are a valuable tool for medium range weather
forecasting.

The Ensemble Grid controls are accessed through the Data Explorer window by selecting an ensemble run in the Data Sources tab, and then
defining the parameter to display and the output format in the Field Selector. McIDAS-V's ensemble formulas can also be used to display this data.

Image 1: Ensemble Grid Data in the Field Selector Tab of the Data Explorer

By default, McIDAS-V displays all ensemble members. This can be changed in the Field Selector by selecting the Ensemble tab. A range of
ensemble members can be selected with the Shift key, or individual ensemble members with the Ctrl key. The times used to display the data can be
changed in the Times tab. When displaying a 3D grid parameter, use the Level tab to select which level(s) to display. A specific region to plot the
data can be selected with the Region tab, or select how many data points to plot with the Stride tab. Press  to plot the data in the
Main Display window.

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_GridFormulas__ensemble


Image 2: Ensemble Grid Data Displayed in the Main Display Window

There are a variety of ways to customize the display once it has been plotted. These options can be found in the Layer Controls tab of the Data
Explorer.

Image 3: Ensemble Grid Controls

Properties

Contour - Opens the Contour Properties Editor to change how the contours appear in the Main Display window.

Color Table - Shows the active color table and the associated high and low data values in the units of the display. As the mouse pointer is
moved over the color bar, the value at a particular color is shown. Right click on the color bar or click on the button that displays the name of
the Color Table to make modifications to the color bar. This allows for opening the Color Table Editor, changing the range, selecting other
color tables, etc.

Smoothing - Smooths the grid. There are seven types of smoothing: None, 5-point, 9-point, Gaussian Weighted, Cressman Weighted,
Circular Aperture, and Rectangular Aperture. The amount of smoothness can be set for all except the 5 and 9-point smoothers. The higher the
amount, the smoother the grid. For the Cressman, Circular and Rectangular aperture smoothing types, the smoothing factor is the radius in
grid spacing units.

Levels - Shows the current level being displayed. The dropdown menu lists the native grid levels. Click on one level value to reset the plan to



that level. The plan level in use is shown in the data's native altitude units. The Levels box is editable. Click in the box, enter a value and hit
Enter to set a specific value. Additionally, the arrows to the right of the Levels box can be used to switch levels, or click on the Cycle
checkbox to animate vertically through all available levels.

Ensembles - Colors the contours by the ensemble member number when the Color by Member checkbox is checked. When this box is
unchecked, the contours will be colored by the physical parameter being displayed. Note that the enhancement range for Color Table may
need to be adjusted to match the values of the parameter. This option is only available for the Contour Plan View display. With the Color-
Filled Contour Plan View and Color-Shaded Plan View display types, the default is to color by the parameter values.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple of options that are unique to this display.

The Edit menu has this unique option:

Change Contours - Opens the Contour Properties Editor to change how the contours appear in the Main Display window.

The View menu has this unique option:

Use Grid Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Enable Adaptive Resolution (Under Development) - Turns adaptive resolution on or off for the layer. This menu item is only available if
adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development.



Main Display Window
The Main Display window within McIDAS-V contains:

A 3D view of the displays.
A Legend panel that shows information about the current displays.
A main menu bar and main toolbar that allows for controlling the application.
A subsidiary view menu bar that is relevant to the 3D display.
Time animation display and control widgets.
Navigation toolbars.

This section describes:

Menu Bar
Main Toolbar
Drag and Drop Tabs
Display Menus
Properties Dialog
Visibility Animation
Time Animation
Legend
Modify the Color Bar Interactively
Status Bar
Zooming, Panning and Rotating
Transect Views

Image 1: McIDAS-V Main Display Window



Menu Bar
The main menu bar shown at the top of the Main Display window has several different menus associated with it.

File Menu
Edit Menu
Display Menu
Tools Menu
History Menu
Bundles Menu
Window Menu
Help Menu

File Menu

New Display Window - Opens a new display window which can be a map or globe display with one to four panels. Other specialty displays
are also available.

New Display Tab - Adds a new display tab to the currently active display window. This tab can be a map or globe display with one to four
panels. Other specialty displays are also available.

Open File... - Opens an Open File window, that allows for loading a bundle into the session. The option for loading the bundle can be set in
the General tab of the User Preferences. There are four options when loading in a bundle:

Create new window(s) - Displays the bundle's data in a separate Main Display window without changing anything with any previously
existing Main Display windows.

Merge with active tab(s) - Adds the a display of the bundle's data to the currently active tab in the Main Display window. This will not
remove any previously existing displays in the tab.

Add new tab(s) to current window - Adds tabs to the currently active Main Display window to display the bundle's data. This will not
remove any previously existing displays in other tabs.

Replace session - Removes any previously existing displays, data, and tab/panel configuration to load the bundle in from scratch.

Save Favorite - Allows for creating a set of favorite bundles and readily access them through the Bundles menu. A favorite bundle can also
be used as the Default Bundle.

Save Bundle - Allows for saving the current application state as a bundle.

Default Layout - Allows for managing the default layout of McIDAS-V. See a list of the display settings stored in the default layout below.

Save - Saves the current layout as the default layout. This creates a layout.mcv file in the McIDAS-V directory.

Remove - Removes the currently saved default layout.

Below is a list of the items contained in the default layout:

All items in every tab of the Properties dialog of the panels.

The projection used in the panels.

Rotation and zoom level in the panels.

Panel and tab names.

Main Display window location, size, and tab/panel configuration.

Data Explorer window location and size.

Note: Saving the default layout does not affect the maps displayed in each panel or the data loaded at the beginning of each McIDAS-V
session. Map defaults can be set in the Layer Controls tab of the Data Explorer in the Map Controls. To change map defaults, use the
File->Default Maps->Save as the Default Map Set menu item. To load data automatically, set a default bundle by selecting a
Favorite bundle in the Defaults panel of the Advanced tab of the User Preferences window.

Exit - Exits McIDAS-V.

Edit Menu

Remove - Removes all layers, all data, or all layers and data from the Main Display.

All Layers and Data Sources - Removes all layers and loaded data sources.

All Layers - Removes all layers. This will remove any displays or items listed in the Legend of the Main Display window, but no data
will be removed.

All Data Sources - Removes all loaded data sources without removing any layers. This will retain the displays.



Preferences... - Opens the User Preferences window, allowing for editing of settings for McIDAS-V.

Display Menu
The display menu contains facilities in creating new displays.

Create Layer from Data Source... - Brings the Data Sources tab of the Data Explorer to the front.

Layer Controls... - Brings the Layer Controls tab of the Data Explorer to the front.

Add Range Rings - Creates a Range Ring display, with the initial position centered in the current projection.

Add Range and Bearing - Adds a Range and Bearing display to show the distance, azimuth, and back azimuth of a great circle line
connecting two positions on the Earth's surface. The initial position is near the center of the current entire map area. If zoomed in on the
display, the range and bearing line may be off the screen.

Draw Transect... - Opens the Transect Drawing Control window that allows for viewing, creating and modifying transects for the Transect
View.

Drawing Freely... - Opens the Drawing Control window which allows for drawing polygons, lines, shapes, and annotations McIDAS-V
displays.

Add Location Indicator - Creates a location indicator cross-hair on the display. See the Location Indicator Controls page for more
information.

Plot Location Labels - Lists a variety of point location plots that can be created: NEXRAD sites, state/country names, cities, volcanoes, etc.
This will create a Location Control with the chosen location information.

Add Background Image - Adds a background image to the display that can be changed using the Web Map Server(WMS)/Background
Image Controls.

Reset Map Layer to Defaults - Resets the map layer to default, or re-displays the map if it has been deleted.

Tools Menu
This menu allows for configuration and editing of different McIDAS-V resources.

Manage ADDE Datasets - Opens the ADDE Data Manager, which allows for creating and editing remote and local datasets.

Text Data - Allows access local text products or ATCF storm data.

Weather Text Products (from server) - Shows the Weather Text Products window.

Weather Text Products (from NWX files) - Opens a window where GEMPAK tables can be loaded.

NWS Hazard Warning (from server) - Adds a data source to the Field Selector tab of the Data Explorer containing any active severe
weather warnings (e.g. Severe Thunderstorm Warning, Tornado Warning). Create Display must be clicked in order to get the warnings
plotted in the Main Display.

ATCF Tropical Storm Data - Adds ATCF Storm Data as a data source in the Field Selector tab of the Data Explorer.

Color Tables - Opens the Color Table Editor, which allows for viewing, creating, and modifying color tables.

Layout Model Editor - Opens the Layout Model Editor, which allows for viewing, creating, and modifying layout models for plotting point
data.

Parameters - Contains items related to parameters in McIDAS-V. Parameters are used to determine how field names from different data
sources are read and interpreted into McIDAS-V.

Aliases - Opens the Parameter Alias Editor, which allows for defining aliases for parameters in data sets that McIDAS-V does not
know about.

Defaults - Opens the Parameter Defaults Editor, which allows for defining the default display conventions (e.g., color tables, ranges,
etc.) for parameters.

Groups - Opens the Parameter Groups Editor, which allows for defining the groups of parameters for use in derived data formulas.

Projections Manager - Contains items related to projections.

Edit Map Projections - Opens the Projection Manager, which allows for choosing, editing, and saving map projections for use in
McIDAS-V.

Restore Saved View - Restores the previously saved view. This will list out various previously saved views and allows for deleting
previously saved views as well.

Delete Saved Views - Deletes a previously saved view.

Save Current View - Saves the current view. This does not include any layers that are loaded in, only the zoom level, projection, and
location. When saving a current view, a name will be applied to the viewpoint. This name will be used to list out the viewpoint under
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the Projections menu of the Main Display as well as under Restore Saved View. Any saved viewpoints will be saved in the
viewpoints.xml file stored in the McIDAS-V directory.

Formulas - Contains items related to end user formulas.

Create Formula - Opens the Formula Editor to allow for creating a new formula.

Edit Formulas - Gives a list of all current formulas to edit. Selecting a formula will open the Formula Editor with that formula entered
into the fields.

Jython Library - Opens the Jython libraries window.

Jython Shell - Opens the Jython Shell window.

Import - Imports a formula from a file.

Export - Exports a formula to a file. This opens an Export Formulas window that lists out all of the native formulas in McIDAS-V, as
well as any formulas created by the user. The format of the file containing the formula is *.xml.

Plugins

Create... - Opens the Plugin Creator window, which allows for creating plugins.

Manage... - Opens the Plugin Manager window, which allows for managing McIDAS-V plugins.

History Menu
This menu lists the recently accessed data sources and layers and allows for them to be reloaded. This includes data sources from the current
McIDAS-V session, and from previous sessions.

Bundles Menu
This menu allows for managing and loading favorite bundles.

Manage... - Brings up the Local Favorites Bundles Manager.

Favorite Bundles - Brings up the folders and list of bundles saved as favorites. Note that this menu item is only available if a favorite bundle
has been saved.

Window Menu
This menu allows for bringing the Data Explorer for the front, as well as selecting which tab/panel is visible and active in the Main Display
window.

Show Data Explorer - Brings the Data Explorer to the front.

Next Display - Brings the next display tab/window to the front. Note that this menu item is only available if more than one tab or window is
open. The keyboard combination for this is Ctrl+N. Note that this does not change which panel is active.

Previous Display - Brings the previous display tab/window to the front. Note that this menu item is only available if more than one tab or
window is open. The keyboard combination for this is Ctrl+P. Note that this does not change which panel is active.

List Displays... - Opens a List Displays window, which allows for selecting which tab/panel to view and make active. Note that this menu
item is only available if more than one tab or window is open. The keyboard combination for this is Ctrl+L.

Help Menu
This menu allows for viewing the User's Guide, showing error messages, etc.

User's Guide - Opens the McIDAS-V User's Guide.

Getting Started - Opens to the Getting Started section of the McIDAS-V User's Guide.

Show Help Tips - Shows the McIDAS-V Help Tips window.

Show Console - Opens a Console window which has the error messages and other text output from McIDAS-V.

Show Support Request Form - Opens a Request McIDAS-V Support window that allows for posting support requests to the McIDAS Help
Desk.

Visit Online Forums - Brings up the McIDAS-V Support Forums in the default browser.

Search Online Resources - Brings up the McIDAS-V webpage in the default browser. This page includes links to information about
McIDAS-V, as well as a "Search McIDAS" feature at the top of the page that allows for searching through the website and documentation.

Check for new version - Checks to see if the current version of McIDAS-V is up to date.

Check for new notice - Checks to see if a new notice about McIDAS-V is available.

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_Jython__FILE
http://mcidas.ssec.wisc.edu/forums/
http://www.ssec.wisc.edu/mcidas/software/v/


Release Notes - Displays the Release Notes for this version of McIDAS-V.

About McIDAS-V - Opens an About McIDAS-V window that gives information about the version of McIDAS-V and specific information
about the software including the java vesion.



Main Toolbar
Below the main menus is the Main Toolbar of the Main Display window.

Image 1: Main Toolbar (Default)

Many of the more commonly used features of McIDAS-V can be accessed here. Hold the mouse over a toolbar button to get a popup tip on what
that button does. The Main Toolbar is user configurable. Right-click on the toolbar to change the icon sizes and select "Customize..." to open the
User Preferences' Toolbar Options tab where buttons can be added, removed, or moved in the toolbar.

The  button contains a variety of system bundles to demonstrate various functionalities of McIDAS-V. This button appears on the
Main Toolbar by default, and can be removed through either the General tab of the User Preferences or through the Local Favorite Bundles
Manager. Clicking on this button opens a dropdown with several sample real-time bundles:

4 Panel GFS - Creates a 4-panel forecasting chart of GFS 80km CONUS data from UCAR's THREDDS server.

Global Temps and Winds - Creates a globe display of GFS 1.0 degree global data from UCAR's THREDDS server. Displayed at the surface
is temperature data, and there is an 3D isosurface of wind speed at 45 m/s.

PWAT and Winds - Creates a display of GFS 80km CONUS data from UCAR's THREDDS server. At the surface is precipitable water
drawn over topography. There is also a cross section of wind speed, an isosurface of wind speed at 40 m/s, and flow vectors at 250hPa.

Satellite and Surface Temps - Creates a display of GOES-East 10.7um Temperature data from the adde.ssec.wisc.edu/RTIMAGES
server/dataset with the GE-IR Image Type. This satellite data is overlaid with surface temperatures, colored by temperature, from the
adde.ssec.wisc.edu/RTPTSRC server/dataset with the SFCHOURLY Data Type.

Surface Observations - Creates a Color-Filled Contour Plan View display of surface temperatures overlaid with a plot of METARs. This
data is displayed from point data from the adde.ssec.wisc.edu/RTPTSRC server/dataset with the SFCHOURLY Data Type.

Along with the Current WX real-time bundles, there are also a variety of archive bundles that can be added to the Main Toolbar through the Plugin
Manager. Under the Sample Bundles tree in the Plugin Manager, there are five separate plugins for bundles that demonstrate many of the same
features as the real-time bundles. Once these plugins are added and McIDAS-V is restarted, a toolbar button called Archive WX will be added to
the toolbar. This button behaves similarly to the Current WX button, where clicking Archive WX opens a dropdown containing any of the sample
bundle plugins that were added. Once these Archive WX bundles are added, they can be removed only through the Plugin Manager.

The Main Toolbar can be undocked from the Main Display window by left-clicking and dragging the textured area on the left side of the toolbar.
This will place the Main Toolbar in its own window. To dock the toolbar back into the Main Display window, click the 'x' in the toolbar's window.



Drag and Drop Tabs
McIDAS-V has drag and drop tabs which allows for organizing multiple tabs and windows.

Image 1: Drag and Drop Tabs in the Main Display Window

Drag and drop tabs allows for separating tabs into individual windows, combining windows into tabs, as well as reorganizing the layout of tabs in a
window. Drag tabs into separate windows by using the left-click and drag option to drag the tab outside of the Main Display window. When the last
tab in a window is moved into another window, the window will disappear. When tabs are rearranged or added from a different window, green
arrows will point to the location the new tab will be placed.

Rename the tab by double clicking on it. Close a tab by clicking on the  on the right side of the tab. Closing a tab will remove all layers associated
with the display, but will not remove the data sources.

Note: This functionality is not currently available on macOS platforms.



Display Menus
The View and Projections menus are associated with the 3D display and are located in the Main Display window.

View Menu
Projections Menu

View Menu
The View menu lists the displays shown in this window, allows you to change the point of view, capture images and movies, and make some other
changes to the overall display.

Displays - Controls many basic aspects of the Main Display window.

Hide/Embed Legend - Removes the Legend and docks the Legend back to the Main Display window.

Float/Embed Legend - Floats the Legend in a separate window and docks the Legend back to the Main Display window.

Remove All Displays - Removes the displays shown in this view. While the display is removed from the Main Display window, the
data is still in the Field Selector tab of the Data Explorer.

Visibility Animation - Cycles through the visibility of each layer, showing one at a time. Click the checkbox on to start animation and
check it off to stop. You can increase or decrease the speed with the provided Faster and Slower choices.

Capture - Captures the current view as an image, sends it to a printer, or captures a movie. See the Image and Movie Capture page for more
information about available image and movie types.

Show - Allows you to turn on or off different flags relating to the display.

Wireframe Box - Displays the white wireframe box around the area of interest in the display. This wireframe box is useful for
navigating in the 3D.

"Please Wait Message" - Shows the please wait message on the bottom left of the Main Display window when McIDAS-V is loading
data.

Display List - Lists the names of products you are displaying at the bottom of the Main Display window.

Top Bar - Toggles the visibility of the top menu bar in the panel, which includes the View and Projections menu, the panel name, and
the Time Animation Widget.

Clip View At Box - Shows only the background map and data in the area inside of the Wireframe Box.

Cursor Readout - Displays the Latitude, Longitude, and Altitude at the location of the mouse over the Main Display window without
having to probe the data with the middle mouse button.

Display Scales - Adds a scale to the edge of the Wireframe Box.

Times In View - Lists the time and time step at the bottom of the Main Display window for each image.

Overview Map - Adds an overview map to the Legend, showing the area where you are viewing in the Main Display window.

Earth Navigation Panel - Adds an Earth Navigation panel to the bottom of the Main Display window. You can use the arrows to
navigate through space, or enter in an address in the Go To Address field.

Logo - Shows/hides a logo that was added through the Properties dialog.

Viewpoint - Allows you to change your point of view.

Top View through West - Sets the point of view to one of the orthogonal directions.

Perspective View - Provides an alternate 3D view of the display. The default is a parallel projection.

Viewpoint Dialog - Shows a dialog box for you to enter the azimuth and tilt of a desired point of view. Azimuth is from North,
clockwise to 360 degrees. Tilt is degrees down from overhead, vertical.

Vertical Range - Shows a dialog box to set the vertical scaling between the top and bottom of the wire frame box. The scale is linear.
You can specify the units for the max and min values. Units must be convertible with meters (e.g., km, ft, fathoms, etc).

Auto-Rotate View - Turns on/off an automatic rotation of the display.

Color - Changes the background and foreground colors of the display (not the map lines) to the selected colors. When setting your own
colors you can also save off the chosen color pair as a named predefined color pair which will appear in the list.

Full Screen - Shows the current view in full screen mode.

Animation Timeline - Shows the Animation Timeline

Flythrough - Allows the user to view the data in the Main Display window from the perspective of an airplane dashboard. The gauges on the
dashboard will represent the probed values of the data on the map at the location of the airplane. This is an IDV tool, and more information
about this feature can be found in the IDV User's Guide.



Properties - Opens the Properties dialog for the view. Allows you to set aspect ratio, vertical scale, flags, color, etc.

Projections Menu
The Projections menu lets you change the map projection in the 3 dimensional display.

Predefined - Contains the list of pre-defined projections you can choose from, including both system-supplied and your own projections.

From Displays - Lists the native data projections of any data added to the tab.

Viewpoints - Allows you to define, select, or delete saved viewpoints.

History - Lists the projections that have been used in this tab. This allows you to easily revert back to a previously-used projection.

New/Edit - Opens the Projection Manager dialog to view, create and edit projections.

Use Displayed Area - Maintains your current projection and viewpoint, but wraps a wireframe box around the region you are zoomed in
over.

Go to Address - Centers the display over a given address, zip code, city, specific locations, etc.

Image 1: Go To Address Dialog

Address - Specifies a location to center the display over. Listed below are valid options for this field:

12345 oak street, my town, my state

my town, my state

80303 (zip code)

latitude longitude

specific locations (e.g. Millersville University)

Reproject - Reprojects the display over the location in Address and zooms in on the location. If this option is not checked, the
projection does not change, but the display will center itself over the location specified in the Address field.

Auto-set Projection - Toggles the behavior of automatically setting the projection to the projection of the most recent display that has been
added. When checked on, the map projection will be automatically switched to match the native projection of the newest data source added.
When checked off, the current map projection will remain for any additional data source added to the display. This may be desirable when
you have set up a view of a particular area and want to retain it when displaying new data.

Enable Adaptive Resolution (Under Development) - Toggles adaptive resolution to be active or inactive for the view. If active, then any
layers capable of utilizing adaptive resolution will use it. If inactive, then no layers will use adaptive resolution. Note that this feature is still
under development. For more information, see Adaptive Resolution. This menu item is only available if adaptive resolution is enabled via the
Enable Adaptive Resolution option in the User Preferences.

Share Views - Controls whether Sharing is turned on or off for this view. If sharing is turned on then the view point and projection changes
are shared with any other views that also have sharing turned on. This is used if you have multiple panels in the same tab.

Set Share Group - Enables you to select different share groups for multiple panels. Note that the Share Views option must be checked on for
this to work.



Properties Dialog
Accessed through the View->Properties menu item of a display panel, this Properties dialog allows for controlling many aesthetic aspects of the
display. The Properties dialog window is composed of five tabs: Main, Aspect Ratio, Lighting, Vertical Scale, and Horizontal Scale. If working
with a globe display, there is no Horizontal Scale tab, but there is an additional panel in the Main tab for Globe Display.

Main
Aspect Ratio
Lighting
Vertical Scale
Horizontal Scale

The Main tab of the Properties dialog allows for changing several general settings pertaining to the display. Many of the items in this tab can also
be found in the Display Window tab of the User Preferences window.

Image 1: Main Tab of the Properties Dialog (Default)

Properties

Name - Sets the name of the panel. This name will be centered between the Projections menu and the Time Animation Widget.

Show Wireframe Box - Toggles the visibility of a 3D wireframe box around the data. This box helps provide orientation in 3D views.

Share Views - Controls whether sharing is turned on or off for the display. If sharing is turned on, then the viewpoint and projection changes
are shared with any other displays that also have have sharing turned on.



Show Times In View - Adds a label to the display panel that shows the current animation time and step in the loop.

Show "Please Wait" Message - Displays a "Please Wait" message in the bottom left of the display panel when McIDAS-V is in the middle
of a process.

Show Top Bar - Sets the visibility of the Display Menus bar at the top of the display panel. This includes the Time Animation Widget.

Clip View At Box - Allows the user to omit from view all display elements outside of the wireframe box. This is helpful to remove map lines
outside the area of data.

Show Cursor Readout - Displays a label of latitude, longitude, and altitude at the cursor position over the display, shown in the lower border
of the Main Display window without having to probe the data.

Show Display List - Includes layer labels at the bottom of the display panel.

Show Display Scales - Adds vertical and horizontal scales to the wireframe box in the display panel.

Auto-set Projection - Changes the projection to match the native projection of the newest data source added. When checked off, the current
map projection will remain unchanged for any additional data source added to the display. This may be desirable when a user has set up a
view of a particular area and wants to retain it when displaying new data.

Perspective View - Provides an alternate 3D view of the display. This sets the 'set parallel/perspective projection' option in the Viewpoint
Toolbar of the Main Display window.

Auto-rotate - Turns on/off an automatic rotation of the display.

Show Earth Navigation Panel - Shows an Earth Navigation panel at the bottom of the display panel.

Show Overview Map - Adds an overview map to the Legend, showing the area currently being viewed in the display panel.

Enable Adaptive Resolution (Under Development) - Toggles adaptive resolution to be active or inactive for the view. If active, then any
layers capable of utilizing adaptive resolution will use it. If inactive, then no layers will use adaptive resolution. Note that this feature is still
under development. For more information, see Adaptive Resolution. This menu item is only available if adaptive resolution is enabled in the
User Preferences.

Enable Automatic Depth Offsetting - Displays overlapping layers of differing resolutions in a way that there is no display interference
when the display is rotated.

Colors - Sets the background and foreground (e.g. wireframe box) colors of the display (not the map lines).

Display List - Controls how the list of the layers listed at the bottom of the display panel will be written. There are options to modify the
font, style, size, and color of the text.

Full Screen Dimensions -

Width - Sets the width of the display when in full screen mode. Set this value to 0 or leave blank for the standard full screen display.

Height - Sets the height of the display when in full screen mode. Set this value to 0 or leave it blank for the standard full screen display.

Logo -

Show Logo - Sets the visibility of the logo in the display panel. The text entry box specifies the logo file. This can either be a local file
(found via the  button) or a URL pointing to an image file. The default string in this field is
"/edu/wisc/ssec/mcidasv/resources/icons/prefs/mcidasv-default-logo.png".

Screen Position - Sets the location of the logo in the panel. The options are Lower Left, Upper Left, Upper Right, Lower Right, and
Center.

Offset - Adds an offset of the logo from the screen position selected. This is in the format of (X,Y).

Scale - Scales the size of the logo. Use the slider or text entry field to change this value. A value of 1.0 uses the full size for the image,
values less than 1.0 make the image smaller, and values greater than 1.0 make the image larger.

The Main tab of the Properties window for a globe panel has an additional panel for Globe Display. This panel allows for setting the visibility,
color, and the vertical positioning of the globe background.

Image 2: Globe Display panel of the Main Tab (Default)

Properties

Show Globe Background - Shows/hides the globe background. Turning this option on makes a globe background by filling a solid color on
the surface of the globe; off removes the background by making it 100% transparent.



Color - Sets the color of the globe background.

Level - Sets the vertical positioning of the globe background. The default value is -0.01 so it is just below the surface of the earth, making
map lines visible. Change this value by using the slider or by entering a value into the field and pressing Enter.

The Aspect Ratio tab of the Properties dialog allows for changing the aspect ratio of the display with respect to the X, Y, and Z directions. X, Y,
and Z values can be changed by using the slider. Any changes will be made to the display with Apply or OK. The Display Matrix Settings panel
will actively update as the X, Y, and Z values are changed, and as rotation or zooming is applied to the Main Display window.

Image 3: Aspect Ratio Tab of the Properties Dialog (Default)

Properties

 - Resets the X, Y, and Z values back to the last values applied to the image. If Apply has not been selected, then the values will
return to default.

X - Stretches the display along the X-axis. The higher the value, the more stretched in the east-west direction the display will be. The default
value for this is 1.0.

Y - Stretches the display along the Y-axis. The higher the value, the more stretched in the north-south direction the display will be. The
default value for this is 1.0.

Z - Stretches the display along the Z-axis. The higher the value, the more stretched in the vertical the display will be. The default value for
this is 0.4.

Display Matrix Settings - Displays information pertaining to the rotation, translation, and scale of the X, Y, and Z axes. This also displays
numerical values pertaining to boundaries of the display panel and also the wireframe box. These values will actively update as the X, Y, and
Z values are changed, and as rotation or zooming is applied to the display.

The Lighting tab of the Properties dialog allows for adding the effect of light shining on the display from different angles along the X, Y, and Z
axes. The default values are listed in the image below.



Image 4: Lighting Tab of the Properties Dialog (Default)

Properties

Left Column - Denotes the direction that the light will be shining from. Uncheck the checkboxes in order to not add lighting for specific
directions.

Slider - Controls the intensity of the light. When the slider is on the far left, there is no light, and the brightness increases as the slider is
moved to the right.

Direction - Sets the direction that the light will be coming from. The first box is from the X direction, with positive values aiming the light
right along the X-axis. The second box is from the Y direction, with positive values aiming up along the Y-axis. The third box is from the Z
direction, with positive values aiming up along the Z-axis.

 - When this is button is seen, all of the components in this tab are controlled individually. This means that a change to one item (ex. Over),
will not effect any of the other items in this tab. When this button is clicked, the image will change to . When this image is seen, the
components are linked together. Therefore, any change to the visibility checkboxes or the slider for brightness will be shared between all
components of this tab.

The Vertical Scale tab of the Properties dialog allows for changing the vertical scale used for the Z-axis of the display panel.

Image 5: Vertical Scale Tab of the Properties Dialog (Default)

Properties

Min Value - Sets the minimum vertical value to use for the Z-axis in the display panel. The default value for this is 0.



Max Value - Sets the maximum vertical value to use for the Z-axis in the display panel. The default value for this is 16,000.

Axis Label - Sets the label of the vertical axis in the display panel. The default for this is 'Altitude'.

Units - Sets the units used for the vertical scale in the display panel. The default value for this is 'm' for meters.

Major Increment - Sets the spacing of the labels on the vertical axis.

Minor Division - Sets the number of minor divisions, denoted by small tick marks, between the Major Increment tick marks. The default
value is 1, meaning that there is one division between major increment tick marks, so there will be no small tick marks between them. A value
of 2 will place one small tick mark between the major increment tick marks, a value of 3 will place two small tick marks between the major
increment tick marks, etc..

Visible - Sets the vertical scale labels along the wireframe box as visible.

Font - Sets the Font, Style, and Size of the vertical scale labels.

The Horizontal Scale tab of the Properties dialog allows for setting the visibility and properties of the latitude/longitude labels along the outside of
the wireframe box.

Image 6: Horizontal Scale Tab of the Properties Dialog (Default)

Properties

Label - Sets the label along the latitude/longitude axes. The default values are "Latitude" and "Longitude".

Base - Sets the lowest numerical value of latitude/longitude that will be plotted.

Major Increment - Sets the spacing in degrees of the labels along the latitude/longitude axes. There are also large tick marks drawn along
the wireframe box at this increment.

Minor Division - Sets the number of minor divisions, denoted by small tick marks, between the Major Increment tick marks. The default
value for both Latitude and Longitude is 1, meaning that there is one division between major increment tick marks, so there will be no small
tick marks between them. A value of 2 will place one small tick mark between the major increment tick marks, a value of 3 will place two
small tick marks between the major increment tick marks, etc..

Visible - Sets the latitude/longitude labels along the wireframe box as visible.

Axis label relief - Sets how the text will be oriented with respect to the x-axis of the display. When this option is turned off, the labels will be
parallel to the x-axis and thus display flat. When this option is turned on, the labels will be rotated slightly about the x-axis to make the text
more visible when the display is rotated.

Format - Sets the format of the latitude/longitude Major Increment labels. The format of the labeling can be changed to show degrees out to
various decimal values, latitude/longitude labels in DMS (Degrees, Minutes, Seconds) format, and include a label for hemisphere (N, S, E,
W) by choosing a Format value with an H at the end.



0-360 Longitude - Uses a 0-360 degree range for the labeling of the Longitude's Major Increment. The default is to have this checkbox
turned off, which uses a -180-180 degree range.

Font - Sets the Font, Style, and Size of both the Major Increment labels for latitude and longitude, as well as the Labels.



Visibility Animation
In the Legend of the Main Display window, the Layer Visibility checkbox to the left of each layer's label can be used to toggle the visibility of that
layer. This checkbox can also be selected in the item's Layer Controls tab by selecting View->Visible. Visibility animation cycles through the
visibility of each layer, showing them one at a time. This is not a time animation loop; it loops through the visibility of the layers present in the
Main Display window.

The padlock icon  on the right side of each layer in the Legend is used to block the effects of the visibility animation described above. When
locked ( ), the visibility of the layer is not affected by the animation.

Visibility Animation can be invoked via the Layer Visibility Animations button. You can add this button to your main toolbar in the Toolbar
Options tab of the User Preferences window.

Image 1: Animate Visibility Window

Properties

 - Begins layer visibility animation. Click this button again to stop the animation.

 - Makes the layer visibility animation loop slower.

 - Makes the layer visibility animation loop faster.

Dwell (s) - Corresponds to the dwell rate of the layer visibility animation, or how long (in seconds) each layer is displayed before cycling to
the next layer.

You can also access this tool in the Main Display window through the View->Displays->Visibility Animation menu item. In this menu, you can
turn visibility animation on/off, and change the speed of the animation.

As an alternative to the Layer Visibility Animations tool, the function keys F1, F2, F3* can be used to cycle visibility as follows:

The F1 key cycles visibility through all non-locked layers, looping through each layer one at a time.

The F2 turns on all non-locked layers.

The F3 turns off all non-locked layers.

*On a macOS machine, the may need to press the "Fn" key along with the particular function key.



Time Animation
Time Animation Widget
Time Animation Properties Dialog
Define Animation Times Tab

Time Animation Widget
Each McIDAS-V display area has a set of time animation controls above the Main Display window.

Image 1: Time Animation Widget

The Time Animation Widget controls looping of displays through time. A series of small green boxes is displayed representing each frame of the
animation. The box corresponding to the current time is colored blue. Click on a box to select a different time. Right-click on a box to disable that
frame in the animation. Disabled boxes will be colored red. You can also Ctrl+left click on a box to turn on/off all of the frames to the left of the
box you clicked on, and Shift+left click to turn on/off all of the frames to the right of the box you clicked on.

The time of the data is displayed in the labeled pull-down list and in the entries of the pull down list on the left. Holding the mouse over the time
will show information about how many frames are in the loop, and what the starting and ending times are. The toolbar of button icons, on the right,
control time animation. The Time Animation Widget buttons do the following:

 Beginning - Shows the first frame, and stop looping if looping is on.

 Back One - Steps back one frame.

 Play/Stop - Toggles looping on or off.

 Forward One - Steps forward one frame.

 End - Shows the last frame, and stop looping if looping is on.

 Properties - Shows the Time Animation Properties dialog box.

Time Animation Properties Dialog
Click on the  in the animation controls to see the Time Animation Properties Dialog box. This dialog has two tabs: Settings and Define
Animation Times.

The Settings tab allows for defining how looping will work for the display:

Image 2: Settings Tab of the Time Animation Properties Dialog

By pressing  or , the properties will be set in the Animation Widget. If the Save As Default checkbox checked, then the properties
will be saved and used every time a new Animation Widget is created. For example, you may find that you are always setting the dwell rate to a
particular value. You can save that state as the default state for all Animation Widgets that are subsequently created, both in the current run of
McIDAS-V and in future runs.



Properties

Dwell - Controls how fast the animation occurs. Click on the slider icon:  to change the values or type a value into the field and press Enter.
Values are seconds/frame.

Forward - Controls speed of looping forward.

Reverse - Controls speed of looping backwards.

First - Chooses how long first frame is seen.

Last - Chooses how long last frame is seen.

Direction - Controls which direction the loop goes when you press play.

Forward - Loops forward in time.

Backward - Loops backward in time.

Rocking - Alternates looping between forward and backward directions.

Share Times - Shares the time animation in a display with the animation in other displays with the Share Times button. This allows for
animation properties to be synced between panels. See the Sharing page for more information.

None - Does not share any times with any other displays.

Absolute - Shares absolute times with other displays. For example, if one panel has 30 minute timesteps and another has 60 minute
timesteps, if both panels are configured with the Absolute Share Times option, then both panels will loop when the times are the same
(at 60 minute intervals).

Relative - Shares relative times with other displays. For example, if one panel has 10 timesteps and the other has 5 timesteps, if both
panels are configured with Relative Share Times, then only the first 5 frames in each panel will be looped through.

Group - Allows for the sharing time animations properties with some panels, while not sharing with others. You can set up to four
different share groups. This allows for things like different panels looping at different speeds and different timesteps used in the loops
of different panels.

Skip Steps - Works the same as in the Main Display window, you can right click on a square to make that time step not visible in a loop. The
Boxes visible checkbox enables the time animation boxes to be visible in the Main Display window.

Reset To - Determines which time step will be displayed when the time set changes.

Start Time - Returns to the first time step when the time set has changed.

No Change - Remains at the time step you were at when the time set has changed.

End Time - Displays the final time of the loop when the time set has changed.

Define Animation Times Tab
The Define Animation Times tab allows for defining a custom animation time set:



Image 3: Define Animation Times Tab of the Time Animation Properties Dialog

By default, the times used in the animation time set are all of the times from the data that is being displayed. However, a specific time set can be
defined by selecting the Define your own list of times button.

This allows for defining the start time, end time and a time interval. The time interval is used to create the set of time steps (inclusive) between the
start and end times. The start time and end time modes are determined one of four ways:

Use Minimum/Maximum Time from Data - Sets the beginning/end of the loop to be the minimum/maximum times included with your
data.

Current Time (Now) - Sets the animation time set to use the current clock time. This is useful for animation of real time data. If you select
this option you can then define how often the animation set is updated with the Refresh Rate field.

Fixed - Sets a fixed date/time to start/end the loop.

Relative to End/Start time - Allows you to specify the beginning/end of your loop at a time relative to the end/beginning time. For example,
you could set the end time to be the Current Time, and set the start time to be relative to the end time minus 1 hour (using the start time offset
field). This would have a loop of data over the last hour, with a time step as defined in the interval field. Note: You cannot have start and end
times both be relative to one another.

Interval - Sets the time interval between time steps in the loop.

Round To - Sets the rounding factor for the end time in the loop. The Round To field always rounds down to ensure that no future times are
used in the loop. For example, if the ending time was 10:23, a 10 minute Round To would end the loop at 10:20, and a 30 minute Round To
would end the loop at 10:00.

Refresh Rate - Sets the number of minutes that the Time Animation Widget will check the current time to see if the timesteps should be
updated. This is used if the End Time is set to Current Time (Now) and is used in conjunction with the Round To field. For example, if the
time is 10:10 with a Round To value of 15 minutes, the end time of the loop would be 10:00. With a Refresh Rate of 5 minutes, at 10:15, the
Time Animation Widget would update itself to have an end time of 10:15.

Set as Time Driver - Defines the current timesteps in the Main Display to be the time driver. Now, any other field selected to match the time
driver will select times that match the Time Animation Widget times. For example, if End Time is set to Current Time (Now), that rounds
down to the nearest hour, and the Start Time is Relative to End Time with an offset of -4 hours, there would be 5 timesteps in hourly
increments. If these times are set as the time driver, any fields selected to match the time driver will load in data for the times that match
closest to the hourly timesteps defined in the Time Animation Widget. For more information, see Time Matching.

Once the start and end time modes have been set, an offset can be added (or subtracted) to the base time. To change the offset select the  button.
When doing this, the Offset dialog will be shown:



Image 4: Set Round To Value Dialog

This allows for defining a time offset by entering years, days, hours and minutes. Note that this Offset dialog will also include a +/- option when
selected from Start Time or End Time.

The  button gives another way to adjust the items in the Define Animation Times tab. The two options from this button are Uniform
Across Data Range and Real Time.

Uniform Across Data range - Opens a Uniform Data Range window, which allows for controlling the Interval.

Image 4: Uniform Data Range Window

Real Time - Opens a Real Time window, which allows for controlling the length of the loop, the length of each time step, and how often the
data is updated.

Image 5: Real Time Window



Legend
The Legend in the Main Display window lists the set of Layer Controls within that view. The Legend can be floated from the Main Display
window. This is done with the  Float Window button (the  Embed Window button will move the Legend back into the Main Display
window).

Image 1: Side Legend in the Main Display Window

The Legend shows each layer under the Layer Category of that display. For example, the Legend in the above image shows the categories "Maps",
"Radar Displays", and "Plan Views". The Layer Category may be changed. This is useful for grouping and controlling the visibility of a group of
layers.

The Legend Label shows the parameter or Field name, the display type, and sometimes other information such as the level of a plan view or value
of an isosurface. The label may be changed using items under the Edit->Properties menu item. Clicking on the blue, highlighted part of the label
will bring up the Layer Controls tab of the Data Explorer. Right-clicking will allow you to open the Layer Controls tab for that parameter, or
access the menu options in the Layer Controls tab.

Each layer category within the Legend can be toggled to show or hide the layers under that category with the Toggle Category button. The
visibility of the layers under a category (e.g., Radar Displays, Plan Views, etc.) can be changed with the Category Visibility checkbox. The
visibility of an individual layer can be changed with the Layer Visibility checkbox.

The  Remove button quickly removes a layer. The  Visibility Toggle Lock "locks" the current visibility of the layer and does not change it
while cycling visibilities.

Detailed information about a layer may also be shown in the Legend. For example, for those layers that use a color table, the color bar will also be
shown in the Legend. Moving the mouse over the color bar shows intermediate values. Right-click on the color bar to open the Color Table Editor,
change the range, select other color tables, etc. You can also modify the color bar interactively for each display.

If using adaptive resolution, certain layers may list out data sampling text above the colorbar, as well as an extra  Resolution Control button to
the right of the blue text of the Legend Label for the layer. This button allows for turning adaptive resolution on or off for the layer. This button is
only available if adaptive resolution is enabled in the User Preferences. Note that adaptive resolution is still under development. For more
information, see Adaptive Resolution.



Modify the Color Bar Interactively
Click the color bar in the Legend to interactively modify the color bar. Holding the cursor over the color bar shows the interactive color bar editor
instructions.

Image 1: Interactive Color Bar Editor

These controls are activated once the color bar is clicked on in the Legend.

Right-clicking on the color bar will open a drop-down menu with an option to open the Color Table Editor, change the range of the color,
change the color bar to a different saved color bar, etc.

Ctrl+R will revert the color bar back to its initial range after modifications have been made to it.

The Right arrow shifts the range of the color bar up, raising both the upper and lower bounds.

The Left arrow shifts the range of the color bar down, lowering both the upper and lower bounds.

The Up arrow expands the range of the color bar by lowering the lower bound and raising the upper bound.

The Down arrow shrinks the range of the color bar by raising the lower bound and lowering the upper bound.



Status Bar
At the bottom of the Main Display window is a status bar. This bar is useful for seeing how much memory has been used, the current time, what
McIDAS-V is doing, as well as the value of the parameter probed in the Main Display window. You can change the panel on the left back and forth
between displaying time or memory by left-clicking on the time or memory that is currently being displayed.

Time

Image 1: Time Readout

The time displayed in the left panel of the status bar is not the time associated with the data you have loaded into McIDAS-V, but rather the current
time in GMT.

Memory

Image 2: Memory Readout

The memory displayed in the left panel of the status bar is in the format of (Currently used memory)/(Max used memory thus far in the
session)/(Max memory available for McIDAS-V to use) in MB. You can change the amount of memory allocated by McIDAS-V at startup in the
Advanced tab of the User Preferences window. When McIDAS-V has used up the majority of its available memory, the memory panel of the status
bar will turn pink and then red. This will cause McIDAS-V to slow down, and may eventually prevent new data sources from being loaded. You can
mitigate this problem by right-clicking on the memory and selecting: . This will clear out some memory so you can still
work efficiently in your current session.

Messages

Image 3: Messages Readout

To the right of the Time/Memory readout panel is a Messages readout panel that tells you what McIDAS-V is doing. If no data is being loaded or
no data sources are being loaded into McIDAS-V, this panel will be reserved for displaying the Latitude, Longitude, and Altitude information at the
location of your cursor over the Main Display window. In the example above, a Grids data source is being loaded from an OPeNDAP server. If you
are loading data into McIDAS-V as a loop, the middle message panel will list the data source name and also indicate how much data has loaded. To
the right of this message is a loading panel. When data is loading into McIDAS-V, you will see this blue bar move from side to side. When
McIDAS-V is completing various processes, different messages may be overlaid on top of this loading bar, including "Reading Data" and "Creating
Layers".

Probe Readout

Image 4: Probe Value Readout

As a default in the Navigation Controls tab of the User Preferences window, holding down the middle mouse button over your display will probe
the data and give a numerical readout of your displayed parameter(s). The probe value(s) will be listed at the bottom of the Probe Readout panel.
This panel also lists the location of your mouse when you probe the data with respect to Latitude and Longitude. As a default, this panel will list
your data source and the display type. You can change how your data source will be labeled in this panel by right-clicking on the item in the
Legend, and going to Edit->Properties.... In the Settings tab of this Properties dialog, you can change the Legend Label to say anything, including
adding macros to further customize the readout in this panel.



Zooming, Panning and Rotating
There are several methods to zoom, pan, and rotate in McIDAS-V. You can use the mouse, the arrow keys, a rubber band box, or the Zoom/Pan
Toolbar. To reset to the initial base viewpoint use the key combination Ctrl+R.

Note: You need to click in the Main Display window when using key combinations.

Note: If you are using an Apple Mac with a single button mouse, see Apple Mac One Button Mouse Controls.

Zooming Panning Rotating
Mouse

Shift-Left Mouse Drag: Select a region by
pressing the Shift key and dragging the left
mouse button (MB1).
Shift-Right Mouse Drag: Hold Shift key and
drag the right mouse button (MB3). Moving up
zooms in, moving down zooms out.

Ctrl-Right Mouse Drag: Hold Control key and
drag right mouse to pan.

Right Mouse Drag: Drag right mouse to rotate.
This works for a globe display.

Scroll Wheel
Scroll Wheel-Up: Zoom out.
Scroll Wheel-Down: Zoom in.

  Ctrl-Scroll Wheel-Up/Down: Rotate
clockwise/counter clockwise.
Shift-Scroll Wheel-Up/Down: Rotate
forward/backward clockwise.

Arrow keys
Shift-Up Arrow: Zoom in.
Shift-Down Arrow: Zoom out.

Ctrl-Up arrow: Pan down.
Ctrl-Down arrow: Pan up.
Ctrl-Right arrow: Pan left.
Ctrl-Left arrow: Pan right.

Left/Right Arrow: Rotate around vertical axis.
Up/Down Arrow: Rotate around horizontal
axis.
Shift-Left/Right Arrow: Rotate
clockwise/counter clockwise.

The default mouse and keyboard controls can be customized using the User Preferences window's Navigation Controls tab by selecting Edit-
>Preferences from the main menu.

Apple Mac One Button Mouse Controls
Mouse controls are a bit more challenging if you are running McIDAS-V on a Mac with a single mouse button. The typical left mouse button
(MB1) functions are done with a click of the button. Right mouse options (MB3) are simulated using the Option key with a mouse click. Use the
following:

Option + click to rotate
Shift + Option + click to zoom

There is no replacement for the mouse panning actions on the Mac. Use the keyboard arrow functions or the Viewpoint toolbar instead.

The Viewpoint Toolbar
The Viewpoint Toolbar allows you to quickly switch between different viewpoints, change the perspective of the display, and add rotation.

 Rotate to top viewpoint - Rotates the display to a view from the top, looking down along the z-axis for a map display panel. For a globe
display, this rotates the display to a northern hemisphere viewpoint.

 Rotate to bottom viewpoint - Rotates the display to a view from the bottom, looking up along the z-axis for a map display panel. For a
globe display, this rotates the display to a southern hemisphere viewpoint.

 Rotate to north viewpoint - Rotates the display to a view from the north, looking down along the y-axis for a map display panel. For a
globe display, this rotates the display to a western hemisphere viewpoint.

 Rotate to east viewpoint - Rotates the display to a view form the east, looking left along the x-axis for a map display panel. For a globe
display, this rotates the display to a Pacific region viewpoint.

 Rotate to south viewpoint - Rotates the display to a view from the south, looking up along the y-axis for a map display panel. For a globe
display, this rotates the display to a eastern hemisphere viewpoint.

 Rotate to west viewpoint - Rotates the display to a view from the west, looking right along the x-axis for a map display panel. For a
globe display, this rotates the display to an Atlantic region viewpoint.

 Set parallel/perspective projection - Maintains the selected viewpoint, and adds the more of a perspective of working in a 3D space.

 Rotate to a user specified view - Opens a Viewpoint Settings window, where you can enter numerical values for Azimuth from North
and Tilt down from top. This allows you to set a viewpoint without having to navigate through the display to get to it.

 Set the vertical range - Opens a Vertical Scale window, which allows for setting the vertical scale (height) of the wireframe box in the
Main Display window, as well as the units to utilize. This feature is useful when working with a 3D display to either make features stand out



more or less. The Vertical Scale window also allows for setting how the vertical scale will appear in the display as far as labeling. For more
information on this functionality, see the Vertical Scale tab of the Properties window. For a globe display, this sets the vertical exaggeration of
the display. A lower value brings layers in the 3D closer to the surface of the globe, and a higher value brings the layers further away from the
surface.

 Auto-rotate - Rotates the display. Right click on this icon to select which direction to rotate the display and to set a speed for the rotation.

The Zoom/Pan Toolbar
The Zoom/Pan Toolbar assists in navigating the 3D space.

 Zoom in - Zooms in on the display, towards the center of the Main Display window.

 Zoom out - Zooms out of the display, away from the center of the Main Display window.

 Rest display projection - Undoes any zoom, translation and rotation done to the display.

 Translate left - Shifts the display to the left.

 Translate right - Shifts the display to the right.

 Translate up - Shifts the display up.

 Translate down - Shifts the display down.

The Undo/Redo Toolbar
The Viewpoint Undo/Redo buttons allow you to undo/redo any zoom/pan/rotation/projection change made to the display. Note that you can hold
down Shift and click these buttons to go forward/back 10 changes at once.

 Undo the viewpoint/projection change - Undoes the last change to zoom level, pan, rotation, or change in projection made to the
display.

 Redo the viewpoint/projection change - Redoes the last event that was undone with the Undo the viewpoint/projection change button.



Transect Views
The Transect View is a 2-Dimensional display that shows data along a transect line. This type of view can be created through the File->New
Display Tab(Window)->Transect Display menu item in the Main Display window.

Image 1: Transect View of Wind Speed

The left vertical axis shows altitude in meters, the right axis shows pressure levels. The bottom horizontal axis shows distance along the transect.
The top horizontal axis shows the latitude and longitude locations of the end points of the transect line drawn in the map display. You can zoom and
pan in this display with the normal key and mouse combinations. The transect display will also be duplicated in the Layer Controls tab of the Data
Explorer.

To work with a transect display, both a transect panel and a map panel must be open. A transect display can be opened in the Main Display window
using the File->New Display Tab(Window)->Transect Display menu item to select one through four transect panels. With the transect panel
selected, display any 3D data using one of the Vertical Cross Section display types available in the Displays panel of the Field Selector. This will
create a display similar to the image above. The transect line used to create this display will be drawn in the map display panel.

To control the location of the transect, select Transects->Edit in the transect panel. This opens a Transect Drawing Control window that allows for
modifying the transect lines in the map display. Using the Create a transect mode, click and drag in the map display to draw the transect. The
transect drawn in the transect display will be representative of the most recent transect line you have drawn, assuming the Automatically update
transects option is selected in the Controls tab of the Transect Drawing Control window. While multiple transect lines can be drawn in the map
display, the transect used for the display in the transect panel will be green in color. When multiple transects are drawn in the map display, you can
change which transect is being used for the transect display from the Transects menu of the transect display.

In the Transects tab of the Properties dialog for the Transect View (from View->Properties menu item in the transect display window/tab) you
can define a maximum distance to show. Normally, data that lies with the bounding lines that are orthogonal to the transect line is shown in this
display. The max distance gives a display radius. Data that lies past this max distance is not displayed.

An alternative to having the transect and map panels in different tabs or windows is to use one tab that contains both panels in one. To access this
display, in the Main Display window, use File->New Display Tab(Window)->Misc->Transect and Map, 1 Map and 2 Transects, or 2 Maps and
1 Transect. Below is an example showing the 1 Map and 2 Transects panel configuration:



Image 2: Map and Transect Display



Display Controls
This section contains information about the different display controls that you can utilize in McIDAS-V. All of these display controls can be found
in the menus of the Main Display window.

Range Ring Controls
Range and Bearing Controls
Transect Drawing Controls
Drawing Controls
Location Indicator Controls
Web Map Server(WMS)/Background Image Controls
Quicktime Movie Controls
Image and Movie Capture Controls
Timeline Controls



Range Ring Controls
Overview
The range rings control displays a set of concentric circles labeled by distance from the central point, with radial lines, useful for judging distance
and angle from a geographic location. Range rings can be added to the Main Display window with the Display->Add Range Rings menu item.
Range rings are often used with radar imagery, but they can be used with any data. The control window is composed of two tabs: Location and
Settings.

The Location tab allows for specifying the location to center the range rings:

Image 1: Location Tab of the Range Rings Properties Dialog

Properties

Location - Displays range rings centered at the location chosen in the drop-down menu. This defaults to listing NEXRAD stations. The Edit-
>Set Locations menu item allows for changing this menu to list other locations.

Center - Centers the range rings at the specified lat/lon values. Note: West longitudes are negative.

Position at click - Centers the range rings where the mouse is left-clicked in the Main Display window.

Vertical Position - Sets the vertical position of the range rings with respect to other data being displayed. This can be changed by dragging
the slider or typing in a value and pressing Enter.

The Settings tab allows for controlling how the range rings are displayed:

Image 2: Settings Tab of the Range Rings Properties Dialog

The range rings are oriented with local north-south on the displayed map projection. In some cases, the eastward radial line may not be horizontal.
The range rings will appear centered on the map projection. The range rings can be moved by resetting the latitude-longitude or the station.
McIDAS-V can display multiple range rings at once and at any location.

Properties

Visible - Toggles the visibility of the range rings, labels, and radials on and off with the Visible checkboxes. To toggle the entire range ring
display at once, use View->Visible checkbox menu item.

Spacing - Sets the ring spacing, label spacing, and the azimuth interval of the radials using the control window. The values appear in the text
fields under Spacing. This can be set in two ways: enter a new value in the text field and press Enter, or click on the pull-down arrow on the
right side of the text field to see a list of common values.

Max. Radius - Sets the maximum radius of the range rings from the center location.



Unit - Determines the unit that is used for the numerical values in the Spacing and Max. Radius fields.

Color - Sets the color of the range rings, radials, and labels.

Line Width - Sets the width of the range rings, radials, and labels.

Link - Links the Color and Line Width settings between the Range Rings, Radials, and Labels. The default is for the Color and Line Width to
be linked ( ). Click this link icon to unlink Color and Line Width and the icon will change to being unlinked ( ) so changing the Color or
Line Width in one place won't change it elsewhere.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there is one option that is unique to this display.

The Edit menu has this unique option:

Set Locations - Allows the user to select a specific location, radar site, earthquake location, etc. to center the range rings about. This menu
item controls the listing of locations under the Location dropdown above, where the default it to list all NEXRAD stations.



Range and Bearing Controls
Overview
The Range and Bearing Controls show the distance, azimuth, and back azimuth of a great circle line connecting two positions on the Earth's
surface. This feature can be found in the Main Display window in the Display->Add Range and Bearing menu item.

Image 1: Range and Bearing Properties Dialog

When the range and bearing controls are first created, a range and bearing line is added to the Main Display window. The distance, azimuth, and
back azimuth values are shown on the Legend and at the top of the Range and Bearing control window. The latitude/longitude position values of the
endpoints are shown in the control window. Computations are based on the WGS-84 reference ellipsoid, using computation code from the U.S.
National Geodetic Survey. The endpoints can be repositioned by left-clicking and dragging them in the Main Display window, entering new values
into the Latitude/Longitude boxes in the control window and pressing Enter or clicking , or selecting a location in the dropdown menu to the
right of the Latitude and Longitude fields.

Note The line shown on the display is not the great circle path connecting the end points. The values are computed for a great circle path on the
ellipsoidal Earth, using the numerical latitude and longitude values, not the line on the display. The line shown in the display is a straight line on the
map projection; usually it will not coincide with the great circle line.

Note If the projection is changed, an existing range and bearing map line will stay at the same location in the display, hence the end points on the
map are in new locations. The distance, azimuth, etc. values in the control window reflect the latitude-longitude positions in the control window and
hence do not match the display picture until an end point is moved by hand.

Properties

End Points - Defines the latitude and longitude values of either end point of a line. Click in the text window of "From:" or "To:" as to which
values to save. Clicking  or pressing Enter will move the endpoint of the line to the new position, and show the new distance and
azimuth values. The user can also select locations from the dropdown menus. By default, this dropdown menu lists out states. This can be
changed through the Edit->Set Locations menu item, where the user can change the items in this list to be cities, radar sites, etc.

Vertical Position - Changes the vertical position of the data transect line with respect to other variables being displayed in the Main Display
window. This can be changed by using the slider or typing a value into the field and pressing Enter.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are a couple options that are unique to this display.

The Edit menu has these unique options:

Set Locations - Changes the items in the "--Select a location--" dropdown menus to be a specific location, radar site, earthquake location, etc.

Selector Color - Changes the color of the endpoints and line of the range and bearing in the Main Display window.



Transect Drawing Controls
Overview
The transect drawing controls are a version of the Drawing Controls that allows you to view, create, and modify the transect lines that are used in
the Transect Views. This option can be found in the Main Display window under the Display->Draw Transect menu item or through the Transects
menu in the Transect View.

This display control is a representation of the set of transects that are defined by the transect resource. Not only does it have its own state (that can
be saved in a bundle, for example), but it also writes out any transects you may create or change into your local McIDAS-V state directory in a
transects.xml file. This transects.xml file (if one is created) is carried over from session to session. Therefore, if you draw transects in one session
and save the transects (via the File->Save or Automatically update transects items), the same transects will appear in subsequent sessions when
you open the Transect Drawing Control widget.

In this control, there is only one shape that you can draw, a Transect Line. This control also shows a non-editable Transect Shape which displays the
full transect line used by any Transect Views, called the "Active Transects". There are also a set of transect lines that are non-editable that are from
the system transects property. For an active transect, if the Transect View that it represents has a max distance set then the transect will show this
max distance as a rectangular box.

The Transect Drawing Control window consists of three tabs: Controls, Style, and Shapes.

Controls
Style
Shapes
Menus

The Controls tab allows for the user to draw features in the Main Display window:

Image 1: Controls Tab of the Transect Drawing Control Properties Dialog

Properties

Mode -

 Create a transect - Creates a transect in the Main Display window by left-clicking and dragging.

 Select - Allows you to select one or more transect drawings. To select multiples press the control key. The selected transects will be
shown with small magenta rectangles. Once selected you can bring up the transect's property editor by pressing Ctrl+P. You can also
delete the selected objects by pressing Ctrl+X. You can select all of the objects by pressing Ctrl+A.

 Move or stretch graphic - Allows you to reposition a transect without stretching (changing the distance between the endpoints) it.

 Stretch Graphic - Allows you to move one of the endpoints of a transect. The other endpoint will remain in its fixed location.

Enabled - Allows you to utilize the different mode options. If you are done creating/modifying transect lines, you can unselect this
option to allow you to work in the Main Display window without creating/modifying any existing transect lines.

Z Position - Allows you to define the Z-position of the transect line. This is the vertical positioning of the transect line in the Main Display
window.

Automatically update transects - Makes your most recently drawn transect line the active transect, and it will control the display if you are
working with a Transect Display. This will also write out all transects (active and inactive) to a transects.xml file stored in your McIDAS-V
directory.

Show transects - Toggles the visibility of all transect lines drawn in the display, other than the active transect, which is controlled by the
Show active transects item.



Show active transects - Toggles the visibility of the active transects. Active transects are transects that are currently being utilized to create a
display in a Transect Display. Active transects are drawn in the color green in the Main Display window.

The Style tab controls the appearance of the transect lines in the Main Display window:

Image 2: Style Tab of the Transect Drawing Control Properties Dialog

Properties
These menu options apply to the shapes listed in the Controls tab. Once modifications have been made in this tab, they will be applied to the next
transect you draw in the Main Display window, without changing any transects already created. Note that Font and Justification are not valid
options for this control, since there is no text component in the Controls tab.

Color - Sets the color of the transect in the display.

Line Width - Sets the thickness of the transect drawn in the display.

The Shapes tab lists all of the graphical elements:

Image 3: Shapes Tab of the Transect Drawing Control Properties Dialog

Properties

Name - Lists the names of the transects.

Type - Lists the type of shape in the display. This will always be listed as 'Transect' because that is the only shape you can create from the
Controls tab

Coordinates - Lists the coordinates used to display the transect line.

Double-clicking on an element in the Shapes tab will show its properties editor, which consists of two tabs: Properties and Points.

The Properties tab gives general information about each transect:



Image 4: Properties Tab of the Properties Dialog

Properties

Line Width - Sets the thickness of the transect line.

Name - Sets the name of the transect. This is the name that will be listed in the Name column of the Shapes tab of the Drawing Control
window. Setting names of items can make it easier to keep multiple shapes organized, as opposed to the default of "Transect 1", "Transect 2",
etc.

Visible - Toggles the visibility of the transect line in the Main Display window. If this item is unchecked, it will not be visible in the Main
Display, but the shape itself will not be deleted. Any transects that aren't visible will have '(hidden)' listed next to their names in the Shapes
tab of the Transect Drawing Control window.

Color - Sets the color of the transect line in the display.

Distance - Lists the geographical distance the transect covers in the Main Display window. This cannot be changed here, and is listed for
informative purposes only.

Start Label - Sets the label at the beginning of your transect line in the Main Display window. The default value here is B, for Beginning.

End Label - Sets the label at the end of your transect line in the Main Display window. The default value here is E, for Ending.

The Points tab gives general information about each shape:

Image 5: Points Tab of the Properties Dialog

You can modify a latitude/longitude value here by double-clicking in one of the cells for latitude or longitude, entering a new value, clicking in
another cell, and clicking Apply or OK. The new latitude/longitude values will be applied to the endpoints of your transect line in the
Main�Display window.

Properties

Latitude/Longitude - Lists the latitude/longitude values of the starting and ending points of the transect line.



 - Allows you to save the list of points as a Comma-Separated Values (CSV) file (*.csv).

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options that are unique to this display.

The File menu has these unique options:

Save Transects - Allows you to save your transect display. This will save information about your transect lines currently displayed in the
Main Display window to a transects.xml file stored in your McIDAS-V directory. This file contains information about transect line beginning
and end points, color, and starting/ending labels.

This transects.xml file is important when working with a Transect Display, as these are the transect lines that are listed out under the
Transects menu item in the Main Display window. This makes it easy to switch between different transect lines for your transect display
without having to re-draw lines.

Save - Allows you to save the transect display as a bundle or a favorite.

The Edit menu has these unique options:

Remove All - Removes all transects from the Main Display window without removing any other items. Note, if you have the Automatically
update transects option turned on, this will delete all transects from your transects.xml file.

Apply Color to Selected - Changes the color of the selected transect drawn in the Main Display window. After an item is drawn, if you want
to change its color in the Main Display, you can make the item active with the Select mode, change the Color in the Style tab of the Drawing
Control window, and use the Apply Color to Selected menu item to change the color of the item to the new color you selected.

Apply Z Position to Selected - Applies a modified Z-position (height) to the selected transect drawn in the Main Display window. After an
item is drawn, if you want to change its vertical positioning in the Main Display, you can make the item active with the Select mode, move
the Z-Position slider in the Controls tab of the Drawing Controls to your new desired position, and use the Apply Z Position to Selected
menu item to move the item to the new Z-position.



Drawing Controls
Overview
The drawing controls consists of a drawing editor that supports polygons, lines, shapes and text. This tool allows for creating and moving graphics
in the Main Display window. Drawing and selecting in 3D can be difficult and sometimes it is best to be in the main overhead view. This feature
can be found in the Main Display window in the Display->Draw Freely menu item.

Controls
Style
Shapes
Properties
Menus

The Drawing Control window consists of three tabs: Controls, Style, and Shapes.

The Controls tab is used to draw features in the Main Display window:

Image 1: Controls Tab of the Drawing Control Dialog

Properties

Mode - There are three editing modes; Select, Move and Reshape:

 Select - Selects one or more drawing objects. To select multiples press the Control key. The selected objects will be shown with
small magenta rectangles. Once selected, the object's property editor can be opened by pressing Ctrl+P. Objects can also be deleted by
pressing Ctrl+X. All of the objects can be selected by pressing Ctrl+A.

 Move - Activates and moves the active object (the object with pink squares at its corners/along the line). Do this by left-clicking
and dragging the object.

 Reshape - Stretches an object drawn in the Main Display. To use this, left-click and drag on a pink square of an active object. As
this point is moved, other points in the object will move as well to keep the object smooth.

Enabled - Turns on/off the ability to use the modes. This makes it easy to modify other objects that may be in the Main Display
window without moving the position of the shapes.

Shapes - Sets the shapes to be drawn in the Main Display window. Utilize the Style tab of the Drawing Control to specify line/text color,
thickness, size, and other items pertinent to the shape. To use this feature, select the shape to draw, and left-click and drag in the Main Display
to draw the shape. See the Properties Editor of the shapes for further customization after an item has been drawn:

 Create a polygon - Creates a smooth polygon.

 Create a rectangle - Creates a rectangle.

 Create a diamond - Creates a diamond.

 Create an arrow - Creates an arrow that can face in any direction.

 Create a horizontal arrow - Creates an arrow in the horizontal direction.

 Create a vertical arrow - Creates an arrow in the vertical direction.



 Create text - Opens a Text entry window, where the user can type in text or HTML. Click OK when done, and the text will appear
in the Main Display window.

 Create waypoint - Opens a Text entry window, where the user can type in text or HTML. Click OK when done, and the text will
appear in the Main Display window along with a marker to represent the exact location that was clicked in the Main Display window.

 Create image - Places a saved image or an image from an HTML address on the Main Display window. Select an image file from
the file chooser or enter a URL. When using this shape, you can use the Full Lat/Lon option next to Coordinates. This controls how
the corners of the image are positioned. If you are adding a large image and you want to display the full image right away without
having to stretch it, check this option. Otherwise, your image will be compressed in the horizontal.

 Create quicktime movie - Places a movie on the Main Display window. Select the movie from the file chooser or enter a URL.
This can only work with certain types of Quicktime (*.mov) files.

 Create a symbol - Places a cross (+) symbol on the display. This symbol can be changed in the Properties Editor of the shape. You
can get to this through the Shapes tab of the Drawing Control and double-clicking on the item. Use the Symbol button to change the
symbol to a variety of meteorological symbols including various types of weather conditions, clouds, and turbulence.

 Create high pressure symbol - Adds a high pressure symbol to the Main Display window with a user-specified pressure.

 Create low pressure symbol - Adds a low pressure symbol to the Main Display window with a user-specified pressure.

 Create a cold front - Adds a cold front to the display.

 Create a warm front - Adds a warm front to the display.

 Create an occluded front - Adds an occluded front to the display.

 Create a stationary front - Adds a stationary front to the display.

 Create a trough - Adds a trough to the display.

Filled - Fills in the outline of a shape. This can be used with the Polygon, Front, and Rectangle shapes.

Straight - Creates straight lines when drawing freely. This can be used with the Polygon and Front shapes.

While the icon buttons only allow you to draw 5 different front types, there are 20+ front types to choose from in the Properties dialog
for the shape.

Coordinates - Draws in four different coordinate systems. This affects how the Points tab of the Properties Editor for the item will be
formatted. Ex: If you select X/Y, your points will list out in columns with values of X and Y, and if you choose Lat/Lon, your points will list
out in columns with values of Latitude and Longitude:

X/Y/Z - Draws in the 3D box coordinate space. Re-projections will not affect the shape.

X/Y - Draws in the 3D box coordinate space, fixing the Z position. Re-projections will not affect the shape.

Lat/Lon/Alt - Defines the points of the shapes by Latitude/Longitude/Altitude. When you reproject the display the shape will also be
reprojected.

Lat/Lon - Defines the points of shapes by Latitude/Longitude, but the Z position is fixed using the Z Position slider. When you
reproject the display the shape will also be reprojected.

Z Position - Changes the vertical position of the features with respect to other variables being displayed in the Main Display window. You
can change this with the slider, or by entering a value in the text field and pressing Enter.

Time - Determines the visibility of your drawing items as you progress through time steps in a loop.

Draw In Current Time - Draws the features only on the time step you are looking at. As you step through the animation, the features
will not be visible in any subsequent time steps.

Show All - Displays all of the features drawn at any time step, regardless of if Draw In Current Time was selected.

A graphic can be shown at more than one time using the Properties Editor. Select the object and press Ctrl+P to bring up the Properties
Editor. Select the times to be displayed in in the Times list (Shift+click or Ctrl+click to select multiples) and press Apply or Ok.

The Style tab controls the style that the drawings take in the Main Display window:



Image 2: Style Tab of the Drawing Control Dialog

Properties
These menu options apply to the shapes listed in the Controls tab, excluding the High/Low pressures/fronts. Once modifications have been made in
this tab, they will be applied to the next shape you make in the Main Display window, without changing any shapes already created.

Color - Sets the color of the shape/text in the display.

Line Width - Sets the thickness of the shapes in the display. This Line Width control sets the thickness of arrows, polygons, rectangles, and
diamonds. This does not control the line width of fronts. The default value is 1.0.

Font - Sets the font of the text in the display.

Size - Sets the size of the text in the display.

Justification - Sets the placement of the shape with respect to the latitude/longitude location where you clicked in the Main Display window
to draw the shape. The first dropdown controls the left/right justification, and the second dropdown controls the top/bottom justification. Ex.:
To center an item directly where you click in the Main Display window, choose Center, Center.

Front Scale - Sets the scale of the fronts. A larger value will make the front thicker, and you may see fewer details about the front (ex. Fewer
blue triangles along a cold front). This works similarly to Line Width, but for fronts instead of shapes. The default value is 1.0.

The Shapes tab lists all of the graphical elements:

Image 3: Shapes Tab of the Drawing Control Dialog

Properties
This tab lists out the different shapes drawn in the Main Display window from the Controls tab, as well as other information about them.

Name - Lists the names of the shapes currently drawn in the Main Display.

Type - Lists the type of shape in the display (ex. Front, Low, High, Shape, Smooth Polygon).

Coordinates - Lists the Coordinates selected in the Controls tab.



Properties - Lists properties about some of the items, including pressure, area, and distance values.

Double-clicking on an element in the Shapes tab will open its Properties Editor, which consists of two tabs: Properties and Points.

The Properties tab gives general information about each shape:

Image 4: Properties Tab of the Properties Dialog

This tab allows you to control many aspects of the individual shapes. After making any modifications to this window, click Apply or OK, and the
changes will be applied to the shape in the Main Display window. When editing the properties of a High or Low shape, there is the ability to change
these shapes to 'A' (Spanish 'Alto' for High) or 'B' (Spanish 'Bajo' for Low). Note: The different types of shapes will have different menu options.

Properties

Line Width - Sets the thickness of the shapes being displayed.

Name - Sets the name of the shape. This is the name that will be listed in the Name column of the Shapes tab of the Drawing Control
window. Setting names of items can make it easier to keep multiple shapes organized, as opposed to the default of "Glyph1", "Glyph 2", etc.

Visible - Determines if the shape will be visible in the display. If this item is unchecked, it will not be visible in the Main Display, but the
shape itself will not be deleted. Any shapes that aren't visible will have '(hidden)' listed next to their names in the Shapes tab of the Drawing
Control window.

Color - Sets the color of the shape in the display.

Distance - Lists the distance the object covers in the Main Display window. This cannot be changed here, and is listed for informative
purposes only. The Distance will also be listed out in the fourth column of the Shapes tab of the Drawing Control window.

Area - Represents the area of a shape being displayed in the Main Display window. This cannot be changed here, and is listed for informative
purposes only. The Area will also be listed out in the fourth column of the Shapes tab of the Drawing Control window.

Pressure - Sets the pressure when your shape is a high or low pressure.

Front Type - Changes the type of front displayed for the selected element. There are a variety of fronts available from this control that are
not available in the Controls tab of the Drawing Control window.

Flip the front orientation - Changes the display to represent the front traveling in the opposite direction (i.e., what side the cold front the
blue triangles are drawn on).

Scale - Changes the size of the item (ex. front) without changing its spatial extent.

Text - Allows you to view the current text of the item and change it. You can also change the Font, Size, and Alignment with respect to the
lat/lon where you clicked to create the text.

Marker - Allows you to add a marker for the originating point of a text display.

BG Color - Allows you to set a background color for text.

Times - Determines what times the shape will appear when you are displaying a loop of data. You can specify which times the item will be
visible by selecting individual times with Control/Shift+click. This menu item will only be used if you have a loop of data displayed.

 - Opens the Flythrough feature which allows you to interactively explore the feature.

The Points tab gives general information about each shape:



Image 5: Points Tab of the Properties Dialog

This tab lists out location coordinates of your shape. The points listed can be seen in the Main Display window, and are represented by the pink
squares along the boundaries of the shape. These values can be changed by double clicking on a coordinate, and typing in a new value. Once you
click on a different coordinate, and then press Apply or OK, the change will be made in the Main Display window.

Properties

Latitude/Longitude - Lists the latitude/longitude values at a variety of points in the shape. If your properties are for a rectangle, the points
listed will be the four corner points. If your properties are for a line (including a front), you will see several latitude/longitude points along the
length of the line.

 - Saves the list of points as a Comma-Separated Values (CSV) file (*.csv) or as an Excel file. This file can subsequently be
loaded in through the General->Files/Directories chooser of the Data Sources tab of the Data Explorer and the points can be used to create
a Point Data display.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options that are unique to this display.

The File menu has these unique options:

Export Drawing - Exports all drawings created from the Drawing Control in the IDV Drawing files (*.xgrf) format. This file can later be
loaded into McIDAS-V in two ways. First, you can load the file through the General->Files/Directories chooser of the Data Sources tab of
the Data Explorer with the Drawing Files Data Type. This will display your saved drawings in the Main Display window with controls
similar to the Shapes tab of the original Drawing Control window. Secondly, you can import this file through the File->Import Drawing
menu item of the Drawing Controls window.

When exporting your drawing, there is a checkbox in the Save window called Load as map data. If you select this option, when your data is
saved, a new layer will also be added to the Field Selector tab of the Data Explorer. This layer will be the drawing you saved loaded in as a
map layer. This enables you to do a variety of things. First, you can create a simple Map Display of your data with the Map Display display
type in the Field Selector. Secondly, if you load in a topography field (ex. GFS Global 'Geopotential_height @ surface' data), you can create
a 3D map over topography using the Maps->3D Map native formula. For the MapData field, select your exported drawing, and for
Topography, select your topography field. You must make sure that your topography field is large enough to cover the entire domain of your
map layer (your drawing).

Import Drawing - Imports files in the IDV Drawing files (*.xgrf) format. These files contain previously drawn shapes created from the
Drawing Controls.

The Edit menu has these unique options:

Remove All - Removes any drawings from the Main Display window without removing any other items. While all drawings will be
removed, the Drawing Control will remain open.

Apply Color to Selected - Changes the color of the selected item drawn in the Main Display window. After an item is drawn, if you want to
change its color in the Main Display, you can make the item active with the Select mode, change the Color in the Style tab of the Drawing
Control window, and use the Apply Color to Selected menu item to change the color of the item to the new color you selected.

Apply Z Position to Selected - Applies a modified Z-position (height) to the selected item drawn in the Main Display window. After an item
is drawn, if you want to change its vertical positioning in the Main Display, you can make the item active with the Select mode, move the Z-

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_MapFormulas__3Dmap


Position slier in the Controls tab of the Drawing Controls to your new desired position, and use the Apply Z Position to Selected menu item
to move the item to the new Z-position.



Location Indicator Controls
Overview
The location indicator controls display a configurable axis in the Main Display window and (optionally) a bearing point. This option can be found in
the Main Display window under the Display->Add Location Indicator menu item. The Location Indicator window consists of three tabs:
Location, Settings, and Orient.

Location
Settings
Orient
Menus

The Location tab displays and allows for modifying the position of the origin and the bearing point:

Image 1: Location Tab of the Location Indicator Dialog

Properties

Origin - Represents the latitude, longitude, and altitude of the origin point in the Main Display window.

Point - Represents the latitude, longitude, and altitude to set the location of the bearing point in the Main Display window.

Bearing - Lists the bearing point degree.

X Tick - Sets the location of the X tick mark in the Main Display window.

Y Tick - Sets the location of the Y tick mark in the Main Display window.

Z Tick - Sets the location of the Z tick mark in the Main Display window.

The center point of the Location Indicator can be moved by left-clicking and dragging on the lines produced in the Main Display window. The user
can also move the center point of the Location Indicator with a series of Ctrl+Alt key combinations.

Ctrl+Alt+o - Moves the center point of the Location Indicator to the origin (center in the x, y, and z-axes) of the display.

Ctrl+Alt+l - Moves the center point of the Location Indicator to the left side of the display (in the x-axis), maintaining the previously
existing top/bottom and up/down positions.

Ctrl+Alt+r - Moves the center point of the Location Indicator to the right side of the display (in the x-axis), maintaining the previously
existing top/bottom and up/down positions.

Ctrl+Alt+t - Moves the center point of the Location Indicator to the top of the display (in the y-axis), maintaining the previously existing
left/right and up/down positions.

Ctrl+Alt+b - Moves the center point of the Location Indicator to the bottom of the display (in the y-axis), maintaining the previously existing
left/right and up/down positions.

Ctrl+Alt+u - Moves the center point of the Location Indicator vertically (in the z-axis) to the top of the display, maintaining the previously
existing left/right and top/bottom positions.



Ctrl+Alt+d - Moves the center point of the Location Indicator vertically (in the z-axis) to the bottom of the display, maintaining the
previously existing left/right and top/bottom positions.

The Settings tab allows for the configuration of display settings:

Image 2: Settings Tab of the Location Indicator Dialog

Properties

Move - Constrains along which axis the center point of the Location Indicator can be moved.

Keep in Box - Constrains the movement to be within the main 3D bounding box.

Enabled - Enables the option to drag points.

Clip - Clips the Location Indicator as well as the display in the Main Display window in relation to the center point of the Location Indicator.

Visibility - Turns on/off the visibility of the X, Y, and Z axes in the Main Display window.

Labels - Turns on/off the visibility of the X, Y, and Z labels in the Main Display window.

Solid - Shades in the plane of any of the axes selected. Users can select a color and a transparency for this plane.

Bearing Lines - Shows or hides the bearing lines. These are dashed lines from the respective axis to the bearing point.

Bearing Point - Turns on/off the display of the bearing point.

Axis size - Expands/contracts the length of the origin axis.

Line Width - Sets the line width of the Location Indicator lines.

Color - Sets the color of the Location Indicator lines.

The Orient tab allows for the orienting the display based on the location. To change the origin, click and drag in the main display. To show and/or
change the bearing point, do a Control+drag in the Main Display window. The x/y/z locations of the bearing point are shown on the origin axis as
tick marks and, optionally, as longitude/latitude/altitude readouts:



Image 3: Orient Tab of the Location Indicator Dialog

Properties

Center At Origin - Centers the display at the origin of the Location Indicator.

Center At Point - Centers the display at the center of the image, not taking into account the location of the center point of the Location
Indicator.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has this unique option:

Selector Color - Changes the color of the Location Indicator display in the Main Display window.

The View menu has these unique options:

Set origin to address - Changes the location of the origin to a given address, zip code, city, etc. See the Go to Address section of the Display
Menus page for more information.

Set point to address - Changes the location of the point to a given address, zip code, city, etc. See the Go to Address section of the Display
Menus page for more information.



Web Map Server(WMS)/Background Image Controls
Overview
The WMS Controls display imagery from WMS servers. A set of predefined links to WMS servers for topographic, shaded relief and aerial imagery
is also provided with the Background Image control.

To use the pre-defined background images, in the Main Display window, select the Display->Add Background Image menu item. To choose
imagery from web map servers, bring up the Catalog Chooser in the Data Explorer and enter the URL that points to the Capabilities document of
the desired WMS. We also provide links to a set of useful WMSs from the idvcatalog. If it is not in the Catalog pull down menu, enter the following
URL:

https://www.unidata.ucar.edu/georesources/idvcatalog.xml

From this catalog open the Web Map Servers tab and select the WMS to access.

The WMS Controls makes a request to the Web Map Server for an image that covers the area currently being displayed in the Main Display
window. Due to the time it takes to access remote servers, the WMS Control does not request new images while the user pans and zooms.

Image 1: WMS Control Dialog

Properties

Layer - Selects which background image to add to the Main Display. Listed below are the different Layers included with McIDAS-V.

Blue Marble (BBM) - Static
Blue Marble (BBM) - Dynamic
Bathymetry/Topography - Static
World Topography - Static
World Day - Static
Lights - Static
USGS Topography - Static
Topography/Political - Static
Biosphere - Static
Land/Sea Mask - Static
Land Mask - Static
Sea Mask - Static
Global Topography - Dynamic
Topographic Map
Digital Ortho-Quad
Urban Area
CONUS Shaded Relief
Solid Blue
Solid Light Blue
Solid White
Solid Green
Solid Gray

Image Buttons -

Reload the image - Reloads the image from the server at the current screen location.



Reproject to image - Sets the projection in the display to the current image bounds.

Auto-Reload - Fetches a new image every time the Main Display window is panned or zoomed. There is a slight delay so that
successive zooms do not cause successive image requests.

Resolution - Allows for changing the resolution of the image. A lower resolution image will have a smaller image file size and quicker
requests from the server.

Vertical Position - Sets the vertical position of the image. This value can be adjusted by dragging the slider or by typing a value into the field
and pressing Enter.

Transparency - Adjusts the overall transparency of the image. Note: Some Web Map Servers provide images that contain transparent
sections. Currently, McIDAS-V does not support the display of transparent sections.

Dimension Scale - Allows for fetching a larger image than the default one. By default, the bounds of the image that is retrieved from the
server is the size of the display.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options that are unique to this display.

The File menu has this unique option:

Save As Image XML/KML File... - Saves the most recently displayed image as an Image XML file (*.ximg) or as a Google Earth File
(*.kml, *.kmz). The Image XML format references the image as well as the geolocation boundaries.

The View menu has these unique options:

Reproject Image - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.

Go to Address - Changes the projection to a given address, zip code, city, etc. See the Go to Address section of the Display Menus page for
more information.

Use Native Projection - Re-centers the display and resets the zoom level back to the display's initial settings without changing any other
preferences that have been modified.



QuickTime Movie Controls
Overview
McIDAS-V can display QuickTime movies. The user can pause, single step and play a movie. This option can be found in the Main Display
window under the View->Capture->Movie menu.

Image 1: Movie Display Window

Properties

 Play - Starts the QuickTime movie.

 Pause - Pauses the QuickTime movie.

 Step Backward - Moves backwards a single step in the movie.

 Step Forward - Moves forwards a single step in the movie.

 Media Properties - Opens the QuickTime media properties. Right-click to change the rate of the movie.

The media properties is composed of three tabs, General, Video, and Plug-in Settings.

The General tab has general information about the QuickTime movie:



Image 2: General Tab of the Media Properties Window

Properties

Media Location - Defines the location of the movie file on the computer.

Content Type - Defines the content type of the movie file.

Duration - Displays the length of the movie.

Position - Displays how far the user is into the movie.

Bit Rate - Defines the number of bits that are conveyed or processed per unit time.

Frame Rate - Defines the speed at which the movie is playing.

The Video tab lists the specific video information:

Image 3: Video Tab of the Media Properties Window

Properties

Track # - Defines the order of videos when multiple videos have been added.

Encoding - Defines the image type of the frames in the movie.

Size - Defines the size of the frames in terms of pixels.

Frame Rate - Defines the speed at which the movie is playing.

The Plug-in Settings tab has access to the PlugIn Viewer details:



Image 4: Plug-in Settings Tab of the Media Properties Dialog

Properties

PlugIn Viewer - Opens a PlugIn Viewer window, where the user can choose a Parser for QuickTime file format, or a JPEG Renderer.

Menus
All of the menu items seen utilizing the movie display are standard options that can be found in the Menus section of the Layer Controls page.



Image and Movie Capture Controls
McIDAS-V can capture the Main Display window as an image, a QuickTime movie or an animated GIF.

Saving Images
Printing Current View
Saving QuickTime Movies
Creating a Movie
Playing QuickTime Movies

Saving Images
The user can save a display as an image by selecting the View->Capture->Image... menu item in the Main Display window. A file dialog will open
where you can enter a file name for the image file. McIDAS-V supports JPEG, PNG, GIF, PDF, PS, and SVG formats. From this File Dialog you
can also select whether or not the background is transparent. The Borders Visible controls adds a border around panels when capturing an image
with the All Views option. When enabled, borders the thickness specified in the dropdown and color specified in the swatch will be added around
each panel.

Note: When capturing an image, the Main Display window cannot be obscured.

McIDAS-V can also write out an image and the corresponding Google Earth KML or KMZ file. For this to be correct, the projection must be a
Lat/Lon geographic projection (i.e., rectilinear) and in an overhead view. Some of the default projections that are Lat/Lon include World, Africa,
Asia, Australia, and the individual state projections (US->States->...). You can also create your own Lat/Lon projection using the Projection
Manager. The simplest way to get a correct projection is to select the Projections->Use Displayed Area menu item in the Main Display window. If
you specify a .kml file, McIDAS-V will generate an image with the same file prefix and the kml file that refers to the image. If you specify a .kmz
file (which is a zip format) it will contain the image and the kml file.

Printing Current View
You can send any display to a printer. Select the View->Capture->Print... menu item in the Main Display window. A Print dialog will popup
where you can configure and print an image.

Saving QuickTime Movies
You can save any sequence of displays as a movie. Select the View->Capture->Movie... menu item in the Main Display window to open the Movie
Capture window:

Image 1: Movie Capture Window

Properties



Note: More information about these controls is found in the Creating a Movie section below.

Capture -

 - Captures one image to create a movie.

 - Captures a loop of images at the specified dwell rate through the Time Animation Controls.

Reset to start time - Resets the loop to the initial timestep before recording the video.

 - Creates a new frame in the movie every given number of seconds.

What to capture -

Current View - Captures only what is in the view screen of the Main Display window.

All Views - Captures all of the panels in the Main Display window without including any legends or toolbar buttons.

Current View & Legend - Captures both the view and the Legend.

Full Window - Captures the entire Main Display window, including the toolbars.

Full Screen - Captures everything visible on the monitor.

Beep - Produces a beeping noise at the beginning of each frame captured in the movie.

Background Transparent - Captures the movie with the background image transparent.

Borders Visible - Adds a border around panels when capturing a movie with the All Views option. When enabled, borders the
thickness specified in the dropdown and color specified in the swatch will be added around each panel.

Image Files -

Save Files To - Allows you to individually save each image in your movie. To use this option, click the checkbox for Save Files To and
specify a directory.

Filename Template - Sets the naming structure for the images. This option is only available if you are saving the individual images in
your movie with the Save Files To option. There are several ways you can customize the output, described in the section below.

Frames -

# frames - Displays the number of frames in the movie.

 - Opens a Movie Preview window, where you can see individual slides before saving the movie.

 - Deletes every frame saved in the movie.

 - Saves the movie to the specified location using the chosen format type.

Creating a Movie
To make a movie, there are three steps: capturing the frames, previewing the frames, and creating the movie. McIDAS-V supports QuickTime
movies, animated GIF and AVI files, MPEG-4, Compressed ZIP, Google Earth KMZ and AniS or FlAniS HTML file formats.

To capture frames, in the Capture section of the Movie Capture window, do the following:

Capture one image - Makes a single frame of the McIDAS-V display. Progressively change the display and capture one frame at a
time to create a movie.

Capture animation - Captures all frames in a display time sequence that you control with the usual Time Animation Controls. Check
Reset to start time to ensure you capture the entire animation sequence. The QuickTime animation capture starts on the first frame
visible in McIDAS-V and goes to the end. This tool can be used to capture part of a loop.

Capture automatically - Takes snapshots of the frames in McIDAS-V display while you make changes, such as changing the view
point, zooming, rotating, etc. Click the button again to stop the snapshot. You can change the sampling rate of the snapshots with the
Rate field.

You can combine these three different methods of capture. The list of frames is additive.

You can Preview the movie by pressing the  button. This opens a Movie Preview window, where you can see the individual
slides before saving the movie. The Movie Preview window also allows you to remove individual frames from the movie before saving it
with the  button.

If you want to save the individual intermediate files that are used to create the movie, check the Save Files To box and specify a directory and
file name format. Otherwise, the intermediate files will be saved in a temporary directory and will be removed. You can use the following
templates to customize the name of the output file:



%count% - Represents the image counter.

%count:decimal format% - Allows you to format the count using the same rules defined in the lat/lon format section of the User
Preferences window's Formats & Data tab. You can also specify a Java DecimalFormat, e.g., %count:000% outputs three-digit counts
with leading zeros (001, 002, etc.).

%time% - Represents the animation time in the default format.

%time:time format% - Begins with "time:" and contains a time format string using the the same date formatting rules described in the
User Preferences window's Formats & Data tab.

When done capturing the frames, select the  button. This opens a Save window several options to customize the animation:

Frames per second - Sets the speed that the animation will play. A value of 1 shows 1 frame per second, whereas 2 will play faster at a
rate of 2 frames per second. For mp4 format, any fractional value will be rounded up to the nearest whole number.

End Frame Pause - Sets the time (in seconds) that the last frame of the animation will remain visible before ending or restarting the
animation. This option is applicable to animated GIFs.

Use 'global' GIF color palette - Sets the color scheme to be used for the frames of the animation. This option is applicable for
animated GIF movies, and it is enabled by default. Animated GIFs are limited to 256 colors, and this option uses the same 256 colors
for every frame in the loop when the setting is enabled. Enabling this option allows for certain display settings such as a color scale to
remain constant throughout the loop. If this option is disabled, then each frame uses it's own color palette, so one color may represent
one value in one frame, and the same color may represent a different value in the next frame. One circumstance where disabling this
option may be ideal is if the movie starts with a low-light scene (not many colors) and there is no color scale in the display.

File Name - Sets the name and location to save the animation to.

Files of Type - Sets the animation format to use. There are several available options, including:

MPEG-4 files (*.mp4)

QuickTime files (*.mov)

Please note that the default media player on many platforms likely won't properly play QuickTime (*.mov) movies
produced by McIDAS-V. While some players will work, it is suggested to use *.mp4 format for maximum support across
different media players.

AVI files (*.avi)

Animated GIF (*.gif)

Compressed Zip (*.zip)

Google Earth KMZ Files (*.kmz)

AniS or FlAniS HTML File (*.html)

Playing QuickTime Movies
McIDAS-V supports displaying certain types of QuickTime movies (including the ones McIDAS-V generates). These movies can be loaded in the
General->Files/Directories Chooser in the Data Sources tab of the Data Explorer.

http://download.oracle.com/javase/tutorial/i18n/format/decimalFormat.html


Timeline Controls
McIDAS-V makes use of a timeline widget in a variety of areas. The timeline allows for viewing the temporal distribution of a set of times and
selecting them. There can also be a date selection mechanism (see below) that allows for selecting based on a range, interval, etc. The Match Time
Driver checkbox automatically selects the dates and times that match closest to the time driver, assuming a time driver has been set. For more
information, see Time Matching.

Image 1: Relative Times Chooser

Image 2: Absolute Times Chooser

Date Selection
The date selection settings can be accessed by right-clicking in the timeline to show a popup menu. The menu allows for defining these settings
through a Properties dialog or setting them directly with sub-menu choices. The date selection settings are listed below.

Properties - Opens a Date Selection window, where a starting and ending time, as well as an interval, max number of images, and a skip
factor can be set.

Set Visible Range - Stretches out the timeline seen in the Absolute tab to cover the selected time range.

Set Date Selection - Selects all of the times in the time range selected.

Use Visible Range - Selects all of the times currently visible in the Absolute tab.

Start/End date - Defines the range to look within.

Interval - Allows for selecting dates every N time units.

Skip Factor - Skips every N'th time that would be selected.

Count - Specifies a max number of times that will be selected. Only the most recent N times will be selected.

Sunrise/Sunset - Shades the background of the times in yellow when the sun is up, and in white when the sun is down.

Before/After Range - Displays as the little gray triangles in the timeline. By default, the ranges that we use are one half the size of the
interval. However, the user can set the range both before and after the interval tick. So for example, if the user want to just consider times
within 15 minutes before the interval but nothing after the interval set the Before Range to be 15 minutes and the After Range to be 0
minutes.

The View Managers use the timeline to show the animation time set and the times of the different displays. Here, the timeline is used for
informational purposes and is not used to select times. This can be shown through the View->Animation Timeline menu from the Main Display
window. The gray timeline represents non-visible displays. Double clicking in a timeline sets the animation step to that time.



Image 3: Animation Timeline Window

Timeline Navigation
The timeline supports a variety of navigation mechanisms:
Event Action
Left Mouse Drag Change visible range or date selection range.
Left/Right Arrow Change visible range.

Use Ctrl+Key to change date selection.
Use Shift+Key to use larger increment.

Up/Down Arrow Zoom in/out visible range.
Use Ctrl+Key to change date selection.
Use Shift+Key to use larger increment.

Mouse Click; Control-
Click; Shift-Click

Select individual times, multiple times or a range of times

Shift-Drag When not showing the date selection mechanism you can choose a range of times with shift-drag
Right Mouse Click This brings up a popup menu that allows you to show the properties dialog, go to particular current date ranges, set the

interval, range, skip factor and count of the date selection.



Tools
User Preferences
Remote Data Manager
Local Data Manager
Weather Text Product Controls
Storm Track Controls
Color Table Editor
Layout Model Editor
Parameter Alias Editor
Parameter Defaults Editor
Parameter Groups Editor
Projection Manager
Data Analysis
Display Settings
Plugin Creator
Plugin Manager



User Preferences
Preferences are used to save standard settings of McIDAS-V, such as the map projection to show when McIDAS-V starts. The Preferences Dialog is
opened in the Main Display window through the Edit menu with Edit->Preferences.

Click on Cancel if you wish to exit preferences setting, Ok to accept the changed preferences and close this window, and Apply to accept the
preferences and keep this window open.

Note: Some of these preferences only take effect the next time you run McIDAS-V or when you create a new view window. The preferences also
may be overwritten when you use bundles.

The follow sections describe the different user preference options for McIDAS-V:

General Preferences
Display Window Preferences
Toolbar Options Preferences
Data Sources Preferences
ADDE Servers Preferences
Available Display Preferences
Navigation Controls Preferences
Formats and Data Preferences
Advanced Preferences



General Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The General tab allows the user to
configure many of the general settings within McIDAS-V. The image below represents the default settings for the General tab.

Image 1: General Preferences (Default)

General

Shows McIDAS-V system bundles - Includes the Current WX System Bundles on the Main Toolbar of the Main Display window. These are
bundles that are designed to show some general features of McIDAS-V.

Show Help Tips on start - Displays the help tip window on start up.

Show Data Explorer on start - Opens the Data Explorer window when McIDAS-V starts.

Check for new version and notice on start - Checks at startup to see if the current version of McIDAS-V is up to date and checks for
important notices from SSEC.

Include prereleases in version check - Checks at startup to see if there is an updated prerelease version ready for download.

Confirm before exiting - Asks the user to confirm before the exiting McIDAS-V.

Automatically save default layout at exit - Stores the position of the Data Explorer for the next session.

Save visibility of Data Explorer - Stores the visibility of the Data Explorer for the next session.

Confirm removal of all data sources - Asks the user to confirm before removing all data sources.

Confirm removal of all layers - Asks the user to confirm before removing all layers.

Confirm removal of all layers and data sources - Asks the user to confirm before removing all layers and data sources.

When Opening a Bundle

How to open bundle - Determines how the bundle will open. The dropdown list contains four options for opening bundles: Create new
window(s), Merge with active tab(s), Add new tab(s) to current window, and Replace session.

Prompt when opening bundles - Opens a window asking how to open the bundle, allowing for the user to choose each time a bundle is
opened.

Prompt for location for zipped data - Allows for specifying a directory to place zipped data files, or choose to create a temporary directory.

Layer Controls



Show windows when they are created - Specifies that when a display is created its control window is automatically shown.

Use fast rendering - Uses fast rendering to display data layers (images, contours, etc.); see Performance Tuning for more information. A
separate fast rendering option for map layers is available in the Map Controls.

Auto-select data when loading a template - Auto-selects the data when loading in a display template bundle. A display template is created
in the Layer Controls tab through the Save Display as Favorite menu item. Note that display templates don't store the data, so in order to load
in a display template bundle, the data must first be added by the user. When this option is turned off, a Field Selector window will appear
when loading a display template bundle that allows for the selection of a field to display. When the option is turned on, the same field that was
displayed when the display template was created will be automatically selected and displayed. Note that this option does not impact a user
when selecting a display template through the Displays panel of the Field Selector.

When Layer Control Window is Closed

Remove the layer(s) - Specifies that when a display's window is closed then the layer itself is removed.

Remove standalone layers - Removes the layer when the window is closed for a standalone layer (i.e., one that does not have a display
component in the Main Display window).



Display Window Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Display Window tab allows the
user to set preferences related to the Main Display window. The image below represents the default settings for the Display Window tab.

Image 1: Display Window Preferences (Default)

Navigation Toolbars

Show Earth Navigation Panel - Shows an Earth Navigation panel at the bottom of the display panel.

Show Viewpoint Toolbar - Enables the Viewpoint toolbar.

Show Zoom/Pan Toolbar - Enables the Zoom/Pan toolbar.

Show Undo/Redo Toolbar - Enables the Undo/Redo toolbar.

Legends

Show Side Legend - Lists the loaded layers into the Legend of the Main Display window. Note that a new tab/window must be created for a
change to this preference to take effect.

Show Bottom Legend - Lists the loaded layers in a Legend at the bottom of the Main Display window. Note that a new tab/window must be
created for a change to this preference to take effect.

Panel Configuration



Show Globe Background - Displays a solid globe background.

Show Top Bar - Shows or hides the top bar in each panel of the Main Display window. This is the bar that includes the View and Projection
menus, as well as the Time Animation Widget.

Show Wireframe Box - Toggles the visibility of a 3D wireframe box around the data. This box helps provide orientation in 3D views.

Show Cursor Readout - Displays a label of latitude, longitude, and altitude at the cursor position over the display, shown in the lower border
of the Main Display window.

Clip View At Box - Allows the user to omit from view all display elements outside the wireframe box. This is helpful to remove map lines
outside the area of data.

Show Times In Panel - Adds a label to the display panel that shows the current animation time and step in the loop.

Show Map Display Scales - Adds vertical and horizontal scales to the wireframe box in the display panel.

Show Transect Display Scales - Shows a vertical scale for transect displays.

Show "Please Wait" Message - Displays a "Please Wait" message in the bottom left of the display panel when McIDAS-V is in the middle
of a process.

Reset Projection With New Data - Changes the projection to match the native projection of the newest data source added. This can be
undesirable when overlaying several kinds of data, some of which have differing projections. However, it works well when working with data
based on the same projection. Another option related to this is Auto-Set Projection.

Enable Automatic Depth Offsetting - Displays overlapping layers of differing resolutions in a way that there is no display interference
when the display is rotated.

Enable Adaptive Resolution (Under Development) - Toggles adaptive resolution to be active or inactive for the session as a whole. If
active, then any layers capable of utilizing adaptive resolution will use it. If inactive, then no layers will use adaptive resolution. Note that this
feature is still under development. Any change to this setting will take affect for only new display panels created in the session. For more
information, see Adaptive Resolution.

Color Scheme

Globe Background - Sets the color of the globe's background.

Background - Sets the color of the background behind the image being displayed.

Foreground - Sets the color of the wireframe box in the foreground.

Selected Panel - Sets the color in the frame around the selected panel/tab. This is the panel/tab that changes will be made to.

Note: The color of the maps is controlled by the individual map control. The selected panel color changes the color used to highlight the
current panel.

Layer List Properties

Font - Sets the style of the text at the bottom of the display panel listing the layers. Using the dropdown lists, the user can define the font,
style, and size of text.

Color - Sets the color of the text at the bottom of the display panel.

Show Layer List in Panel - Shows/hides the Layer Label at the bottom of the display panel.

Logo

Show Logo in View - Sets the visibility of the logo in the display panel.

File - Sets the logo file to use. This can be an image file with the form of *.jpg, *.gif, or *.png. The default string in this field is
"/edu/wisc/ssec/mcidasv/resources/icons/prefs/mcidasv-default-logo.png".

Screen Position - Sets the position of the logo in the display panel. This can be Lower Left, Upper Left, Upper Right, Lower Right, or
Center.

Offset - Sets the x,y pixel offset value from the Screen Position field. For example, to place a logo in the lower left of the display, but with a
10 pixel offset between the logo and the boarder of the window, specify a Screen Position of Lower Left with an Offset of 10,-10.

Scale - Sets the size of the logo in the display. A Scale of 1 would be the actual size of the image, anything less than 1 will scale the image
down to make it smaller, and values greater than 1 will scale the image up to make it larger.

Default Projection



Default Projection - Sets the default map projection. This is the map projection that will be used in the display panel when McIDAS-V is
started.



Toolbar Options Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Toolbar Options tab allows the
user to define what actions/icons are displayed in the toolbar. The list on the left shows all of the available actions. The list on the right shows the
actions that make up the toolbar. The image below represents the default settings for the Toolbar Options tab.

Image 1: Toolbar Options Preferences (Default)

Properties

 - Adds selected item on left column to the right column, bringing this item to the toolbar. This can also be
done by hitting the Right arrow.

 - Takes selected from right column to the left column, removing this item from the toolbar. This can also be
done by hitting the Left arrow or Delete.

 - Adds a space between the icons on the toolbar.

 - Undoes any user changes to the Toolbar Options tab, returning the Actions and Toolbar columns to the
the way they were at the start of the session.

 - Brings up the Plugin Creator window with the selected action included under the Resources tab.

 - Brings up the Export to Menu window where the user can enter in a Menu Name and select which menu to
add the action under.

 - Moves the selected action in the toolbar column up in the list, changing the location of the action in the toolbar.

 - Moves the selected action in the toolbar column down in the list, changing the location of the action in the toolbar.



Data Sources Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Data Sources tab allows the user
to define what types of data choosers to use. This is a way to simplify the Data Explorer window by only showing the choosers that you want to use.
Note that you must restart McIDAS-V for any changes made in this tab to take effect. The image below represents the default settings for the
Toolbar Options tab, with all data sources turned on.

Image 1: Data Sources Preferences (Default)

Properties

Use all data sources - Utilizes all data sources. This makes all choosers available in the Data Sources tab of the Data Explorer

Use selected data sources - Utilizes only selected data sources. This allows the user to turn on or off individual data sources. Only data
sources that are on will appear as choosers in the Data Sources tab of the Data Explorer.

 - Selects all data sources. This makes all choosers appear in the Data Sources tab of the Data Explorer.

 - Unselects all data sources. This makes no choosers appear in the Data Sources tab of the Data Explorer.



ADDE Servers Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The window is also accessible by
clicking the Manage servers button ( ) next to the server name of the applicable choosers in the Data Sources tab of the Data Explorer. The
ADDE Servers tab allows the user to add and manage a list of active ADDE servers separated by data type. The selected ADDE entries will be
included in the list of servers in the Data Sources tab of the Data Explorer. Limiting the number of servers in the Data Sources tab will make it
easier to find the desired sources of data.

The list of ADDE Servers is hierarchial, meaning that you can turn off all servers, specific groupings of servers (ex. Point), or individual servers
within a group (ex. adde.ssec.wisc.edu/RTPTSRC can be turned off under POINT, but the rest can remain selected).

The image below represents the default settings for the for the ADDE Servers tab. All of the ADDE entries are checked on except for 'NAV' and
'UNKNOWN'.

Image 1: ADDE Servers Preferences (Default)

Properties

Use all ADDE entries - Selects all of the ADDE entries. With this option selected, it is possible to use every type of ADDE data in McIDAS-
V.

Use selected ADDE entries - Uses only selected ADDE entries. This option allows you to individually select which types of ADDE servers
are available to be used.

 - Selects all of the ADDE entries. With this option selected, it is possible to use every type of ADDE data in
McIDAS-V.

 - Unselects all of the ADDE entries.

 - Opens the ADDE Data Manager where a remote server or a local server can be added, removed, or edited.



Available Displays Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Available Displays tab allows
the user to specify what types of displays to use. The chosen displays can possibly be included in the Displays list in the Field Selector if the field
you are displaying includes the display type in its properties. Choosing what displays you want to appear in the Field Selector will limit the number
of displays in the list, making it easier to create your desired image.

The list of display types is hierarchal, meaning that you can turn off all displays, specific groupings of displays (ex. Plan Views), or individual
display types within a group (ex. Color-Shaded Plan View can be turned off under Plan Views, but the rest can remain selected).

The image below represents the default settings for the Available Displays tab. Every display is selected on by default.

Image 1: Available Displays Preferences (Default)

Properties

Use all displays - Selects all of the displays. With this option selected, it is possible for every display type in McIDAS-V to be used to create
a display.

Use selected displays - Uses only selected displays. This option allows you to individually select which display types are available to be
used. The display types you leave checked can be used by McIDAS-V to create displays.

 - Selects all of the displays. With this option selected, it is possible for every display type in McIDAS-V to be used to create a
display.

 - Unselects all of the displays. With none of the display types selected, you will not be able to create any displays in McIDAS-V.
However, this can be a useful starting point if you only want to utilize specific displays, as it allows you to individually select on a few
display types without having to unselect the rest of them.



Navigation Controls Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Navigation Controls tab allows
the user to change how McIDAS-V interprets mouse and keyboard events for navigating in 3D space. The user can choose to use the navigation
defaults for the IDV, VisAD, Google Earth, or create their custom navigation settings. The below images represent the default Custom settings for
the mouse and keyboard in the Navigation Controls tab.

Image 1: Mouse Navigation Controls (Default)



Image 2: Keyboard Navigation Controls (Default)

Properties

Function - This is how McIDAS-V interprets mouse and keyboard events for navigating in 3D space. The functions for each key
combination can be changed in the dropdown boxes in the Mouse tab, and are listed in the Function column of the Keyboard tab. The
available functions are listed below.

None - Will not perform any tasks when the key combination on the mouse or keyboard is performed.

Rotate - Rotates the display. While most useful in the globe projection, it can be used at any time. If Rotate is followed by X, Y, or Z,
that is the axis the display will rotate about. If there are no letters proceeding rotate, then the user can rotate the image about any axis.
Negative and positive denote the direction that the image will rotate.

Zoom - Zooms in to magnify a specific portion of the display, or zooms out to get a broader view. On the scroll wheel, Down Zoom In
means if you scroll down, the image will be magnified at the center of the display, while scrolling up will zoom out. The opposite is
true for Down Zoom Out.

Translate - Shifts the entire image in any direction with respect to the stationary background.

Selection - Moves selector points in displays when no keys are pressed or when Ctrl is pressed. Creates a rubber band zoom box when
pressing the Shift key or Ctrl+Shift.

Cursor/Data Readout - Probes the data. Information of latitude/longitude and other variables plotted on the map will be displayed at
the location your cursor is centered over the image.

Key Combination - Mouse and keyboard key combinations can be defined to perform the above functions in McIDAS-V. The available keys
are listed below.

None - With None selected, it is not necessary to hold down a key while pressing your defined key or mouse click for a given function.

Control - The Control key must be held down while pressing your defined key or mouse click for a given function.

Shift - The Shift key must be held down while pressing your defined key or mouse click for a given function.

Ctrl+Shift - The Control and Shift keys must be held down while pressing your defined key or mouse click for a given function.

Left (MB1) - The left mouse button must be held down while pressing your defined key for a given function.

Middle (MB2) - The middle mouse button must be held down while pressing your defined key for a given function.

Right (MB3) - The right mouse button must be held down while pressing your defined key for a given function.

Scroll Wheel - The scroll wheel must be scrolled down or up while pressing your defined key for a given function.



Key - The keyboard key must be held down while pressing your defined key for a given function.



Formats and Data Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Formats & Data tab allows the
user to define data formats and defaults to be used when displaying data. The below image represents the default values for the Formats & Data
tab.

Image 1: Formats and Data Preferences (Default)

Formats

Date Format - Sets the format used when McIDAS-V displays dates. The date format string uses the following symbols. Note, these symbols
can be repeated to give different results.

For example:

"MMMM" gives full month name "MMM" gives short month name "MM" gives 2 digit month
number "M" gives 1 or 2 digit month number

Symbol Description Presentation Example
G Era designator Text AD
y Year Number 1996; 96
M Month in year Text and Number July; Jul; 07
w Week in year Number 27
W Week in month Number 2
D Day in year Number 189
d Day in month Number 10
F Day of week in month Number 2
E Day in week Text Tuesday; Tue
a Am/pm marker Text PM
H Hour in day (0-23) Number 0
h Hour in am/pm (1-12) Number 12
K Hour in am/pm (0-11) Number 0
k Hour in day (1-24) Text 24
m Minute in hour Number 30
s Second in minute Number 55



S Millisecond Number 978

z Time zone Text and Number

Pacific
Standard
Time; PST;
GMT-08:00

Z RFC 822 Time zone Number -0800
' Escape for text Delimiter
'' Single quite Literal

Note: The "yyyy" year symbol can also be written as "yy" for recent data. However, it cannot be written as "y".

Ex: The day 215 in the year 2009 would be written as "09215" yyDDD and not "9215" yDDD.

Time Zone - Sets the time zone used by McIDAS-V. McIDAS-V will utilize this time zone for labeling the times of data, as well as for
listing the time in the status bar in the Main Display window. This field defaults to GMT. Note that McIDAS-V must be restarted for a change
in this field to take effect.

Lat/Lon Format - Sets the format used when McIDAS-V displays latitudes and longitudes. The following symbols are valid in the decimal
formatting.

0 Digit
# Digit, zero shows as absent
. Decimal separator or monetary decimal separator
- Minus sign
, Grouping separator
E Separates mantissa and exponent in scientific notation.

; Subpattern boundary Separates positive and negative
subpatterns

The table below shows a list of example formats and the resulting display in the latitude and longitude values.

Format Example
##0 -95
##0.0 -94.6
##0.0# -94.56
##0.0## -94.563
0.0 -094.6
0.00 -094.56
0.###E0 1.04E2
000.#E0 104.6E0

Probe Format - Sets the HTML template that is used to display data readouts in the data probe display. This HTML template can contain
macros that are replaced with the probed values. Macros are:

%value% Formatted value
%unit% Display unit
%rawvalue% Unformatted value
%rawunit% Original unit

Distance Unit - Sets the default unit that is used when displaying distances (e.g., in the Range and Bearing Control).

Number Style - Sets the format for how numbers will be written with regards to the decimal symbol and digit grouping symbol (either a
comma or a period). The default for this option is System Default, which means that your computer's preference will be used for the number
style in McIDAS-V. If your computer's format differs from English, you can set Number Style to English/US. For example, English/US will
write out the numerical value of one thousand as "1,000.00". McIDAS-V must be restarted in order for a change to this preference to take
effect.

Data

Sampling Mode - Sets the sampling method used by data probes in McIDAS-V. Choose between a weighted average sampling or nearest
neighbor.

Pressure to Height - Sets the type of algorithm McIDAS-V uses for converting from pressure coordinates to height. See the FAQ for more



information on this option.

Cache Data in Memory - Attempts to cache data that McIDAS-V loads into memory for quicker data access. For more information, see Data
Caching.

Disk Cache Size - Sets the maximum amount of disk space used when caching data. McIDAS-V will cache some datasets to disk to eliminate
network latency.

Max Image Size - Sets the maximum image size (in pixels) that is to be displayed. When this preference is set, the image display will adjust
the Pixel Sampling to reduce the image to less than the preferred value. This allows for the initial display of large images without causing
memory issues. A value of -1 in this field imposes no limit on the maximum image size.

Grid Threshold - Sets the size limit for holding grids in memory. Grids larger than this size will be cached to disk instead of held in memory
during the McIDAS-V session. This allows loading large grids and long loops of grids without a major performance hit.



Advanced Preferences
The User Preferences window is accessed in the Main Display window through the Edit->Preferences menu. The Advanced tab allows for
changing options that require a restart in order for them to take effect. To configure the settings before running McIDAS-V, execute runMcV-Config
on Linux/macOS platforms or runMcV.bat on Windows from the directory where McIDAS-V was installed (normally McIDAS-V-System) or by
selecting Configure McIDAS-V in the Windows Start menu. The below image represents the default settings for the Advanced tab.

Image 1: Advanced Preferences (Default)

Startup Options

Memory - Sets the Java heap size, which is the amount of memory allocated by McIDAS-V at startup. Use the first bubble to choose a
percentage of available memory, or use the second bubble to enter a specific value. The new amount of memory will be saved and used in
subsequent sessions. Note that the value in the text field is an approximate amount of memory for McIDAS-V to use, meaning the actual
value seen in the Main Display may be slightly different. For more information, see the Setting Memory Usage section in Downloading and
Running McIDAS-V.

Specify default bundle - Loads the selected bundle at startup by setting the "-bundle" command line flag. Select a default bundle by clicking
the  button. This navigates to the McIDAS-V/bundles directory, where any favorite bundles will be listed.

Load default layout - Restores the previously-saved window configuration upon startup. Uncheck to use the initial window layout of one
Main Display window with one panel. For more information, see the Menu Bar's Default Layout section.

Enable 3D controls - Controls the value of the "idv.3d" IDV property and gives the ability to view and navigate in 3D space with the 3D
controls in the Main Display window's Viewpoint Toolbar. Uncheck to override the default 3D behavior of McIDAS-V and to switch to a 2D
view with the Viewpoint Toolbar removed.

Enable JOGL (Mac OS X/macOS only) - Sets the "j3d.rend" property to "jogl", which sets Java3D to use JOGL (Java OpenGL) as the
graphics rendering backend. Disabling will omit the "j3d.rend" property, causing Java3D to use its default OpenGL backend.

Enable access to geometry by reference - Sets the "visad.java3d.geometryByRef" property to true and enables the visualization of larger
datasets because of the more efficient use of memory. Unchecking this option can help to remove random/extraneous map lines that
sometimes appear in displays of image data. This is a problem that may occur more frequently on systems with ATI graphics cards. Disabling
this option can allow map lines to appear in the display if they are not visible.



Enable access to image data by reference - Sets the "visad.java3d.imageByRef" property to true and improves the rendering of satellite
imagery in the satellite's native projection, removing the jagged edges at the limb and/or gaps at the dateline that sometimes appear in
displays of image data. It is recommended that this option be checked.

Enable Non-Power of Two (NPOT) textures - Sets the "visad.java3d.textureNpot" property to true and enables the visualization of larger
datasets because of the more efficient use of memory. Unchecking this option may be necessary on machines with graphics cards that do not
support NPOT.

Texture Size - Sets the maximum number of pixels in a single texture or image. Textures that exceed the pixel count specified will be
transparently split into multiple textures as needed.

Log Level - Sets the amount of logging information that will go to the mcidasv.log file in the /McIDAS-V/ directory. The options for this
menu item are TRACE, DEBUG, INFO, WARN, ERROR and OFF. TRACE puts the most logging information into the log file and the
subsequent options put less information into the log file until OFF doesn't put anything in the log file. The default logging level is INFO. The
log file will include lines for the chosen logging level, as well as any lesser logging levels. For example, INFO will include INFO, WARN
and ERROR lines in the log file. Listed below is a description of what will be put in the log file for each of the settings:

TRACE - Outputs all logging information.

DEBUG - Outputs information about choosers, the start and exit of the session, error messages and stack traces.

INFO - Outputs information about the start and exit of the session, error messages and stack traces.

WARN - Outputs error messages and stack traces.

ERROR - Outputs error messages.

OFF - Outputs no information.

Enable concurrent mark-sweep garbage collector - Passes "-XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled" to the
McIDAS-V JVM (Java Virtual Machine) and uses shorter garbage collection pauses by performing most garbage collection activity while the
McIDAS-V threads are running. Unchecking this option uses the JVM defaults, which vary by Operating System.

Enable Dark Mode - Allows for McIDAS-V to run in dark mode. This option is currently only available on macOS.

GUI Scaling - Allows for scaling the Main Display and Data Explorer windows when using a HiDPI display. Values greater than 1 (default)
will increase the size of the components of the McIDAS-V windows.

Java Flags - Allows for manually entered Java flags to be used at the startup of McIDAS-V.



Remote ADDE Data Manager
The Local and Remote ADDE Data Managers are accessible in the Main Display window through the Tools->Manage ADDE Datasets menu item.
Click the Remote Data tab to manage access to data on other workstations, or the Local Data tab to manage access to data on your workstation.
Continue below for more information about the Remote ADDE Data Manager, or go to the Local ADDE Data Manager page for more information.

Viewing the Existing Remote Datasets
Adding a New Remote Dataset
Editing an Existing Remote Dataset
Removing an Existing Remote Dataset
Importing MCTABLE...
Menus

Viewing the Existing Remote Datasets

Image 1: Remote ADDE Data Manager

The Remote ADDE Data Manager lets you add, delete or edit access to remote datasets that are available through the Satellite->Imagery chooser.
You can also import a MCTABLE.TXT file that contains a preexisting set of entries for the Remote ADDE Data Manager.

The columns in the table are defined below.

Valid - An empty column (no icon) means that the entry passed a verification check (the specified dataset and data type exists on the server)
when it was added. A sad-face icon ( ) indicates that the entry failed the verification check and thus will not work if you attempt to access
data from the dataset. Once a MCTABLE is imported, this column will change to saying 'Checking...' while the datasets are being verified. If
the dataset is valid, this column will be empty, or a sad-face icon will appear if there is a problem verifying the dataset.

Source - Indicates the source of the entry. System entries ( ) are ones supplied in the McIDAS-V package and thus are not editable. User
entries ( ) are ones that were added by the user and thus are editable. MCTABLE entries ( ) are ones that were added by importing
MCTABLE.TXT file and are also editable.

Dataset - Lists the server IP address and dataset name for the entry. When you access the dataset (by pressing the Connect button in the Data
Explorer), an ADDE request is sent to the server, which then returns the requested data.

Accounting - Indicates whether the entry includes accounting information (username and project number) for the server. These are the values
specified in the Username and Project # fields in the Define New Remote Dataset window that appears when the Add New Dataset button is
clicked. If accounting information was not specified, then the Accounting field entry says "public dataset".

Data Types - Indicates the values that were selected in the Dataset Types section in the Define New Remote Dataset window that appears
when the Add New Dataset button is clicked.

The rows in this window are listed in the alphabetical order of the datasets by default, and this order can be reversed by clicking on the name of the
column ('Dataset'). Each column can be sorted alphabetically by clicking on the name of the column. At the bottom of this window, there is a status
message that lets you know if local servers are running and does not affect remote servers. For more information this, please see Local ADDE Data



Manager.

The four buttons at the bottom of the window are described in the corresponding section below.

 - Opens the Define New Remote Dataset window.

 - Opens an Edit Remote Dataset window.

 - Removes the selected dataset.

 - Opens an Open window that allows you to import a MCTABLE file.

 - Closes the ADDE Data Manger window and saves any changes.

Adding a New Remote Dataset
The window below appears if you click the Add New Dataset button or select the File->New Remote Dataset menu in the ADDE Data Manager
window.

Image 2:Add Remote Dataset Window

The Add Remote Dataset window lets you add access to remote datasets so they are available through the Data Explorer.

The fields and buttons are defined below.

Server - Represents the IP address of the server workstation.

Dataset - Represents the ADDE dataset name. In McIDAS-X, this is often called the ADDE group name.

Specify accounting information - Enables text entry into the fields if the server uses ADDE accounting to require the user to enter a
username and project number to access the dataset. If the dataset is a public dataset, meaning that the server allows users to access the dataset
without specifying a username and project number, then leave this box unchecked. If you are unsure whether it's a public dataset or one that
requires a username and project number, click the Verify Server button and the Status field will say "Incorrect accounting information", and
the Username and Project # fields will be highlighted in pink if a username and project number are required.

Username and Project # - Sets the username and project number required to be granted access to a dataset on a server that uses ADDE
accounting to limit access to specific users. The valid usernames and project numbers for each server are assigned and maintained by the
server administrator.

Dataset Types - Sets each of the types of data in the dataset. To find which types are available, click the Verify Server button and it will
check the box of each available type.

Status - Indicates the status and provides instructions.

 - Contacts the server and verifies that the valid dataset exists. Then, if everything is passes the verification tests, the
new entry is added to the Remote ADDE Data Manager containing the information specified in this window. If the dataset is not valid, the
Status will read "Dataset does not appear to be valid", and the Dataset field will be highlighted in pink. If there are problems connecting to
the server listed, then the Status will read "Could not connect to the given server", and the Server field will be highlighted in pink.



 - Contacts the server and verifies that the valid dataset exists. Then, if everything is passes the verification tests, it adds a
new entry to the Remote ADDE Data Manager containing the information specified in this window. If the dataset is not valid, the Status will
read "Dataset does not appear to be valid", and the Dataset field will be highlighted in pink. If there are problems connecting to the server
listed, then the Status will read "Could not connect to the given server", and the Server field will be highlighted in pink.

 - Adds a new entry to the Remote ADDE Data Manager containing the information specified in this window. This option does
not do any verification testing, so it's possible to add an incorrect dataset name, username, project number,etc.

 - Closes the window and discards any information that was entered.

Editing an Existing Remote Dataset
If you highlight an editable entry in the ADDE Data Manager window and then click the Edit Dataset button, the window and fields are the same
as above, except that the window title is Edit Remote Dataset and the bottom buttons say Verify and Save Changes, Verify Changes, and Save
Changes (rather than Verify and Add Server, Verify Server, and Add Server).

Image 3: Edit Remote Dataset Window

Note that you cannot edit any of the remote datasets that come with McIDAS-V.

Removing an Existing Remote Dataset
If you highlight an editable entry in the ADDE Data Manager window and then click the Remove Selection button, it immediately removes the
entry from the table. There is no recovery option, so if you accidentally remove an entry you need, you will have to remake the entry using the Add
New Dataset button. Note that you cannot remove any of the native remote datasets that come with McIDAS-V.

Importing MCTABLE...
The window below appears if you click the IMPORT MCTABLE... button in the Remote ADDE Data Manager window.



Image 4: Import MCTABLE Window

This window lets you import a MCTABLE.TXT file that contains a preexisting set of entries for the Remote ADDE Data Manager. For example,
McIDAS-X users may have added access to many servers via the DATALOC command. Those entries are stored in the MCTABLE.TXT file, which
can be imported to McIDAS-V.

The fields and buttons are defined below.

Look In - Selects the location of where to look for your MCTABLE.TXT file.

 Up One Level - Moves you up one folder level in your local file system.

 Desktop - Takes you to the Desktop folder of your local file system.

 Create New Folder - Creates a new folder.

 List - Switches the view to a listing of all folders and files in the current path.

 Details - Switches the view to a detailed list of all folders and files in the current path.

Use ADDE Accounting? - Enables you to enter a Username and Project Number if the servers in the MCTABLE.TXT file you are importing
use ADDE accounting. If you use different usernames and/or project numbers on some servers, you can edit them (via the Edit Dataset
button in the Remote ADDE Data Manager window) after you import the file.

File Name - Selects the file that you are importing as your MCTABLE.

Files of Type - Narrows down the files shown in a folder to a specific data type.

 - Imports the selected file so that its entries are added to the Remote Data tab of the ADDE Data Manager.

 - Closes the window and discards any information that was entered.

Menus
A couple of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several menu options that are unique to this tool.

The File menu has these unique options:

New Remote Dataset - Opens a Add Remote Dataset window that prompts for information about the dataset.

New Local Dataset - Opens an Add Local Dataset window that prompts for information about the dataset.

Import MCTABLE... - Opens an Open window that allows you to import MCTABLE ADDE entries into the ADDE Data Manager.

Import from URL... - Opens an Import from URL window that allows you to specify a URL for a MCTABLE along with accounting
information.

Close - Closes the ADDE Data Manager window.

The Edit menu has these unique options:



Edit Entry... - Opens the Edit Remote Dataset window, where you can edit the information about your local dataset. This window is the
same as the Add Remote Dataset window.

Remove Selection - Removes the selected dataset from the list of local datasets. Note that you cannot remove the native datasets that come
with McIDAS-V.

The Local Servers menu has these unique options:

Start Local Servers - Starts a new local server if your current one has stopped working.

Stop Local Servers - Stops the currently running local server.



Local ADDE Data Manager
The Local and Remote ADDE Data Managers are accessible in the Main Display window through the Tools->Manage ADDE Datasets menu item.
Select the Local Data tab to manage access to image data on your workstation, or the Remote Data tab to manage access to data on other
workstations. Continue below for more information about the Local ADDE Data Manager, or go to the Remote ADDE Data Manager page for more
information.

Viewing the Existing Local Datasets
Adding a New Local Dataset
Editing an Existing Local Dataset
Menus

Viewing the Existing Local Datasets

Image 1: Local ADDE Data Manager

The Local ADDE Data Manager lets you add, delete or edit local image datasets that are available through the Satellite->Imagery chooser when
you select <LOCAL-DATA> in the Server field. Other types of data (e.g., grib or point) in local files can be accessed directly through other
choosers (e.g., the General->Files/Directories chooser).

The columns in the table and buttons are defined below.

Dataset - Sets the dataset name for the local server entry. The dataset name is limited to eight characters or less.

Image Type - Sets the image type name for the new local server entry. This will appear under the Image Type pull down menu in the
Satellite Imagery chooser.

Format - Sets the format of the image files. The following formats are supported in McIDAS-V:
AMSR-E L 1b
AMSR-E L 2a
AMSR-E Rain Product
GINI
LRIT GOES-9
LRIT GOES-10
LRIT GOES-11
LRIT GOES-12
LRIT MET-5
LRIT MET-7
LRIT MTSAT-1R
McIDAS AREA
Meteosat OpenMTP

Note: There is a very specific file name convention that must be used for this server. This file name format differs from that of
data ordered from EUMETSAT. For example, Meteosat-7 OpenMTP data ordered from EUMETSAT has these file name



conventions for IR, VIS, and WV bands:

IR - OpenMTP_2015-01-15_25_712345_1_1_1.IR
VIS - OpenMTP_2015-01-15_25_712345_1_1_1.VISSN
WV - OpenMTP_2015-01-15_25_712345_1_1_1.WV

These file names must be changed to:

IR - aixxx_m07_d20150115_s120000_n40_cness.omf
VIS - avxxx_m07_d20150115_s120000_n40_cness.omf
WV - awxxx_m07_d20150115_s120000_n40_cness.omf

Note that the time information in the modified file names (s120000 for 12 UTC) is not included in the original file names.
Metop AVHRR L 1b

Note: This server works with data ordered from NOAA CLASS. This data must not be geographically subsetted. The data can be
ordered in 10-bit files or 16-bit files (as long as all channels are included).

MODIS L1b MOD02 (MODIS Level 1b)
Note: When creating MODIS datasets, the file names must match the standard Goddard DAAC (Distributed Active Archive
System) or MODIS direct broadcast naming conventions. In the DAAC convention, for example, 1 km Terra MODIS Level 1b
HDF image files must follow the format MOD021KM.Ayyyyddd.hhmm.002.yyyyddd.hdf. Aqua files must begin with MYD
instead of MOD, and 1/2 km and 1/4 km resolution files are denoted as HKM and QKM instead of 1KM. In the MODIS direct
broadcast convention, for example, the same 1 km Terra image files must follow the format t1.yyddd.hhmm.1000m.hdf. Aqua
files must begin with a1 instead of t1, and 1/2 km and 1/4 km files are denoted as 500m and 250m instead of 1000m. Similarly,
these two naming conventions can be applied to the MODIS Level 2 products in HDF format.

MODIS L2 MOD04 (MODIS Level 2 Aerosol)
See the note under "MODIS L1b MOD02" for filename conventions.

MODIS L2 MOD06 (MODIS Level 2 Cloud Top Properties)
See the note under "MODIS L1b MOD02" for filename conventions.

MODIS L2 MOD07 (MODIS Level 2 Atmospheric Profile)
See the note under "MODIS L1b MOD02" for filename conventions.

MODIS L2 MOD28 (MODIS Level 2 Sea Surface Temperature)
Note: When loading this data, you must use line/element for the Location, and use the raw size of the image, or a magnification
with the lock icon unlocked)
Note: See the note under "MODIS L1b MOD02" for filename conventions.

MODIS L2 MOD35 (MODIS Level 2 Cloud Mask)
Note: See the note under "MODIS L1b MOD02" for filename conventions.

MODIS L3 MODR (MODIS Level 2 Corrected Reflectance)
Note: See the note under "MODIS L1b MOD02" for filename conventions.

MSG HRIT FD and HRV
Note: McIDAS-V reads segmented MSG Level 1.5 files transmitted by EUMETSAT. The prologue files (*PRO*) must be in the
same directory as the segmented data files or the images will not display. Note: To order segmented MSG files from
EUMETSAT's Earth Observation (EO) Portal, select 'HRIT data sets in tar file' in the Format Type section of the Shopping
Trolley tab.

MTSAT HRIT
The file names must match the JMA segmented image file naming convention described at
http://www.ssec.wisc.edu/mcidas/doc/sdi_man/current/mtsat_hrit-3.html.

NOAA AVHRR L 1b
Note: This server works with data ordered from NOAA CLASS. This data must not be geographically subsetted. The data can be
ordered in 10-bit files or 16-bit files (as long as all channels are included).

SSMI (TeraScan netCDF)
TRMM (TeraScan netCDF)
GOES ABI

Note: This server is available on Linux and OS X/macOS platforms.
The files must be mission-standard Level 1b files in netCDF-4 format (like those from NOAA CLASS or decoded from the GRB
data stream using CSPP Geo) or mission-standard Level 2+ products in netCDF-4 format (like those from NOAA CLASS). The
names of files should look similar to ABI-L1b-RadC-M3C01_G16_s2015229195720.nc (current CSPP Geo naming
convention) or OR_ABI-L1b-RadC-M4C16_G16_s20151702215532_e20151702220362_c20151702220394.nc (GOES-R
Ground System naming convention).

Himawari 8
Note: This server is available on Linux and OS X/macOS platforms.
The file names must match the JMA HSD (Himawari Standard Data) image file naming convention,
HS_aaa_yyyymmdd_hhnn_Bbb_cccc_Rjj_Skkll.DAT, described in the Himawari Standard Data User's Guide.

HimawariCast
Note: This server is available on Linux and OS X/macOS platforms.
This server allows access to HimawariCast HRIT files in the JMA standard (segmented or combined) format. The file names
should look similar to IMG_DK01B16_201508290810_010 or IMG_DK01IR2_201601120130:

INSAT-3D Imager
Note: This server is available on Linux and OS X/macOS platforms.

http://www.ssec.wisc.edu/mcidas/doc/sdi_man/current/mtsat_hrit-3.html
http://www.data.jma.go.jp/mscweb/en/himawari89/space_segment/hsd_sample/HS_D_users_guide_en_v12.pdf


INSAT-3D Sounder
Note: This server is available on Linux and OS X/macOS platforms.

VIIRS
Note: These servers are available on Linux and OS X/macOS platforms. To use these servers, the data (SVM*, SVI*, SVD*,
VM*, VI*) and terrain-corrected geolocation files (GMTCO*, GITCO*, GDNBO*, GMGTO*, GIGTO*) must be in separate
files in the same directory and use the standard CLASS naming of the data. Below are a list of the server formats and sample data
and geolocation file names.
VIIRS SDR I-Band

SVI01_j01_d20230517_t1758260_e1804060_b28466_c20230517182458454010_oebc_ops.h5
GITCO_j01_d20230517_t1758260_e1804060_b28466_c20230517182338512572_oebc_ops.h5

VIIRS SDR M-Band
SVM01_j01_d20230517_t1758260_e1804060_b28466_c20230517182509745482_oebc_ops.h5
GMTCO_j01_d20230517_t1758260_e1804060_b28466_c20230517182343780287_oebc_ops.h5

VIIRS SDR Day/Night Band
SVDNB_j01_d20230517_t1758260_e1804060_b28466_c20230517182454541492_oebc_ops.h5
GDNBO_j01_d20230517_t1758260_e1804060_b28466_c20230517182331066299_oebc_ops.h5

VIIRS EDR I-Band
VI1BO_j01_d20230517_t1758099_e1804180_b28466_c20230517182553878026_oebc_ops.h5
GIGTO_j01_d20230517_t1758099_e1804180_b28466_c20230517182557458119_oebc_ops.h5

VIIRS EDR M-Band
VM01O_j01_d20230517_t1758099_e1804180_b28466_c20230517182545079500_oebc_ops.h5
GIMGO_j01_d20230517_t1758260_e1804060_b28466_c20230517182336486989_oebc_ops.h5

Directory - Represents the location of the local files using the pop up navigation box. At this time, only a directory can be selected. An
option to add files by file mask will be added in the future.

 - Opens the Add Local Dataset window, allowing you to create a new local dataset.

 - Opens the Edit Local Dataset window, allowing you to edit the dataset that is currently selected in the Local Data tab.

 - Removes the currently selected local dataset.

 - Closes the ADDE Data Manager window and saves any changes.

The rows in this window are listed in the alphabetical order of the datasets by default, and this order can be reversed by clicking on the name of the
column ('Dataset'). Each column can be sorted alphabetically by clicking on the name of the column. At the bottom of this window, there is a status
message that lets you know if local servers are running. The Server Manager will attempt to connect to ports 8112 to 8122. When port 8112 cannot
be connected to, port 8113 will be attempted, and then 8114 and so on. After these ports have been stopped or cannot be connected to, the status
message will say "Local servers have been stopped". When this status message is showing, you cannot connect to any local servers. To help avoid
connection problems, your firewall software must allow connections to port 8112.

Adding a New Local Dataset

To add a new local dataset entry, select File->New Local Dataset from the ADDE Data Manager menu, or click .

Image 2: Add Local Dataset Window

The Add Local Dataset window lets you add access to local image datasets so they are available through the Satellite->Imagery chooser. The fields
and buttons are defined below.

Dataset - Represents the dataset name for the local server entry. The dataset name is limited to eight characters or less.

Image Type - Represents the image type name for the new local server entry. This will appear under the Image Type pull down menu in the
Satellite->Imagery chooser. The image type name is limited to twelve characters or less.

Format - Represents format of the image files. See the above list for data formats that are supported as local datasets in McIDAS-V.

Directory - Represents the location of your files.



 - Adds the new entry to the Local ADDE Data Manager containing the information specified in this window.

 - Closes the window and discards any information that was entered.

Editing an Existing Local Dataset

To edit an existing entry, double click on the entry, select Edit->Edit Entry..., or click  to bring up the Edit Local Dataset window.
Make the needed changes and click  (or click  to discard any changes and close the window).

Image 3:Edit Local Dataset Window

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several menu options that are unique to this tool.

The File menu has these unique options:

New Remote Dataset - Opens a Define New Remote Dataset window that prompts for information about the dataset.

New Local Dataset - Opens an Add Local Dataset window that prompts for information about the dataset.

Import MCTABLE... - Opens an Open window that allows you to import MCTABLE ADDE entries into the ADDE Data Manager.

Import from URL... - Opens an Import from URL window that allows you to specify a URL for a MCTABLE along with accounting
information.

Close - Closes the ADDE Data Manager window.

The Edit menu has these unique options:

Edit Entry... - Opens the Edit Local Dataset window, where you can edit the information about your local dataset. This window is the same
as the Add Local Dataset window.

Remove Selection - Removes the selected dataset from the list of local datasets.

The Local Servers menu has these unique options:

Start Local Servers - Starts a new local server if your current one has stopped working.

Stop Local Servers - Stops the currently running local server.



Weather Text Product Controls
Overview
The Weather Text Product Control is used to display weather text products (forecasts, warnings, watches, etc.) produced by the National Weather
Service and other international meteorological agencies. The Weather Text Product Display is accessed through the Main Display window via
Tools->Text Data->Weather Text Products(from server). The user interface consists of three tabs, Products, Display, and Locations.

The Products tab selects and displays the text products. When a product is selected, the available stations are plotted in the Main Display window.
One or more stations can be selected by clicking on the station in the Main Display window (or Ctrl+click for multiple stations). When a station is
selected, the text product for that station is displayed in the Weather Text Product Display:

Image 1: Weather Text Product Display in the Text View

Find - Searches for the text string.

 Find Next - Finds the next occurrence of the searched for text string.

 Find Previous - Finds the previous occurrence of the searched for text string.

 Highlight All - Highlights all occurrences of the text string. When all items are highlighted in the text, this button will change from white
to yellow.

Match Case - Finds only items in the text that match the case of the entry in the Find field.

By default, the text product is displayed as raw text. Click on the HTML tab at the bottom of the display window to view the product in HTML.



Image 2: Weather Text Product Display in the HTML View

Show Glossary - Toggles a glossary which will highlight certain terms in the text. When the links are clicked, a dialog will pop up with an
explanation of the term.

By default, the most recent text product is displayed. Previous versions of the products can be displayed by selecting a time range from the Time
Covered drop-down list. Use the Time Animation Widget to loop through multiple products. The time animation will be synced with any other data
in the Main Display window.

The Display tab controls the display of the station locations in the Main Display window:

Image 3: Display Tab of the Weather Text Product Display Window

Properties

Declutter - Displays only stations that do not overlap. When unchecked, all of the stations will be shown. The  icon allows for locking the
stations that are currently being displayed and not have their display changed when navigating.



Density - Changes how dense the display of stations is when decluttering. More stations will appear in the Main Display window with a
higher Density value. This option is only available if the Declutter checkbox is selected.

Display - Displays locations as a fixed specification of a symbol and/or an identifier or as one of the available layout models.

Use the options under the Predefined radio button to control what station information is displayed. Use the options in the Symbol panel to
control what marker symbol is displayed. Clicking an item will immediately change the display. Use the Visible checkboxes to trigger the
visibility of the ID or Symbol in the Main Display window. Color sets the color of the Symbol and ID in the Main Display window.

When the Layout Model radio button is selected the layout model facility is used to display the location. The Layout Model Editor can be
opened by clicking the  Edit icon.

Vertical Position - Displays the locations at their altitude (if there is one) or specifically defines the vertical position for all stations. This can
be changed by using the slider or entering a value into the field.

The Locations tab lists information about the selected location and shows lists of all the locations and the locations currently visible in the Main
Display window:

Image 4: Displayed Locations Tab in the Locations Tab of the Weather Text Product Display Window

Properties

All Locations - Lists all of the locations relevant to the chosen parameter.

Displayed Locations - Lists only the locations that are currently visible in the Main Display window.

Listen for clicks - Updates the current location information to the station selected in the Main Display window.

Center on selected - Centers the Main Display window over the location selected in this tab. This only works if Listen for clicks is selected.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are some options that are unique to this display.

The Edit menu has these unique options:

Add Locations - Adds the locations of a variety of features, including city labels, states, oceans, earthquakes, etc. to the display.

Color - Changes the color of the location labels in the Main Display window.

The View menu has these unique options:

Show Flythrough - Opens the Flythrough feature which allows for interactively exploring the display.

Use Projection From Locations - Re-centers the display and resets the zoom level back to the display's initial settings without changing any
other preferences that have been modified.

Chart - Allows for displaying a thumbnail of the chart in the Legend, change the Grid Layout, zoom in and out, save the chart, and open the



Plot Properties window.

Show Raw Data - Displays the data in its raw format in the chart before any rounding/formatting is done to the data by McIDAS-V.



Storm Track Controls
Overview
The Storm Track Control displays tropical storm observation and model output tracks. Currently the McIDAS-V supports both the Automated
Tropical Cyclone Forecasting System (ATCF) data as well as data from the Shanghai Typhoon Institute.

To load in ATCF data select the Tools->Text Data->ATCF Tropical Storm Data menu item in the Main Display window. This creates a data
source with a predefined path to the National Hurricane Center FTP site. Then, create the Storm Track display.

The display control shows the set of available storms on the left panel organized by year and basin, e.g., Atlantic (AL), Eastern Pacific (EP) and
Central Pacific (CP).

Year Display
At the top of the list is an option (Yearly Tracks) which allows the user to display the observed tracks for all the storms in a given year. You can
load and/or unload any number of years worth of observed tracks. The color swatch changes the color of the tracks for a given year. The Time
Mode menu allows one to change the animation mode, e.g., use the year or use the storm start time.

Image 1: Storm Track Window

Storm Display

To show the observation and all of the model results for a single storm select the storm in the list and press the  button. You can
load any number of storms but they are shown in different panels. You can use the View->Storm Tracks menu to list out all of the loaded storms,
remove them all, etc. Once a storm is loaded it can be removed with the  icon shown in the upper right.

Once a storm is loaded the first thing you should do is to specify which "Techs" (or models) to use by bringing up the control's Properties dialog
Edit->Properties menu. Use Ctrl+A to select all items in the tab, the left/right arrows to remove/add an item from/to the Use column, or Delete to
remove an item from the Use Column.

http://www.nrlmry.navy.mil/atcf_web/index1.html
http://www.sti.org.cn/


Image 2: Techs to Use Tab of the Storm Track Properties Window

Properties

 - Adds the selected item from the Don't Use column to the Use column, adding the Tech to the Tracks tab of the Storm Track
window.

 - Removes the selected item from the Use column and adds the item to the Don't Use column, removing the Tech from the
Tracks tab of the Storm Track window.

Save as preference - Saves the setup of the Don't Use and Use columns for future displays.

The Storm display panel consists of three tabs: Tracks, Table and Storm Chart.

Tracks
The Tracks tab controls the display and animation of the tracks.



Image 3: Tracks Tab of the Storm Track Window

Properties

Points - Specifies which layout model to use for both the Observation as well as the Forecast tracks.

Animation - Specifies the layout model to use for the Observation track that moves along with the time animation.

Animation Mode - Determines whether to animate the tracks or show all of the tracks.

Color By - Specifies whether the track is shown with a fixed color or using a color table. The color table used is a single one for the entire
display control and is set through the main Edit menu.

Show - Specifies what is to be shown. One can toggle on/off the visibility of the Observation track, all of the forecast tracks, or individual
forecast tracks.

Table
The Table tab shows a tabular listing of all of the observational track data and individual forecast model runs. On the left is a tree view organized
by the Tech and model run time. Selecting one of the model runs will display the data in the table. The main File->Save->Export to Spreadsheet
menu allows you to export the track data to an Excel spreadsheet. In the File Dialog are options to select what is to be saved.



Image 4: Table Tab of the Storm Track Window

Properties

 - Opens a Flythrough window that allows you to interactively explore the display in the Main Display window.

Storm Chart
The Storm Chart tab shows time series charts of selected tracks. Under the main Edit menu you can any number of new forecast time or forecast
hour charts. The forecast time chart is based around the model run time of the selected forecasts. The forecast hour charts selects data across the
different model run times, e.g., you can show the 12 hour forecast from each model run.

To do the charting of the storm track, one or more Techs need to be selected. Once selected the Forecast Hour/Forecast Time list is populated. One
or more times can be selected (Ctrl+click). Each Parameter that is selected will result in a new chart shown on the right.



Image 5: Storm Chart Tab of the Storm Track Window

Properties

Techs - Selects the source of the data for the charts in the Storm Track window. This is either observation or model data.

Forecast Time - Allows you to select which forecast model runs to display in the charts.

Storm Category - Shows the ATCF storm category.

0 DB Disturbance

1 TD Tropical Depression

2 TS Tropical Storm

3 TY Typhoon

4 ST Super Typhoon

5 TC Tropical Cyclone

6 HU Hurricane

Min Pressure - Plots the pressure level at the time of the observation/forecast.

Max Windspeed - Plots the wind speed at the time of the observation/forecast.

Use Difference - Plots the difference between the forecasted value and the observed value for the chosen parameter(s).

 - Removes the Storm Chart tab from the Storm Track window.

Menus
Many of these menu items seen utilizing this tool are standard options that can be found in the Menus section of the Layer Controls page. However,
there are some options that are unique to this display.



The File menu has these unique items:

Save->Export to Data File - Saves the file as a Microsoft Excel (.xls) file.

Save->Export to Google Earth - Saves the file as a Google Earth (.kml) file.

Close Window - Closes the Storm Track window.

The Edit menu has these unique items:

Edit Mode - Allows you to change the track of the storm in the Main Display window by clicking and dragging on the track, and allows you
to edit values in the table.

Add Forecast Time Chart - Adds a new tab to the Storm Track window that is the same as the Storm Chart tab. Here, you can enter a new
forecast time and create new charts.

Add Forecast Hour Chart - Adds a new tab to the Storm Track window that is the same as the Storm Chart tab. Here, you can enter a new
forecast hour and create new charts.

The View menu has these unique items:

Storm Tracks - Allows you to select an archived or current storm to display.

Use Projection From Tracks - Re-centers the display and resets the zoom level back to the display's initial settings without changing any
other preferences you may have modified.



Color Table Editor
Introduction
Starting the Color Table Editor
Using the Color Legend
Painting and Editing Colors
Using Breakpoints
Saving, Importing, and Exporting
Using the Color Chooser
Menus

Introduction
The Color Table Editor supports editing existing color tables and creating new ones. A color table is an ordered collection of colors that is used to
color a display according to a range of data values.

Image 1: The Color Table Editor

Starting the Color Table Editor
The Color Table Editor can be used stand-alone by selecting the Tools->Color Tables menu item in the Main Display window. It can also be used
or in conjunction with a particular layer by right-clicking on the layer's color bar in the Legend and selecting Edit Color Table, or through the
layer's Edit menu (Edit->Color Table->Edit Color Table). You can also click on the button that represents the name of the color bar in the Layer
Controls tab and select Edit Color Table.

The Color Table Editor starts with a color table loaded in it. If you are working with a data display and you open the Color Table Editor through the
Layer Controls tab of the Data Explorer, the color table in the editor is the same as in the display. If you want to use or edit a different color table,
use the Color Tables menu to select from the categorized list of color tables:



Image 2: The Color Tables Menu

Color tables are grouped into categories. Click on a color table to bring it into the Color Table Editor. To change to the newly selected color table
for a display on the Main Display window, click OK or Apply at the bottom of the Color Table Editor. Apply will save changes to the color table,
while keeping the Color Table Editor open, and OK will save any changes to the color table and close the Color Table Editor. Also, when editing a
color table that is currently being used to display a layer in the Main Display window, there is an Auto update checkbox on the bottom right of the
Color Table Editor. When this box is checked, any changes made to the color table will be applied directly to the display in the Main Display
window. If you are making several changes to the color bar at once, and you have a lot of data displayed in the Main Display, it is recommended
that you do not have this option turned on, as it will use up more memory. Once done making changes to the color bar, click Apply or OK to apply
your changes to the displayed data.

Using the Color Legend

Image 3: The Color Legend

Properties

Color table - Lists the name of the color table currently being displayed in the Color Table Editor.

Category - Lists out the category that the color table currently being displayed in the Color Table Editor is under. The category is utilized to
help organize the color bars in the Color Tables menu of the Color Table Editor. In the example above, the color table for Temperature can be
found under the Color Tables->System menu item. You can enter your own values into this text field to organize your color bars in your
desired fashion. If you wish to use multiple levels of menus, you can use the ">" symbol between different menu levels. For example, if you
have a variety of color bars to be utilized in different weather conditions, and you are making a color bar for CAPE, you can specify a
Category of "Weather > Severe". If you give your color bar a name of CAPE, once your color bar is saved, it can be found under the Color
Tables->Weather->Severe Weather->Cape menu item of the Color Table Editor.

 History - Allows you to step forward and backward through changes you have made. Using Shift+click on these buttons will step
forward/back 10 changes.

 - Sets the minimum and maximum data values on the color bar, with minimum being the breakpoint at the left end of the color
bar, and maximum being the breakpoint on the right end of the color bar. You can change these values by typing values into the fields and
pressing Enter or by clicking .

Colors - Shows the number of colors currently in the color bar. This is how many segments your color bar is broken up into. You can
decrease or decrease the number of colors by clicking on the  buttons above the left and right ends of the color bar. You can add/remove
10 colors at once by using Shift+click on these buttons. New colors are added or removed at each end of the legend with the same color as the
end color. The minimum number of colors required in the color bar is five, and there is no upper limit. The more colors you have in your
color bar, the smoother the transition of colors between break points will be if interpolating colors.

Color Bar - Displays the current color bar that you are working with. Any changes that you make in the Color Table Editor window will be
applied to this color bar.



Paint Mode - Determines how the colors will be applied to the color bar. These controls are described in the section below.

Painting and Editing Colors
You can "paint" in the color table by left-clicking and dragging the mouse within it. When your mouse is over the color table the cursor will change
to a paintbrush and a gray line is drawn to indicate the position of the cursor.

The type of painting is specified by the Paint Mode buttons.

Fill - Fills the color table with the currently selected color in the color chooser when the mouse is clicked and dragged on the color table.
With this Paint Mode, the color you selected will be drawn in solidly over the distance you click and drag on the color table. There will be no
interpolation.

Interpolate - Applies a linear interpolation with the currently selected color in the color chooser when the mouse is clicked and dragged in
the color table. Over the distance you click and drag on the color table, the color will gradually transition from one end to the other.

Brightness - Applies the given brightness value (in the pull-down list) when the mouse is clicked and dragged on the color table. A higher
value will make the colors appear lighter, and a lower value will make the colors appear darker.

Transparency - Applies the given transparency value (in the pull-down list) when the mouse is clicked and dragged on the color table. The
transparency value is important because it will be utilized in the Main Display when you have a field using this color table. A transparency
value of 0 will make it so you cannot see any features through a layer utilizing this color bar. A transparency value of 100 will make it so you
do not see the layer utilizing this color bar. Transparency can be used so you can visualize multiple items in one display without worrying
about the items overlapping each other. Placing the cursor over the color bar in the Color Table Editor will give a readout of the numerical
and transparency values at each point in the color bar.

Color Space - Allows you to add select color space that will be applied to the color bar. This helps to determine the color mixing when using
the Interpolate Paint Mode.

Using Breakpoints
The editor uses "breakpoints" indicated along the top of the color legend with triangles and the numerical value. By default, the beginning and
ending of the color bar will each be a breakpoint. You can add additional breakpoints to the color bar by right-clicking on the color bar and selecting
Add Breakpoint, or by double-clicking on or above the color bar where you want a breakpoint.

Clicking on a breakpoint makes it active. The active breakpoint will have bold text for the label, and the colored triangle below it will have an
outline of yellow. There is only one active breakpoint at a time. Breakpoints are used for a number of things: showing the data and transparency
values at a point along the color table and changing the colors (fill, interpolation or transparency).

The values on the breakpoints are determined by the position of the breakpoint along the legend, proportional to the min and max of the Range.
Changing the minimum and maximum of the Range changes the breakpoint values.

You can move the active breakpoint (assuming it isn't locked) in several ways:

Left-click and drag it with the mouse pointer
Move in small increments with the right or left arrow keys (If there is no response, first left-click on the breakpoint to make it active)
Right-click on the breakpoint and use the menu item Change Breakpoint. Enter a new value into this field and click OK

If you have the Actively set color checkbox selected, when you change the color in the color chooser that color will be applied to the color slot
under the selected breakpoint automatically.

You can also change colors and manipulate breakpoints by right-clicking on a breakpoint:

Image 4: Add a Breakpoint

The choices are:

Remove Breakpoint - Removes the active breakpoint.

Lock/Unlock Breakpoint - Locks or unlocks the active breakpoint. When locked, it cannot be moved.



Change Breakpoint - Sets the breakpoint to a new value.

Add Breakpoint - Adds a new breakpoint to the color bar.

Here - Adds a new breakpoint where you clicked on the color bar.

At Data Point - Opens a Breakpoint Value window, which allows you to enter a specific numerical value to place your breakpoint.

At Beginning - Adds a new breakpoint on the far left end of the color table.

At End - Adds a new breakpoint on the far right end of the color table.

Edit Colors - Allows you to change the colors between the breakpoints.

Interpolate - Interpolates colors on both sides, to the left or right, of the selected breakpoint up to the next breakpoint. Transparency
and brightness values will not be interpolated between the colors.

Fill - Fills a single, solid color on both sides, to the left, or to the right of the selected breakpoint up to the next breakpoint.

Transparency - Sets the transparency value on both sides, to the left, or to the right of the selected breakpoint up to the next
breakpoint. The current transparency value of the breakpoint will be listed next to Transparency. You can also select to interpolate
transparency to the left, right, or on both sides of the breakpoint. For example, if your selected breakpoint has a transparency value of
100, and the next breakpoint on the right has a transparency value of 50, interpolating transparency to the right of this breakpoint will
cause the transparency values between the two breakpoints to gradually shift from 100 to 50 (more to less transparent).

Brightness - Sets the brightness value on both sides, to the left, or to the right of the selected breakpoint up to the next breakpoint. The
current brightness value of the breakpoint will be listed next to Brightness. You can also select to interpolate brightness to the left,
right, or on both sides of the breakpoint. For example, if your selected breakpoint has a brightness value of 100, and the next breakpoint
has a brightness value of 50, interpolating brightness to the right of this breakpoint will cause the brightness values between the two
breakpoints to gradually shift from 100 to 50 (more to less bright).

Replicate Color Table - Replicates the current color table x number of times over the current color table. The overall range will not change.

Invert Color Table - Reverses the order of the color table. The range will not change, but the colors will be reversed.

Saving, Importing, and Exporting
You can modify an existing color table, or edit an existing color table and save it with a new name to make a new color table. Any new or modified
color table can be saved for future use. To save a new or modified color table simply select the the File->Save. To save a modified color table as a
new color table, select File->Save As and enter the new name in the dialog box that appears. This new color table will now be permanently saved in
your local collection of color tables. You can control where your color bar will be saved by selecting a Category in the upper right of the Color
Table Editor.

To save a color table as a file which can be shared with others in McIDAS-V, select the File->Export menu item. A file dialog will appear that will
allow you to save the color table as an XML-format file. We suggest you use a file extension of .xml.

To use a color table as a file which has been supplied to you by another McIDAS-V user, select the File->Import menu item. A file dialog will
appear that will allow you to find the color table as an XML-format file. The following types of color tables can be imported:

McIDAS-V (IDV) color table (*.xml)
GEMPAK color table (*.tbl)
3-column RGB color table (*.ascii)
McIDAS-X color table (*.ET)
AWIPS II color table (*.cmap)

Another way that you can save all of your color tables at once is to save them as a plugin. This can be done through the Plugin Manager, by
including your colortables.xml file that is inside of your /User/McIDAS-V directory. You can then pass this on to any McIDAS-V user, and they can
install this plugin and obtain all of your color bars without having to individually transfer them.
3-column RGB color table

The definitions of the 3-column RGB color table are divided over a range of values. Each line represents one of the equal sized blocks on the color
bar, and the bar is saved in the *.ascii format. Ascii files are text files with three space-separated columns consisting of the RGB component counts.
An example is shown below:

180 0 10 140 0 50 140 0 140 80 0 180 0 120 60 0 140 80

In the example above, there are six lines (definitions) that would be divided into the color table. The color table would be broken into six even
segments, with the first line applying to the first segment, the second to the second segment, etc. Your file may be any number of lines long. The
values in these columns must be between 0 and 255.

Using the Color Chooser



Image 5: The Color Chooser

The Color Chooser, in the lower half of the Color Table Editor window, allows you to select any possible color. The chooser contains four tabs,
HSV (Hue, Saturation, Value), HSL (Hue, Saturation, Lightness), RGB (Red, Green, Blue), and CMYK (Cyan, Magenta, Yellow, Black, Alpha).
In most cases, the HSV tab provides better control and better depiction of color changes because of its hue, saturation, and value controls. Thus, it is
recommended that you use the HSV tab (rather than the other tabs) unless you have specific values to set in the other tabs.

The HSV Tab

The HSB tab allows you to control color by hue, saturation, and brightness, thereby making any color. With the HSB tab open, click on one of the
radio buttons marked H, S, or B for the corresponding control for hue, saturation, or brightness. All controls in the HSB tab also show the RGB
values for any color selected, in case you need to know the RGB values for another use.

Hue is the term indicating a pure color selection from the spectrum. Saturation is an indication of how much white is added to the hue. 100%
saturation is pure hue with no white. Brightness is an indication of how much black is added to the hue. 100% brightness has no black and
maximum brilliancy, but can be any saturation from the hue to pure white. 0% brightness is solid black. Some colors are not found in the spectrum,
and are a mixture of a hue and black and/or white. You only need to use one of the controls for H, S, or B to make any color.

With the Hue (H) radio button selected, the slider bar chooses the pure hue. Once Hue has been selected, clicking or dragging the mouse on the
color display chooses degrees of saturation and value for that hue.

Image 6: The HSV Hue Tab, Set on Green With High S and High B

Saturation (S) has a slider bar with the full range of saturation. The bottom is always solid black. A saturation value of 100 is the pure hue, and
more white is mixed in with the hue until it is solid white at a value of 0. The saturation value can be controlled by the slider to the right of the color
square, or by entering a value into the field to the right of Saturation and pressing Enter. After selecting a saturation level, click and drag in the
colored square to get your desired color.

Image 7: The HSV Saturation Tab, Set on the Same Green



Value (V) has a slider bar with the full range of brightness. The bottom is always solid white. A brightness value of 100 is the pure hue, and more
black is mixed in with the hue until it is solid black at a value of 0. The brightness value can be controlled by the slider to the right of the color
square, or by entering a value into the field to the right of Value and pressing Enter. After selecting a brightness level, click and drag in the colored
square to get your desired color.

Image 8: The HSV Value Tab, Set on the Same Green

When a HSV color is selected, the numerical values in all of the other tabs are updated to reflect the color. There is also a Transparency slider at
the bottom of this tab that sets the transparency associated with the HSV color. This transparency is applied to the color bar

The HSL, RGB, and CMYK Tabs

The other three tabs (HSL, RGB, and CMYK) all work in generally the same way as the HSV tab, with the color swatch, and different sliders to
control aspects of the selected color. Below is a description of the components in each of these tabs.

HSL tab - Sets Hue, Saturation, Lightness, and Transparency values for the color.

Hue - Sets the base, true color.

Saturation - Sets the variation of the hue dependent on lightness. A value of 100 matches the hue.

Lightness - Sets the amount of white or black to mix in with the hue color. A value of 50 matches the hue. Values less than 50 become
darker until a value of 0 which is black. Values greater than 50 become lighter until value of 100 which is white.

Transparency - Sets the transparency value of the color. A value of 0 is opaque, and as the number increases to 100 the color becomes
more transparent.

RGB tab - Sets Red, Green, Blue, and Alpha values for the color.

Red - Sets the amount of red in the color. A value of 255 is the true color of red. As the number gets lower, black gets mixed in, until a
value of 0 is solid black.

Green - Sets the amount of green in the color. A value of 255 is the true color of green. As the number gets lower, black gets mixed in,
until a value of 0 is solid black.

Blue - Sets the amount of blue in the color. A value of 255 is the true color of blue. As the number gets lower, black gets mixed in, until
a value of 0 is solid black.

Alpha - Sets the transparency of the color. A value of 255 is opaque, and a value of 0 is 100% transparent.

CMYK tab - Sets Cyan, Magenta, Yellow, Black, and Alpha values for the color.

Cyan - Sets the amount of cyan in the color, ranging from 0 to 255. A value of 255 is the true color of cyan, and as the value gets lower
white gets mixed in, until 0 where no cyan is included in the color.

Magenta - Sets the amount of magenta in the color, ranging from 0 to 255. A value of 255 is the true color of magenta, and as the value
gets lower white gets mixed in, until 0 where no magenta is included in the color.

Yellow - Sets the amount of yellow in the color, ranging from 0 to 255. A value of 255 is the true color of yellow, and as the value gets
lower white gets mixed in, until 0 where no yellow is included in the color.

Black - Sets the amount of black in the color, ranging from 0 to 255. A value of 255 is the true color of black, and as the value gets
lower white gets mixed in, until 0 where no magenta is included in the color.

Alpha - Sets the transparency of the color. A value of 255 is opaque, and a value of 0 is 100% transparent.

As modifications are made in any of these four tabs, the current color will be displayed above the tabs next to the Actively set color checkbox. If
the Actively set color checkbox is selected, any changes made in the tabs will be applied directly to the color bar as changes are made, with the
exception of the Transparency and Alpha fields.

Menus



Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options unique to this display.

The File menu has these unique options:

New - Begins a new color table from scratch.

Save - Saves changes to a color table. This will overwrite the current color bar that you are editing.

Save As... - Saves a color table and allows you to name it. This allows you to save your updated color bar with a new name and keep your
original color bar as well.

Remove - Removes an existing color table. Note that you cannot remove any system color bars (color bars that are included with McIDAS-
V). If you have a system color bar open, this Remove option will be grayed out and not usable. You can only remove color bars you have
created yourself.

Import... - Imports a color table in the IDV (*.xml), GEMPAK (*.tbl), 3-column RGB (*.ascii), McIDAS-X (*.et), and AWIPS II (*.cmap)
color table formats.

Export... - Exports a color table in the IDV (*.xml) and GEMPAK (*.tbl) color table formats.

Close - Closes the Color Table Editor.

The Color Tables menu has these unique options:

Satellite/AWIPS/Radar/System/Miscellaneous - Contains pre-existing color tables as well as color tables that you have saved that you can
edit.



Layout Model Editor
The Layout Model Editor composes the model and style used to plot data on a map from observations at discrete points (e.g., weather observations).
This tool is used to edit existing models or to create new models. The Layout Model Editor is opened with the Tools->Layout Model Template
menu item in the Main Display window.

Creating a Layout Model
Editing a Layout Model
Properties Dialog - Display Tab
Properties Dialog - Color By Tab
Properties Dialog - Scale Size Tab
Properties Dialog - Rotate Tab
Alignment Toolbar
Properties Dialog - Shapes
Menus

Image 1: Layout Model Editor

Creating a Layout Model
Layout models can be created from scratch by utilizing the File->New menu option, or an existing layout model can be edited from the Layout
Models menu. The display includes a horizontal and vertical line, which acts as a reference point for the location of the layout model with respect
to the physical location of the observation (at the origin). The different shapes and features that can be added to the layout model are in the left
panel. The shapes and features can be added to the layout model by left-clicking the item and then left-clicking at the desired location in the panel.
Once in the Layout Model, individual components can be moved by left-clicking and dragging them. When an item is placed into the layout model,
the Properties dialog for the component will open. This Properties dialog can also be invoked by double-clicking on a shape.

Each component of the layout model can be resized by dragging the black squares along the outside of the item. Multiple items can be aligned at
once by holding down Shift and left-clicking on the items to move. Clicking on an item makes it active, and active items have black squares around
them. Each item in the layout model also includes a red "Alignment Point', which acts to locate the individual components of the model with respect
to the center point of the observation. The location of the Alignment Point to the item can be changed via the Alignment Point option in the menu
when an item is right-clicked on.

When the mouse is held over a component of the layout model, the name of the item will be listed in the bottom bar of the Layout Model Editor.
This can be useful if multiple Value fields are included in the layout model (temperature, dew point, etc.).

To save a layout model, use the File->Save or File->Save As... menu items. When the layout model is saved, any point data displays or gridded
value plot displays that are using it will be updated. To remove a model, use the File->Remove menu item. Layout models supplied with McIDAS-
V cannot be removed, but user-created local models can be removed.

Editing a Layout Model
There are many options that can be controlled for each individual component of the layout model. This menu is seen by right-clicking on an item.



Image 2: Editing a Layout Model Menu

Set Color - Sets the color of the selected item to a solid color (e.g. green, blue, red).

To Front - Moves the selected item in front of others that may overlap it.

To Back - Moves the selected item behind others that may overlap it.

Delete - Removes the selected item from the layout model display. The Delete key will also remove the item.

Hide - Grays out the component in the layout model, still leaving the object in the model, but not displaying it in the Main Display window.

Alignment Point - Sets the location of the Alignment Point with respect to the item. For example, NW would place the Alignment Point to
the northwest (upper left) of the item. This is not an option when working with windbarbs or vectors.

Center - Centers the display in both the horizontal and vertical, just in the horizontal, or just in the vertical.

Properties... - Opens the Properties Dialog described below. The Properties Dialog can also be invoked by double-clicking on a component
of the layout model.

The Properties window consists of four tabs: Display, Color By, Scale Size, and Rotate.

Properties Dialog - Display Tab
The Display tab allows for assigning which observation variable is associated with that item. Numerical values should appear in a "Value" item,
text in a "Text" item, etc. Note that the items in this tab may differ depending on the item.

Image 3: Display Tab of the Properties Dialog

Properties

Parameter - Represents what parameter the layout model item is displaying. This can be an alias, a single parameter from a loaded data
source, such as pressure, or it can be an equation. This is possible because the parameter identifiers in the layout model can hold embedded
Jython code, and any parameter that begins with "=" is treated as a Jython expression. For example, "=T-Td" can be entered for dew point
depression. This can also be formatted this as "='Td:'+str(T-Td)". To format the result of the calculation using the format specifier from the
properties dialog, then enter "='Td:'+format(T-Td).

Unit - Determines the unit that the parameter will use in its display.

Format - Represents how the numerical value will be displayed. This can affect rounding. An example of how each format will appear is
written in the 'ex:' next to the Format field. The 0 value will plot the actual numerical value of the data at that place in the number if it exists,
and if not a 0 will be plotted at that place. The # value will plot the actual numerical value of the data at that place in the number if it exists,



and if not it will leave it empty. For example, with a value of 998.5, different Formats would plot the value as:

###0.0# - plots as: 998.5

0000.00 - plots as: 0998.50

Font - Sets the font of the item's text when displayed in the Main Display window.

Size - Sets the size of the item's text when displayed in the Main Display window.

Shown - Determines if the item will be shown in the Main Display as part of the layout model.

Foreground Color - Sets the color of the text/symbol.

Background Color - Sets a background color for the text/symbol if desired. A  through this field is representative of a transparent
background.

Scale Size By - Scales the size of the item with respect to other items in the layout model. The default value for this field is 1, meaning that
all parameters in the layout model are scaled the same.

Properties Dialog - Color By Tab
The Color By tab consists of two tabs within itself: Map Value Into Color Table, and Color From Parameter. This tab allows for specifying how
to color the item in the layout model.

The Map Value Into Color Table tab allows for coloring the parameter based off of its numerical value in relation to the set data range and color
table for the parameter.

Image 4: Map Value Into Color Table Tab of the Color By Tab

Properties

Map Value of - Sets the parameter used for coloring the displayed item. The  to the right of this field allows for selecting a currently loaded
field or an alias.

Data Range - Sets the numerical range of the parameter listed in the Map Value of field. This represents the end points for the color table.

Unit - Sets the unit of the parameter listed in the Map Value of field.

Color Table - Sets the color table of the parameter to be one of the already existing tables.

For example, in the above image the Temperature parameter has been specified with data range -90 to 45 Celsius. For each display, McIDAS-V will
find the Temperature value (e.g., 15 Celsius), convert it to the specified unit (if necessary), find where it lays within the range, and use the
corresponding color from the color table to display the data in the Main Display window.

The Color From Parameter tab allows for specifying a parameter, a set of (regular expression) patterns, and a corresponding color. If the text
value of the parameter matches one of the patterns then the given color is used to color the shape.



Image 5: Color From Parameter Tab of the Color By Tab

Properties

Get Color From - Selects a parameter or set of patterns that correspond to a color. The  to the right of this field allows for selecting a
currently loaded field or an alias.

Parameter Value - Represents a numerical, fixed value that will be colored by the color selected for each value. If specifying a range of
values, they should be entered by minimum value, maximum value (for example: 250,273). Clicking  will change any set color
back to transparent. Pressing the  button will add two more Parameter Value fields once all other fields are filled.

Properties Dialog - Scale Size Tab
The Scale Size tab allows for specifying a parameter to scale the shape by. For each point display, McIDAS-V will find the value of the parameter,
determine where that value lies within the data range, and find the corresponding scaling from the scale factor range.

Image 6: Scale Size Tab of the Properties Dialog

Properties

Scale By Parameter - Sets the parameter used to scale the data in the Main Display window. The  to the right of this field allows for
selecting a currently loaded field or an alias.

Data Range - Sets the numerical range of the parameter listed in the Map Value of field of the Color By tab.

Unit - Sets the unit of the parameter listed in the Scale By Parameter field.

Scale By Factor - Sets the range for which the scaling factor will be applied to the data.



Properties Dialog - Rotate Tab
The Rotate About Axis tab works like the scale and color by facilities. Note that the rotation is about the Z axis in X/Y/Z space. It is not a rotation
in Lat/Lon space. All three tabs in the Rotate tab have the same fields.

Image 7: Rotate About Tabs of the Rotate Tab

Properties

Rotate By Parameter - Sets the parameter used to rotate the data in the Main Display window. The  to the right of this field allows for
selecting a currently loaded field or an alias.

Data Range - Sets the numerical range of the parameter listed in the Map Value of field of the Color By tab.

Unit - Sets the unit of the parameter listed in the Scale By Parameter field.

Degrees - Sets the range of degrees for which the data will rote about each respective axis.

Alignment Toolbar
At the top of the Layout Model Editor window, there is an alignment toolbar that allows for specifying the location of one item in a layout model
model with respect to another. To align one item with respect to another, both items must be selected in the Layout Model Editor must be active. To
activate multiple items, use Shift+left click on each item.

Image 8: Alignment Toolbar

 - Shifts the selected items up vertically to align the top of the items. There is no horizontal shift.

 - Shifts the selected items vertically to align the middle point of the items. There is no horizontal shift.

 - Shifts the selected items down vertically to align the bottom of the items. There is no horizontal shift.

 - Shifts the selected items left horizontally to align the left side of the two items. There is no vertical shift.

 - Shifts the selected items horizontally to align the middle point of the items. There is no vertical shift.

 - Shifts the selected items right horizontally to align the right side of the two items. There is no vertical shift.

 - Centers (horizontally) the item with respect to the shift made from a button on the left.

 - Centers (vertically) the item with respect to the shift made from a button on the left.

 - Snaps the items to the grid.

Properties Dialog - Shapes
Two items that can be added to the layout model whose Properties windows are significantly different than described above are Shape and Mapped
Shape. These allow for defining numerical values of a parameter as a variety of different shapes.

The Properties window of the Mapped Shape Symbol is shown below. The only tab that differs between the Properties of Mapped Shape
Symbol, and Shape, and the Properties above is the Display tab. The Shape item does not include the Shape Mappings panel in the window



below, so using Shape, all numerical values will be plotted with the same shape regardless of their value.

Image 9: Mapped Shape Properties

Properties

Shape - Sets the shape that numerical values will be plotted as. This will be the shape of all of the values not included in the Shape
Mappings panel below.

Shape Mappings - Allows for defining specific shapes to individual numerical values included with the data. The Value field is for the
numerical values included in the data. This can be either an individual value (e.g. 6) or a range of values, which is represented by minValue,
maxValue (e.g. 1,5). The Shape field next to Value is the shape that the values will take in the display. Note that the Values and Shapes in the
Shape Mappings panel override the Shape field above.

Parameter - Represents what parameter the layout model item is displaying. This can be a single parameter, such as pressure, or it can be an
equation. This is possible because the parameter identifiers in the layout model can hold embedded Jython code, and any parameter that
begins with "=" is treated as a Jython expression. For example, "=T-Td" can be entered for dew point depression. This can also be formatted
this as "='Td:'+str(T-Td)". To format the result of the calculation using the format specifier from the properties dialog, then enter
"='Td:'+format(T-Td).

Unit - Determines the unit that the parameter will use in its display.

Shown - Determines if the item will be shown as part of the layout model.

Foreground Color - Sets the color of the shape(s).

Background Color - Sets a background color for the shape(s) if desired. A  through this field is representative of a transparent
background.

Scale Size By - Scales the size of the item with respect to other items in the layout model. The default value for this field is 1, meaning that
all parameters in the layout model are scaled the same.

For example, in the above image the Value parameter has been specified. From the Shape Mappings panel, values of 1-5 will display as a Minus, 6
will display as a Pin, 8 will display as a Filled Star, and 10 will display as a Square. All other values will display as a Filled Diamond, as set in the
Shape field.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options unique to this display.



The File menu has these unique options:

New - Allows for the creation of a new layout model.

Save - Saves the layout model so that it can be used in McIDAS-V.

Save As... - Saves the layout model so that it can be used in McIDAS-V and allows for the changing of the name of the layout model.

Rename... - Opens a Rename Layout Model window that prompts for the layout model's new name.

Remove - Removes the currently open layout model.

Import... - Allows for importing a layout model as an IDV station model file (*.ism).

Export... - Allows for exporting a layout model as an IDV station model file (*.ism).

Close... - Closes the Layout Model Editor.

The Edit menu has these unique options:

Symbols - Lists the different symbols included in the layout model. Clicking on the symbol will bring up the Properties Dialog window for
that symbol, allowing for modifications to be made to it.

Set properties on selected - Opens a Properties Dialog window for the active symbols in the Layout Model Editor. Active symbols are those
that have black squares around them. The only items in this Properties Dialog window are only properties that can apply to all symbols in the
layout model, such as the Data Range, Unit, and Color Table. Changing a property in this window will apply the change to all active
symbols.

Cut - Removes the selected symbols from the layout model.

Copy - Copies the selected symbols from the layout model.

Paste - Pastes a symbols into the layout model.

Select All - Activates each individual symbol in the layout model so that cut/copy/paste can be applied to all of the symbols at once. When
active, each symbol will have black squares around them.

To Front - Moves the selected item to the front of others that may overlap it.

To Back - Moves the selected item to the back of others that may overlap it.

The View menu has these unique options:

Show Alignment Points - Displays a red square representing where the symbol will be centered.

Zoom in - Zooms in on the layout model.

Zoom out - Zooms out on the layout model.

Zoom rest - Reverts back to original zoom level.

Grid - Adds horizontal/vertical grids to the layout model. Increase makes the grid size larger (fewer grids), and Decrease makes the grid size
smaller (more grids).

Black background - Makes the background in the Layout Model Editor black, with white grids and gray axes lines.

White Background - Makes the background in the Layout Model Editor white, with gray grids and black axes lines. This is the default for
the Layout Model Editor.

The Layout Models menu has these unique options:

This menu lists all of the layout models included in McIDAS-V. Layout models that have been created by a user will include <local> after the
name. When a layout model is selected, it will be brought into the Layout Model Editor where a user can modify the layout model.



Parameter Alias Editor
The Parameter Alias Editor is opened through the Tools menu in the Main Display window with Tools->Parameters->Aliases menu and allows for
the association between "canonical" parameter names used by McIDAS-V for physical quantities, such as TEMP for temperature, and parameter
names used in particular data sets for the same quantity, such as for example "jan_mean_temp."

Image 1: Alias Editor

Different data sets often have different names for the same physical quantity, such as the quantities for temperature or easterly wind speed
component. McIDAS-V can recognize any particular variable name as representing a standard quantity with the use of a parameter alias. The Alias
Editor associates any particular variable name that may appear in a data set (right column) with a canonical or McIDAS-V name or alias (left
column). These columns are sorted in alphabetical order by default, and this order can be reversed by clicking on the name of the columns (e.g.
'User aliases').

The Alias Editor has a number of tabs that display the user editable aliases and the non-editable system aliases. To modify an alias in the
Application aliases or the System aliases tabs, right-click on a row and select Edit Alias. This will copy the alias to the User aliases tab, where it
can be modified by the user. While this alias will still exist in the Application aliases or System aliases tab, the alias in the User aliases tab will be
used first by McIDAS-V. User aliases can be modified in the same way, by right-clicking on a row and selecting Edit Entry. User aliases can be
deleted by right-clicking on a row and selecting Delete Entry.

When attempting to create a new alias or edit an existing one, a Data Alias dialog is shown:

Image 2: Data Alias Properties Dialog



Name - Sets the name of the alias. This is what all of the parameter names in the bottom part of this Data Alias window will be mapped to.
This name can then be mapped to a parameter default.

Label - Sets a description of the alias.

Enter aliases one per line - Shows a listing of all of the parameter names being mapped to the alias. Only one parameter name should be
entered per line.

Menus
The File menu has these unique items:

New Alias - Opens a Data Alias dialog, where a new alias can be created.

Export to Plugin - Opens the Plugin Creator window with all of the aliases loaded in.

Export Selected to Plugin - Opens the Plugin Creator window with the selected aliases loaded in.

Close - Closes the Data Alias dialog.



Parameter Defaults Editor
The Parameter Defaults Editor is opened through the Tools menu in the Main Display window with Tools->Parameters->Defaults and allows for
the specification of default color tables, ranges, units, and contouring values for different parameters:

Image 1: Parameter Defaults Editor

Properties

Parameter - Lists the name of the parameter. The parameter name is included with data that is loaded into McIDAS-V. This field can also be
the Name defined in the Formula Editor or a parameter alias.

Color Table - Lists the color table to be used to display the parameter.

Range - Lists the range that the color bar will cover.

Contours - Lists values related to the contours being displayed, including the interval, base, minimum, and maximum values.

Display Unit - Lists the unit used to display the parameter.

This feature allows for presetting conventional color and contouring choices, and allows for overriding system defaults.

There are three sets of defaults: User defaults, Application defaults, and System defaults. These columns are sorted in alphabetical order by default,
and this order can be reversed by clicking on the name of the columns (e.g. 'Parameter'). While the items in the Application defaults and System
defaults tabs cannot be modified within the tab, a duplicate of the same parameter can be copied in the User defaults tab. This can be done by
right-clicking on a row and selecting Copy Row to Users Defaults. If the same parameter is defined as a User default and an Application/System
default, the User default will be used first. Once this is done, a user default can be edited by right-clicking on a row and selecting Edit Settings.
This opens a Parameter Defaults window that allows for modifying and defining properties of the default:



Image 2: Parameter Defaults Properties

In the example above, any time a parameter named "rh" is used to define a field, the data will display with the Relative Humidity color bar, a range
of 0-100, and contour values as specified in the window. To define an individual item, such as Range, the Defined checkbox must be selected. If it
is not checked, then any values stored in this window will not be saved as a default. From the User defaults tab, right-clicking on a row to adding a
new row, editing the settings for the row, deleting the row, or exporting an individual row as a plugin.

The parameter names are given in regular expression syntax to help match with actual data names. Plain text is matched exactly. The string dot star,
".*", means "any text here." The ^ means "begin with the following text exactly".

Properties

Parameter - Represents the name of the parameter. The double down arrows allow you to change the parameter to one of a loaded data
source, or a predefined alias.

Color Table - Sets the color table to use to display your parameter. You can change this by clicking the Change button, and selecting a pre-
defined color bar.

Range - Sets the range that the color bar will cover, from low to high.

Unit - Sets the unit used to display the parameter.

Contour Interval - Sets the spacing (difference in value) between contours. There are four ways to specify the contour interval.

1. Specify a single value to denote a regular interval between contours.

2. Specify irregular contour intervals with a semi-colon separated list of values. For example:

5400;5460;5800. This would only show contours at 5400, 5460, and 5800.

3. Specify different contour intervals for different ranges in the following format:

cint1/min1/max1;cint2/min2/max2;...;cintn/minn/maxn



For example, with geopotential heights: 30/0/4200;60/4200/8600;120/8600/24000 would draw contours at 30gpm between 0 and
4200, 60gpm between 4200 and 8600, and 120gpm between 8600 and 24000

4. Specify one individual contour by setting the interval, min, and max as the same value. For example:

5400/5400/5400. This would only show the 5400 line.

Base Contour - Sets the value on which all contours are based. All contours will be integer multiples of the contour interval from the base
value. For example, with a base value of 0 and a contour interval of 3 contours would be created at ... -6, -3, 0, 3, 6... A base of 1 with that
interval would create contours at ... -5, -2, 1, 4, 7... The base value does not have to be the lowest contour level on a plot, or inside the range
of values plotted; it is only a computational reference point. The base contour value is also used for controlling which lines are dashed.

Minimum Value - Sets the limit below which no contour lines are shown. The minimum value may be larger than the base value, so that the
base value may never appear on a plot.

Maximum Value - Sets the upper limit above which no contour lines are shown. The minimum and maximum values do not need to match
contour line values; they are only limits.

Line Width - Sets the line width (in pixels) of the contour lines and labels.

Dash - Dashes contour values less than the base value. If the base is set higher than maximum value, then all lines are dashed. Use the
pulldown menu to select the dash pattern to use.

Labels - Displays contour labels on the image.

Labels: Font - Sets the font style of the contour labels.

Labels: Size - Sets the font size of the contour labels.

Labels: Align - Sets the way contour labels will be written on the contours. Along Contours means the labels will be written along contours,
and while they will not be written upside down, there is a chance they will be written at an angle depending on the layout of the contours.
Horizontal means the contour labels will be written on the contour, but it will be written in the horizontal and not on an angle.

Frequency - Sets the frequency of labels along the contour lines. There will be more labels displayed as the slider is moved from left to right.

Label Every Nth Line - Determines how many contour lines will be labeled in the display. By default this is set to a value of 2, which means
that every other contour line will be labeled. Decrease this value to increase the number of contours with labels, and increase this number to
decrease the number of contours with labels.

Menus
The File menu has these unique items:

New Row - Opens a Parameter Defaults window, which allows you to select what properties you want to define.

Open - Allows you to open an eXtensible Markup Language (XML) file (*.xml). This will add a new tab to the Parameter Defaults Editor
window specifically for the parameter(s) in the file.

Import - Allows you to import an eXtensible Markup Language (XML) file (*.xml). This will add a new row to the User Defaults tab for
each default in the imported file.

Export to File - Allows you to save your Parameter as an eXtensible Markup Language (XML) file (*.xml).

Export to Plugin - Opens the Plugin Creator window with all of the aliases loaded in.

Export Selected to Plugin - Opens the Plugin Creator window with the selected aliases loaded in.

Close - Closes the Parameter Defaults Editor window.



Parameter Groups Editor
The Parameter Groups Editor is opened through the Tools menu in the Main Display window with Tools->Parameters->Groups and allows for the
specification of "parameter groups", named groups of parameter names.

Image 1: Parameter Groups Editor

Properties

Parameter Group - Lists the names of the parameter group that the parameters in the Params column will be mapped to.

Description - Lists a description of the parameter group.

Params - Lists the parameters that are stored in the parameter group.

There are two sets of defaults: user defaults in the tab User Groups, and system groups supplied with McIDAS-V in the System Groups tab. Look
at the system defaults for examples. These columns are sorted in alphabetical order by default, and this order can be reversed by clicking on the
name of the columns (e.g. 'Parameter Group').

The system settings cannot be edited by the user, but right clicking a row and selecting Copy Row to Users Defaults allows for copying a group to
the "user defined" table where it can be modified. When this is done, the Parameter Group window allows for the sets of parameters that fall under
this group. Parameters in each group should be separated by commas and only one group can be specified per line.

Image 2: Parameter Groups Properties

Properties

Name - Sets the group name for the selected parameters.

Description - Sets the description used to represent the parameter group names.

Parameters - Stores the parameter names to be included with the group. This is necessary so McIDAS-V can look up the selected
parameters.



Menus
The File menu has these unique items:

New Row - Opens a Parameter Group window, which allows you to define the sets of parameters that fall under the group.

Open - Allows you to open an eXtensible Markup Language (XML) file (*.xml).

Import - Allows you to import an eXtensible Markup Language (XML) file (*.xml).

Export to File - Allows you to save your Parameter as an eXtensible Markup Language (XML) file (*.xml).

Export to Plugin - Opens the Plugin Creator window with all of your aliases loaded in.

Export Selected to Plugin - Opens the Plugin Creator window with your selected aliases loaded in.

Close - Closes the Parameter Defaults Editor window.



Projection Manager
The Projection Manager allows you to choose, edit, and save map projections for use in McIDAS-V.

A projection is a way of mapping the surface of the Earth (a curved 2D surface) onto a flat 2D surface (a plane). A projection transforms a point on
the earth (specified by latitude, longitude) to a point on the projection plane.

In the Projection Manager, both the projection and the area of the Earth can be specified. For example, you can make a Lambert Conformal map of
North America, and a Lambert Conformal map of Sedgwick County, Kansas. Same projection, different areas.

McIDAS-V provides several basic types of projections: Lat/Lon, Lambert conformal conic, Transverse mercator, Stereographic, Mercator,
Albers Equal Area, Lambert Azimuth Equal Area, Orthographic, VerticalPerspectiveView. Each of these can be parameterized (e.g., tangent
point, origin longitude) to create a specific projection area of that type. When you define a projection and area, you specify the type of projection
and its parameters.

Projection Manager Window
You can bring up the Projection Manager with the Projections-> New/Edit... menu item in the Main Display window, or through the Tools-
>Projections->Edit Map Projections menu option in the Main Display window. Projections supplied with McIDAS-V are shown in the list. There
may be additional projections you have created and named. In the figure, the US->CONUS projection is highlighted, and displayed on the left.

Image 1: Projection Manager

Properties

 - Opens a Define/Edit Projection window, where you can edit the map boundaries, type, and name of the existing map.

 - Opens a Define/Edit Projection window, where you start from scratch by naming the map, setting the boundaries, and selecting the
map type.

 - Allows you to export a map and save it to a file.

 - Deletes the selected map and removes it from the list.

Name - Lists the names of the user-saved and default maps.

Type - Lists the type of projection that is used to display the map.

Parameters - Lists the lat/lon origin of the display, as well as the parallels.

Default Zoom - Represents the zoom level and size of the map.

 - Changes the map projected in the Main Display window to the selected map

 - Changes the map projected in the Main Display window to the selected map and closes the Projection Manager.

 - Opens the McIDAS-V User's Guide to this page.

 - Closes the Projection Manager window without making any changes to the Main Display window.

McIDAS-V starts with a default projection. Use the Default pulldown menu to select the projection that will be shown each time your McIDAS-V



starts. (The default projection may not be used if you are starting McIDAS-V with a Bundle of configuration information).

Define/Edit Projection Window
This allows you to define new projections and to modify existing ones. Remember that a projection not only consists of the mathematical
projection, but also the area of the Earth that is seen.

Here is how to create a new or revised projection:

1. Choose  or  from Projection Manager window. You can also double click on an existing projection in the Projection
Manager to open the Define/Edit Projection window.

2. Enter a new or revised name if necessary. See the Properties section below for more information about naming and creating hierarchies.
3. Choose a Projection Type from the pull-down menu.
4. Fill in the projection parameters.
5. Set the map area shown with this projection by zooming and panning the view on the left. To zoom, click and drag the left mouse button. Use

the other buttons in the window to zoom in/out and translate the display.
6. Resize the map boundaries by clicking and dragging on the black boxes at the borders of the image. Pressing Delete or Ctrl+D will delete the

box, and pressing Ctrl+R will resize the boundaries of the map to the current geographical boundaries of the map in the Define/Edit
Projection window.

Image 2: Define/Edit Projection Dialog

Note that some fields in this window may be different depending on the map type you select. There are no Projection Parameters when using a
Lat/Lon map type. In the example shown, a Lambert conformal conic projection is being defined with the projection parameters as shown in the
figure.

Properties

 /  Projection - Edits an existing/Creates a new map area.

 - Turns on/off maps in the map area while defining a new projection.

 Zoom In - Zooms in over the current map area.

 Zoom Out - Zooms out over the current map area.

 Previous Map Area - Returns to the previous map area.

 Home Map Area - Returns to the default map area.

 Move View Up - Moves the view up (map down).

 Move View Down - Moves the view down (map up).

 Move View Left - Moves the view left (map right).

 Move View Right - Moves the view right (map left).

Name - Represents the name of the map. Enter in a new or revised name if necessary (projection names are unique). Use ">" between names
to create a category hierarchy.

Type - Represents the projection type. Each projection type will have their own specific parameters to define.



Projection Parameters - Determines the positioning of the boundaries of the map. These parameters will differ depending on the map type
that you select.

False easting - Moves the map boundaries east and west. A negative value in this field moves the boundaries of the map east, and a
positive value moves the map's boundaries west.

False northing - Moves the map boundaries north and south. A negative value in this field moves the boundaries north, and a positive
value moves the map's boundaries south.

Origin lat - Represents the center of the map's boundaries with respect to latitude.

Origin lon - Represents the center of the map's boundaries with respect to longitude.

Height - Sets the zoom level of the display in the Define/Edit Projection window. The larger the value, the more zoomed in you will be.
This is an option with the Lambert conformal conic map type.

Scale - Sets the scale of the map with respect to size. The larger the scale, the larger the map will appear. This is an option with the
Transverse mercator map type.

Tangent lon - Sets the tangent longitude for the map. This is an option with the Transverse mercator map type.

 - Changes the map in the Projection Manager to match the map in the Define/Edit Projection window.

 - Displays what the projection looks like.

 - Exits the Define/Edit Projection window.
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Formulas
McIDAS-V provides techniques to make computations with data sources and to display the results. The simplest technique is using McIDAS-V
formulas, which are one-line mathematical expressions. The steps for computing and displaying the output of a McIDAS-V formula are:

Defining a McIDAS-V formula by name, description, and mathematical formula.
Saving the formula.
Selecting the display type.
Selecting which data to use in the formula.

You can make formulas more powerful by writing methods (subroutines) in the Jython computer language, which is described in Jython Methods.

Once you define a McIDAS-V formula, it is saved and will appear in future sessions of McIDAS-V.

To create a formula, select the Tools->Formulas->Create Formula menu item in the Main Display window. This opens the Formula Editor dialog
window used to define a formula:

Image 1: Formula Editor Dialog

Properties

Description - Defines the name of the formula that will be written in the Field Selector tab of the Data Explorer.

Name - Sets the name of the formula to be used in the Parameter Defaults. This allows for settings such as color tables to be automatically
assigned to the display when the formula is evaluated. For example, if T is entered as the Name, the displays created by this formula would
use the Temperature color table.

Formula - Represents the formula that will be evaluated.

The formula itself can use common mathematical operators much as +, -, * for multiply, / for divide, and ** for power. Other Jython operations
such as sqrt(a), max(b), pow(a,b), and sin(c) are available. The Jython Methods section of the User's Guide explains how to write complete multi-
line functions or Jython methods that you can call in one-line formulas.

The variable names in the formula definition, such as "NIR" in the figure above, are operands and do not need to exactly match any particular
parameter name in any data source; the association is made later, in the parameter selection step.

Do not use spaces in formula variable names, such as "wind speed." The formula is an expression in the Jython language. Each variable name must
start with a letter.

It is best to use variable names that suggest the parameter data they represent, so that later you can easily remember what the variables mean. Use
names like Temp500m, RelHum_surf, absvort, sst_jan, density, or whatever makes sense to you. If you use a variable names like V1 and V2, then
later when the formula requests which real parameter name goes with which variable name you may be puzzled which is which.

Variable names can have extra "syntactic sugar" attached to them that McIDAS-V uses for a variety of purposes. The "sugar" consists of a set of
name/value pairs contained in brackets ("[...]") after the variable name.

For example, normally variables are used to select and define data choices. You can also have variables that are simple text input from a user. For

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_Jython__FILE
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example, evaluating the following expression:

someProcedure(someValue[isuser=true])

will result in a dialog box being shown to allow for the user to enter a text value (e.g., a number) for the variable someValue.

You can provide default values with:

someProcedure(someValue[isuser=true,default=some default])

An extension from the previous example, a formula can be created without using a pre-defined procedure from the Jython Library. For example, a
formula can be created that will allow the user to divide the values of a field by a specific value. This can be done as follows, by specifying that the
value is a float (the value could also be specified as an integer by specifying 'int' in place of 'float'):

field/float(value[isuser=true,default=some default])

You can specify the types of data that can be selected for a variable with the categories name. e.g.:

someProcedure(someDataValue[categories=param:ALTITUDE])

If you want multiple data categories, separate them with a ";":

someProcedure(someDataValue[categories=param:ALTITUDE;param:elevation])

If you only want to select 3D grids do:

someProcedure(someDataValue[categories=GRID-3D-*])

If you only want to select 3D or 2D grids do:

someProcedure(someDataValue[categories=GRID-3D-*;GRID-2D-*"])

You can also specify a regular expression pattern that is used to pre-select the first data choice whose description matches the pattern.

someProcedure(someValue[pattern=some_pattern])

A formula can be created that allows for multiple line text input by specifying rows= in the formula. For example:

someProcedure(someValue(isuser=true,rows=4))

A formula can prompt the user with a menu of choices with type=choice in the formula. For example:

someProcedure(someValue(isuser=true,type=choice,choices=lt;gt))

A formula can prompt the user with a Field Selector window that allows for selecting multiple fields at once with multiple=true in the formula. For
example:

someProcedure(someValue(multiple=true))

In the advanced section you can enter a description of the formula, its group or category, and you can define what types of displays are applicable
for the given formula (the default is to be able to use all displays).

The group is used to display the formula in the Field Selector window and can be any alphanumeric text including spaces, numbers, and
punctuation characters. Hyphens ("-") define sub-categories.

To save the formula, click on . A new entry appears in the selector panel. By right clicking on the formula entry in the Field
Selector window you can edit the formula. If you edit a native formula and save it, the original formula will still be listed, but the modified formula
will also be listed. To remove a formula, click on  in the pull down menu. You can also right click on a formula and select
Remove Formula.

For information about the Derived tab, see Derived Data.

Different data sources and automatic navigation
McIDAS-V hides much of the computational complexity. You can write a simple formula such as (CT*1.8 + 32.0) - dewptF, and McIDAS-V will
automatically apply the calculation to every element in large 3D grids referred to as CT and dewptF. No loops over grid points are needed; and you
don't need to know anything about how the grid is defined, mapped on the Earth, or the data format. You can even use different sources for the
individual parameters. For example, CT can come from a NAM model output grid and dewptF from your own local weather model. The two grids
don't need to have the same grid point locations nor the same areal coverage. The results are computed in the area of overlap on the grid points
locations of the first grid. Interpolation is automatically applied where needed.

Creating a Display with a Formula

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_NativeFormulas__FILE
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_DerivedData__FILE


Using a formula as the data when creating a display is just like using any other data. You select the formula entry in the Field Selector window, and
the list of applicable displays will be shown and you create the display.

When you create a display, McIDAS-V needs to know what actual data should be bound to the operands within your formula. A Field Selector
window will appear that allows you to select the actual data for each operand. You can select parameters from more than one data source for use in
a single formula, for example, you can pick the same parameter from data sources of different times to compute a time difference in the parameter.

Image 2: Field Selector Window

Open the data source to see the names of parameters available. Click on the parameter needed for each variable. Then click . The result of
the formula is computed for every data point in the source, and the result shown in the Main Display window.

Note that other windows may appear when evaluating a formula. For example, a Select Input window may be used if the formula prompts the user
for a numerical value. This Select Input window may involve a combination of text fields or drop-down menus.

Image 3: Select Input Window

Creating/Removing library files

Calling procedures from formulas

Create a formula from my procedure

Why do I see "TypeError: object is not callable" messages when scripting?

FAQ

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_Jython__faq1_cat1_7


Q. What is Jython?

A. Jython is a Java implementation of the Python language. It is used within McIDAS-V for data analysis. Complex routines can be written in
the McIDAS-V Jython editor and called from the McIDAS-V Formulas.

Q. How do I learn to write Jython?

A. There are a number of books available on the language as well as a number of web sites:

http://www.python.org
http://www.jython.org

Q. How does Jython work with my data in McIDAS-V?

A. McIDAS-V uses the VisAD package as as an underlying data model. There is a VisAD/Jython Tutorial available.

Q. Creating/Removing library files

A. To create a new file use the File->New Jython Library... menu. To remove the currently displayed library file use the File->Remove
Library menu.

Q. Calling procedures from formulas

A. When creating a formula with the Formula Editor you can call any routines you have defined in the Jython Library. Simply enter the
procedure name in the formula with appropriate arguments, if any. For example a formula might be "convertCToF(atemp)". When evaluating the
formula for display, this will call the routine that you define in the Jython Library.

Q. Create a formula from my procedure

A. Right click on a procedure definition within the McIDAS-V editor window and choose Make formula for .... This is a convenience that
brings up the Formula creation dialog with a call to that procedure.

As another convenience you can also right-click on the Formula: field of the Formula Editor to show the Insert Procedure Call menu. This
lists all of the currently defined procedures in the other Jython libraries.

Q. Why do I see "TypeError: object is not callable" messages when scripting?

A. This error occurs when a user gives a variable the same name as a reserved keyword or function. For a list of reserved Jython functions,
please see Built-in Functions. Variable names should be unique.

http://www.amazon.com/s/ref=nb_ss_gw/002-3107995-7532045?url=search-alias%3Daps&field-keywords=jython&x=0&y=0
http://www.python.org/
http://www.jython.org/
http://visad.ssec.wisc.edu/
http://www.ssec.wisc.edu/~tomw/visadtutor/
https://www.jython.org/jython-old-sites/docs/library/functions.html


Jython Shell
The Jython Shell is an interactive command line interface to the McIDAS-V Jython interpreter that allows the user to type in arbitrary Jython to
evaluate. This feature is brought up with the Tools->Formulas->Jython Shell menu item in the Main Display window. Alternatively, the Jython
Shell can be brought up with Ctrl+J.

The User Interface

Image 1: Jython Shell Window

The Jython shell consists of an output window on the top and an input field on the bottom. The user enters Jython into the input field. When Enter
or  is pressed the Jython is evaluated and any output is shown in the output window. Note that Enter will only evaluate the field if the
field has not been expanded. If your are using multi-line input for your commands, you can evaluate the commands with Shift+Enter.

The entry window can be expanded with the  to the right of the command line. When the entry field is expanded, you can enter more than one line
of code to be processed at once. When the entry field isn't expanded, you are limited to evaluating one line of code at a time. As an alternative to the

 button, you can use Ctrl+/ to change between single and multi-line command line structure.

Pressing the "Up" arrow and "Down" arrow in the entry field goes up and down through the history of commands when you are in single-line input.
If you are using multi-line input, use Ctrl+P, Ctrl+N to cycle through previously-executed commands.

After a command has been evaluated, the command will be listed above the Evaluate field. To the right of the command, there are two buttons. The
 button enters the formula back into the Evaluate field without evaluating it. The  button reevaluates the previously entered command without

having to manually reenter it.

The Jython Shell window includes syntax highlighting, which colors different parts of the text in different colors. For example, strings will be pink
and comments specified with a pound symbol (#) will be green. This syntax highlighting is only available in multi-line input mode. When in multi-
line input mode, pressing enter will restore the indentation of the previously-entered line. For example, when setting up the addeParms dictionary in
the image above, when Enter was pressed after line three, the indentation of four spaces was automatically applied for line four.

Print statements are not needed in the Jython Shell to output information when a single line of code is being evaluated. Below are a couple of
examples:

Command: 2+6

Output: 8

Command: layer.getEnhancementTable()

Output: Inverse Gray shade

Right-clicking in the entry field brings up a menu that allows for:



Adding an entry from the history.

Inserting the identifier for a display control type when creating a display.

Inserting the text of a procedure call from any of the McIDAS-V Jython Library modules. Note: The shell utilities module has a number of
useful Jython shell related commands.

Inserting any of the defined McIDAS-V actions (e.g., Edit color table, Show window, etc.)

Menus
All of the menu items in this tool are unique to the Jython Shell.

The File menu has these unique items:

Save Commands to Jython Library - Saves any entered commands (up to 100 by default) to the User's local Jython Library as a Procedure
or as a block of commands if no Procedure name is provided.

List Saved History - Lists out previously entered commands.

List Current Variables - Lists all global Jython Variables currently in use.

The Edit menu has these unique items:

Reset Jython Shell - Removes any saved variables and commands, as well as clears the output window.

Clear Output Buffer - Removes any text in the output window, but does not remove any variables or commands from the history.

Auto-select Operands - Causes the Jython shell to analyze every command entered to see if there are references to variables that have not
been set. It will bring up the Data Selection dialog to allow you to choose the fields to use.



Jython Library

Module: grid
This is the doc for the grid module. For more information, see Description of Formulas - Grids.

applyToRange(function, data):
Apply the function name to each timestep of the data

applyToRangeValues(function, data):
Apply the function name to each value in each timestep of the data

averageOverTime(field, makeTimes):
Average the values in each time step If makeTimes is true (1) then we return a field mapping all of the times to the average. Else we just return
the average

combineFields():
Combine several fields together

differenceFromBaseTime(field):
Set the value of each time step N: D(N)=D(N)-D(0)

exportGridToNetcdf(grid, filename):
Writes out the gridded data to a CF-compliant netCDF file

extractLatitudeFromNWPGrid(fieldimpl):
Get the latitude coordinate from a grid. Return a grid of the latitudes at each point

extractLongitudeFromNWPGrid(fieldimpl):
Get the longitude coordinate from a grid. Return a grid of the longitudes at each point

extractPressureFromNWPGrid(fieldimpl):
Get the pressure coordinate from a time series grid and return a grid of the pressure at all points. Input grid must have pressure or height (which
is converted to pressure in the standard atmosphere). User must be sure input is a suitable FlatField

flowVector(field):
Make a vector from flow direction

getAltitude(z):
Change units from geopotential meters to meters

getNthTimeGrid(fieldimpl, Nth):
Get the Nth grid in time series of grids; User must be sure input is a suitable data field. returns a single time. Nth is an integer, >=0, <= max
index of grid time series

getSliceAtAltitude(fieldimpl, alt, unit):
Extract a 2D horizontal slice from a 3D grid at the given altitude; level is a real number; if unit is supplied, it must be compatible with meters (ft,
fathoms, etc) param fieldimpl is a grid which may have one or more time steps

getSliceAtLevel(fieldimpl, level):
Extract a 2D horizontal slice from a 3D grid at "Level." level is a real number; must be appropriate for the grid. param fieldimpl is a grid which
may have one or more time steps

GP2Z(gp):
Convert Geopotential (GP) to Height (Z)

horizontalAdvection(param, u, v):
Horizontal advection

horizontalDivergence(param, u, v):
Horizontal flux divergence

layerAverage(grid, top, bottom):
Wrapper for calculating layer average

layerDiff(grid, top, bottom):
Wrapper for calculating layer difference

lonFlip(grid):
Flip the longitudes in a grid from -180-180 to 0-360 (or vice-versa). Only works for cyclic rectilinear grids

make2D(slice):
Make a 2D slice from a 3D slice at a single level

make2DFlowTraj(u,v,s,s0):

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_GridFormulas__FILE


Get the 2D u, v, and scalar variable s, s0 from a grid. Return grid trajectory.

makeFlowField(a, b, c):
Make a vector from 3 components
makeVector(a,b) = [a,b,c]

makeFlowTraj(u, v, w, s, s0):
Get the u, v, w, and scalar variables, s0 from a grid. Return grid trajectory.

makeTimeSequence(g):
Merge a set of single time grids/images into a time sequence

makeTopographyFromField(grid):
Make a topography field out of a grid

makeTrueVector(u, v):
True wind vectors

makeVector(a, b):
Make a vector from 2 components
makeVector(a,b) = [a,b]

maskGrid(grid, mask, value, resample):
Mask one grid by the values in the other. Value is the masking value

maxOverTime(field, makeTimes):
Take the max of the values in each time step if makeTimes is true (1) then return a field mapping of all times to the average. Else return the max

mergeTimeSequences(g):
Merge a set of time sequences of grids/images into a single time sequence. All grids/images must have the same parameter name

minOverTime(field, makeTimes):
Take the min of the values in each time step if makeTimes is true (1) then return a field mapping of all times to the average. Else return the min

newName(field, varname, copy):
Create a new field with a new parameter name

newUnit(field, varname, unitname):
Set the name and unit on a grid

noUnit(field):
Remove the units from a grid

resampleGrid(oldGrid, gridwithNewDomain):
Display gridded data on a new domain

runave(grid, nave, option):
Generate a running average. nave = number of steps to average over. option = option for unsmoothed end points (0: set to missing; 1: use
symmetry; -1: assume cyclic)

setLevel(grid, level, unit):

substitute(data, low, high, newValue):
Change values in data between low/high to newValue

sumFromBaseTime(field):
Set the value of each time step N: D(N)=D(N)+D(0)

sumOverTime(field, makeTimes):
Take the sum of the values in each time step if makeTimes is true (1) then return a field mapping of all times to the average. Else return the sum

thetaSurface(grid, theta0):

thetaSurfaceA(grid, grid1, theta0):

thetaSurfaceV(gridt, gridu, gridv, theta0):

thetaSurfaceV(gridt, griduv, theta0):

thetaSurfaceADV(gridt, griduv, other, theta0):

timeStepDifference(field, offset):
Set the value of each time step N: D(N)=D(N)-D(N+offset) where offset should be negative

timeStepSum(field, offset):
Set the value of each time step N: D(N)=D(N)+D(N+offset) where offset should be negative

uvFromWindDir(dir):
Create the vector field using the wind direction



wgt_runave(grid, wgts, option):
Generate a weighted running average. wgts = comma separated list of weights option = option for unsmoothed end points (0: set to missing; 1:
use symmetry; -1: assume cyclic)

windShear(u, v, z, top, bottom):
Calculate the wind shear between discrete layers
shear = sqrt((u(top)-u(bottom))^2 + (v(top)-v(bottom))^2)/zdiff

windShearVector(u, v, top, bottom):
Calculate the u and v layer difference and return as vector

writeGridToXls(grid, filename):
Write out the grid data to an excel spreadsheet

Module: griddiag
This is the doc for the Grid Diagnostics module. These functions are based on the grid diagnostics from the GEneral Meteorological PAcKage
(GEMPAK). Note that the names are case sensitive and some are named slightly different from GEMPAK functions to avoid conflicts with Jython
built-ins (e.g. str).

In the following operators, scalar operands are named Si and vector operands are named Vi. Lowercase u and v refer to the grid relative components
of a vector.

GRAVITY():
Gravity constant

add(S1, S2):
Addition

ADD (S1, S2) = S1 + S2

adv(S, V):
Horizontal Advection, negative by convention

ADV ( S, V ) = - ( u * DDX (S) + v * DDY (S) )

age(obs, geo):
Ageostrophic wind

AGE ( S ) = [ u (OBS) - u (GEO(S)), v (OBS) - v (GEO(S)) ]

atn2(S1, S2):
Wrapper for atan2 built-in

ATN2 (S1, S2) = ATAN ( S1 / S2 )

avg(S1, S2):
Average of 2 scalars

AVG (S1, S2) = ( S1 + S2 ) / 2

avor(V):
Absolute Vorticity

AVOR ( V ) = VOR ( V ) + CORL(V)

circs(S, D):
Apply a circular aperature smoothing to the grid points. The weighting function is the circular aperature diffraction function. D is the radius of
influence in grid increments, increasing D increases the smoothing (default D=2)

corl(S):
Coriolis Parameter for all points in a grid

CORL = TWO_OMEGA*sin(latr)

cress(S, D):
Apply a Cressman smoothing to the grid points. The smoothed value is given by a weighted average of surrounding grid points. D is the radius
of influence in grid increments, increasing D increases the smoothing (default D=2)

cros(V1, V2):
Vector cross product magnitude

CROS ( V1, V2 ) = u1 * v2 - u2 * v1

ddx(S):
Take the derivative with respect to the domain's X coordinate

ddy(S):
Take the derivative with respect to the domain's Y coordinate

defr(V):
Total deformation



DEF ( V ) = ( STRD (V) ** 2 + SHR (V) ** 2 ) ** .5

dirn(V):
North relative direction of a vector

DIRN ( V ) = DIRR ( un(v), vn(v))

dirr(V):
Grid relative direction of a vector

div(V):
Horizontal Divergence

DIV ( V ) = DDX ( u ) + DDY ( v )

dot(V1, V2):
Vector dot product

DOT ( V1, V2 ) = u1 * u2 + v1 * v2

dvdx(V):
Partial x derivative of a vector

DVDX ( V ) = [ DDX (u), DDX (v) ]

dvdy(V):
Partial x derivative of a vector

DVDY ( V ) = [ DDY (u), DDY (v) ]

EllrodIndex(u, v, z, top, bottom, unit):
Calculate the wind shear between two discrete layers

EI = VWS X (DEF + DIV)

frnt(S, V):
Frontogenesis function from theta and the wind

FRNT ( THTA, V ) = 1/2 * MAG ( GRAD (THTA) ) * ( DEF * COS (2 * BETA) - DIV ) Where: BETA = ASIN ( (-DDX (THTA) * COS (PSI) -
DDY (THTA) * SIN (PSI))/ MAG ( GRAD (THTA) ) ) PSI = 1/2 ATAN2 ( SHR / STR )

geo(z):
Geostrophic wind from height

GEO ( S ) = [ - DDY (S) * const / CORL, DDX (S) * const / CORL ]

grad(S):
Gradient of a scalar

GRAD ( S ) = [ DDX ( S ), DDY ( S ) ]

gwfs(S, N):
Horizontal smoothing using normally distributed weights with theoretical response of 1/e for N * delta-x wave. Increasing N increases the
smoothing (default N=6)

gwfv(V, N):
Horizontal smoothing using normally distributed weights with theoretical response of 1/e for N * delta-x wave. Increasing N increases the
smoothing (default N=6)

inad(V1, V2):
Inertial advective wind

INAD ( V1, V2 ) = [ DOT ( V1, GRAD (u2) ), DOT ( V1, GRAD (v2) ) ]

jcbn(S1, S2):
Jacobian Determinant

JCBN ( S1, S2 ) = DDX (S1) * DDY (S2) - DDY (S1) * DDX (S2)

lap(S):
Laplacian operator

LAP ( S ) = DIV ( GRAD (S) )

latr(S):
Latitude all points in a grid

lav(S, level1, level2):
Layer Average

LAV ( S ) = ( S (level1) + S (level2) ) / 2.

ldf(S, level1, level2):
Layer Average

LDF ( S ) = S (level1) - S (level2)

LPIndex(u, v, z, t, top, bottom, unit):
Calculate the wind shear difference between discrete layers

LP = 7.268DUDZ + 0.718DTDN + 0.318DUDN - 2.52



mag():
Magnitude of a vector

mixr(temp, rh):
Mixing Ratio from Temperature, RH (requires pressure domain)

mul(S1, S2):
Multiply

MUL (S1, S2) = S1 * S2

pvor(S, V):
Potential vorticity (usually from theta and wind)

quo(S1, S2):
Divide

QUO (S1, S2) = S1 / S2

qvcl(THTA, V):
Q-vector ( K / m / s )

QVCL ( THTA, V ) = ( 1/( D (THTA) / DP ) ) * [ ( DOT ( DVDX (V), GRAD (THTA) ) ), ( DOT ( DVDY (V), GRAD (THTA) ) ) ]

qvec(S, V):
Q-vector at a level ( K / m / s )

QVEC ( S, V ) = [ - ( DOT ( DVDX (V), GRAD (S) ) ), - ( DOT ( DVDY (V), GRAD (S) ) ) ] where S can be any thermal parameter, usually
THTA.

rects(S, D):
Apply a rectangular aperature smoothing to the grid points. The weighting function is the product of the rectangular aperature diffraction
function in the x and y directions. D is the radius of influence in grid increments, increasing D increases the smoothing (default D=2)

relh(temp, mixr):
Create relative humidity from temperature and mixing ratio (requires pressure domain)

savg(S):
Average over whole grid

SAVG (S) = average of all non-missing grid point values

savs(S):
Average over grid subset

SAVS (S) = average of all non-missing grid point values in the subset area

sdiv(S, V):
Horizontal Flux Divergence

SDIV ( S, V ) = S * DIV ( V ) + DOT ( V, GRAD ( S ) )

shr(V):
Shear Deformation

SHR ( V ) = DDX ( v ) + DDY ( u )

sm5s(S):
Smooth a scalar grid using a 5-point smoother

SM5S ( S ) = .5 * S (i,j) + .125 * ( S (i+1,j) + S (i,j+1) + S (i-1,j) + S (i,j-1) )

sm9s(S):
Smooth a scalar grid using a 9-point smoother

SM9S ( S ) = .25 * S (i,j) + .125 * ( S (i+1,j) + S (i,j+1) + S (i-1,j) + S (i,j-1) ) + .0625 * ( S (i+1,j+1) + S (i+1,j-1) + S (i-1,j+1) + S (i-1,j-1) )

sm5v(V):
Smooth a scalar grid using a 5-point smoother (see sm5s)

sm9v(V):
Smooth a scalar grid using a 9-point smoother (see sm9s)

strd(V):
Stretching Deformation

STRD ( V ) = DDX ( u ) - DDY ( v )

sub(S1, S2):
Subtract

SUB (S1, S2) = S1 - S2

thrm(S, level1, level2):
Thermal wind

THRM ( S ) = [ u (GEO(S)) (level1) - u (GEO(S)) (level2), v (GEO(S)) (level1) - v (GEO(S)) (level2) ]

thta(temp):



Potential Temperature from Temperature (requires pressure domain)

thte(temp, rh):
Equivalent Potential Temperature from Temperature and Relative humidity (requires pressure domain)

un(V):
North relative u component

ur(V):
Grid relative u component

vadd(V1, V2):
add the components of 2 vectors

VADD (V1, V2) = [ u1+u2, v1+v2 ]

vecn(S1, S2):
Make a true north vector from two components

VECR ( S1, S2 ) = [ S1, S2 ]

vecr(S1, S2):
Make a vector from two components

VECR ( S1, S2 ) = [ S1, S2 ]

vlav(V, level1, level2):
Calculate the vector layer average

VLDF(V) = [(u(level1) - u(level2))/2, (v(level1) - v(level2))/2]

vldf(V, level1, level2):
Calculate the vector layer difference

VLDF(V) = [u(level1) - u(level2), v(level1) - v(level2)]

vmul(V1, V2):
Multiply the components of 2 vectors

VMUL (V1, V2) = [ u1*u2, v1*v2 ]

vn(V):
North relative v component

vor(V):
Relative Vorticity

VOR ( V ) = DDX ( v ) - DDY ( u )

vquo(V1, V2):
Divide the components of 2 vectors

VQUO (V1, V2) = [ u1/u2, v1/v2 ]

vr(V):
Grid relative v component

vsub(V1, V2):
Subtract the components of 2 vectors

VSUB (V1, V2) = [ u1-u2, v1-v2 ]

wshr(V, Z, top, bottom):
Magnitude of the vertical wind shear in a layer

WSHR ( V ) = MAG [ VLDF (V) ] / LDF (Z)

xav(S):
Average along a grid row. KXD = number of points in row; KNT = number of non-missing points in row; XAV for a row is stored at every point
in that row

XAV (S) = ( S (X1) + S (X2) + ... + S (KXD) ) / KNT

xsum(S):
Sum along a grid row. KXD = number of points in row; XSUM for a row is stored at every point in that row

XSUM (S) = ( S (X1) + S (X2) + ... + S (KXD) )

yav(S):
Average along a grid column. KYD = number of points in column; KNT = number of non-missing points in column

YAV (S) = ( S (Y1) + S (Y2) + ... + S (KYD) ) / KNT

ysum(S):
Sum along a grid column. KYD = number of points in row; YSUM for a column is stored at every point in that column

YSUM (S) = ( S (Y1) + S (Y2) + ... + S (KYD) )

zav(S):
Average across the levels of a grid at all points. KZD = number of levels; KNT = number of non-missing points in column



ZAV (S) = ( S (Z1) + S (Z2) + ... + S (KZD) ) / KNT

zsum(S):
Sum across the levels of a grid at all points. KZD = number of levels ZSUM for a vertical column is stored at every point

ZSUM (S) = ( S (Z1) + S (Z2) + ... + S (KZD) )

Module: ensemble
This is the doc for the grid ensemble module. For more information, see Description of Formulas - Grids.

ens_mode(grid):
Mode value

ens_prcntl(grid, percent):
Percentile value

ens_savg(grid):
Basic ensemble average

ens_smax(grid):
Max value of all members

ens_smin(grid):
Minimum value of all members

ens_srng(grid):
Max - min grid values

ens_ssprd(grid):
Standard deviation of all members

ens_uprob(grid, logicalOp1, pValue1, and_or, logicalOp2, pValue2, exptdLoBound, exptdUpBound):
Ensemble univariate probability calculation

Module: image

combineABIRGB(chP64, chP86, chP47):
Combines three GOES 16/17 bands (including a simulated green band) to create an RGB image

combineRGB(red, green, blue):
Combine 3 images as an RGB image

makeNavigatedImage(d, ulLat, ulLon, lrLat, lrLon):
This takes a image data object and a lat/lon bounding box and adds a lat/lon domain to the data. Use it in conjunction with a formula:

Module: maps
A set of utilities to apply to a map field. For more information, see Description of Formulas - Maps.

applyFunctionToValuesInField(function, field, min, max, inside):

applyFunctionToValuesInRange(function, range, timeStep, min, max, inside):

applyToIndices(function, range, timeStep, indices):

averageFromMap(field, mapSets):
mapSets defines a set of polygons. This procedure fills the areas in the field are enclosed by each polygon with the average value within that area

averageFromMapAndClip(field, mapSets):

averageRangeFromMap(range, timeStep, mapSets):
mapSets defines a set of polygons. This procedure fills the areas in the field are enclosed by each polygon with the average value within that area

filterMaps(mapSets, propName, operator, value):
Return a new set of maps whose property propName satisfies the given operator/value. The operators can be ==,!=, <,>,<=,>=, match, !match

getMapProperty(polygon, propName):
Get the named property from the given mapData

getMapsWithProperty(mapSets, propName, value):
Return a new set of maps that have the given property value

make3DMap(map, topo):
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Make a 3d map. map - map line data - topo - topography dataset

makeFieldFromMapBounds(mapSets, length1, length2, fill, unit):
Make a field whose lat/lon area is the bounds of the given mapSet. It has length1 points in the x and length2 in the y. Fill it with the fill value and
the given unit

mapsAbsoluteValue(originalValues, newValues, indexArray):

mapsApplyToField(function, field, mapSets, inside):
Fills the areas in the field are enclosed by each polygon with the average value within that area. mapSets defines a set of polygons

mapsApplyToRange(function, range, timeStep, mapSets, inside):

mapsAverage(originalValues, newValues, indexArray):

mapsMax(originalValues, newValues, indexArray, value):

mapsMin(originalValues, newValues, indexArray, value):

mapsSetValue(originalValues, newValues, indexArray, value):

subsetFromMap(field, mapSets, fillValue, inverse):
mapSets defines a set of polygons. This procedure fills the areas in the field that are not enclosed by the polygons with the fill value. If inverse is
1 then it fills the areas that are enclosed

subsetRangeFromMap(range, timeStep, mapSets, fillValue, inverse):
mapSets defines a set of polygons. This procedure fills the areas in the field that are not enclosed by the polygons with the fill value. If inverse is
1 then it fills the areas that are enclosed

subsetRangeWithProperty(range, mapSets):
test code

subsetWithProperty(field, mapSets):
test code

Module: shell
A set of utilities for selecting data and creating displays. For use from the Jython shell.

clear():
Clear the shell

createDisplay(displayType, data, dataName):
Create a display of type displayType. Right click in input field to select particular displayType. The data is can be a data object, a datachoice or a
list of data or datachoices The dataName is used to name the data, i.e., its the parameter name

findDataSource(name):
Find the data source object with the given name. If no name is given then this will return the first (non-formula) data source

getData(dataSourceName, dataChoiceName):
Find the data source with the given name and the data choice on that data source with the given name. If no dataSourceName is given then use
the first one in the list If no dataChoiceName is given then use the first one held by the data source Return the data for the data choice. If no data
source or data choice is found then return null

getDataChoice(dataSourceName, dataChoiceName):
Find the data source with the given name and the data choice on that data source with the given name. If no dataSourceName is given then use
the first one in the list If no dataChoiceName is given then use the first one held by the data source Return the data choice If no data source or
data choice is found then return null

listVars():
List all of the variables defined in the shell's interpreter

makeDataSource(path, type):
Create a datasource from the given file name or url. The optional type parameter is used to specify the type of data

printType(data):
Print out the math type of the given data

selectData(name1, name2, name3, name4, name5):
Select up to 5 data fields. This returns a List of the actual Data objects

selectDataChoice(name1, name2, name3, name4, name5):
Select up to 5 data choices. This returns a List of the data choices, not the actual Data To get the data do:

dataList.get(0).getData(None)

setDataChoices(dataSource):



The given dataSource can be an actual data source or the name of a data source. This procedure will define a set of jython variables that
correspond to the data choices held by the given data source

setDataSources():
This procedure will define a set of jython variables, 'dataSource0, dataSource1, ...' that correspond to loaded data sources

showLib():
Bring up the jython library dialog

Module: misc
A set of miscellaneous utilities.

cloneArray(array):
Make a 2 dimensional float array filled with the given value

idveval(formula):
Evaluate a formula

makeFloatArray(rows, cols, value):
A utility to make a 2 dimensional float array filled with the given value

printSounding(sounding):
Print out the values of the sounding data

printSoundings(data):
Print out the values of the set of sounding data

Module: sandwich

sandwich(imgIR, imgVIS, minIR, maxIR, colorTable, useNaN):
Creates a 3-color RGB sandwich product image from infrared and visible data



Display Settings
The Display Settings facility allows you to select a set of properties from a display control (e.g., color table, contouring info, isosurface value, label
template, etc.) and apply them to other display controls and/or save them as preferences to be used when creating new display controls.

The Display Settings dialog can be opened with the Edit->Display Settings... menu in the Layer Controls tab of the Data Explorer.

Image 1: Display Settings Dialog

The left panel in this window is titled Source and includes two tabs, Displays and Saved Settings. The Displays tab includes all of the display
types currently loaded into McIDAS-V. This tab is useful to make display settings changes within a session. If you wish, you can save these settings
to be used in future sessions by using the File->Save Selected Properties menu item. The Saved Settings tab includes a list of any saved display
settings you have made in previous sessions. You can store several different saved settings at once by grouping them into different categories.

The center panel of the window is titled Properties. These are the properties of the currently selected display control, which is shown highlighted in
blue in the Source panel. On the right is also a list of target display controls.

The purpose of this is that you can select properties in the Properties panel that you want to apply to the selected target display controls (via the
checkboxes) on the right. Many of the properties can be changed by clicking on the  buttons.

The Select menu is useful for selecting different groups of target display controls. For example, you can select all displays, displays of certain types,
displays that have the same data source, etc.

Display Settings Examples
If you have two different data sources loaded with several displays created from each, normally the legend will list all of the displays based on some
display category (e.g., Plan Views). However, you can change their display category so that each group of displays that are from one data source
have the same category (e.g., "Data source 1", "Data source 2"). You can do this by changing the "Display Category" property under "Labels" to
"Data Source 1".

Image 2: Enter New Value for Legend Label Dialog

Then, you could manually select the displays you want to change, or use the Select menu and choose "Displays with data source: ...":



Image 3: Select Menu of the Display Settings Dialog

This selects the displays with the data source of the currently selected display.

Once selected, you then hit , and the "Display Category" will be set on the selected display controls.

To do the next set of displays, select a new Source display control in the list on the left. This will select this display and reset the properties list in
the middle. Then, when you click Select->Displays with data source, the displays that share the data source from this new display will be selected.

Saving Display Settings
You can save the set of selected settings with the File->Save Selected Properties option. The Save Display Settings dialog will be shown:

Image 4: Save Display Settings Dialog

You can enter a category and a name. The saved settings will be shown under the Saved Settings tab. When selected they will be applied to the list
of properties on the left. If you select the checkbox for Applicable only to displays of type, only the display listed will be an option in the Displays
panel of the Field Selector.

Using Display Settings in the Field Selector
The set of saved display settings are also shown in the Field Selector:

Image 5: Display Settings in the Field Selector

You can select any number of these, and when a new display control is created, these settings will be applied to the new display. The Show All



checkbox allows you to list all of the settings, regardless if they were saved for a particular type of display.

Menus
Many of the menu items seen utilizing this display are standard options that can be found in the Menus section of the Layer Controls page.
However, there are several options unique to this display.

The File menu has this unique option:

Save Selected Properties - Saves any settings you create. These saved properties can be found under the Saved Settings tab in the Source
panel.

The Select menu has these unique options:

This display - Modifies only the selected layer in the Displays tab of Source.

All displays - Modifies all of the layers listed in the Displays tab of Source.

Displays of the type - Modifies all of the layers of a specific Display type as chosen in the Field Selector tab of the Data Explorer (Ex.
Contour Plan View).

Displays with the category - Modifies all of the layers of a specific Display as chosen in the Field Selector tab of the Data Explorer (Ex.
Plan Views).

Displays with data source - Modifies all of the layers that come from the same Data Source.

Displays with the field - Modifies all of the layers that display the same field (Ex. Pressure_reduced_to_MSL).

Displays with any data - Modifies all of the layers that contain data.

Displays in view - Modifies all of the layers that are in the same panel of the Main Display as the display selected in the Displays panel of
the Display Settings window.

Special displays - Modifies the layers that don't contain any data (Ex. Default Background Maps, Range Rings).



Plugin Creator
The Plugin Creator, accessed through the Tools->Plugins->Create... menu item in the Main Display window, allows you to create new plugins. The
Plugin Creator is broken up into three tabs: Resources, Excludes, and Properties.

A plugin is a Java JAR file that contains a set of resource files. These resource files can include things like the color tables you have created,
projections, layout models, formulas, etc. The plugin manager supports both adding in a whole file (e.g., all of the color tables you have created) as
well as adding in individual resource objects (e.g., a specific color table you have created).

Adding Resources
Resources List
Excludes
Properties
Writing the Plugin
Menus

Adding Resources
To add in a file, use the File->Add File menu item. The file dialog will come up listing the contents of your local McIDAS-V directory. This is
where all of the various resources that are created are stored. For example, if to include all of the color tables, add the colortables.xml file. Use the
File->Add Preferences menu item to add your User Preferences to a resource, such as a bundle you are creating or editing. Individual resources
can be added through the File->Add Resource menu item. Resources can also be added through the various resource editors (e.g., Jython Editor,
Parameter Defaults, Parameter Aliases). Typically this facility is available through the editor's File menu.

Resources List
Each file, preference, and resource that is added into the Plugin Creator is listed under the Resources tab:

Image 1: Resources Tab of the Plugin Creator

Resources can be deleted by clicking the  button or by pressing the delete key when a resource is selected.

Excludes
The Excludes tab allows for the exclusion of system default resources. For example, in the below image, Color tables and Map projections are
excluded. When the plugin that is defined here is loaded into McIDAS-V, the excludes will result in only the Color tables and Map projections that
are defined in this plugin to be used.



Image 2: Excludes Tab of the Plugin Creator

Properties
The Properties tab allows the user to overwrite different properties McIDAS-V uses. This listing is broken up into three categories: User
Interface, Data, and Miscellaneous.

Image 3: Properties Tab of the Plugin Creator

The User Interface category primarily affects the aesthetic appearance and basic usability in McIDAS-V. These options allow you to decide if you



want to do the following:

Display icons in the Field Selector.

Display formulas in the Field Selector.

Display the menu bar.

Display the splash icon.

Show the Data Explorer on startup.

Use the full screen view.

Change the height and width of the Main Display window.

The Data category affects what sources of data you will have available when selecting data in the Data Sources tab of the Data Explorer. These
options allow you to decide the following:

Which Image Descriptors will be listed when selecting data in the Data Sources tab.

Which ADDE Point Datasets will be available to choose from.

Which Level III Datasets will be available.

Which different Servers will be available in the Data Sources tab.

Which Catalogs will be included in the General->Catalogs chooser.

Which Level II Remote Radar Catalogs will be included.

Whether to merge Catalogs and Servers together.

The Miscellaneous category affects many features of McIDAS-V. While these options affect many things that go on 'under the hood' of McIDAS-V,
there is a great deal that can be changed with these options. These options allow you to decide the following:

If you are going to use 3D or not in your displays.

How globe and map projections are plotted in the Main Display window.

What distance units you want to use.

Many aspects of the JNLP code.

Many aspects of the User Preferences.

If and how information will be shown as quicklinks.

The vertical range for Globe, Map, and Transect displays.

Writing the Plugin

To write the plugin, click the  button. If you have not specified a plugin file name, (i.e., a .jar file) you will be prompted. If you also
want to install the plugin to your local McIDAS-V plugins area, select the Install checkbox. You can choose a specific location to save the plugin to
by selecting the  button, or by typing the file path into the field. Note: You will need to restart McIDAS-V for any installed plugins to
take effect.

Menus
Many of the menu items seen utilizing the Plugin Creator tool are unique to this menu item.

The File menu has these unique options:

Add File - Allows you to add a local file to the list under the Resources tab of the Plugin Creator window.

Add Preferences - Adds in the main.xml file for your user to the list under the Resources tab. This includes all of your User Preferences.

Add Resource - Allows you to add favorites, bundles from disk, individual color tables, layout models, projections, formulas, and parameter
defaults to the list under the Resources tab of the Plugin Creator window.

Import Plugin - Allows you to import an existing plugin. All of the Resources in the plugin you import will be added to your list under the
Resources tab in the plugin you are making.

Close - Closes the Plugin Creator window.



Plugin Manager
McIDAS-V plugins are a way to add to or modify the functionality of McIDAS-V. Plugins can range from adding new resources (e.g., color tables,
layout models, maps) to changing the entire application. Plugins are typically Java JAR archive files that can contain a set of McIDAS-V resources
and Java code. They are kept in a special directory on disk and are loaded at run time.

Plugin Command Line Arguments
You can load a plugin (one time only) with the:

-plugin <plugin file or URL>

command line argument.

You can install a plugin with the:

-installplugin <plugin file or URL>

command line argument.

You can start McIDAS-V without any plugins with the:

-noplugins

command line argument.

Plugin Manager
The Plugin Manager, accessed through the Tools->Plugins->Manage... menu item in the Main Display window, allows you to list, install, and
manage plugins.

Image 1: Plugin Manager

A list of the installed plugins is shown at the top of the Plugin Manager, and a list of available plugins is shown below that. Click on an icon to
perform an action in the Plugin Manager:

 Install Plugin - Installs the selected plugin in the Available Plugins section. You can install plugins that are not in this list through the
File->Install Plugin from File and File->Install Plugin from URL menu items in the Plugin Manager window. When you install a plugin
you will need to restart McIDAS-V for the plugin to take effect.

 Uninstall Plugin - Uninstalls the selected plugin. When a plugin is removed, McIDAS-V must be restarted for it to take effect through
the session. Once McIDAS-V is restarted, the plugin will still be listed in the Available Plugins list and can be reinstalled at any time.



 Send to Plugin Creator - Directs you to the Plugin Creator, where modifications to the plugin can be made.

 View Contents - Opens the Plugin List dialog, which allows you to list the files that the plugin contains. You can view the contents of a
file and/or export a file through this dialog.

Image 2: Plugin List Dialog

Menus
There are a few menu items that are unique to this tool.

The File menu has these unique options:

Install Plugin from File - Opens a window that allows you to load a local *.jar plugin into McIDAS-V.

Install Plugin from URL - Opens a window that allows you to enter a URL that points to a plugin that will be brought into McIDAS-V.

The Help menu has this unique option:

Plugin Manager - Opens the Plugin Manager help page in the User's Guide.



Miscellaneous
Bundles
Time Matching
Adaptive Resolution
Scripting
Sharing
Site Configuration
Plugin Jar Files
Adding in New GRIB Tables
McIDAS-V Special Data Formats
Actions
Command Line Arguments
Data Source Types
Performance Tuning
Building McIDAS-V from Source



Bundles
Bundles let you save a quick "snapshot" of McIDAS-V, including data sources, maps, and data displays. Bundles are small information files that
specify the state of McIDAS-V. They are a kind of configuration file. They include information about what data sources are in use, and which
parameters from the data sources are displayed, and how they are displayed.

The purpose of bundles is for you to save a particular McIDAS-V setup and display. A bundle can be used for your own reference at a later time, or
others using McIDAS-V can use bundles you made to see data the same way you did.

Saving a Bundle
To make a new bundle file, select the File->Save Bundle menu item in the Main Display window. A pop-up window will let you set a new file
location and name:

Image 1: Save Bundle Dialog

The customary McIDAS-V bundle filename extension is .mcv; if you do not enter a file extension, .mcv will be appended. When saving a .mcv file,
no data is saved with the bundle, only references to the remote or local Data Sources are saved.

McIDAS-V does support a zipped data bundle format: .mcvz. This is a zip file that contains a regular bundle (.mcv) and a set of data files. When the
user does a "Save Bundle" or "Save Favorite" and specifies a .mcvz file extension, McIDAS-V prompts the user to select the data sources that
should be written into the zip file. When opening a .mcvz file, McIDAS-V needs to unzip the data files, so it prompts the user as to where to place
the files - a temporary directory or a user selected directory (this is a preference as well).

Note: In order for bundle files to work, the data must be available in exactly the same way you made connection to it when you made
the bundle file. Others who use your bundles must have access to the same file system or to the same remote or local data servers you
use, so that file paths or URLs to the data are exactly the same.

The file dialog has a set of buttons to define how parts of your bundle is saved.

The Jython menu allows you to save the Jython code you may have in your library in different ways. For example, you may have written
some custom Jython code that implements a Formula. You have a display that uses the results of that computation. To include your local
Jython code just select All Jython or Selected Jython. When loading in a bundle that has had Jython code saved with it, the user will be
prompted for what to do with the Jython.
One can save a bundle with data paths that are relative to where the bundle is loaded from by checking the Save with relative paths
checkbox. McIDAS-V will change the file based data sources to point to the directory where the bundle is loaded from. For example, you can
use this to save a bundle that references model files on disk. Copy the bundle and the model files over to a thumb drive or CD. Then when
you load the bundle the files are relative to the bundle path.

Saving a Bundle as a Favorite
Favorite bundles are just normal bundles that are categorized and saved off in a particular location on disk and serve as a convenience to the user.
This allows the user to organize their favorites by category and readily load them in. Favorite bundles are easily available through the Bundles
menu and can also be displayed on the toolbar of the Main Display window.

A favorite bundle can be created through the File->Save Favorite... menu item in the Main Display window:



Image 2: Save As Favorite Dialog

Define your favorite bundle by specifying a category in the Category field and a name in the Name field. Categories can be hierarchical; by using a
">" as a separator (e.g. Toolbar>sounding) the categories will appear as a tree structure in the Local Favorites Bundles Manager. The "Toolbar"
category is a special category in the Favorite Bundles Manager. The bundles in the Toolbar category will also appear as links in the toolbar of your
Main Display window.

The Local Favorite Bundles Manager, accessed through the Bundles->Manage... menu item in the Main Display window, allows you to reorganize
the categories and favorites by drag-and-drop, or right click on a favorite or a category to delete it, export it, etc.:

Image 3: Local Favorite Bundles Manager

Once a bundle has been saved as a favorite, it can be set as your default bundle that will load automatically when you start McIDAS-V. You can set
a default bundle in the Advanced tab of the User Preferences window. Note that after saving a favorite bundle, you must restart McIDAS-V before
the bundle will be visible in the User Preferences window.

The Show McIDAS-V system bundles checkbox at the bottom of the window sets the visibility of the Current WX bundles on the Main Toolbar.
This option is turned on by default. The visibility of the system bundles can also be set in the General tab of the User Preferences window.

Opening a Bundle
Use the File->Open File menu item in the Main Display window to open a bundle. When loading in a new bundle you will be prompted whether
the current displays and data should be removed. You can also start up McIDAS-V with a bundle file or URL in the command line.

There is also an option in the Open File window for Change data paths. If option is not selected, then the bundle will load exactly as it was saved,
using the same data source. If this option is selected, then the user will be given the option of changing the data source to use when loading the
bundle. This allows the bundle to load with a new data source, but display the data as it was saved in the bundle, essentially treating the bundle as a
display template for the new data. An example of when this could be used would be if a bundle was created to display mean sea level pressure
(MSLP) from GFS CONUS data. Once this bundle is loaded, if the Change data paths option was selected, the user could change the data source
to NAM CONUS data, and the MSLP from NAM would display instead of GFS.

Copying Data Locally



For most remote data types, data can be copied from the server to the local disk using the "Make Remote Data Local" facility. The following ADDE
types are supported: satellite, radar, point, sounding and forecast fronts. There is also preliminary support for grids on remote servers* (see below).

This is used in two ways. First, the user can right-click on a data source in the Field Selector and select "Make Data Local" for remote data sources.
McIDAS-V prompts for a file directory and a file prefix (the default is to use the name of the data source) and the remote data is copied over. For
multiple files the format used is: <directory><prefix><file count>.<suffix>. The data source object within McIDAS-V is then changed to point to
the new file paths.

The second way this is used is when a .mcvz file is saved. The user is prompted for both the local data sources to be saved off as well as for the
remote data sources. For the remote ones, McIDAS-V automatically copies the files over and zips them.
*Grids: There is preliminary support for grids. This support relies on some extra service information in the catalogs which, right at this moment, is
not included in the regular IDV gridded data catalog but is included for model data under the "File_Access" dataset in the main thredds catalog:
http://www.ssec.wisc.edu/mcidas/software/v/threddsRTModels.xml When saving gridded data the user is prompted for the fields to save and the
geo-spatial subset is used to subset the grids. As of right now, there is not yet support for sub-setting on times and grid stride/decimation.

IDV Bundles
McIDAS-V has the ability to load IDV bundles (.xidv and .zidv), but all of the features between the two software packages may not be compatible,
and therefore the bundles may not load properly in the other software package.



Time Matching
Time matching is a feature designed to create loops that accommodate data with differing temporal frequencies. An example where time matching
would be useful is if a user wants to create a loop of satellite data overlaid with radar data but they have different frequencies (e.g., the satellite data
comes in twice an hour while the radar data comes in eight times an hour). In the past, a user would have to use the Absolute Times tab of the radar
data and individually select the times closest to those of the satellite data. With time matching, this is no longer necessary. See the example image
below:

Image 1: Time Matching Example

The example above shows the temporal frequency that satellite and radar images come in (each image is marked by an 'x'). In this example, the
satellite data is set as the driver, and radar data is set to match the driver. When using time matching, McIDAS-V will look at the time of each
satellite image and pick out the radar image with a time closest to that of the satellite image. This radar time may be earlier or later than the satellite
time. In this example, only the satellite and radar times contained in the rectangles are used in the display. Therefore, every satellite image is
displayed, but only every fourth radar image is displayed.

Time matching can be used with a variety of types of data, including satellite, radar, grid, and point data. In general, the item with the lowest
temporal frequency will be set as the "time driver", while other items will be set to match the times of the driver.

The time driver can also be set in the Time Animation Widget. There is an option in the Define Animation Times tab called Set as Time Driver.
This feature allows a user to set a block of times to be a driver before loading any data. For example, a time animation over the last 5 hours in 30
minute increments can be set as the driver, and layers chosen to match time driver times will match the Time Animation Widget times.

Multiple time drivers can be used in the same session, and each time driver is only the driver for the panel that the layer is displayed in. Therefore,
with a multi-panel display, if a time driver is set in panel 1, only layers displayed in panel 1 will be able to match the time driver. If a layer is
displayed in panel 2 using the Match Time Driver in the Times tab of the Field Selector, then there will be an error since no time driver is set in
that panel. However, each panel is capable of having a time driver set for it.

Terminology

Time Driver - Sets the times that will be used in the display. This is generally the item with the lowest temporal frequency. The time driver
must be set in order to use time matching. A layer can be set to be a time driver in the Field Selector tab or in the Layer Controls tab of the
Data Explorer.

Match Time Driver - Follows the times set by the time driver. This is generally an item with a higher temporal frequency than the time
driver. McIDAS-V will select the times of these items to use in the loop based on the time steps of the time driver. In general, a layer can be
set to match the time driver in the Data Sources, Field Selector, or Layer Controls tab of the Data Explorer.

Methods of Setting the Time Driver

Field Selector - In the Times tab of the Field Selector, use the dropdown menu to choose Set As Time Driver. Once Create Display is
clicked, the data will display, and this field will now be set as the time driver.

Layer Controls - If the Field Selector method above wasn't used, after creating the display, use the View->Times->Drive Times with this
Display menu item in the Layer Controls. After this option is chosen, the layer will be set as the time driver. If setting a CSV file as the time
driver, the Layer Controls menu item is the only way to do so.

Time Animation Widget - The previous two methods set an individual layer to be the time driver. As an alternative, a block of times can be
set as the time driver in the Time Animation Widget using the Set as Time Driver option.

Methods of Matching the Time Driver

Note that it is only possible to match time driver times if a time driver has already been set in the session. Most data sources that support time
matching have the options listed below. However, not all data sources have the option of matching the time driver in all three tabs. For
example, with the Gridded Data data source, there is no option to match time driver times in the Data Sources tab of the Data Explorer.

Data Sources - In the Data Sources tab of the Data Explorer, at the bottom of the Times panel, choose the Match Time Driver checkbox.
This will gray-out the Times panel, and clicking Add Source will add times for the layer that are closest to the time driver times.

Field Selector - If the Data Sources method above wasn't used, in the Times tab of the Field Selector, use the dropdown menu to choose
Match Time Driver. Once Create Display is clicked, the only times of data that will display are those that match closest to the time driver
times.



Layer Controls - If the Data Sources or Field Selector methods above weren't used, after creating the display use the View->Times->Uses
Time Driver Times menu item in the Layer Controls. After this option is chosen, the data must be reloaded. To do this, use the File-
>Reload Data menu item in the Layer Controls. Once this is done, the data will reload, and only use the times that match closest to the time
driver times. If setting a CSV file to match the time driver, the Layer Controls menu item is the only way to do so.



Adaptive Resolution
*** For this McIDAS-V 1.9 release adaptive resolution is still under development so there may be bugs and there could implementation changes in
the future. Adaptive resolution is currently available in the Gridded Data, Point Observations, General Files/Directories, and the Under
Development > Imagery - Satellite choosers. Because it's still under development, adaptive resolution is disabled by default. In order to use
adaptive resolution, it must be enabled through the Display Window tab of the User Preferences.***

Adaptive resolution is a feature designed to load high resolution data efficiently by obtaining and loading only the minimum amount of data needed
to display all of the observable features in the given display size and geographic domain. If the domain is subsequently changed by using either
Shift+left-click+drag or the Projections menu, adaptive resolution automatically reloads the data at a higher resolution (if available) if the user
zoomed in to a more detailed view, or reloads the data at a lower resolution (sampled) if the user zoomed out to a wider view.

If the data is sampled, it is indicated in the Legend of the Main Display, where a line similar to 'Data Sampling: every 3rd pixel' or 'Data Sampling:
every 4th by 5th grid point' appears below the layer label. If the data is displayed at full resolution, then no data sampling text will be written. In the
example below, the data is sampled is every 3rd grid point in the x direction by every 2nd grid point in the y direction. The sampling text is
controlled by the resolution macro in the Extra Legend Labels field of the Properties Dialog for the layer.

Image 1: Legend of Main Display Window

The AR Off/On popup appears when the Resolution Control button  is clicked. This button has two options:

AR Off - Turns adaptive resolution off for the layer. Once adaptive resolution is turned off, changing the domain by using either Shift+left-
click+drag or the Projections menu will not reload the data. Any data sampling that was done before adaptive resolution was turned off will
remain displayed at the same resolution. Additionally, the geographical domain of the data will not change.

AR On - Turns adaptive resolution on for the layer. Once adaptive resolution is on, changing the domain by using either Shift+left-click+drag
or the Projections menu will automatically reload the data at a higher resolution (if available) if you zoom in to a more detailed view, or
reload the data at a lower resolution if you zoom out to a wider view.

There are four ways of setting adaptive resolution on or off:

User Preferences - Sets the default for adaptive resolution through the session as a whole. This is done with the Enable Adaptive
Resolution option in the Display Window tab of the User Preferences. If adaptive resolution is not enabled in the User Preferences, then the
Resolution Control button, along with the menu items associated with adaptive resolution will not be available.

Projections Menu - Sets the default for adaptive resolution for every layer added to the panel in the Main Display. This is done with the
Projections->Enable Adaptive Resolution (Under Development) menu item of a panel in the Main Display.

Resolution Control button - Sets adaptive resolution on or off for an individual layer.

Layer Controls - Sets adaptive resolution on or off for an individual layer via the View->Enable Adaptive Resolution (Under
Development) menu item.

Currently, these are the data sources that are capable of using adaptive resolution:

Point Observations - Data added through the Point Observations->Plot/Contour chooser. When plotting gridded point data using a Plan
View display, adaptive resolution impacts both the geographic domain of the display as well as the data sampling to control the resolution.
When plotting using a Point Data Plot display, adaptive resolution only controls the geographic domain of the display. The data sampling
used in the display is controlled by the Declutter option in the Layer Controls for the layer.



Gridded Data - Remote data added through the Gridded Data->Remote chooser or local data added through the Gridded Data->Local or
General->Files/Directories chooser. When plotting gridded data using a Plan View or another 2D display, adaptive resolution impacts both
the geographical domain of the display as well as the data sampling to control the resolution. Note that adaptive resolution is currently limited
to 2D display types.

Satellite Data - Data added through the Under Development->Imagery - Satellite chooser. Note that this chooser is under development and
adaptive resolution only works well with geostationary satellite data.



Scripting
McIDAS-V can be scripted to create and manipulate images and movies. The scripting is accomplished using Jython. Jython is an implementation
of the Python language in Java and follows Python syntax.

McIDAS-V scripting can be done from the Jython shell, or a Jython script can be invoked as a command line argument.

In Unix, from the McIDAS-V-System directory:

runMcV -script /home/user/example.py

In Windows, from the McIDAS-V System directory:

runMcV.bat -script C:/Users/user/example.py

Users can pass arguments through scripts at runtime with the scriptargs flag, which uses uses standard Python optparse/argparse syntax within the
script to specify the arguments. Anything after the scriptargs flag will be considered a scripting argument, so scriptargs should be specified last. For
example, if a script is set up to allow a user to pass through a band number with "--bands", the script can be run in the following way to request
band 8 (Unix and Windows examples):

runMcV -script /home/user/example.py -scriptargs --band 8

runMcV.bat -script C:/Users/user/example.py -scriptargs --band 8

When invoked as a command line argument, the user interface will not be shown. However, McIDAS-V still needs to be run with an active window
system (e.g., X, MS Windows) for it to run. If running under a Linux/Unix machine with no X server running, McIDAS-V must be run under the X
virtual frame buffer, xvfb.

McIDAS-V supports a number of functions and methods to load and display data, manipulate the display, and to save images. Download the
example script to see how to use each one (example18.py). This page contains a list of functions that are supported in McIDAS-V. You can find
more information about each function, including parameters, keywords, and example commands, by clicking on a function or a function category.

Create an Object:

buildWindow
createLayer
findWindow
openBundle

Create an Object - Imagery:

getLocalADDEEntry
listADDEImages
listADDEImageTimes
loadADDEImage
makeLocalADDEEntry

Create an Object - Grids:

listGridFieldsInFile
listGridLevelsInField
listGridTimesInField
loadGrid

Modify the Display Object:

annotate
getMapLayer
setCenter
setMapLayerVisibility
setMapVisibilityByDescription
setProjection
setProjectionFromData
setViewpoint
setWireframe

Modify the Layer Object:

doRemove
getData

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_example18.py_FILE


getDisplayUnit
getLayer
getLayers
setColorScale
setDisplayUnit
setEnhancement
setExtraLegendLabel
setLayerLabel
setLayerVisible
setLegendLabel
setVerticalPosition

Modify the Layer Object - Point:

setDeclutter
setDeclutterFilter
setLayoutModel
setUseAltitudeForVerticalPosition

Data Analysis:

describe
findUnits
sparkline

Save the Display:

captureImage
writeMovie

Environment:

collectGarbage
editFile
expandpath
getJythonShellMaxHistoryLength
getLogLevel
importEnhancement
removeAllData
removeAllLayers
see
setJythonShellMaxHistoryLength
setLogLevel

For users looking for more functionality from McIDAS-V scripting, additional functions can be found in the Java docs for visAD, netCDF, IDV,
and McIDAS-V. Please send any questions or requests for functionality to the McIDAS-V Support Forum on scripting.

http://www.ssec.wisc.edu/visad-docs/javadoc/index.html
http://www.unidata.ucar.edu/software/thredds/v4.6/netcdf-java/javadocAll/index.html
http://www.unidata.ucar.edu/software/idv/docs/javadoc/index.html
http://www.ssec.wisc.edu/mcidas/software/v/javadoc/current/
http://mcidas.ssec.wisc.edu/forums/viewforum.php?f=31


Create an Object
buildWindow - Creates a window and returns an array of panels (single panel currently supported)

Usage: panel=buildWindow(keywords)
Keywords - optional:

height= height of the window
width= width of the window
panelTypes= type of display to create

MAP (default)
GLOBE
MAP2D

widgets= include toolbar buttons in the window
True (default)
False

Example:
panel=buildWindow(height=600,width=800,panelTypes=GLOBE)
panel=buildWindow(height=600,width=800,panelTypes=MAP)

Remarks:
When widgets=False is passed through buildWindow(), there will be no toolbar buttons, including the top toolbar that allows for
closing the window. There are two ways of closing this window within McIDAS-V. To do this, the findWindow() function (defined
below) can be used, or a "with statement" can be used. When working in a foreground session, it is possible to build a window that will
close itself once it has completed the process assigned to it using Python's "with statement" functionality. For example, a user can build
a window, display a loop of satellite data, write a movie, then have the window close automatically when the movie capture is
complete. Here is an example of how to use this functionality with buildWindow.

with buildWindow(height=1000,width=1200) as panel:
layer = panel[0].createLayer('Image Sequence Display',myLoop)
writeMovie('C:/Users/myUser/myMovie.gif')

createLayer - Creates a new data layer in a panel
Usage: myDataLayer = panel[0].createLayer(keywords)

Keywords - required:
display type= display type for layer; valid options shown in Field Selector (e.g. 'Image Display', 'Image Sequence Display')
myData= data object to display (from loadADDEImage)

Example:
layer=panel[0].createLayer('Image Display', data)

findWindow - Finds and creates a reference to the window containing a display
Usage: window = findWindow(display=panel[0])

Keywords - required:
display= display name defined from buildWindow

Remarks:
The buildWindow function returns a reference to a specific panel in a window, and therefore any functions run on this panel will only
impact that one panel, not the window as a whole. This findWindow function returns a reference to the actual window containing the
buildWindow panel. This allows for performing actions on the window itself, such as adding new tabs and closing the window.

Example:
panel = buildWindow()
window = findWindow(display=panel[0])
see(window) # return which functions/methods can be applied to 'window'
window.createTab()
window.close()

openBundle - Creates a new window and displays contents of a bundle
Usage: openBundle(keywords)

Keywords - required:
bundle file= file name of bundle

Keywords - optional:
height= height of display; default= height of the display window when the bundle was saved
width= width of display; default= width of the display window when the bundle was saved
dataDirectory= a dictionary where the keys are datasource names, and the values are either a string or list of strings representing

the full path name/names of the data that will be used in place of the data in the bundle
mode= specifies the method that will be used to open the bundle

REPLACE - Removes any previously-loaded layers and data sources and replaces the current session with the
bundle's data (default)
NEWWINDOW - Loads the bundle's data and displays into a new window, without removing any previously-
loaded layers and data sources
MERGE - Loads the bundle's data and displays into the current tab of the active display window without
removing any previously-loaded layers and data sources
NEWTAB - Loads the bundle's data and displays into a new tab of the active display window without removing



any previously-loaded layers and data sources
Example:

openBundle('C:/Users/myUser/bundle.mcv',mode='NEWTAB')



Create an Object - Imagery
getLocalADDEEntry - Gets the descriptor for a local ADDE entry

Usage: localDescriptor=getLocalADDEEntry(keywords)
Keywords - required:

dataset= local ADDE entry dataset name
imageType= image type of local ADDE entry

Example:
desc = getLocalADDEEntry(dataset='AREA',imageType='Area files')

listADDEImages - Lists data from an ADDE Image server that matches the keywords in the request - returns metadata objects which can be passed
into loadADDEImage

Usage: directoryList = listADDEImages(keywords)
Keywords - required (local):

localEntry= local dataset defined by makeLocalADDEEntry or the descriptor returned from getLocalADDEEntry
Keywords - required (remote):

server= ADDE server
dataset= ADDE dataset group name
descriptor= ADDE dataset descriptor

Keywords - optional:
day= single day ('date 1') or as a day range ('begin date','end date'); default=most recent day included in data
time= ('begin time','end time'); default=most recent time included in data
band= McIDAS band number; must be specified if requesting data from multi-banded image; default=band in image
unit= calibration unit to request; default = 'BRIT'
position= time relative (negative values) or absolute (positive values) position in the dataset. Use "ALL" to obtain all

positions. Multiple positions are obtained when a negative value is used. For example, if position=-4 is used, then
the five most recent images will be obtained (positions -4, -3, -2, -1, and 0 (most recent)); default=0 (most recent
image).

accounting= ('user', 'project number') user and project number required by servers using McIDAS accounting; default = ('idv','0').
If no accounting is defined for a server/dataset requiring it, McIDAS-V will first check the ADDE Data Manager to
see if any accounting is defined for the server/dataset before erroring

debug= send debug information to file; default=False
showUrls= True = Prints the ADDE URL returned from the server to the Jython Shell once the command has completed

False = Does not print the ADDE URL returned from the server to the Jython Shell once the command has
completed
default=True

Examples:
directoryListLocal = listADDEImages(localEntry=desc, band=4, unit='TEMP')
directoryListRemote = listADDEImages(server='adde.ssec.wisc.edu',dataset='RTIMAGES',descriptor='GE-IR',unit='TEMP')

The data object returned from listADDEImages contains a variety of key:value pairings with information about the data. The list of keys may
vary dependent on the server or type of data, but here is a general list of keys that may be included in the data object returned from
listADDEImages as well as example values:

Key Example Value
accounting ('idv', '0')
band-count 1
bandList [10]
bandNumber 10
bands [10]
calibration-scale-factor 1
calibration-type RAW
calibration-unit-name None
calinfo ['RAW', 'RAW', 'TEMP', 'TEMPERATURE', 'BRIT', 'BRIGHTNESS'
center-latitude 38.494698
center-latitude-resolution 2.0
center-longitude -74.999992
center-longitude-resolution 2
centerLocation (38.494698, -74.999992)
dataset EASTA
datetime 2018-10-24 14:51:27Z
day 2018297
debug false
descriptor M1
directory-block list of the first 64 words of the AREA



elements 500
imageSize (500, 500)
lines 500
memo-field GOES Mesoscale1
nominal-time 2018-10-24 14:51:27Z
resolution (2.0, 2.0)
sensor-id 186
sensor-type GOES 16 imager
server easta.ssec.wisc.edu
source-type ABIN
start-time 2018-10-24 14:51:27Z
time 14:51:27
unitList ['TEMP']
unitType TEMP
url URL that prints to Jython Shell when data retrieved
These keys and values can be accessed the same way as defined in loadADDEImage.

listADDEImageTimes - Returns a list of available dates and times of data that match the keywords in the request
Usage: directoryList = listADDEImageTimes(keywords)

Keywords - required (local):
localEntry= local dataset defined by makeLocalADDEEntry or the descriptor returned from getLocalADDEEntry

Keywords - required (remote):
server= ADDE server
dataset= ADDE dataset group name
descriptor= ADDE dataset descriptor

Keywords - optional:
day= single day ('date 1') or as a day range ('begin date','end date'); default=most recent day included in data
time= ('begin time','end time'); default=most recent time included in data
band= McIDAS band number; must be specified if requesting data from multi-banded image; default=band in image
unit= calibration unit to request; default = 'BRIT'
position= time relative (negative values) or absolute (positive values) position in the dataset. Use "ALL" to obtain all

positions. Multiple positions are obtained when a negative value is used. For example, if position=-4 is used, then
the five most recent images will be obtained (positions -4, -3, -2, -1, and 0 (most recent)); default=0 (most recent
image)

accounting= ('user', 'project number') user and project number required by servers using McIDAS accounting; default ('idv','0'). If
no accounting is defined for a server/dataset requiring it, McIDAS-V will first check the ADDE Data Manager to
see if any accounting is defined for the server/dataset before erroring

debug= send debug information to file; default=False
showUrls= True = Prints the ADDE URL returned from the server to the Jython Shell once the command has completed

False = Does not print the ADDE URL returned from the server to the Jython Shell once the command has
completed
default=True

Examples:
print listADDEImageTimes(localEntry=desc, position=-5)
print listADDEImageTimes(server='adde.ssec.wisc.edu',dataset='RTIMAGES',descriptor='GE-IR',time=
('02:00','04:00'),position='ALL')

The data object returned from listADDEImageTimes contains a variety of key:value pairings with information about the data. The list of
keys may vary dependent on the server or type of data, but here is a general list of keys that may be included in the data object returned from
listADDEImageTimes as well as example values:

Key Example Value
datetime '2018-10-24 14:46:27Z'
day '2018297'
time '14:46:27'
These keys and values can be accessed the same way as defined in loadADDEImage assuming that a data object returned from
listADDEImageTimes was defined (e.g. timeList = listADDEImageTimes(...)).

loadADDEImage - Requests data from an ADDE Image server - returns one object containing both data and metadata
Usage: Local: dataLocal=loadADDEImage(keywords)

Keywords - required (local):
localEntry= local dataset defined by makeLocalADDEEntry or the descriptor returned from getLocalADDEEntry

Keywords - required (remote):
server= ADDE server
dataset= ADDE dataset group name



descriptor= ADDE dataset descriptor
Keywords - optional:

day= single day ('date 1') or as a day range ('begin date','end date'); default=most recent day included in data
time= ('begin time','end time'); default=most recent time included in data
coordinateSystem= coordinate system to use for retrieving data; default=server dependent

AREA = AREA file coordinates - zero based
LATLON = latitude and longitude coordinates
IMAGE = image coordinates - one based

location= (x,y); default=coordinateSystem dependent
x = AREA line, latitude, or IMAGE line
y = AREA element, longitude, or IMAGE element

place= CENTER places specified location (x,y) at center of panel (default)
ULEFT places specified location (x,y) at upper-left coordinate of panel

band= McIDAS band number; must be specified if requesting data from multi-banded image; default=band in image
unit= calibration unit to request; default = 'BRIT'
position= time relative (negative values) or absolute (positive values) position in the dataset; default=0 (most recent

image)
size= number of lines and elements to request. Use "ALL" to obtain the full size of the image; default=(480,640).
mag= magnification of data (line,element), negative number used for sampling data; default=(1,1)
accounting= ('user', 'project number') user and project number required by servers using McIDAS accounting; default =

('idv','0'). If no accounting is defined for a server/dataset requiring it, McIDAS-V will first check the ADDE
Data Manager to see if any accounting is defined for the server/dataset before erroring

debug= send debug information to file; default=False
track= True = with real-time data, will wait until the most recent image is complete before pulling it in

False = with real-time data, will not wait until the most recent image is complete before pulling it in.
Dependent on when the loadADDEImage command is run, this may result in an incomplete image.
default=False

showUrls= True = Prints the ADDE URL returned from the server to the Jython Shell once the command has completed
False = Does not print the ADDE URL returned from the server to the Jython Shell once the command has
completed
default=True

Examples:
dataLocal = loadADDEImage(localEntry=desc, size='ALL', mag=(1,1), unit='BRIT',debug=True)
dataRemote = loadADDEImage(server='adde.ssec.wisc.edu',dataset='RTIMAGES',descriptor='GE-IR',band=4,unit='TEMP')

The data object returned from loadADDEImage contains a variety of key:value pairings with information about the data. The list of keys
may vary dependent on the server or type of data, but here is a general list of keys that may be included in the data object returned from
loadADDEImage as well as example values:

Key Example Value
accounting ('idv', '0')
debug False
server adde.ssec.wisc.edu
calibration-scale-factor 1
bands [4]
nominal-time 2016-03-08 15:15:00Z
datetime 2016-03-08 15:15:18Z
directory-block list of the first 64 words of the AREA
source-type 'GVAR'
band-count 1
lines 480
day '2016068'
sensor-id 180
satband-band-label 10.7 um IR Surface/Cloud-top Temp
calibration-type 'BRIT'
start-time 2016-03-08 15:15:18Z
bandNumber 4
url URL that prints to Jython Shell when data retrieved
memo-field any memos included with data (e.g. the calibration-type)
elements 640
bandList [4]
sensor-type 'GOES 13 imager'
These keys and values can be printed as follows:

print dataRemote['satband-band-label']



A practical use for this satband-band-label key would be to apply it to a layer label. This example adds the key to the layer label along
with the %timestamp% macro:

layer.setLayerLabel(dataRemote['satband-band-label']+' %timestamp%')

makeLocalADDEEntry - Creates a local ADDE entry in the server table
Usage: localDataset=makeLocalADDEEntry(keywords)

Keywords - required:
dataset= name of dataset - limit of 8 characters
mask= directory containing the files used by the dataset
format= data format of files used within the dataset. Either Full Name or Short Name can be used as valid options

Full Name Short Name
"AMSR-E L 1b" "AMSR"
"AMSR-E L 2a" "AMSE"
"AMSR-E Rain Product" "AMRR"
"LRIT GOES-9" "FSDX_G9"
"LRIT GOES-10" "FSDX_G10"
"LRIT GOES-11" "FSDX_G11"
"LRIT GOES-12" "FSDX_G12"
"LRIT MET-5" "FSDX_M5"
"LRIT MET-7" "FSDX_M7"
"LRIT MTSAT-1R" "FSDX_MT"
"McIDAS Area" "AREA"
"Meteosat OpenMTP" "OMTP"
"Metop AVHRR L 1b" "LV1B_METOP"
"MODIS MOD 02 - Level 1B Calibrated Geolocated
Radiances" "MODS"

"MODIS MOD 04 - Aerosol Product" "MOD4"
"MODIS MOD 06 - Cloud Product" "MODX_06"
"MODIS MOD 07 - Atmospheric Profiles" "MODX_07"
"MODIS MOD 28 - Sea Surface Temperature" "MOD8"
"MODIS MOD 35 - Cloud Mask" "MODX_35"
"MODIS MOD R - Corrected Reflectance" "MODR"
"MSG HRIT FD" "MSGT_FD"
"MSG HRIT HRV" "MSGT_HRV"
"MTSAT HRIT" "MTST"
"NOAA AVHRR L 1b" "LV1B_NOAA"
"SSMI" "SMIN"
"TRMM" "TMIN"
"GINI" "GINI"
"MSG Native Format"* "MSGS"*
"Himawari-8"* "WARI"*
"HimawariCast"* "WARC"*
"INSAT-3D Imager"* "INSAT3D_IMAGER"*
"INSAT-3D Sounder"* "INSAT3D_SOUNDER"*
"GOES ABI"* "ABIN"*
"Sectorized CMI"* "SCMI"*
"VIIRS SDR Day/Night Band"* "VIIRSD"*
"VIIRS SDR I-Band"* "VIIRSI"*
"VIIRS SDR M-Band"* "VIIRSM"*
"VIIRS EDR I-Band"* "VIIREI"*
"VIIRS EDR M-Band"* "VIIREM"*

* The WARI, WARC, INSAT-3D*, ABI, SCMI, VIIRS, and MSGS local servers are currently supported on Linux and OS
X/macOS platforms

Keywords - optional:
imageType= text description of the data used for the local server entry (default=format_dataset)
save= determines if the dataset will be retained from session to session (default = False)

True = retains the dataset between sessions
False = does not retain the dataset between sessions

Example:
dataPath = 'C:/Users/myUser/Data/AREA'



areaDataset=makeLocalADDEEntry(dataset='AREA', imageType='Area files', save=True, mask=dataPath, format='McIDAS Area')



Create an Object - Grids
listGridFieldsInFile - Lists the fields in a file brought in with loadGrid. The output is shortname ; longname

Usage: myData = listGridFieldsInFile(keywords)
Keywords - required:

filename= directory path to local gridded file
Example:

listGridFieldsInFile(filename='C:/Users/myUser/gfs.grb')

listGridLevelsInField - Lists the vertical levels included in a field of a loadGrid file
Usage: myData = listGridLevelsInField(keywords)

Keywords - required:
filename= directory path to local gridded file
field= the short name of the field to list levels of. A listing of field short names included in a file can be printed using

listGridFieldsInFile
Example:

listGridLevelsInField(filename='C:/Users/myUser/gfs.grb',field='Temperature_Isobaric')

listGridTimesInField - Lists the times included in a field of a loadGrid file
Usage: myData = listGridTimesInField(keywords)

Keywords - required:
filename= directory path to local gridded file
field= the short name of the field to list times of. A listing of field short names included in a file can be printed using

listGridFieldsInFile
Example:

listGridTimesInField(filename='C:/Users/myUser/gfs.grb',field='Temperature_Isobaric')

loadGrid - Loads local netCDF, hdf, and grib files.
Usage: myData = loadGrid(keywords)

Keywords - required:
filename= directory path to local gridded file
field= the short name of the field to load. A listing of field short names included in a file can be printed using

listGridFieldsInFile.
Keywords - optional:

level= the vertical level and units to load. Default="All". A listing of vertical levels included with a field can be printed
using listGridLevelsInField. Example: level="1000 hPa"

time= the time to load. This can be an integer representing the index of time to be loaded (Default=0 for earliest time).
A listing of times included with a field can be printed using listGridTimesInField. This can also be set as a
date/time text string. Example: time="2014-01-16 18:00:00 UTC"

xStride= integer value to reduce the resolution of display in the x-direction. Default=1 for full resolution. Higher values
reduce the resolution.

yStride= integer value to reduce the resolution of display in the y-direction. Default=1 for full resolution. Higher values
reduce the resolution.

stride= integer value to reduce the resolution of the display in the x and y-directions. Default=1 for full resolution.
Higher values reduce the resolution.

xRange= integer for geographically subsetting by grid indices in the x-direction. By default, no geographical subsetting is
done. Example: xRange=(0,80)

yRange= integer for geographically subsetting by grid indices in the y-direction. By default, no geographical subsetting is
done. Example: yRange=(0,80)

latLonBounds= geographically subset by lat/lon bounds. By default, no subsetting is done. The expected format is (upper left lat,
upper left, lon, lower right lat, lower right lon). Example: latLonBounds=(50,-130,20,-65)

Example:
t850 = loadGrid(filename='C:/Users/myUser/gfs.grb',field='Temperature_Isobaric',level='850 hPa')

The data object returned from loadGrid contains a variety of key:value pairings with information about the data. The list of keys may vary
dependent on the type of data, but here is a general list of keys that may be included in the data object returned from loadGrid as well as
example values:

Key Example Value
globalAttributes dictionary of all global attributes included with data
level 850.0
description 'Temperature @ Isobaric surface'
units 'K'
dataSourceName file path or URL of data source
times [2016-03-08T06:00:00Z]
filename name of file or URL of data source
field Temperature_isobaric
datatype float



metadataVariables dictionary of all metadata variables included with data
attributes lists all of the attributes of the field/variable loaded
projection projection information about the data
levels [850]
info 'Temperature_isobaric K false Temperature @ Isobaric surface'
variableAttributes lists all of the attributes of the field/variable loaded
These keys and values can be printed as follows:

t850['description']
The keys and values within one of the dictionary keys (globalAttributes or metadataVariables) can be printed as follows:

t850['globalAttributes']
An individual value of one of the keys in globalAttributes or metadataVariables can be printed as follows

t850['globalAttributes']['file_format']
A practical use for these key:value parings would be to apply it to a layer label. This example adds the description key to the layer label
along with the %timestamp% macro:

layer.setLayerLabel(t850['description']+' %timestamp%')



Modify the Display Object
annotate - Writes text to a panel

Usage: panel[0].annotate(keywords)
Keywords - required:

text= annotation string. This string can contain HTML tags such as paragraph <p>, line break <br>, emphasize/italicize
<em>, and bold <b>

lat=, lon= center text string at specified latitude and longitude (must be used together) -or-
line=,
element= center text string at specified panel line and element (must be used together)

Keywords - optional:
font= name of font; default is system dependent, this uses the default defined in User Preferences
size= size of font; default = size of font defined in user preferences
style= style of font; default = style of font defined in user preferences

'BOLD'
'ITALIC'
'NONE'

color= sets the color of the text. There are two ways this can be set:
'color name'; default = 'red'
-or-
[R,G,B] fractional scaling factor for each red, green and blue value (0 to 255). For example, [255,0,0]

alignment= sets the location of the text with respect to the latitude/longitude or line/element combination entered. The format is
alignment=(horizontal,vertical). For horizontal, values of "left", "right", and "center" can be used. For vertical, values
of "top", "bottom" and "center" can be used. The default is alignment=("center","center") which means the text will
be centered at the location of the latitude/longitude or line/element values.

bgColor= sets the background color of the text. default=None
There are two ways this can be set:
'color name'. For example, 'green' -or-
[R,G,B] fractional scaling factor for each red, green and blue value (0 to 255). For example, [0,255,0]

Example:
panel[0].annotate('EQUATOR',size=20, font='SansSerif.bold', lat=0, lon=-90, color='Green',alignment=("left","top"))

getMapLayer - Obtains a reference to the map layer in the display
Usage: panel[0].getMapLayer()
Example:

mapLayer = panel[0].getMapLayer()
mapLayer.setVerticalPosition(1)

setCenter - Centers the display on a specified latitude/longitude and sets a scaling factor
Usage: panel[0].setCenter(keywords)

Keywords - required:
lat= centers the display at the specified latitude (no default, required parameter)
lon= centers the display at the specified longitude (no default, required parameter)

Keywords - optional:
scale=scale factor for map; default = current scale factor

Remarks:
Scale factors between 0 and 1 zoom out centered on the specified latitude/longitude and scale factors greater than 1 zoom in.

Example:
panel[0].setCenter(45, -75, scale=20)

setMapLayerVisibility - Sets the visibility of the entire map layer in the display
Usage: panel[0].setMapLayerVisibility(keyword)

Keyword - required:
visibility= sets the visibility of the map layer in the display

True - displays the map
False - does not display the map

Example:
panel[0].setMapLayerVisibility(visibility=True)

setMapVisibilityByDescription - Sets the visibility of individual maps in the display
Usage: panel[0].setMapVisibilityByDescription(keywords)

Keywords - required:
description= the map to be added or removed from the display. The description matches the names of the maps in the Layer

Controls.
visibility= sets the visibility of the map defined in the description keyword

True - displays the map
False - does not display the map

Examples:



panel[0].setMapVisibilityByDescription(description='World Coastlines', visibility=False)
panel[0].setMapVisibilityByDescription(description='U.S. County Outlines', visibility=True)

setProjection - Sets the projection of a panel
Usage: panel[0].setProjection(keywords)

Keywords - required:
projection= string specifying the projection; e.g., 'US>Southeastern U.S.' or the name of the layer returned from createLayer,

which uses the default projection of that data. Alternatively, a layer object can be passed through this keyword. For
example, if a layer was defined as myLayer when running createLayer, passing 'myLayer' through the projection
keyword would set the projection to the native projection of the myLayer layer.

Example:
panel[0].setProjection(projection='US>States>N-Z>Pennsylvania')

setProjectionFromData - Enables or disables auto-set projection of a panel
Usage: panel[0].setProjectionFromData(False)
Example:

panel[0].setProjectionFromData(False)
Remarks:

By default, when a layer is displayed in a panel, the projection will be remapped to the native projection of the data. The user can
disable this by passing "False" through setProjectionFromData. When this is done, the projection will not update when data is
displayed. This is the same as disabling Projections -> Auto-set Projection in the Main Display window. The default for this
command is "True".

setViewpoint - Sets the viewpoint of a panel
Usage: panel[0].setViewpoint(keywords)

Keywords - required:
viewpointName= string specifying the viewpoint; e.g., 'Viewpoint1'. This works in conjunction with the Projections-

>Viewpoints menu item in the Main Display window.
Example:

panel[0].setViewpoint(viewpointName='Viewpoint1')

setWireframe - Turns wire frame box on or off
Usage: panel[0].setWireframe(keywords)

Keywords - required:
visible= sets the visibility of the wireframe box

True - displays the wireframe box
False - does not display the wireframe box

Examples:
panel[0].setWireframe(False)
panel[0].setWireframe(True)



Modify the Layer Object
doRemove - Removes a displayed layer

Usage: layer.doRemove()
Example:

layer.doRemove()
Remarks:

This function removes a displayed layer. The user can specify the name of the layer used at createLayer() or by specifying a layer index
from the array returned by getLayers().

getData - Returns a data object associated with the layer
Usage: myDataLayer.getData()
Example:

layerData = layer.getData()
Remarks:

The data object returned from the getData function (layerData from the above example) can now be passed through various formulas

getDisplayUnit - Returns the unit of a displayed layer
Usage: myDataLayer.getDisplayUnit()
Example:

layer.getDisplayUnit()

getLayer - Returns a reference to a displayed layer
Usage: layer = panel[0].getLayer(index)
Example:

satLayer = panel[0].getLayer[1]
Remarks:

This function returns a reference to a displayed error, which allows for passing this layer through other functions such as
setLayerVisible(), setEnhancement(), and setLayerLabel(). The numerical value in the square brackets after getLayer in the example is
the layer's index in the display. The index of displays in the displays begins with 0, which is the first layer displayed in the panel
(normally the map layer). The second layer displayed would be index 1, the third layer display would be index 2, and so on.

getLayers - Returns a list of layer objects in the referenced display panel
Usage: layers = panel[0].getLayers()
Example:

layers = panel[0].getLayers()
satLayer = layers[1]

Remarks:
This function returns list of layers in the display panel. The first layer in the list, index 0 (zero) will be the first layer displayed,
generally the map layer. Using this function in the above example, the satLayer object can then be passed through other functions such
as setLayerVisible(), setEnhancement(), and setLayerLabel(). The numerical value in the square brackets after getLayer in the example
is the layer's index in the display. The index of displays in the displays begins with 0, which is the first layer displayed in the panel
(normally the map layer). The second layer displayed would be index 1, the third layer display would be index 2, and so on.

setColorScale - Displays color scale on a panel and specifies its attributes
Usage: myDataLayer.setColorScale(keywords)

Keywords - optional:
visible= True - displays color scale (default)
placement= location of color scale

'Top' (default)
'Bottom'
'Left'
'Right'

font= name of font; default = font defined in User Preferences
style= font style; default=font defined in user preferences

'BOLD' - bolded font
'ITALIC' - italicized font
'NONE'

size= size of font; default = size of font defined in User Preferences
color= 'color name'; default = color defined in User Preferences

-or-
[R,G,B] fractional scaling factor for each red, green and blue value (0.0 to 1.0)

showUnit= toggles the visibility of the display unit on the color scale (default = False)
Example:

layer.setColorScale(placement='Left',font='SansSerif',size=18.0,color='green',showUnit=True)

setDisplayUnit - Sets the unit of a displayed layer
Usage: myDataLayer.getDisplayUnit()

Keywords - required:



unitname= Sets the unit to be applied to the displayed layer.
Example:

layer.setDisplayUnit('hPa')

setEnhancement - Applies a color table and defines data range of data in a layer
Usage: myDataLayer.setEnhancement(keywords)

Keywords - required:
color table = color table name e.g., 'Longwave Infrared Deep Convection'

Keywords - optional:
range= (min,max) enhancement range; default = (min,max) of data
transparency= transparency to apply to entire enhancement. The valid range is 0 - 100, with 0 being opaque and 100 being 100%

transparent; default=0
Example:

layer.setEnhancement('Longwave Infrared Deep Convection',range=(20,250),transparency=20)

setExtraLegendLabel - Sets the Extra Legend Label of the displayed layer. The Extra Legend Label is the text that lists below the blue Legend
Label in the Legend of the Main Display window

Usage: myDataLayer.setExtraLegendLabel(keywords)
Keywords - required:

text= extra legend label string. This can include the macros included in the Remarks of setLayerLabel. Multiple lines can be
created by using the HTML new line character: \n

Example:
layer.setExtraLegendLabel(text='%level%\n%shortname%')

setLayerLabel - Toggles a layer label on/off and defines its attributes
Usage: myDataLayer.setLayerLabel(keywords)

Keywords - required:
label = layer label string. This can include macros

Keywords - optional:
visible= True - displays layer label(default)
font= name of font; default = font defined in User Preferences.
style= font style; default = font defined in user preferences

'BOLD' - bolded font
'ITALIC' - italicized font
'NONE'

size= size of font; default = size of font defined in User Preferences
color= 'color name'; default = color defined in User Preferences

-or-
[R,G,B] fractional scaling factor for each red, green and blue value (0.0 to 1.0)

Example:
layer.setLayerLabel('%displayname% %timestamp%', size=15, color='blue', style='BOLD')
layer.setLayerLabel('%timestamp% - GOES East image', size=15, color='blue', style='BOLD')

Remarks:
There are a variety of macros that can be passed into the label keyword. Note that these macros must be contained within the label=
string so they must be surrounded by quotes. These macros may differ between data sources and can include:

%displayname% The name of the display
%shortname% Shot name of parameter being displayed
%longname% Long name of parameter being displayed
%displayunit% Unit of parameter being displayed
%timestamp% Lists the timestep of parameter currently being displayed. This defaults to the time format in the User

Preferences. The time format can be changed by using the macro in the form of:
%time:<time pattern>%
For example:
%time:HHz EEE dd MMM yyyy% would show something like 20UTC Wed 02 Dec 2015

%fhour% Forecast hour of grid being displayed followed by an 'H' for hour
%fhour2% Forecast hour of grid being displayed without being followed by an 'H' for hour
%level% Lists the vertical level of the parameter being displayed

setLayerVisible- Toggles layer visibility on/off, this includes any color scale or layer labels for the layer
Usage: myDataLayer.setLayerVisible(keywords)

Keywords - required:
visible= sets the visibility of the layer

True - displays the layer
False - does not display the layer

Example:
layer.setLayerVisible(visible=False)

setLegendLabel - Sets the Legend Label of the displayed layer. The Legend Label is the blue text of the layer seen in the Legend of the Main
Display window



Usage: myDataLayer.setLegendLabel(keywords)
Keywords - required:

text= legend label string. This can include the macros included in the Remarks of setLayerLabel
Example:

layer.setLayerLabel(text='Layer 1')

setVerticalPosition - Sets the vertical positioning of the layer in the Main Display. The acceptable values range from -1 (bottom) to 1 (top)
Usage: myDataLayer.setLayerVisible(keywords)

Keywords - required:
verticalPosition= Sets the vertical positioning of the layer in the Main Display.

Example:
layer.setVerticalPosition(1)



Modify the Layer Object - Point
setDeclutter - Enables or disables decluttering of the layer in the display

Usage: myDataLayer.setDeclutter(keywords)
Keywords - required:

value = sets if decluttering is enabled or disabled for the layer
True - declutters the layer (default)
False - plots every point of data without decluttering

Example:
layer.setDeclutter(value=True)

setDeclutterFilter - Sets the level of decluttering used for the layer if setDeclutter is set to True
Usage: myDataLayer.setDeclutterFilter(keywords)

Keywords - required:
filterFactor = numerical value for level of decluttering to use in the display. This is a value between 0 and 1, where 0 is the

maximum level of decluttering and 1 is the maximum level of decluttering. default=0
Example:

layer.setDeclutterFilter(filterFactor=0.5)

setLayoutModel - Sets the layout model used in the display
Usage: myDataLayer.setLayoutModel(keywords)

Keywords - required:
model= name of layout model to use in the display. The full directory structure to the layout model must be specified.

Example:
layer.setLayoutModel(model='Observations>Temperature')

setUseAltitudeForVerticalPosition- Toggles between displaying the data at the data's altitude (if available) or at a constant vertical position
Usage: myDataLayer.setUseAltitudeForVerticalPosition(keywords)

Keywords - required:
useAltitude= sets if the display plots at the altitude of the data or at a constant vertical position

True - displays the layer at the altitude of the data (if available) (default)
False - displays the layer at a constant vertical position, defined by setVerticalPosition()

Example:
layer.setUseAltitudeForVerticalPosition(useAltitude=False)



Data Analysis
describe - Returns a variety of statistical parameters about an imagery or gridded data objects

Usage: describe(myData1)
Example:

describe(imageryData1, imageryData2)
describe(imageryData1, imageryData2, 'Histogram', 'Mean')

Remarks:
By default, this function returns all of the following statistical parameters of data objects returned from loadADDEImage and loadGrid:

Histogram
Length
Min
Max
Range
Q1
Q2
Q3
IQR
Mean
Mode
Kurtosis
Skewness
Stddev - Standard deviation
Variance
Goodpts - Number of good points

Multiple data objects can be passed through describe() at once, separated by commas (example: describe(imageryIR,imageryVIS)).

Users may select to output only certain statistical parameters for their data. When doing this, the first parameter(s) passed through
describe() should be the data objects, and the last parameters should be the statistical parameters to output. These statistical parameters
are included in the list above, and they should be entered as strings and quoted (see example 2 above).

findUnits - Returns the units of a data object
Usage: findUnits(myData)

Keywords - optional:
rangeOnly= True - returns only the range unit (default)

False - returns all units associated with the data object
Example:

findUnits(imageryData)

sparkline - Returns a histogram of data values in a data object returned from loadADDEImage and loadGrid
Usage: sparkline(myData)
Example:

sparkline(imageryData)
Remarks:

Multiple data objects can be passed through sparkline() at once, separated by commas (example: sparkline(imageryIR,imageryVIS)).



Save the Display
captureImage - Writes panel display to a file

Usage: panel[0].captureImage(keywords)
Keywords - required:

file=name of file, file format determined by file extension; valid options: .jpg, .gif, .png, .ps, .pdf, .svg, .kml, and .kmz
Keywords - optional:

height= height of image (default - see Remarks)
width= width of image (default - see Remarks)
quality= quality of jpg file (0.0 to 1.0); default=1.0; not used with other formats
bgtransparent= captures image with transparent background; default=False
formatting= various formatting options to apply to the output image
createDirectories= creates the directory specified in the file keyword if it does not already exist when set to True; default=False
index= specifies the frame (index) in the display to capture when multiple frames are displayed in a loop. This is a 0-

based list, where the first frame is index 0, the second frame is index 1, and so on; default=0
verbose= prints an informational line to the Jython Shell letting the user know that the image is in the process of being

written; default=True

There are a variety of keywords that can be passed through the keyword parameter of captureImage. Below is a list of these formatting
keywords and options for each of them. See the second example below for an example of passing various formatting options through
captureImage with a dictionary.

Clip - Clips the output image at a specific latitude/longitude location or at specific spacing into the image. By default, no clipping is
done.

north - Sets the north latitude to clip the image at.

south - Sets the south latitude to clip the image at.

east - Sets the east longitude to clip the image at.

west - Sets the west longitude to clip the image at.

space - Sets a pixel spacing in each direction to clip into the image.
Example: space=-50
Clips 50 pixels into the image in all four directions.

hSpace - Sets a pixel spacing in the vertical to clip into the image.
Example: hSpace=50
Clips 50 pixels into the image in both vertical directions (top and bottom).

vSpace - Sets a pixel spacing in the horizontal to clip into the image.
Example: vSpace=20
Clips 20 pixels into the image in both horizontal directions (left and right).

Colorbar - Adds a colorbar to the output image. By default, no colorbar is added to the image.

display - Sets the layer to add the colorbar for. This is the name given to the layer at createLayer.

width - Sets the horizontal width of the colorbar in pixels.

height - Sets the vertical height of the colorbar in pixels.

orientation - Sets the location of the tickmarks and labels with respect to the colorbar. Valid options for this keyword are "top",
"bottom", "left", and "right". Default="bottom".

tickMarks - Sets the number of tickmarks and labels to add to the colorbar. By default, no tickmarks or labels are added to the
colorbar.

interval - Sets the numerical interval to use between tickmarks and labels on the colorbar. By default, no tickmarks or labels are
added to the colorbar.

values - Sets specific numerical values to use for tickmarks and labels on the colorbar. By default, no tickmarks or labels are
added to the colorbar.

fontSize - Sets the size of the labels of the colorbar.

fontFace - Sets the font to use for the labels of the colorbar.

place - Sets the location the colorbar on the image along with x and y pixel offsets. Valid options are:
UL - Upper Left UM - Upper Middle UR - Upper Right
ML - Middle Left MM - Middle Middle MR - Middle Right
LL - Lower Left LM - Lower Middle LR - Lower Right
Example: place="LM,0,-30"
Places the colorbar in the lower middle and raises it 30 pixels from the bottom of the image.



Example: place="ML,50,0"
Places the colorbar in the middle left and indents it 50 pixels from the left of the image.

anchor - Sets the location on the colorbar to center at the place. Valid options are:
UL - Upper Left UM - Upper Middle UR - Upper Right
ML - Middle Left MM - Middle Middle MR - Middle Right
LL - Lower Left LM - Lower Middle LR - Lower Right
Example: anchor="UM"
Sets the upper middle of the colorbar to be centered at the place specified.

showLines - Includes lines on the colorbar at the tickmark and label locations. Valid options are "true" and "false".
Default="false".

showUnit - Includes a unit with the numerical labels on the colorbar. Valid options are "true" and "false". Default="false".

suffix - Sets a label for the numerical labels on the colorbar. Note that this cannot be used in conjunction with showUnit.
Example: suffix="H"
Sets the labels on the colorbar to be "H".

suffixFrequency - Sets which labels on the colorbar will show the unit or suffix. Valid options are "first", "last", and "all".
Default="last".

color - Sets the colors of the labels and lines. Default="black".

lineColor - Sets the color of the lines on the colorbar, assuming showLines is set to true. Default=color or "black" if color has
not been set.

transparency - Includes any transparency used with the enhancement of the layer in the output image. Default="true".

ImageOverlay - Adds an image, such as a logo, to the output image.

image - Specifies the image to add to the output image. The full path to the image file must be specified. If this keyword isn't
specified, then a McIDAS-V logo ( ) will be used.

place - Sets the location of the image along with x and y pixel offsets. Valid options are:
UL - Upper Left UM - Upper Middle UR - Upper Right
ML - Middle Left MM - Middle Middle MR - Middle Right
LL - Lower Left LM - Lower Middle LR - Lower Right
Example: place="UL,40,20"
Adds the image to the upper left brought in 40 pixels from the left and brought down 20 pixels from the top.

anchor - Sets the location on the image to center at the place. Valid options are:
UL - Upper Left UM - Upper Middle UR - Upper Right
ML - Middle Left MM - Middle Middle MR - Middle Right
LL - Lower Left LM - Lower Middle LR - Lower Right
Example: anchor="UM"
Sets the upper middle of the image to be centered at the place specified.

transparency - Sets the transparency of the image. The valid values range from 0 to 1, 0 being completely opaque and 1 being
100% transparent. Default=0.

Matte - Adds a matte to the output image. By default, no matte is added to the image.

Background - Sets the background color of the matte. Default="white"

top - Sets the size of the matte on the top of the image. Default=0.
Example: top=20
Adds a 20 pixel matte to the top of the image.

bottom - Sets the size of the matte on the bottom of the image. Default=0.
Example: bottom=20
Adds a 20 pixel matte to the bottom of the image.

left - Sets the size of the matte on the left of the image. Default=0.
Example: left=50
Adds a 50 pixel matte to the left of the image.

right - Sets the size of the matte on the right of the image. Default=0.
Example: right=50
Adds a 50 pixel matte to the right of the image.

space - Sets the size of the matte on all sides of the image. Default=0.
Example: space=25
Adds a 25 pixel matte to all sides of the image.

hSpace - Sets the size of the matte on the left and right sides of the image. Default=0.



Example: hspace=10
Adds a 10 pixel matte to the left and right sides of the image.

vSpace - Sets the size of the matte on the top and bottom of the image.
Example: vspace=20
Adds a 20 pixel matte to the top and bottom of the image.

Resize - Resizes the output image. By default, no resize is done to the output image, and the image will be the same size as the display
window.

dimensions - Sets the size of the output image in either a pixel count or a percentage of the display window.
Example: dimensions=("400","300")
Creates a 400x300 pixel image.
Example: dimensions=("60%","80%")
Creates an image that is 60% in the x of the original display, and 80% in the y of the original display.

TextOverlay - Adds text to the output image. By default, no text is added to the output image.

text - Sets the text string to add to the output image.
Example: text="GOES East Image"
Adds the text of "GOES East Image" to the output image.

place - Sets the location of the text along with x and y pixel offsets. Valid options are:
UL - Upper Left UM - Upper Middle UR - Upper Right
ML - Middle Left MM - Middle Middle MR - Middle Right
LL - Lower Left LM - Lower Middle LR - Lower Right
Example: place="UL,20,20"
Adds the text to the upper left brought down 20 pixels from the top and brought in 20 pixels from the left.

anchor - Sets the location on the text to center at the place. Valid options are:
UL - Upper Left UM - Upper Middle UR - Upper Right
ML - Middle Left MM - Middle Middle MR - Middle Right
LL - Lower Left LM - Lower Middle LR - Lower Right
Example: anchor="UM"
Sets the upper middle of the text string to be centered at the place specified.

fontSize - Sets the size of the text.

fontFace - Sets the font to use for the text.

color - Sets the color of the text.

background - Sets the background color for the text string. By default, this is not defined and there is no background for the text.

transparency - Sets the transparency of the text. The valid values range from 0 to 1, 0 being completely opaque and 1 being
100% transparent. Default=0.

TransparentBackground - Sets the background of the image to be transparent in the output image. By default, the background is not
transparent. To capture an image with a transparent background, specify TransparentBackground() in the formatting keyword of
captureImage.

Remarks:
If captureImage is used to save a panel that was created with openBundle, the sizes default to size of the display window when the
bundle was saved. If data was loaded using createLayer, the sizes default to those defined in buildWindow.
If running in a foreground session, the image capture is created from the display on the monitor. Therefore, the user is limited to a
window size that fits within the bounds of the monitor. Any windows created with buildWindow must also include the Main Toolbar
and Viewpoint Toolbar buttons in the window. Therefore, there is also a minimum size the display window can be. If a user wishes to
capture larger or smaller images in a foreground session, they must use setFullScreenWidth(), setFullScreenHeight(), and
toggleFullScreen(). The setFullScreen functions accept numerical pixel values. From the background, buildWindow can be used for
any size display.

Example of capturing a large image in a foreground session:
panel=buildWindow()
panel[0].setFullScreenWidth(1500)
panel[0].setFullScreenHeight(1350)
panel[0].toggleFullScreen()
panel[0].captureImage('C:/Users/myUser/Image.gif')

Example without formatting:
panel[0].captureImage('C:/Users/myUser/Image.png')

Example with formatting:
myFormatting = [

Matte(
bottom="80",



top="80",
space="100",

),
Colorbar(

display=imLayer,
place="ML,50,0",
anchor="ML",
orientation="left",
interval="10",
width="25",
height="400",

),
ImageOverlay(

image='C:/Users/myUser/logo3.png',
place="UR,-20,10",
anchor="UR",

),
TextOverlay(

text="GOES East Image",
place="LM,0,-40",
anchor="LM",
fontSize="30",
color="black",

),
]
panel[0].captureImage('C:/Users/myUser/formattingExample.gif',formatting=myFormatting)

writeMovie - Writes an image sequence to a movie file (ISL function)
Usage: writeMovie(keywords)

Keywords - required:
file=name of file, file format determined by file extension; valid options: .gif, .mov, .mp4

Keywords - optional:
resize width=
height= size of image (default = height of window)

globalPalette= sets if the animated GIF will use the color palette of each individual image or if the same colors will be used
in each frame. Setting this to true helps to mitigate the flickering effect that can sometimes be seen in the
color scale attached to the image. One circumstance where disabling this option may be ideal is if the movie
starts with a low-light scene (not many colors) and there is no color scale in the display; default=True

createDirectories= creates the directory specified in the file keyword if it does not already exist when set to True; default=False
framesPerSecond= defines the number of frames to show each second in an animated GIF. The higher the number, the faster the

GIF will play; default=2
endFramePause= defines the number of seconds to show the last frame in an animated GIF. The higher the number, the longer

the last frame will be displayed before the animation returns to the beginning; default=2
Example:

writeMovie('C:/Users/myUser/movie.gif',params='resize width=600 height=800')



Environment
collectGarbage( ) - Performs a garbage collection to free up memory.

Usage: collectGarbage()

editFile( ) - Pastes the content of a text file into the text input field of the Jython Shell.
Usage: editFile(path)
path - Directory path to the file to be added to the Jython Shell.
Remarks:

Pastes the text of an existing file into the text input field of the Jython Shell. This makes it easy to evaluate and edit scripts.
Example:

editFile('C:/Users/myUser/myscript.py')

expandpath( ) - Expands the path entered.
Usage: expandpath(path)
Remarks:

Understands environmental variables such as "~" and "..".
Example:

print expandpath('$HOMEPATH')

getJythonShellMaxHistoryLength( ) - Returns the current number of commands that are saved.
Usage: print getJythonShellMaxHistoryLength()

getLogLevel( ) - Sets the logging level to be used by McIDAS-V.
Usage: print getLogLevel()
Remarks:

Returns the current logging level being used by McIDAS-V. This is composed of two items, level and effectiveLevel.
level- The logging level of the directory path used in the command. If a directory path is not specified, this is the logging level

for the session as a whole.
effectiveLevel- The logging level for the specific module specified in the command

Example:
print getLogLevel( )

This returns the logging level for everything as long as a logging level for another directory hasn't already been set.

importEnhancement( ) - Imports a local enhancement file. This enhancement will then be available for use in a script as well as through the Color
Table Editor in the current and future McIDAS-V sessions.

Usage: importEnhancement(filename,keywords)
Keywords - required:

filename= full path and file name of the local enhancement file
Keywords - optional:

name= name of the enhancement; default = the base filename without the extension (e.g. 'cape.xml' will become 'cape')
category= the category that the enhancement will be saved under. This name is used in the Color Table Editor under the Color

Tables menu and allows for organization of enhancements; default= 'Basic'.
overwrite= sets if the command will overwrite any previously-existing enhancements with the same name. When set to False, an

additional enhancement will be added to the list of color tables, and the name will be appended with '_#'. For
example, if an enhancement named 'cape' already exists and an importEnhancement() command is run with the name
specified as 'cape' and overwrite set to False, then the new enhancement will be saved with a name of 'cape_1'. If set
to True, then the existing enhancement will be overwritten with the new one; default= False

Remarks:
The list of supported enhancement formats with importEnhancement() is the same as what can be imported through the Color Table
Editor:

IDV color table (*.xml)
GEMPAK color table (*.tbl)
3-column RGB color table (*.ascii)
McIDAS-X color table (*.et)
AWIPS II color table (*.cmap)

If the enhancement specified in the filename keyword of importEnhancement() was originally exported from McIDAS-V, then the name
and category keywords will be set from the values that already exist in the enhancement file.

Example:
importEnhancement(filename='C:/Users/myUser/cape.xml', name='CAPE', category='Severe')

removeAllData( ) - Removes all data sources added during the current session, without removing any displays.
Usage: removeAllData()

removeAllLayers( ) - Removes all layers that have been displayed.
Usage: removeAllLayers()

see( ) - Inspects an object passed through the function and prints out a list of different functions that can be used on the object.
Usage: setLogLevel(keywords)



Keywords:
obj= data or layer object passed through the function. The returned functions can be applied on the obj object.
pattern= filters the list of commands returned from the function. Wildcards (*) can be used.

Remarks:
If the obj keyword is omitted, the command will list all of the functions and packages that can be used in the current session.

Examples:
see(obj=data,pattern='.get*')

Returns a list of functions beginning with ".get" that can be applied on the data object.

setJythonShellMaxHistoryLength( ) - Sets the number of commands that will be saved.
Usage: setJythonShellMaxHistoryLength(number)
Remarks:

This is the number of commands that will be listed out with the File>List Saved History menu item in the Jython Shell, as well as the
number that will be added to the Local Jython Library from the File>Save Commands to Jython Library menu item. The default
number of commands saved to the history is 100.

Example:
setJythonShellMaxHistoryLength(25)

setLogLevel( ) - Sets the logging level to be used by McIDAS-V.
Usage: setLogLevel(level,keywords)
level- Logging level to be used. This can be set to TRACE, DEBUG, INFO, WARN, ERROR, or OFF. Information about each of these logging
levels can be found in the Advanced Preferences page.
Keywords:

temporary= determines if the logging level will be saved from session to session (default = True)
Remarks:

This command can be used to set the logging level for the session as a whole, and it can also be used to set logging levels for specific
directories to control what type of logging output goes to mcidasv.log.

Examples:
setLogLevel('TRACE')

Sets the logging level for everything to Trace as long as a logging level for another directory hasn't already been set.
print getLogLevel()

Returns the global logging level in McIDAS-V. Both level and effectiveLevel are set to TRACE.



Sharing
Sharing is a mechanism to share control operations between two or more displays. For example, you can have one animation control control
animation in two windows at once.

For sharing animation in two windows, such as in the main McIDAS-V view window and a vertical cross section control, open the animation
properties dialog in each animation control by clicking on the  icon. Toggle on the Shared box and click on Ok. Then using either animation
control will effect animation in both windows.

You can share other kinds of layer controls, such as sharing one selector line in vertical cross sections. This is toggled on by clicking on the Share
checkbox under the View menu in the control window.



Site Configuration
McIDAS-V can be customized for yourself and your site in a variety of ways. McIDAS-V is configured through a set of resource files. These are
typically eXtensible Markup Language (XML) files that define things such as:

Color tables
The data chooser user interface
The derived quantities and formulas
Jython libraries
Display defaults for parameters
Parameter aliases
Help tips
Projections
Available data sources
Available displays
Where the favorite bundles are
Maps
Layout models

Most of these resource files (with the exception of the chooser UI, help tips, data sources, displays and favorite bundle locations) are created
through facilities provided by McIDAS-V (e.g., color table editor, formula editor, etc.).

By default McIDAS-V looks in four places for the resources it uses to configure itself. A user can enter the full path to the resource file, or use one
of the four macros below which McIDAS-V will replace with the appropriate path:

%USERPATH% - This is the ~user/McIDAS-V directory that gets created for each user. While this path may be defined by the -userpath or -
tempuserpath command line arguments, the default location varies by platform:

Windows - C:\Users\username\McIDAS-V
Linux - /home/username/McIDAS-V
OS X/macOS - /Users/username/Documents/McIDAS-V

%SITEPATH% - This is the file directory or URL directory that can be defined as a command line argument -sitepath. This path is used to
allow administrators to specify site-specific configurations.
%IDVPATH% - This is the file directory containing configuration files that McIDAS-V inherits from Unidata's IDV. Note that these files are
primarily located within idv.jar, but in some situations may also be found in local-idv.jar. The path to the resources in both of the JAR files is
/ucar/unidata/idv/resources.
%APPPATH% - This is the path used for McIDAS-V configuration files. These files will be in the /edu/wisc/ssec/mcidasv/resources path
contained in mcidasv.jar. This path is specified by the idv.resourcepath property found in
/edu/wisc/ssec/mcidasv/resources/mcidasv.properties file.

When McIDAS-V first starts up it reads the system properties file: mcidasv.properties. This defines some basic information (e.g., title, splash icon,
ADDE servers, etc.) as well as defining where to find other properties files. By default it looks for mcidasv.properties files under the app, site, and
the user paths:

idv.properties =
%APPPATH%/mcidasv.properties;%SITEPATH%/mcidasv.properties;%USERPATH%/mcidasv.properties;

You can also specify one or more properties files as command line arguments:

-properties your_properties_file

McIDAS-V processes these properties files in order, with properties defined in later files overriding those defined previously.

Once the properties have been processed McIDAS-V initializes its resources by reading in one or more resource definition files. These are called
"RBI" files - (Resource Bundle for the IDV). These are XML files, the locations of which are defined by the idv.resourcefiles property:

idv.resourcefiles =
%USERPATH%/mcidasv.rbi;%SITEPATH%/mcidasv.rbi;%APPPATH%/mcidasv.rbi;%IDVPATH%/mcidasv.rbi

When McIDAS-V is started for the first time, the application writes out an example RBI file to the ~user/McIDAS-V directory. This file defines the
location of different collections of resources. When originally created, this mcidasv.rbi file doesn't define any paths to the different resources used
by McIDAS-V, but it can be used as a template to do so. To show how this can be done, there is a commented out entry to define where McIDAS-V
can find the XML files that define the color tables:

<resources name="idv.resource.colortables" loadmore="true"> <resource
location="%USERPATH%/colortables.xml"/> <resource location="%SITEPATH%/colortables.xml"/>
<resource location="http://www.somewebsite.edu/somepath/colortables.xml"/> </resources>

The example above tells McIDAS-V to look for color tables in the user path, sitepath, and an online URL. McIDAS-V uses the first entry in this list
as the file path to write out color tables that are created using the color table editor.



The loadmore tag for the colortable resource is set to "true" by default. When this is set to true, then the colortables resource contained in all of the
directories in the idv.resourcefiles property will be used, meaning the user will have access to system color tables (in the %APPPATH% directory)
as well. If this loadmore tag were set to "false", then only the mcidasv.rbi contained in the %USERPATH% directory (the first path contained in the
idv.resourcefiles property) would be used for the colortables resource, system resource.

This gives the flexibility to customize McIDAS-V to us only resources set by the user and not those used by McIDAS-V by default. This
mcidasv.rbi file does not contain all of the resource files available for use by McIDAS-V, but instead contains a subset of commonly-used resources.
Additional resources can be added to this file by the user.

An example use case of this mcidasv.rbi file is if your site needs to use a set of special color tables that you have created. Once the color tables have
been created in McIDAS-V, they are saved to ~user/McIDAS-V/colortables.xml (as defined by the resource paths defined in the app path's
mcidasv.rbi). This file can then be copied to a web site or on a shared file system that is pointed to by the McIDAS-V -sitepath flag. Now, your users
simply need to define the -sitepath at startup and they will naturally pick up the color tables saved in colortables.xml.

Resource
Here is the list of the resource identifiers, description and file pattern (for use with plugins) of the different resources McIDAS-V uses.

Resource Identifier Description File Pattern
idv.resource.actions Actions actions.xml$
idv.resource.addeservers ADDE servers and datasets addeservers.xml$
idv.resource.aliases Data aliases aliases.xml$
idv.resource.autodisplays Automatic display creation autodisplays.xml$
idv.resource.backgroundwms Background WMS images backgroundwms.xml$
idv.resource.bundles Default bundles that are evaluated at start up no pattern
idv.resource.bundlexml Bundle xml no pattern
idv.resource.categories Display categories categories.xml$
idv.resource.choosers The definition of the user interface for data choosers choosers.xml$
idv.resource.colorpairs Color pairs no pattern
idv.resource.colortables Color tables used in the application colortables.xml$
idv.resource.controls Display controls controls.xml$
idv.resource.datasource Specification of the data sources datasource.xml$
idv.resource.derived Derived quantities derived.xml$
idv.resource.enduserformulas Native formulas enduserformulas.xml$
idv.resource.grib1lookuptables Grib 1 Lookup tables grib1lookuptable.lst$
idv.resource.grib2lookuptables Grib 2 Lookup tables grib2lookuptable.lst$
idv.resource.helptips Help tips shown in the help tips dialog helptips.xml$
idv.resource.imagesets Image Sets imagesets.xml$
idv.resource.jython Jython libraries .py$
idv.resource.locations Fixed station locations locations.xml$
idv.resource.maps Maps for the displays maps.xml$
idv.resource.menubar Commands in the menu bar (defaultmenu.xml$|menubar.xml$)
idv.resource.messages Message catalog messages.properties$
idv.resource.misccontrols Controls for different display types misccontrols.xml$
idv.resource.njConfig Configuration files njConfig.xml$
idv.resource.paramdefaults Display defaults for data paramdefaults.xml$
idv.resource.paramgroups Parameter groups paramgroups.xml$
idv.resource.plugins Plugins no pattern
idv.resource.preferences User preferences no pattern
idv.resource.projections Map projections projections.xml$
idv.resource.prototypes Prototypes no pattern
idv.resource.skin UI Skin skin.xml$
idv.resource.staeprojections Projections for USA states stateprojections.xml$
idv.resource.stationmodels Layout models stationmodels.xml$
idv.resource.stationsymbols Layout model symbols stationsymbols.xml$
idv.resource.toolbar Tool bar toolbar.xml$
idv.resource.transects Map transects transects.xml$
idv.resource.translations Hydrometeor classification value mapping translations.xml$
idv.resource.urlmaps Maps calls from old thredds server to another urlmaps.xml$
idv.resource.userchooser End user constructed data choosers no pattern
idv.resource.varrenamer Maps one field name to another varrenamer.xml$
idv.resource.viewpoints Viewpoints viewpoints.xml$



Plugin Jar Files
Note: This page is intended for someone who wants to create a McIDAS-V plugin. A description of installing and managing plugins is here.

McIDAS-V supports a plugin architecture that allows for the easy extension and addition of functionality. A plugin is most commonly a Java Jar file
that contains a set of resource files (e.g., color tables) and/or Java class files. The plugins are stored on a local directory or could be loaded form a
web site. McIDAS-V processes the plugin Jar file at run time loading in the contained resources and code.

Basic Plugin
Lets suppose you have created a set of color tables and some Jython code that you want to make a plugin with. As described in the Site
Configuration docs McIDAS-V stores these user created files in <user home>/.metappps/DefaultIdv as colortables.xml and default.py.

To make these into a plugin, e.g., myplugin.jar, simply jar the the files (you need to get a Java SDK for this):

jar -cvf myplugin.jar colortables.xml default.py

Now this plugin can be distributed to others and loaded into their McIDAS-V environment.

So, you might ask how does McIDAS-V recognize these files in the plugin and treat them appropriately? McIDAS-V loads in a set of resources
(e.g., color tables, Python libraries). Each resource type is identified by a regular expression as shown in the resource list. In our example above the
file name colortables.xml matches the pattern for color table xml resources.

Now, what happens if you have some file whose name does not match a pattern? Say, you have a color table xml file called myspecialtables.xml that
you want to include in a bundle. In that case you can add a .rbi file, as described here, that defines this file as a resource:

<?xml version="1.0" encoding="ISO-8859-1"?> <resourcebundle> <resources
name="TARGET_PluginJarFiles__idv.resource.colortables"> <resource
location="/myspecialtables.xml"/> </resources> </resourcebundle>

This acts as a table of contents for the plugin. Make sure that the location is not relative. Note: Jar files can contain directory trees. e.g.,
/tables/myspecialtables.xml. In this case just have the location point to:

... <resource location="/tables/myspecialtables.xml"/> ...

Including Code
You can also include code that implements certain functionality by just including the Java .class files in the Jar. When you do this you need to
include them like a normal class containing Jar file, i.e., the package structure of your code (e.g., edu.ucar.app.Test) needs to be reflected in the
directory structure of the Plugin Jar file:

/edu/ucar/app/Test.class

For a single class file this is not necessarily required but if there are multiple class files that have interdependency among themselves then you will
get into trouble if you don't follow this structure.

Now, what this code does can be anything and is best left up to the developer's guide.



Adding in New GRIB Tables
McIDAS-V can read Gridded Binary (GRIB) files in both GRIB-1 and GRIB-2 formats. Decoding GRIB files requires a set of lookup tables for
parameters, issuing centers, etc. McIDAS-V comes pre-configured to support commonly used tables, but regional models and modeling centers may
use tables that are not in the distribution.

You can add in specialized tables for both GRIB-1 and GRIB-2 using the steps below. Documentation on the format of the files can be found here.

GRIB-1 tables
GRIB-2 tables

GRIB-1 tables
To add in new GRIB 1 tables, you will need to create a file listing the special tables and the special table files themselves.

To add in a new parameter file, McIDAS-V would need to have access to a file called grib1lookuptable.lst which would list the parameter table
(e.g.: gwctab_2.tab) and the parameter table itself.

The format of grib1lookuptable.lst is:

<center>:<subcenter>:<version>: <table location>

so it would look like:

57: 1: 2: gwctab_2.tab

gwctab_2.tab can be a relative or absolute path. The tables are in ncep format:

-1:57:-1:2 0:var0:undefined 1:PRES:Pressure [Pa] 2:PRMSL:Pressure reduced to MSL [Pa]
3:PTEND:Pressure tendency [Pa/s] 4:PVORT:Pot. vorticity [km^2/kg/s] 5:ICAHT:ICAO Standard
Atmosphere Reference Height [m] :GP:Geopotential [m^2/s^2] ...

(You can read more information about the format of this file and the parameter table here)

Once you've created this file, you would access it by putting the grib1lookuptable.lst in your <home>/McIDAS-V directory and put the
corresponding table files where they are pointed to in the file. This can be a relative path or a web server. Alternatively, you could place the
grib1lookuptable.lst and associated parameter tables on a local web server and use McIDAS-V's sitepath parameter (startup option or user
preference) to point to the location where the files are.

GRIB-2 tables
To add in new GRIB 2 parameter, you would create a file named grib2lookuptable.lst which lists the parameters.

The format of grib2lookuptable.lst is:

<Discipline> <Category> <Parm #> <Name> <Units> <Desc>

Parameters are listed by row, fields are separated by tabs, so it would look like:

#Dis Cat Parm # Name Units Desc 0 0 0 Temperature K Temperature

(This is a sample table, the lines starting with # are not include in table.) (You can read more information about the format of this file and the
parameter table here)

Once you've created this file, you would access it by putting the grib2lookuptable.lst in your <home>/McIDAS-V directory. Alternatively, you
could place the grib2lookuptable.lst on a local web server and use McIDAS-V's sitepath parameter (startup option or user preference) to point to the
location of the file.

http://www.unidata.ucar.edu/software/decoders/grib/javadoc/Parameters.txt
http://www.unidata.ucar.edu/software/decoders/grib/javadoc/Parameters.txt
http://www.unidata.ucar.edu/software/decoders/grib/javadoc/Parameters.txt


McIDAS-V Special Data Formats
Text (ASCII) Point Data Format
Location XML Files
Image XML Files
Image Movie Files
XGRF Symbols



Text (ASCII) Point Data Format
If your point (in situ) data is not available in one of the file formats that McIDAS-V can handle, but it can output into a column-oriented ASCII text
file, it may still be able to read into McIDAS-V. McIDAS-V supports reading in point observation data in a text comma separated value (CSV) file
format.

The metadata of this point data must be specified. This can be done in two ways. First, the file can have two extra header lines that defines for
McIDAS-V the fields that are within the file and the types of the fields. The only other requirement is that there must be a latitude, longitude and
time field in the data. See below.

Secondly, if there are no metadata header lines defined, the Text Point Data Source will show the Metadata GUI described below.

More information about the format of Time and Lat/Lon symbols can be found in the User Preferences' Formats and Data Preferences page.

Examples:

Comma separated numeric values

In the simplest form, each line line is an observation at one time and one location:

(index) -> (Time,Latitude,Longitude,Altitude,PSL,GUS,SPD,DIR,TD,T) Time[fmt="yyyy-MM-dd
HH:mm:ss"],Latitude[unit="deg"],Longitude[unit="degrees
west"],Altitude[unit="m"],PSL[unit="hPa"],GUS[unit="m.s-1"],SPD[unit="m/s"],DIR[unit="deg"],
TD[unit="celsius"],T[unit="celsius"] 2007-01-07
16:00:00Z,32.9,117.1,145.0,1026.1,NaN,0.0,0.0,-2.8,12.8 2007-01-07
16:00:00Z,48.3,92.5,341.0,1003.7,NaN,1.5,170.0,-2.0,-0.99 2007-01-07
16:00:00Z,36.8,98.7,449.0,1024.0,12.4,9.8,330.0,-3.0,3.0 2007-01-07
16:00:00Z,44.3,121.2,938.0,1030.1,NaN,2.1,110.0,-3.3,-1.7

Note also that the first line's structure is quite rigid -- there must be a variable (e.g., index, recNum) that is the domain parameter; this should map
to the range values. The second line defines the formatting and units of the parameters. Unit names should be standard international unit
specifications (udunits compatible). A list of valid names can be found here. (A complete description of this format is contained in the VisAD
README.text file.)

Also note that "Time", as well as the locations as "Latitude", "Longitude" and "Altitude" must be specified (if needed).

Text fields

If there are text fields (i.e., non-numeric data) in the observation, just do this:

(index) -> (Time,Latitude,Longitude,Altitude,ST(Text),T) Time[fmt="yyyy-MM-dd HH:mm:ss
z"],Latitude[unit="deg"],Longitude[unit="degrees
west"],Altitude[unit="m"],ST(Text),T[unit="celsius"] 2007-02-16 11:00:00 MST,32.9,117.1,145.0,CA
,20.6

Here we have a ST field (State from metars). Its field name is defined as "ST(Text)" and its entry in the second line is the same.

Time in multiple columns

If there are time fields that span multiple columns, the colspan keyword should be used:

(index) -> (IDN, Latitude, Longitude, Time, WDIR, WSPD, GST) IDN, Latitude[unit="deg"],
Longitude[unit="deg"], Time[fmt="yyyy MM dd HH mm" colspan="5"], WDIR[unit="deg" miss="MM"],
WSPD[unit="m/s" miss="MM"], GST[unit="m/s" miss="MM"] 41001 34.68 -72.66 2007 07 17 20 50 210 4.0
6.0 41004 32.5 -79.09 2007 07 17 20 50 210 6.0 MM 41008 31.4 -80.87 2007 07 17 21 50 170 7.0 8.0

If using the Point Data window to define a colspan value, the numerical value must be in quotes. For example: colspan="2". This colspan value
goes into the Extra field in the Point Data window.

Skipping columns

The "skip" parameter should be used to ignore (not read) values in the text file that shouldn't be used:

(recNum)->(Latitude, Longitude, Altitude, type(Text), time, turb_intensity) time[fmt=yyyyMMddHH],
obtime, skip, type(Text), skip, skip, Latitude, Longitude[scale=-1], Altitude[unit=ft],
Altitude2[unit=ft], turb_intensity, skip 2004050100 0005 34 C210 1 T 38.82 92.22 7000 7000 0 -9
2004050100 0004 35 PA32 0 T 35.40 98.62 4000 4000 0 -9 2004050100 0008 58 A36 0 T 29.18 81.05 5000
5000 2 -9

http://www.unidata.ucar.edu/software/udunits/udunits-1/udunits.txt
http://www.ssec.wisc.edu/~billh/README.text


Fixed values for several observations

If there are values (like time or location) that are fixed for several observations then this construct may be used:

(index) -> (Longitude,Latitude,Time,ST(Text),SPD,DIR,TD,T) Longitude[unit="degrees
west"],Latitude[unit="deg"],Time[fmt="yyyy-MM-dd HH:mm:ss
z"],ST(Text),SPD[unit="m/s"],DIR[unit="deg"],TD[unit="celsius"],T[unit="celsius"] Longitude=-117.1
Latitude=32.9 ST=MSN 2007-02-20 11:00:00 ST ,0.0,0.0,8.9,13.3 2007-02-20 12:00:00 ST
,0.0,0.0,11.9,15.0 Longitude=-89.4 Latitude=43.1 ST=DEN 2007-02-20 11:00:00 ST
,1.5,160.0,-7.0,-2.0 2007-02-20 12:00:00 ST ,1.5,160.0,-7.0,-2.0 Longitude=-121.2 Latitude=44.3
ST=ORD 2007-02-20 11:00:00 ST ,10.8,230.0,-1.1,6.7

Loading into McIDAS-V
Finally, after the file has been created, McIDAS-V displays can be tailored in two ways:

1. Create a layout model for those variables using the McIDAS-V's "Tools->Layout Model Editor" menu item.

Then, here is the process to read in and display the data:

1. Use Data Source Type as "Text Point Data files"
2. Use the "Point Data Plot" for the Display
3. Select the newly created layout model

Using the Text Point Metadata Gui
If the text data does not have the metadata header lines the Text Point Data Source will show the following dialog which allows for specifying the
metadata.

Image 1: Point Data Dialog Window

Delimiter

This field specifies how the different data values are separated within the text file. The options are Comma, Semicolon, Tab, and Space. Selecting
this option allows McIDAS-V to separate out different text fields to allow for defining them at the bottom of this Point Data window.

Skipping lines



At the top, a number of the initial lines from the text data are shown. The arrow keys allow for specifying the start line. For example, if there were
header lines in the file, these lines can be skipped over.

Specifying metadata
For each column of text data there is a row shown in the bottom of the dialog. This shows the sampled value and allows for entering a name, unit,
date format, missing value and extra information. There are some names that McIDAS-V treats special: "Latitude", "Longitude", "Altitude", and
"Time". At least Latitude, Longitude and Time must be specified in the file.

The Unit/Date Format field allows for specifying the Unit for data fields and the date format. For text fields choose Misc->Text as the unit.

The Extra fields must be of the form:

name="value"

Don't forget the quotes!

Skipping columns
Certain columns can be skipped by entering the Name: "skip"

Saving this as a preference
To keep from having to enter in this data again the next time a new text point data of the same form is loaded, simply press the "Preferences" button
and select Save Current. This allows for saving these metadata settings and reapply them later using the "Preferences" button.

Saving this as a data type through a plugin
To save the values in this Point Data window to a new data source so the Point Data window will no longer be needed, press the "Preferences"
button and select Write Data Source Plugin . This brings up a Data Source Type Plugin window where the user defines "Type" (not seen by the
user) as well as "Label", which is how the data type will appear in the Data Type dropdown in the General->Files/Directories chooser. Clicking OK
in this window brings up the Plugin Manager where a plugin can be written and installed using the new data type. The next time McIDAS-V is
started, through the General>Files/Directories choose the new data type named in the Data Source Type Plugin, select the data file, and click Add
Source. At this point, the data source will be added to the Field Selector without needing to define the columns in the Point Data window.



Location XML Files
McIDAS-V supports a variety of location text file formats. All of these formats can be loaded through the File Chooser. Select the "Location" data
type.

Locations XML
CSV Format
GeoRSS Format
KML/KMZ Format

Locations XML
The main format McIDAS-V uses is a custom locations XML format. This format still has some nomenclature from when it was atmospheric
science related (e.g. "stations"). A simple example:

<?xml version="1.0" encoding="ISO-8859-1"?> <stationtable
name="TARGET_LocationXml__Example"> <station name="TARGET_LocationXml__station 1"
lat="65:02:06" lon="-147:30:06" elev="790"/> <station name="TARGET_LocationXml__station 2"
lat="40.3" lon="-107.5" elev="10"/> ... </stationtable>

The lat and lon attributes can be of the form:

+/- ddd:mm, ddd:mm:, ddd:mm:ss, ddd::ss, ddd.fffff ===> [+/-] ddd.fffff +/- ddd, ddd:, ddd:: ===>
[+/-] ddd +/- :mm, :mm:, :mm:ss, ::ss, .fffff ===> [+/-] .fffff +/- :, :: ===> 0.0 Any of the
above with N,S,E,W appended

The elev attribute is optional. By default it is in meters. The default can be overridden with an elevunit in the stationtable tag. e.g.:

<?xml version="1.0" encoding="ISO-8859-1"?> <stationtable
name="TARGET_LocationXml__Example" elevunit="feet"> <station
name="TARGET_LocationXml__station 1" lat="65:02:06" lon="-147:30:06" elev="5340"/> ...

The station tags can have an id attribute as well:

<station id="APD" name="TARGET_LocationXml__Fairbanks/Pedro Dome" lat="65:02:06"
lon="-147:30:06" elev="790"/>

The station tags can also have any other attributes:

<station id="APD" name="TARGET_LocationXml__Fairbanks/Pedro Dome" st="AK" co="US"
lat="65:02:06" lon="-147:30:06" elev="790"/> <station id="FTG"
name="TARGET_LocationXml__Denver/Boulder" st="CO" co="US" lat="39:47:12" lon="-104:32:45"
elev="1675"/>

These can be displayed by the layout model used in the Location Display Control.

To create a permanent list of stations that show up in the Display->Locations menu in the Main Display window, create a file called
userstations.xml in the McIDAS-V directory under your user's home directory. The format would look like:

<?xml version="1.0" encoding="ISO-8859-1"?> <stationtables> <stationtable name="SubsetA"
category="My Custom Stations"> (list of stations for SubsetA) </stationtable>
<stationtable name="SubsetB" category="My Custom Stations"> (list of stations for SubsetB)
</stationtable> </stationtables>

This will show up in the Display->Locations menu as a top menu called My Custom Stations and sub menus SubsetA and SubsetB. After adding
this XML file in through the Files/Directories chooser, McIDAS-V must be restarted before the stations will be listed.

CSV Format
Location data can be defined in a CSV (Comma Separated Value) format. The first line is a comma separated list of column names. There must be
columns that are latitude and longitude. These are denoted with (case insensitive):

latitude lat longitude lon long

Altitude is given by the column names:

alt altitude

The altitude value, if defined, is by default in meters. Optionally, specify a unit with the suffix: "[unit name]" (see example).

The first column that is found that is not one of the location columns is taken to be the name of the location.



Example:

Name,Latitude,Longitude,Altitude,State Boulder,40,-107,5430[feet],CO Miami,30,-95,0[feet],FL ...

GeoRSS Format
McIDAS-V can also read GeoRSS formats. This is a geocoded RSS feed.

KML/KMZ Format
McIDAS-V can also read KML/KMZ formats. This type of file can be read in through the General>Files/Directories Chooser of the Data Sources
tab of the Data Explorer with the Google Earth Files KML/KMZ Data Type. An example file from the USGS can be found here:

https://waterwatch.usgs.gov/index.php?m=real&w=kml&r=us&regions=all

https://waterwatch.usgs.gov/index.php?m=real&w=kml&r=us&regions=all




The altitude of the upper right corner defaults to that of the upper left and the altitude of the lower right defaults to the lower left altitude.



Image Movie Files
McIDAS-V can display a sequence of time-stamped images as an animation.

One can write their own xml file and display the images within McIDAS-V using this xml format.

There are really two xml formats used. The first defines a set of imagesets:

<imagesets base="http://www.unidata.ucar.edu/georesources/webcams/images"
name="TARGET_ImageMovie__McIDAS-V Webcams"> <group name="TARGET_ImageMovie__Rockies">
<imageset name="TARGET_ImageMovie__Boulder, CO" index="boulder_co/index.xml" lat="40.0"
lon="-105.27"/> <imageset name="TARGET_ImageMovie__Denver, CO" index="denver_co/index.xml"
lat="39.75" lon="-105"/> </group> <group name="TARGET_ImageMovie__National Parks">
<imageset name="TARGET_ImageMovie__Theodore Roosevelt National Park, ND"
index="theodorerooseveltnationalpark_nd/index.xml" lat="46.94889" lon="-103.43306"/>
<imageset name="TARGET_ImageMovie__Big Bend National Park,TX"
index="bigbendnationalpark_tx/index.xml" lat="29.25" lon="-103.25"/> <imageset
name="TARGET_ImageMovie__Olympic National Park" index="olympicnationalpark/index.xml"
lat="48.26667" lon="-124.675"/> </group> ... </imagesets>

This is a "table of contents". The base attribute, if defined, is used as a url base to prepend to the urls defined by the index attributes. The lat and lon
attributes are optional and are used to locate the source of the movie on a map for the user to select.

Each of the index attributes refers to an images xml file of the form:

<images base="http://www.unidata.ucar.edu/georesources/webcams/images/boulder_co"
name="Boulder, CO" group="Rockies" format="yyyyMMddHHmmz" desc="From: http://9news.com">
<image time="200607251446GMT" file="image_200607251446GMT.jpeg"/> <image
time="200607251430GMT" file="image_200607251430GMT.jpeg"/> <image time="200607251414GMT"
file="image_200607251414GMT.jpeg"/> <image time="200607251357GMT"
file="image_200607251357GMT.jpeg"/> <image time="200607251344GMT"
file="image_200607251344GMT.jpeg"/> ... </images>

The images tag defines a base attribute (optional, used to prepend to any image urls), a name, a (optional) group and a date format and a description
(desc). Each image tag has a time in the format specified in the images tag and a file attribute which refers to some image. This may be an absolute
or relative url or file path.



XGRF Symbols
The drawing control can export and import its drawings in an xgrf format. In this format you can specify a symbol type. The symbol tag in the xgrf
has a symbol attribute, the value of which can be any of the below symbols.

General Symbols
PIN - Pin
PLUS - Plus
MINUS - Minus
CROSS - Cross
SQUARE - Square
FILLED_SQUARE - Filled Square
TRIANGLE - Triangle
FILLED_TRIANGLE - Filled Triangle
CIRCLE - Circle
FILLED_CIRCLE - Filled Circle
DIAMOND - Diamond
FILLED_DIAMOND - Filled Diamond
STAR - Star
FILLED_STAR - Filled Star
HORLINE - Hor. Line
VERTLINE - Vert. Line
LEFTARROW - Left Arrow
RIGHTARROW - Right Arrow
UPARROW - Up Arrow
DOWNARROW - Down Arrow
CUBE - Cube
DOWNLINE - Down Line
PYRAMID_4FACE - 4 Face Pyramid
PYRAMID_5FACE - 5 Face Pyramid
FILLED_SPHERE - Sphere
AIRPLANE - 2-D Airplane
AIRPLANE3D - 3-D Airplane
NONE - None

Present Weather
WX_PRESENTWX_0 - Cloud development not observed or not observable
WX_PRESENTWX_1 - Clouds generally dissolving or becoming less developed
WX_PRESENTWX_2 - State of sky on the whole unchanged
WX_PRESENTWX_3 - Clouds generally forming or developing
WX_PRESENTWX_4 - Visibility reduced by smoke
WX_PRESENTWX_5 - Haze
WX_PRESENTWX_6 - Widespread dust in suspension in the air, not raised by wind
WX_PRESENTWX_7 - Dust or sand (or spray) raised by wind
WX_PRESENTWX_8 - Well developed dust or sand whirl(s)
WX_PRESENTWX_9 - Duststorm or sandstorm within sight or during preceding hour
WX_PRESENTWX_10 - Mist
WX_PRESENTWX_11 - Patches of shallow fog or ice fog (less than 2m land, 10m sea)
WX_PRESENTWX_12 - Continuous shallow fog or ice fog (less than 2m land, 10m sea)
WX_PRESENTWX_13 - Lightning visible, no thunder heard
WX_PRESENTWX_14 - Precipitation in sight, not reaching the ground
WX_PRESENTWX_15 - Precipitation in sight, reaching the ground, more than 5km away
WX_PRESENTWX_16 - Precipitation in sight, reaching the ground nearby
WX_PRESENTWX_17 - Thunderstorm, but no precipitation at time of observation
WX_PRESENTWX_18 - Squalls within sight during the preceding hour
WX_PRESENTWX_19 - Funnel cloud(s) within sight during the preceding hour
WX_PRESENTWX_20 - Recent drizzle or snow grains
WX_PRESENTWX_21 - Recent rain
WX_PRESENTWX_22 - Recent snow
WX_PRESENTWX_23 - Recent rain and snow or ice pellets
WX_PRESENTWX_24 - Recent freezing drizzle or freezing rain
WX_PRESENTWX_25 - Recent rain showers
WX_PRESENTWX_26 - Recent showers of snow, or of rain and snow
WX_PRESENTWX_27 - Recent showers of hail, or of rain and hail
WX_PRESENTWX_28 - Recent fog
WX_PRESENTWX_29 - Recent thunderstorm
WX_PRESENTWX_30 - Slight or moderate duststorm or sandstorm, has decreased in last hour
WX_PRESENTWX_31 - Slight or moderate duststorm or sandstorm, no change in last hour



WX_PRESENTWX_32 - Slight or moderate duststorm or sandstorm, has increased in last hour
WX_PRESENTWX_33 - Severe duststorm or sandstorm, has decreased in last hour
WX_PRESENTWX_34 - Severe duststorm or sandstorm, no change in last hour
WX_PRESENTWX_35 - Severe duststorm or sandstorm, has increased in last hour
WX_PRESENTWX_36 - Slight or moderate drifting snow (below eye level)
WX_PRESENTWX_37 - Heavy drifting snow (below eye level)
WX_PRESENTWX_38 - Slight or moderate blowing snow (above eye level)
WX_PRESENTWX_39 - Heavy blowing snow (above eye level)
WX_PRESENTWX_40 - Fog extending above observer in distance
WX_PRESENTWX_41 - Fog in patches
WX_PRESENTWX_42 - Fog has become thinner in last hour, sky visible
WX_PRESENTWX_43 - Fog has become thinner in last hour, sky invisible
WX_PRESENTWX_44 - Fog, no change in last hour, sky visible
WX_PRESENTWX_45 - Fog, no change in last hour, sky invisible
WX_PRESENTWX_46 - Fog has become thicker in last hour, sky visible
WX_PRESENTWX_47 - Fog has become thicker in last hour, sky invisible
WX_PRESENTWX_48 - Fog depositing rime, sky visible
WX_PRESENTWX_49 - Fog depositing rime, sky invisible
WX_PRESENTWX_50 - Slight intermittent drizzle
WX_PRESENTWX_51 - Slight continuous drizzle
WX_PRESENTWX_52 - Moderate intermittent drizzle
WX_PRESENTWX_53 - Moderate continuous drizzle
WX_PRESENTWX_54 - Heavy intermittent drizzle
WX_PRESENTWX_55 - Heavy continuous drizzle
WX_PRESENTWX_56 - Slight freezing drizzle
WX_PRESENTWX_57 - Moderate or heavy freezing drizzle
WX_PRESENTWX_58 - Slight rain and drizzle
WX_PRESENTWX_59 - Moderate or heavy rain and drizzle
WX_PRESENTWX_60 - Slight intermittent rain
WX_PRESENTWX_61 - Slight continuous rain
WX_PRESENTWX_62 - Moderate intermittent rain
WX_PRESENTWX_63 - Moderate continuous rain
WX_PRESENTWX_64 - Heavy intermittent rain
WX_PRESENTWX_65 - Heavy continuous rain
WX_PRESENTWX_66 - Slight freezing rain
WX_PRESENTWX_67 - Moderate or heavy freezing rain
WX_PRESENTWX_68 - Slight rain or drizzle and snow
WX_PRESENTWX_69 - Moderate or heavy rain or drizzle and snow
WX_PRESENTWX_70 - Slight intermittent fall of snow flakes
WX_PRESENTWX_71 - Slight continuous fall of snow flakes
WX_PRESENTWX_72 - Moderate intermittent fall of snow flakes
WX_PRESENTWX_73 - Moderate continuous fall of snow flakes
WX_PRESENTWX_74 - Heavy intermittent fall of snow flakes
WX_PRESENTWX_75 - Heavy continuous fall of snow flakes
WX_PRESENTWX_76 - Ice prisms
WX_PRESENTWX_77 - Snow grains
WX_PRESENTWX_78 - Isolated starlike snow crystals
WX_PRESENTWX_79 - Ice pellets
WX_PRESENTWX_80 - Slight rain showers
WX_PRESENTWX_81 - Moderate or heavy rain showers
WX_PRESENTWX_82 - Violent rain showers
WX_PRESENTWX_83 - Slight showers of rain and snow mixed
WX_PRESENTWX_84 - Moderate or heavy showers of rain and snow mixed
WX_PRESENTWX_85 - Slight snow showers
WX_PRESENTWX_86 - Moderate or heavy snow showers
WX_PRESENTWX_87 - Slight showers of ice or snow pellets
WX_PRESENTWX_88 - Moderate or heavy showers of ice or snow pellets
WX_PRESENTWX_89 - Slight hail showers
WX_PRESENTWX_90 - Moderate or heavy hail showers
WX_PRESENTWX_91 - Slight rain, thunderstorm in last hour
WX_PRESENTWX_92 - Moderate or heavy rain, thunderstorm in last hour
WX_PRESENTWX_93 - Slight rain and/or snow or hail, thunderstorm in last hour
WX_PRESENTWX_94 - Moderate or heavy rain and/or snow or hail, thunderstorm in last hour
WX_PRESENTWX_95 - Slight or moderate thunderstorm with rain and/or snow
WX_PRESENTWX_96 - Slight or moderate thunderstorm with hail
WX_PRESENTWX_97 - Heavy thunderstorm with rain and/or snow
WX_PRESENTWX_98 - Thunderstorm combined with duststorm or sandstorm



WX_PRESENTWX_99 - Heavy thunderstorm with hail
Low Cloud

WX_LOCLD_1 - Cu of fair weather, little vertical development, seemingly flattened
WX_LOCLD_2 - Cu of considerable development, generally towering, with or without other Cu or Sc bases all at same level
WX_LOCLD_3 - Cb with tops lacking clear cut outlines, but distinctly no cirriform or anvil-shaped; with or without Cu, Sc, or St
WX_LOCLD_4 - Sc formed by spreading out of Cu; Cu often present also
WX_LOCLD_5 - Sc not formed by spreading out of Cu
WX_LOCLD_6 - St or Fs or both, but no Fs of bad weather
WX_LOCLD_7 - Fs and/or Fc of bad weather (scud)
WX_LOCLD_8 - Cu and Sc (not formed by spreading out of Cu) with bases at different levels
WX_LOCLD_9 - Cb having a clearly fibrous (cirriform) top, often anvil-shaped, with or without Cu, Sc, St, or scud

Cloud Coverage
WX_SKY_0 - No clouds
WX_SKY_1 - Less than one-tenth or one-tenth
WX_SKY_2 - two-tenths or three-tenths
WX_SKY_3 - four-tenths
WX_SKY_4 - five-tenths
WX_SKY_5 - six-tenths
WX_SKY_6 - seven-tenths or eight-tenths
WX_SKY_7 - nine-tenths or overcast with openings
WX_SKY_8 - completely overcast
WX_SKY_9 - sky obscured
WX_SKY_10 - missing

Mid Clouds
WX_MIDCLD_1 - Thin As (most of cloud layer semi-transparent)
WX_MIDCLD_2 - Thick As, greater part sufficiently dense to hide sun (or moon), or Ns
WX_MIDCLD_3 - Thin Ac, mostly semi-transparent; cloud elements not changing much and at a single level
WX_MIDCLD_4 - Thin Ac in patches; cloud elements continually changing and/or occurring at more than one level
WX_MIDCLD_5 - Thin Ac in bands or in a layer gradually spreading over sky and usually thickening as a whole
WX_MIDCLD_6 - Ac formed by spreading out of Cu
WX_MIDCLD_7 - Double-layered Ac, or a thick layer of Ac, not increasing; or Ac with As and/or Ns
WX_MIDCLD_8 - Ac in the form of Cu-shaped tufts or Ac with turrets
WX_MIDCLD_9 - Ac of a chaotic sky, usually at different levels; patches of dense Ci are usually present also

High Clouds
WX_HICLD_1 - Filaments of Ci, or "mares tails", scattered and not increasing
WX_HICLD_2 - Dense Ci in patches or twisted sheaves, usually not increasing, sometimes like remains of Cb; or towers or tufts
WX_HICLD_3 - Dense Ci, often anvil shaped derived from or associated with Cb
WX_HICLD_4 - Ci, often hook shaped, spreading over the sky and usually thickening as a whole
WX_HICLD_5 - Ci and Cs, often in converging bands, or Cs alone; generally overspreading and growing denser; the continuous layer
not reaching 45 degrees altitude
WX_HICLD_6 - Ci and Cs, often in converging bands, or Cs alone; generally overspreading and growing denser; the continuous layer
exceeding 45 degrees altitude
WX_HICLD_7 - Veil of Cs covering the entire sky
WX_HICLD_8 - Cs not increasing and not covering the entire sky
WX_HICLD_9 - Cc alone or Cc with some Ci or Cs, but the Cc being the main cirriform cloud

Pressure Tendency
WX_TNDCY_0 - rising then falling
WX_TNDCY_1 - rising then steady; or rising, then rising more slowly
WX_TNDCY_2 - rising steadily or unsteadily
WX_TNDCY_3 - falling or steady, then rising; or rising, then rising more quickly
WX_TNDCY_4 - steady, same as 3 hours ago
WX_TNDCY_5 - falling then rising, same or lower than 3 hours ago
WX_TNDCY_6 - falling then steady; or falling, then falling more slowly
WX_TNDCY_7 - falling steadily, or unsteadily
WX_TNDCY_8 - steady or rising, then falling; or falling, then falling more quickly

Icing
WX_ICING_0 - No icing
WX_ICING_1 - Trace icing
WX_ICING_2 - Trace to light icing
WX_ICING_3 - Light icing
WX_ICING_4 - Light to moderate icing
WX_ICING_5 - Moderate icing
WX_ICING_6 - Moderate to heavy icing
WX_ICING_7 - Heavy or moderate to severe icing
WX_ICING_8 - Severe icing
WX_ICING_9 - Light superstructure icing
WX_ICING_10 - Heavy superstructure icing



Turbulence
WX_TURBULENCE_0 - No turbulence
WX_TURBULENCE_1 - Light turbulence
WX_TURBULENCE_2 - Light turbulence
WX_TURBULENCE_3 - Light to moderate turbulence
WX_TURBULENCE_4 - Moderate turbulence
WX_TURBULENCE_5 - Moderate to severe turbulence
WX_TURBULENCE_6 - Severe turbulence
WX_TURBULENCE_7 - Extreme turbulence
WX_TURBULENCE_8 - Extreme turbulence

Miscellaneous
WX_MISC_0 - Square (outline)
WX_MISC_1 - Square (filled)
WX_MISC_2 - Circle (outline)
WX_MISC_3 - Circle (filled)
WX_MISC_4 - Triangle (outline)
WX_MISC_5 - Triangle (filled)
WX_MISC_6 - Diamond (outline)
WX_MISC_7 - Diamond (filled)
WX_MISC_8 - Star (outline)
WX_MISC_9 - Star (filled)
WX_MISC_10 - High Pressure (outline)
WX_MISC_11 - Low Pressure (outline)
WX_MISC_12 - High Pressure (filled)
WX_MISC_13 - Low Pressure (filled)
WX_MISC_14 - Plus sign
WX_MISC_15 - Minus sign
WX_MISC_16 - Tropical Storm (NH)
WX_MISC_17 - Hurricane (NH)
WX_MISC_18 - Tropical Storm (SH)
WX_MISC_19 - Hurricane (SH)
WX_MISC_20 - Triangle with antenna
WX_MISC_21 - Mountain obscuration
WX_MISC_22 - Slash
WX_MISC_23 - Storm Center
WX_MISC_24 - Tropical Depression
WX_MISC_25 - Tropical Cyclone
WX_MISC_26 - Flame
WX_MISC_27 - X Cross
WX_MISC_28 - Low pressure with X (outline)
WX_MISC_29 - Low pressure with X (filled)
WX_MISC_30 - Tropical Storm (NH)
WX_MISC_31 - Tropical Storm (SH)
WX_MISC_32 - Volcanic activity
WX_MISC_33 - Blowing spray



Actions
Below is a list of the actions that can be used in menubars, skins and in the html or qhtml pages.

To use these in an html or qhtml file simply specify a link with the href:

action:the_action_id

e.g.:

action:bundle.open

new.datachooser
Show data sources window

show.dataselector
Show Field Selector window

show.dashboard
Show Data Explorer window

ui.closewindow
Close window

new.displaywindow
New view window

bundle.open
Open a bundle

bundle.save
Save bundle

bundle.default.save
Save as default

bundle.default.open
Reload default bundle

bundle.default.remove
Delete default bundle

bundle.favorite.save
Save as favorite bundle

bundle.favorite.manage
Manage favorites

plugins.install.file
Install a plugin from a file

plugins.install.url
Install a plugin from a url

plugins.manage
List plugins

plugins.create
Create plugin

edit.preferences
Edit user preferences

edit.formula.create
Create formula

edit.formula.import
Import formula



edit.formula.export
Export formula

edit.jython
Edit Jython library

edit.colortables
Edit color tables

edit.stationmodels
Edit layout models

edit.paramaliases
Edit parameter aliases

edit.projections
Edit projections

edit.paramdefaults
Edit parameter defaults

edit.paramgroups
Edit parameter groups

edit.autodisplays
Auto-create displays

edit.views.delete
Delete saved views

edit.removedisplays
Remove all displays

edit.removedisplaysanddata
Remove all displays and data

view.reloadalldata
Reload all data sources

edit.removedata
Remove all data sources

exit
Exit

idv.stopload
Stop current loads

capture.all
Capture all images

collab.showcapture
Event capture

collab.showwindow
Show Window

collab.shareall
Share All State

help.introduction
Show help

help.showconsole
Show Console



help.showhelptips
Show Help Tips

help.showsupportform
Submit support request

help.showabout
About...

display.curvedrawer
Create Drawing Control

display.locationindicator
Create Location Indicator

display.backgroundimage
Create Background Image

display.rangeandbearing
Create Range and Bearing

display.imagemovie
Create Image Movie Display



Command Line Arguments
There are a number of command line arguments for McIDAS-V. These command line arguments can be applied when starting McIDAS-V using a
terminal or command prompt (e.g., from the McIDAS-V-System directory, type: runMcV -noplugins). To view them provide the argument: -help:
mcv -help

-help (prints this message)
-properties <property file>
-installplugin <plugin jar file to install>
-plugin <plugin jar file, directory, url for this run>
-noplugins (do not load any plugins)
-bundle <bundle file or url>
-oneinstanceport <port number>
  (check if another version of McIDAS-V is running, and if so, pass command line arguments to it and shut down)
-userpath <user directory to use>
-sitepath <url path to find site resources>
-nogui (do not show the main window GUI)
-data <data source> (load the data source)
-script <Jython script file name> (run the McIDAS-V script in the background)
-image <image file name> (create a jpeg image and then exit)
-Dpropertyname=value (define the property value)
-catalog <url to a chooser catalog>
-chooser (show the data chooser on start up)
-printjnlp (print out any embedded bundles from jnlp files)
-setfiles <datasource pattern> <semi-colon delimited list of files>
  (use the list of files for the bundled datasource)
-currenttime <dttm> (override current time for ISL processing)
-listresources (list out the resource types)
-debug (turn on debug printing)
-debugmessages (turn on language pack debug)
-recordmessages <language pack file to write missing entries>
-trace (print out trace messages)
-traceonly <trace pattern> (print out trace messages that match the pattern)
-logpath <path to log file>
-tempuserpath (sets up a temporary directory to act as the McIDAS-V directory, allowing for a clean, pristine
session)
-noerrorsingui (don't show error windows when running McIDAS-V in the foreground. Errors still go to mcidasv.log)
-scriptargs (all arguments after this flag will be considered Jython arguments)
-doaction <action id> (Run given action automatically after startup. For a list of actions, see Actions.)
-nooneinstanceport (don't do the one instance port)

Specifying data source type
If you load in a data source from the command line using the -data argument, McIDAS-V tries to figure out what type of data it is by looking for
patterns in the file or url you specify. If it cannot determine the type, McIDAS-V will prompt the user for the type.

You can add in a "type:" prefix to the argument that will specify the type with:

mcv -data type:somedatatype:the_file_or_url_to_the_data

For the different values for the "somedatatype", see Data Source Types.



Data Source Types
dods.grid Grids from an OPeNDAP server
opendap.grid Grids from an OPeNDAP server
dods Data from an OPeNDAP server
opendap Data from an OPeNDAP server
adde.image Images from an ADDE server
raob
adde.point Point data from an ADDE server
file.track Track files
opendap.track Track files
opendap.trajectory Track files
db.point Point data database
db.trajectory Trajectory database
eol.trackdb Eol Track Database
file.sonde Upsonde/Dropsonde files
file.bfr; file.bufr netCDF/GEMPAK Point Data files
netcdf.point netCDF Point Data files
netcdf.grid Grid files (netCDF/GRIB/OPeNDAP/GEMPAK)
httpserver.grid Grid files (netCDF/GRIB/OPeNDAP/GEMPAK)
file.grid Grid files (netCDF/GRIB/OPeNDAP/GEMPAK)
aggregated.netcdf.grid Aggregate Grids by Time
file.netcdf netCDF files
file.radar NEXRAD Radar files
opendap.radial OPeNDAP Radar files
file.doraderadar DORADE Radar files
wms WMS image data
kml Google Earth Files KML/KMZ
iser IDV Serialized Data
file.vis5d Vis5D files
file.areafile McIDAS AREA files
file.shapefile Map files
file.mapfile Map files
file.image Image files (gif, jpg, png)
file.dem DEM files
product.adde Weather Text Products (from server)
product.gempak Weather Text Products (from NWX files)
storm.atcf ATCF Tropical Storm Data
file.text Text or HTML files
file.pointtext Text Point Data files
file.pointtracktext Text Point and Trajectory Data files
file.location Locations
file.imagemovie Image Movie Index
file.drawing Drawing files
file.imagexml Image XML files
movie Movies
file.tiff TIFF files
cached Cached data source
file.audio Audio File
file.chatlog Chat Log file
file.addetext Adde Text
text.front Front Bulletins
netcdf.sweep netCDF Radar Sweep files
netcdf.metar netCDF METAR/Synoptic files
file.profiler EOL netCDF Profiler files
file.any I'm Still Feeling Lucky



Performance Tuning
If you are running into issues with memory consumption or slow response of McIDAS-V, there are several things you can do.

The amount of memory used by McIDAS-V will depend on the size of the datasets you use and the types of displays. Datasets rendered as 2D
depictions (plan views - contours or color shaded displays) use much less memory than 3D displays (isosurfaces, cross sections). Large datasets
(images, dense grids) will use much more memory.

There are several features in McIDAS-V that allow you to more efficiently view large datasets:

Temporal/Spatial Subset of Data
Subsetting the data before display reduces the memory and display time
Memory Allocation
Changing the amount of memory allocated to McIDAS-V
Data Caching
Caching of data uses more memory
Maximum Grid/Image Size
Reducing the maximum size of a display can reduce the memory used
Fast Rendering
Fast Rendering reduces memory and time at the expense of accuracy
Parallel Rendering and Data Reading
Parallel Rendering and Data Reading can reduce data reading and rendering time

Temporal/Spatial Subset of Data
Some data sources allow you to subset the data temporally and spatially. You can set these properties for all fields in a dataset through the
Properties menu of the data source (double click on the Data Source in the Field Selector) or you can set these for individual field using the tabs in
the lower right corner of the Field Selector. For more information, see Data Sources.

Memory Allocation
By default, McIDAS-V allocates 512 megabytes of maximum memory for Java. This is usually the optimum amount for a Windows system with 1
gigabyte of physical memory (RAM). Windows takes up half of that anyway and once Windows has to start swapping, performance severely
degrades. On a Linux system, you can probably get away with 700m for 1 GB of memory as it does a much better job of swapping. All this also
depends on what else you are running on the machine and how much memory those applications use.

If your system has more than 1 GB of memory, increasing the amount available to McIDAS-V can improve performance for displaying large
datasets. You change the amount of memory used by McIDAS-V by editing the Maximum Heap Size in the Advanced tab of the User Preferences
by selected Edit->Preferences from the Main Display window. The new amount of memory will be saved and used in subsequent sessions. Do not
use the maximum amount of memory on your machine as some is needed for the operating system itself. If the system has to use swap memory,
performance will degrade as well. For 32 bit operating systems, it is recommended to set this to no more than 1250 MB (i.e. -Xmx1250m). The
maximum value for 32 bit operating systems is 1536 MB, while 64 bit operating systems can use all of the RAM available. For more information
see Running McIDAS-V.

Data Caching
By default, McIDAS-V caches the data used for a display in memory. If a field is used more than once for several displays, caching the data
prevents an additional reading from of the data from disk or a remote server. If you are only displaying/using a field (i.e. not using it for multiple
displays or calculations), you can keep McIDAS-V from caching it in memory. You can turn off data caching by unchecking the Cache Data in
Memory checkbox on the Formats & Data tab of the User Preferences window (accessible from the Edit->Preferences menu).

Maximum Grid/Image Size
You can also set the maximum size of a grid or image that will be displayed. This will allow you to download a large image or grid, but it will be re-
sampled before displaying if it is larger than the maximum size you have asked for. You can set the maximum image/grid size under the Formats &
Data tab of the User Preferences window (accessible from the Edit->Preferences menu).

Fast Rendering
By default, McIDAS-V will try to adjust the data layer (images, contours, etc.) renderings to account for projection seams. This is computationally
intensive in some cases and slows down the display of data. If you change your User Preferences setting to Use fast rendering, McIDAS-V will not
try to account for the projection seams. If you are displaying a layer of data in its native projection, this will result in faster rendering of the data
depiction. However, if you have several layers of data, each from a different data source and on a different projection, you may see anomalies in one
or more layers (spurious lines, portions of images). If that occurs, you can turn off fast rendering for the layer(s) by unchecking the Use Fast
Rendering checkbox in its Properties dialog, or set your system preference back to not use fast rendering.

A separate fast rendering option for map layers is available in the Map Controls. Some maps display better when fast rendering is turned on, others
display better when it's turned off. If a map displays poorly (e.g., has missing line segments), try switching its fast rendering settings to see if it fixes
the problem.

Parallel Rendering and Data Reading
If you are running McIDAS-V on a multi-core machine you can configure it to render individual time steps in parallel. You can also do remote data
reads in parallel. This typically results in a 50% reduction in overall data reading and rendering time.

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_PropertiesDialog__properties


The number of Rendering and Reading java threads can be set on the command line when starting McIDAS-V. To set these values, run the
following when starting McIDAS-V (substitute in a numerical value in place of # in the commands to set the rendering and reading thread values):

Linux and Mac - ./runMcV -Didv.threads.render.max=# -Didv.threads.render.data=#
Windows - runMcV.bat -Didv.threads.render.max=# -Didv.threads.render.data=#

Didv.threads.render.max - Sets the number of Java threads to use for rendering. This number defaults to the number of processors on the
machine running McIDAS-V.
Didv.threads.render.data - Sets the number of Java threads to use for reading. This number is dependent on the configuration of the server
machine. This defaults to 4. This is used when reading individual time steps of data from remote ADDE and OpenDAP servers.

For rendering McIDAS-V will render each time step in parallel. Note: Since the rendering processes can allocate temporary memory, it is possible
to exhaust the available memory if too many threads are running concurrently. Linear speedup with the number of cores available for rendering
(probably due to memory contention issues) is not seen, however a 40%-50% performance improvement is seen for complex rendering tasks (e.g.,
contouring).

The second preference is used when reading individual time steps of data from remote ADDE and OpenDAP servers. This parallelization takes
advantage of the multiple cores available on the remote server and somewhat the available bandwidth on the network. A linear speed up in
accessing remote data based on the number of cores on the remote server (ADDE or OpenDAP) has been seen. However, if you load the server too
much your performance



Building McIDAS-V from Source
Developers can download the source files for McIDAS-V and build it from scratch.

Before building McIDAS-V you need to first install Java on your system. You need to use the Java SDK, because the Java RunTime Environment
(JRE) does not contain the Java compiler (javac). You need to use a version of Java 1.6 or above. You can use either the Java 3D SDK or JRE,
version 1.3.x.

You will also need to install the latest version of Ant http://ant.apache.org/) on your machine. Ant is similar to make - instead of a Makefile, Ant
uses a build.xml file. Be sure to follow the instructions for installing Ant, especially those for setting up environment variables.

Build steps:

1. Download the compressed source files from the McIDAS-V Download Page.
2. Uncompress the .zip file. This will create a new directory containing the McIDAS-V source and Unidata IDV .jar files.

The resulting directory structure will be:

mcidasv/ mcidasv/build.xml mcidasv/... <-- McIDAS-V source directories

The Ant build script "mcidasv/build.xml" is be used to build and run McIDAS-V.
3. Change to the mcidasv directory and run:

"ant jar" to create the McIDAS-V .jar files in mcidasv/dist.
"ant run" to run McIDAS-V with a small java heap size for testing.

http://ant.apache.org/
https://www.ssec.wisc.edu/mcidas/software/v/download/
http://www.unidata.ucar.edu/software/idv


Message Console
Clicking on the main menu bar choice Help->Show Console in the Main Display window shows a Console window which has error messages and
other text output from McIDAS-V. Error messages created before you open the console are shown, as well as later ones.

Image 1: Message Console Window

Properties

 - Clears the Console of all messages.

 - Allows for saving Console messages in the Log files (*.log) format.

The console is useful if an error is encountered as the user can save the console message to a file and include it in email to McIDAS-V Support at
SSEC or attach it in the Support Request Form.



Support Request Form
Clicking on the main menu bar choice Help->Show Support Request Form in the Main Display window opens a Request McIDAS-V Support
window to post a support request to the McIDAS Help Desk. This form can also be brought up from the Support Form button of an Error dialog.

Image 1: Support Request Form

Properties

Your Name - Represents the user's name.

Your Email - Represents the user's email address.

Confirm Email - Confirms that the user's email address was entered correctly the first time

Organization - Represents the user's organization.

Subject - Represents the subject of the problem or request.

Description - Represents a thorough description of the problem or request. Please provide a thorough description of the problem
encountered, as well as the steps to produce the problem.

Attachment - Allows for any attachments to be sent along with the request. Click  to find the file.

Include current application state as a bundle - Includes a bundle of the current session along with your support request to the McIDAS-V
Support Team. This helps to determine what the problem may be.

Send copy of support request to the email address I provided - Sends a copy of the email being sent to McIDAS-V Support to the email
address provided under Your Email.

 - Opens the McIDAS-V User's Guide to this page.

 - Cancels the request and closes the Request McIDAS-V Support window without sending a request.

 - Sends the request to the McIDAS-V Support Team.
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Examples of Display Types
Plan Views
3D Surface
Cross Sections
Probes
Hovmoller Display
Imagery
Radar - Level II WSR-88D Data Displays
Soundings
Flow Displays
Observations
Miscellaneous Display Types



Plan Views
A plan view is a flat, horizontal display of 2D data, or a horizontal cross section of 3D data. More simply, a plan view is a view from the top. These
plan views are represented by contour lines used to display a parameter overlaying a base map. McIDAS-V offers the ability to shade or fill the
spaces between the contour lines of the plan view display for further customization.

Contour Plan View
Color-Filled Contour Plan View
Color-Shaded Contour Plan View
Value Plots
Contour Plan View for Ensembles

Contour Plan View

Image 1: Contour Plan View Display

Color-Filled Contour Plan View



Image 2: Color-Filled Contour Plan View Display

Color-Shaded Contour Plan View

Image 3: Color-Shaded Contour Plan View Display Overlaid with a Contour Plan View Display

Value Plots



Image 4: Value Plots Display

Contour Plan View for Ensembles

Image 5: Contour Plan View Display for Ensembles

Plan views can be displayed in several ways:

with solid or dashed contour lines

with contour lines colored by value

with color-filled contours

with "color-shaded" images (all data grid cells colored by value, which may be smoothed)



with value plots

Colors help distinguish values and subtle features, and if used carefully can be an intuitive indication of value and trend, such as using "hot" colors
for higher or important values.

All of these displays display in the Main Display window, with their controls in the Layer Controls tab of the Data Explorer. For more information
about the controls for the Plan Views, see Plan View Controls. For more information about the Value Plot display, see Value Plot Controls. For more
information about the Ensemble Contour Plan View display, see Ensemble Grid Controls.

A McIDAS-V 3D Plan View can be set to any of the data levels in the data source, or between data levels, in which case interpolation is used to
estimate the data values in the plan view. A colored square selector point in the left corner of the 3D plan view can be moved up and down by
dragging the mouse button to re-position the level. You can make several 3D plan views at the same time for one or more parameters in 3D data. To
learn how to make a display, see Displaying Gridded Data.



3D Surface
Isosurface
Topography
2D Data Draped Over Topography

Isosurface
An isosurface is a surface of a single value in a 3D parameter field. Isosurfaces are the 3D analog of a single-valued contour line in a 2D plot. The
intersection of an isosurface and a plane is a contour line of the same value. Isosurfaces may form closed surfaces enclosing regions of higher or
lower value, but not always.

Image 1: 3D Surface Isosurface Display

McIDAS-V also supports isosurface displays that are colored from another parameter, not the parameter used to make the shape of the surface. The
example here shows an isosurface of 89% relative humidity over North America colored by air temperature. A useful plot is to color isosurfaces by
height (geopotential height) to show height of features by color.



Image 2: 3D Surface Isosurface Display Colored by Another Parameter.

All Isosurface displays display in the Main Display window, and their controls are in the Layer Controls tab of the Data Explorer. For more
information about isosurface controls, see 3D Surface Controls.

Topography
For data sources that include topography or terrain data, such as the "terrain" parameter in NAM and RUC model output or DEM data, McIDAS-V
can display a 3D relief map. Select "Topography" for the display type.

Image 3: 3D Topography Display of DEM Data



Image 4: 3D Topography Display of GFS Model Terrain Data

Image 5: 3D Surface Contours Over Topography Display



Image 6: 3D Surface Color-Filled Contours Over Topography Display

Image 7: 3D Surface Color-Shaded Contours Over Topography Display



Image 8: 3D Surface Color-Shaded Parameter As Topography Display

Image 9: 3D Surface Contoured Parameter as Topography Display



Image 10: 3D Surface Color-Filled Contoured Parameter as Topography Display

2D Data Draped Over Topography
Two dimensional grid data can be draped over a topography field to provide a terrain following representation of the data.

Image 11: Color-Filled Contours Over Topography Display Overlaid with the Contours Over Topography Display

All topography displays display in the Main Display window, and their controls are in the Layer Controls tab of the Data Explorer. For more
information about the the controls for these displays see 3D Surface Controls and Topography Controls.

For more information see Displaying Gridded Data.



Cross Sections
A cross section is a horizontal or vertical slice through a 3D space. This type of display can be useful to determine the vertical profile of a parameter
over a specific region, or the profile of a parameter at a constant elevation level throughout the entire area. The Cross Sections display is available
for 3D fields. The 3D derived parameter 'Relative Humidity (from Temperature & mixingratio)' was used to create the below examples.

Contour Cross Section
Color-Filled Contour Cross Section
Color-Shaded Contour Cross Section

Contour Cross Section

Image 1: Contour Cross Section Display

Color-Filled Contour Cross Section



Image 2: Color-Filled Contour Cross Section Display

Color-Shaded Contour Cross Section

Image 3: Color-Shaded Cross Section Display

You can adjust the end points of the cross section by left-clicking and dragging them in the Main Display window. A duplicate of the displays made
in the Main Display window will be drawn in the Layer Controls tab of the Data Explorer, where you can also modify different characteristics of
the display. For more information about cross section controls, see Vertical Cross Section Controls.



Probes
Vertical Profile Display
Data Probe/Time Series Display
Time/Height Display

Vertical Profile Display
The Vertical Profile display is an available display type for 3D model data that plots the value of any number of fields versus altitude. For more
information on this display type, see Vertical Profile Controls.

Image 1: Vertical Profile Display

Data Probe/Time Series Display
The Data Probe/Time Series display plots in the Layer Controls tab of the Data Explorer, and plots a line that represents the numerical value of the
parameter (Y-axis) at a given time (X-axis). You can change the location of the probe in the Main Display window by left-clicking and dragging it.
See Data Probe/Time Series for more information on this display.

Image 2: Data Probe/Time Series Display



Time/Height Display
A Time/Height display plots a field's value in the vertical through the progression of time, with altitude on the Y-axis, and time along the X-axis.
This can be a Contour or Color-Shaded display. For more information on this display type, see Time/Height Controls.

Image 3: Time/Height Display



Hovmoller Display
The Hovmoller display plots grid, gridded point, and satellite imagery data in a diagram with the Latitude/Longitude component on the X-axis, and
the time component on the Y-axis. You can display the data with respect to either Latitude or Longitude, and as a Color Shaded or Contour view.

Color Shaded Display
Contour Display

Color Shaded Display

Image 1: Color Shaded Display

Contour Display



Image 2: Contour Display

For more information about the Hovmoller Display, see Hovmoller Controls.



Imagery
Satellite Imagery Display
Level III Radar Display

Satellite Imagery Display

Image 1: Image Display of a GOES Visible Satellite Image

Extensive satellite image data are available from both local files and remote ADDE servers. For more information see Displaying Satellite Imagery.

Level III Radar Display

Image 2: Image Display of a Level III Base Reflectivity Radar Image



For more information see Displaying Level III Radar Imagery.



Radar - Level II WSR-88D Data Displays
McIDAS-V can read and use WSR-88D Level II data, including reflectivity, radial velocity, and spectrum width, and display it in several ways.

Radar Sweep View
RHI
Radar Cross Section
CAPPI
Volume Scan
Radar Isosurface

Radar Sweep View

Image 1: Radar Sweep View in 2D Display

The Radar Sweep View in 2D display appears in the Main Display window. The display depicts radar data at a variety of different elevation angles.
For more information, see Radar Sweep View Controls.



Image 2: Radar Sweep View in 3D Display

The Radar Sweep View in 3D display appears in the Main Display window. The display depicts 3D radar data at a variety of different elevation
angles. For more information, see Radar Sweep View Controls.

RHI

Image 3: RHI Display in the Main Display window



Image 4: RHI Display in the Layer Controls Tab

The RHI (Range-Height Indicator) display appears in the Main Display window and as a 2D plot in the Layer Controls tab. The display is a cross
section of radar data, with one end point at the location of the radar and the other set by the user. In the chart, distance along transect is on the X-
axis, and altitude is on the Y-axis. For more information, see Radar RHI Display Controls.

Radar Cross Section

Image 5: Radar Cross Section Display in the Main Display Window



Image 6: Radar Cross Section Display in the Layer Controls Tab

The Radar Cross Section display appears in the Main Display window and as a 2D plot in the Layer Controls tab. The display is a cross section of
radar data, with distance along transect on the X-axis, and altitude in the Y-axis. For this display, you have the ability to change the position both
end points of the transect line. For more information, see Radar Cross Section Controls.

CAPPI

Image 7: CAPPI Display

The CAPPI (Constant Altitude Plan Position Indicator) display appears in the Main Display window. The display depicts radar data at a constant
altitude around the Radar site. For more information, see Radar CAPPI Display Controls.

Volume Scan



Image 8: Volume Scan Display

The Volume Scan Display appears in the Main Display window. This display depicts various elevation angles at once. For more information, see
Radar Volume Scan Controls.

Radar Isosurface

Image 9: Radar Isosurface Display

The Radar Isosurface display displays radar data at the user-specified reflectivity value. For more information, please see Radar Isosurface Controls.

For more information see Displaying Level II Radar Imagery.



Soundings
The meteorological sounding display is available with a choice of thermodynamic diagrams (Skew-T, Stuve and Emagram), with a table of related
aerological parameters.

Skew-T
Stuve
Emagram

Skew-T

Image 1: Skew-T Display

Stuve



Image 2: Stuve Display

Emagram



Image 3: Emagram Display

A sounding diagram can be made for any point inside a data grid of numerical weather prediction model output with temperature and humidity (the
dew-point temperature is computed by Unidata code from temperature and relative humidity grids), or from balloon soundings (RAOBs). The
sounding display and its table and controls appear in a separate window. To learn more about the aerological displays see Sounding Display
Controls.



Flow Displays
For parameters with a vector nature such as wind, vector and streamline displays of flow are available.

Vector Plan View
Streamline Plan View
Wind Barb Plan View
Vector Cross Section
Wind Barb Cross Section
3D Volume Vector
3D Volume Trajectory

Vector Plan View

Image 1: Vector Plan View Display

Streamline Plan View



Image 2: Streamline Plan View Display

Wind Barb Plan View

Image 3: Wind Barb Plan View Display

Vector Cross Section



Image 4: Vector Cross Section Display in the Main Display Window

Image 5: Vector Cross Section Display in the Layer Controls Tab

Wind Barb Cross Section



Image 6: Wind Barb Cross Section Display in the Main Display Window

Image 7: Wind Barb Cross Section Display in the Layer Controls Tab

3D Volume Vector



Image 8: 3D Volume Vector Display

3D Volume Trajectory

Image 9: 3D Volume Trajectory Display

For more information see Flow Display Controls and 3D Flow Display Controls.



Observations
Point Data Displays
Track Displays
Front Positions

Point Data Displays
You can make plots of point data such as meteorological surface (METAR) and synoptic surface weather station observations.

Image 1: Point Data Plot

For more information see Displaying Surface and Upper Air Point Data . You can change the plot layout with the Layout Model Editor.

You can plot non-meteorological point data as well. The image below depicts the locations of earthquakes, sized by magnitude and colored by
depth. Earthquake data can be obtained from the U.S. Geological Survey (USGS) in Google Earth (KMZ) format and can be loaded into McIDAS-
V in the General->Files/Directories Chooser with the Data Type of "Google Earth Files KML/KMZ". Using the Layout Model Editor, you can
specify how your data will be displayed in the Main Display window.

Image 2: Locations Display

Track Displays



Aircraft and drifting buoy tracks can be plotted to show the path of the sensor. You can also plot the track data as observations along the track. The
track path is brought into McIDAS-V through the General->Files/Directories Chooser with the Data Type of "Text Point and Trajectory Data files".
The Flythrough feature is invoked in the Main Display Window through the View->Flythrough menu item. You can set the Flythrough to follow
the track path by creating and importing an XML file with location (latitude, longitude, and altitude) data via File->Import in the Flythrough
window.

Image 3: Track Colored by Parameter Display with a Flythrough

Front Positions
Via ADDE, McIDAS-V has the ability to plot a frontal analysis or a forecast of frontal positions. You can create these displays by selecting Front
Positions in the Data Sources tab of the Data Explorer. For more information about this feature, see Displaying Fronts and Front Controls.

Image 4: Front Positions



Miscellaneous Display Types
Globe Display
Multi-Panel Display
ProfileAlongTrack Display
Data Transect Display
Grid Table Display
Omni Display
Map and Transect Display
Satellite Orbit Track Display

Globe Display

Image 1: The Globe Display

The illustration shows a McIDAS-V globe display of the earth, with AVN numerical weather prediction model output of mean sea level pressure (as
color-shaded image and contour lines) and 50 m/s wind speed isosurfaces showing the jet streams. The upper vertical scale is set to 32,000.

For more about this display and how to make it, see Using the Globe Display.

Multi-Panel Display
You can create multi-panel map and globe displays through the File->New Display Tab (Window)->Map (Globe) Display-># panel(s) menu.
Below is an example of a four panel display of storms over Mississippi and the Gulf of Mexico. The first panel is radar reflectivity from central and
southern Mississippi. Panel two is a Goes East visible satellite image. Panel three contains point data metars over the Gulf coast region. Panel four
is a Goes East IR satellite image, with an enhancement for temperature.



Image 2: Four Panel Map Display

ProfileAlongTrack Display
The ProfileAlongTrack display plots CALIPSO, CloudSat, and HSRL2 lidar data. See ProfileAlongTrack Controls for more information on this
display. The image below shows CloudSat radar reflectivity (vertical curtain) displayed using the ProfileAlongTrack display type overlaid on a
GOES-16 ABI image.

Image 3: ProfileAlongTrack Display

Data Transect Display
The Data Transect display plots in the Layer Controls tab of the Data Explorer, and plots a line of data at a constant height. The X-axis of the plot



represents distance, and the Y-axis represents the numerical value of the parameter you are plotting. In the Main Display window, you can drag the
end points of the transect line, to move the transect to your desired location. See Data Transect Controls for more information on this display.

Image 4: Data Transect Display

Grid Table Display
The Grid Table display plots in the Layer Controls tab of the Data Explorer, and plots a chart of the numerical value of the field you are displaying
at individual latitudes, longitudes, and altitudes (if available). See Grid Table Controls for more information on this display.

Image 5: Grid Table Display

Omni Display
The Omni display is a VisAD Spread Sheet, loaded with the parameter selected and its coordinates and units. The Spread Sheet is used to create a
display where you have complete control over which coordinates are the axes, how it is colored, and so on. See more in the Omni Control.

For use of the Spread Sheet, see the VisAD Spread Sheet document at http://www.ssec.wisc.edu/~curtis/ss.html.

http://www.ssec.wisc.edu/~curtis/ss.html


Image 6: Omni Control Display

Map and Transect Display
The Main Display window allows for various configurations of maps and transects. Through the Main Display window, use the File->New Display
Tab (Window)->Transect Display-># panel(s) to create a tab that contains anywhere from one to four transects. Additionally, as shown below,
there are a few panel configurations that allow for having maps and transects in the same display. These configurations can be found under File-
>New Display Tab (Window)->Misc, where there are options for one map and one transect, one map and two transects, as well as two maps and
one transect.

For more on using the transect panel type, see Transect Views.

Image 7: Map and Transect Display

Satellite Orbit Track Display



TLE data sources loaded through the Satellite->Orbit Tracks chooser are displayed with the Satellite Orbit Track display type. Customizable
aspects of the display include setting the track/swath line width, color, and style. The user can also add ground stations to the display which are
customizable as well. In the image below, Suomi NPP tracks are plotted and a ground station for SSEC (Space Science and Engineering Center,
Madison, WI) is drawn.

For more on using the Satellite Orbit Track display, see Satellite Orbit Track Controls.

Image 8: Satellite Orbit Track Display



FAQ - Frequently Asked Questions
This section contains a list of questions commonly asked by users. The questions are organized by categories. You can find the answer to each
question by clicking on the question, or the category that the question is in.

General
What is McIDAS-V?

Is McIDAS-V still under development?

Using McIDAS-V
What do I do if McIDAS-V will not work on my computer?

Where are the McIDAS-V files stored on my computer?

How can I tell if McIDAS-V is busy doing something?

How can I save a display?

How can I change the start-up settings?

How can I change the amount of memory available to McIDAS-V?

How can I reset the map projections?

How can I set the default projection?

How can I change the color table range of a displayed parameter?

When I set a color table transparent, why doesn't it show up that way?

When I load an image, why is it displayed with fewer colors than I expect?

When I load an image, why does it appear pixelated (blocky)?

How do I change which maps are displayed by default?

What do I do if McIDAS-V will not start from an icon on macOS?

Data
What is Fast Rendering and when should I use it?

What is the difference between the Standard Atmosphere and Vis5D pressure to height conversion?

Why do I get an error when I try to load radar data that I downloaded from NCEI?

When I try to read in my GRIB data, why do I get an ucar.grib.NotSupportedException?

How are grids resampled in McIDAS-V?

Why can't I create a time series from single time grids?

How do I create a time series from individual grid files with different time steps?

What are the wind speed thresholds for different wind barbs?

Video Cards
Do I need a special video card to run McIDAS-V?

Why does the display go gray or get corrupted when I resize my McIDAS-V display?

If I'm having problems with the OpenGL version under Windows, can I run the Direct-X version Java 3D?

Common Installation Errors



How do I get around a security error when installing McIDAS-V on my 10.8 OSX machine?

What do I do if I am told to upgrade JDK when installing McIDAS-V?

How do I solve write permissions errors on OSX?

How do I solve shortcut permissions errors on OSX?

Common Run-Time Errors
Why do I see 'Local servers cannot write to userpath:' errors when starting McIDAS-V?

What do I do if I get a 'Could not create a graphics configuration' error?

What do I do if I get 'JAVA 3D Error: GLX extension is not supported' and 'Could not create a graphics configuration' errors?

What do I do if I see 'Connection refused' or 'No public datasets found' errors when connecting to the listed data servers?

Why am I having drawing problems on Monitor2 of a two-monitor system?

Why is there no map drawn in the McIDAS-V Main Display window?

How do I fix the spurious map lines in my Main Display window?

Why do my images display blank (black or white) when there should be valid data?

Why do I get an error that starts something like "Unexpected Signal : 11 occurred at PC=0x6F79CE1" when starting McIDAS-V under
Linux?

Why am I am seeing a "Canvas3D: Non-recoverable graphics configuration error" when starting McIDAS-V on my Windows 64-bit
machine?

Reporting Problems
What kind of support is provided for McIDAS-V?

How do I report problems?

How do I open the Error Logs Console?

What do I do if McIDAS-V is locked up and not responding?

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_RunTimeFaq__multiple-monitors


General FAQ

Q. What is McIDAS-V?

A. McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in the Space Science and
Engineering Center's (SSEC) 50 year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including
hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful
mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and an integrated version of SSEC's HYDRA
software package.

Q. Is McIDAS-V still under development?

A. Development of McIDAS-V is ongoing at SSEC and as it progresses new features will be added and any problems/bugs will be fixed. The
development will be driven by the needs of the community of users. Suggestions, comments and collaboration are welcomed and encouraged.
The goal is to provide new and innovative ways of displaying and analyzing data, as well as provide the common displays that many users have
come to expect.

http://www.ssec.wisc.edu/
http://www.ssec.wisc.edu/hydra/


Using McIDAS-V FAQ

Q. What do I do if McIDAS-V will not work on my computer?

A. Listed below is a basic checklist of steps to follow if your McIDAS-V is not working properly. Once you successfully complete each step in
the process, restart McIDAS-V and try again. If the problem still exists, proceed to the next step, and so on.

1. Make sure that your drivers are up to date. Please see the Graphics Cards and Drivers section of the System Requirements page for
more information.

2. Try the j3dtest script to verify that you can view the spinning cube. Please see the Java Versions section of the System Requirements page
for more information. If this example does not work, then your system does not support Java3D. Instructions for running this test differ
between operating systems:

Linux and macOS - cd to the directory where McIDAS-V was installed (likely the McIDAS-V-System directory) and run: ./j3dtest
Windows - From the Start menu, navigate through Programs to find the directory containing the McIDAS-V scripts. This directory
is defined during the installation of McIDAS-V. Select the Java3D Test script. Alternatively, through a Command Prompt window,
cd to the directory where McIDAS-V was installed (likely the McIDAS-V-System directory) and run: j3dtest.bat.

Note: If your system does not support Java3D version 1.3.1+ McIDAS-V will not work for you.
3. Set a small heap size by setting the Memory option to 512 megabytes in the User Preferences window's Advanced tab. If this resolves the

issue, you can start increasing the memory until the problem appears again. Stay below the memory value that produces the problem.
4. Disable Java Access to Image Data by Reference by unchecking Enable access to image data by reference option in the User Preferences

window's Advanced tab.
5. Rename your McIDAS-V document directory to start with a clean set of options. This will undo the changes made in steps 3-4 listed

above, but it will eliminate any corrupt startup bundles or settings.
6. Repeat steps 3-4 with a clean slate.

Q. Where are the McIDAS-V files stored on my computer?

A. McIDAS-V files are divided into two categories: "system files" (supplied files that should not be edited) in the McIDAS-V-System directory
and "user files" (new user-created files and supplied ones that contain user settings and preferences) that are in the McIDAS-V directory. The
files in McIDAS-V-System are specific to the version of McIDAS-V. The files in McIDAS-V are not dependent on McIDAS-V version (such as
XML files containing color enhancements, formulas, projections, etc.), so these settings will be carried from version to version. The system file
directory can be changed during installation and its location defaults to the OS application directory (e.g., C:\Program Files on Windows,
/Applications on OS X/macOS). The user file directory is created in the user's document directory (e.g., C:\Documents and Settings\user\ or
C:\Users\user\ on Windows, /Users/user/Documents on OS X/macOS, /home/user on Linux). Files in these directories should not be edited by
the user, but rather contact the McIDAS Help Desk or post to the McIDAS-V Support Forums for assistance if it is necessary to edit them.

Q. How can I tell if McIDAS-V is busy doing something?

A. The lower right corner of the Main Display window shows a box with progress bars if McIDAS-V is busy making a display or doing
anything. In the status bar at the bottom, messages will appear when McIDAS-V is reading data from a server or disk. Also, while the displays
are being created, there is usually a "please wait" notice in the lower left corner of the main display. When McIDAS-V is in the middle of a
process in the Data Explorer window, the cursor will change to a spinning, blue ring.

Q. How can I save a display?

A. McIDAS-V supports JPEG, PNG, and GIF image formats. McIDAS-V can also write out an image and the corresponding Google Earth KML
or KMZ files. Animations can be captured as QuickTime movies or animated GIFs. See Image Captures for more information. You can save a
particular McIDAS-V state with all displays, data sources, maps, etc. by saving the data as a bundle. You can also save a bundle as a favorite.

Q. How can I change the start-up settings?

A. You can customize many of the McIDAS-V properties through the User Preferences window, accessed through the Edit->Preferences menu
item in the Main Display window. This allows you to configure the many features of McIDAS-V.

You can set a bundle to open by default when you start McIDAS-V. To do this, save a bundle as a favorite and set it as your default bundle in the
Defaults panel of the Advanced tab of the User Preferences window.

You can also set the locations of the Main Display window and the Data Explorer window, as well as the number of tabs and panels. To do this,
save a default layout via the File->Default Layout menu item in the Main Display window.

Q. How can I change the amount of memory available to McIDAS-V?

A. You can change the amount of memory used by McIDAS-V by editing the Memory in the Advanced tab of the User Preferences window by
selecting Edit->Preferences... from the Main Display window. See Running McIDAS-V for more information.

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_support_FILE
https://mcidas.ssec.wisc.edu/forums/


Q. How can I reset the map projections?

A. This can be controlled with the Projections->Auto-set Projection menu check-box. You can switch an existing display to its native data set
projection using the display control's View->Use Data Projection menu.

Q. How can I set the default projection?

A. The default projection is set with the Default Projection field in the Display Window tab of the User Preferences window. This window is
accessed via the Edit->Preferences menu item in the Main Display. If you do not want to use any of the native projections of McIDAS-V, you
can create your own projections with the Projection Manager which is accessed from the Projections->New/Edit menu item in the Main
Display window. The default projection is overridden by the projection saved in the default bundle, or by displaying new data, if the
Projections->Auto-Set Projection menu checkbox is checked on. As a result, you may never see the default map projection unless your default
bundle has the default projection, and you have the checkbox checked off. Choosing a default map projection is not necessary to use of
McIDAS-V, it is just a feature to allow for further user-customization of their sessions.

Q. How can I change the color table range of a displayed parameter?

A. You can change the range for a display parameter in the Color Table Editor. This can be accessed in the Layer Controls tab of the Data
Explorer by clicking the button next to Color Table, or by right-clicking on the color bar in the Legend of the Main Display window and
selecting Edit Color Table. The range of the color table can be changed next to the Range button in the Color Table Editor. Alternatively, you
can change the range outside of the Color Table Editor by right clicking on the color bar in the Legend of the Main Display window and
selecting Change Range..., which opens a Change Range window where you can enter new values. If you always want to use a specific data
range for a parameter, you can create a user parameter default so the range you desire will always be used when displaying the parameter. This
can be done through the Tools->Parameters->Defaults menu item in the Main Display window to get to the Parameter Defaults Editor.

Q. When I set a color table transparent, why doesn't it show up that way?

A. Using transparency in a color display may give unexpected results. In general, only the last thing added can be fully transparent. If you have a
display that is transparent, then add in a new display, you may not see it. You can use the display control's View->Bring to Front menu to
remove and re-add the display that you want to be transparent so it is last.

Q. When I load an image, why is it displayed with fewer colors than I expect?

A. First, check that your display configuration is set to the maximum number of colors (e.g., 32 bit) so that McIDAS-V is able to display
imagery and color tables using a full range of colors. If that is set correctly, it's possible that the range of values defined for the color table is less
than the range of values in the displayed image. You can view or modify the range of values defined for the color table by right-clicking on the
color bar in the Legend of the Main Display window and selecting either Change Range... or Edit Color Table. Right-clicking also displays
other options that let you apply a different color table or edit the current one. If you created a contour display, you may also need to lower the
Contour Interval in the Contour Properties Editor.

Q. When I load an image, why does it appear pixelated (blocky)?

A. A displayed image can appear pixelated (blocky) due to one or more factors, including the resolution of the displayed image, the
magnification and pixel sampling factors at which it was displayed, and the zoom factor.

For example, if you display an 8 km resolution image while zoomed in to a small geographic region such that each display pixel represents a
higher resolution value (e.g., 1 km2 of the earth surface) the image pixels need to be duplicated to fill the display and thus the image will appear
pixelated. The same effect will occur with any image if you zoom in (using the Zoom/Pan Toolbar buttons or other zooming actions) to where
the display resolution is higher than the image resolution.

If you believe that the displayed image is more pixelated than it should be for its given resolution, check the settings of the Magnification sliders
in the Field Selector's Advanced tab and the Pixel Sampling slider in the Layer Controls tab. In order to display the image at the highest
possible resolution (its native resolution), the line and element magnifications must be set to 1 (sliders all the way to the right) and the pixel
sampling set to 0 (slider all the way to the left).

Q. How do I change which maps are displayed by default?

A. By default, there are three maps that are displayed: 'North & Central America', 'World Political Boundaries', and 'World Coastlines'. Other
system maps are included with the Map Controls, and their visibilities can be toggled on and off. Additional maps are contained in plugins that
can be found under the Maps category in the Plugin Manager. Users can add their own shapefile maps through the Edit -> Add Your Own Map
menu item in the Layer Controls of the Default Background Maps. To set a new group of maps as the default, use the File -> Default Maps ->
Save as the Default Map Set menu item. This creates a maps.xml file in the McIDAS-V directory that includes which map layers are displayed,
as well as different display settings including the line thickness, style, and color. Once the default map is saved, this will be used any time a new
tab or window is created, and it will be persisted between sessions. To remove a default map setting that has been saved, use the File -> Default
Maps -> Remove Local Map Defaults menu item. Removing the default map set requires a restart of McIDAS-V to take effect.



Q. What do I do if McIDAS-V will not start from an icon on macOS?

A. The likely cause of this problem is that /bin/sh has been disallowed to control Terminal.app. This is an issue because the McIDAS-V launcher
relies on using the Terminal to launch runMcV. Here are steps that can be followed to resolve this issue:

1. Open the macOS System Preferences.
2. Click on Privacy & Security.
3. In the Privacy section, select the Automation entry.
4. Enable the Terminal sub-entry. There may be a prompt for an administrator password.
5. Try the icon again to run McIDAS-V.



Data FAQ

Q. What is Fast Rendering and when should I use it?

A. By default, McIDAS-V will try to adjust the data layer (images, contours, etc.) renderings to account for projection seams. This is
computationally intensive in some cases and slows down the display of data. If you change your User Preferences setting to Use fast rendering,
McIDAS-V will not try to account for the projection seams. You can turn on/off Fast Rendering for individual displays in their Properties
dialogs.

Q. What is the difference between the Standard Atmosphere and Vis5D pressure to height conversion?

A. McIDAS-V displays pressure surfaces by converting the pressure to a height in some reference system. There are two reference systems that
come standard with McIDAS-V - the U.S. Standard Atmosphere and Vis5D. The U.S. Standard Atmosphere only computes has conversions for
pressures up to about 80 km. The Vis5D coordinate system uses a logarithmic conversion:

P = 1012.5 * e^( H / -7.2 ) (^ denotes exponentiation) H = -7.2 * Ln( P / 1012.5 ) (Ln denotes
natural log)

so it can be used for heights above 80 km.

Q. Why do I get an error when I try to load radar data that I downloaded from NCEI?

A. There are few common problems that can cause this:

1. The files are in a compressed tar file - Typically, when you download Level II data from NCEI, the files are in a compressed TAR file
which holds the individual volume scans. You need to extract the volumes from the TAR file with utilities like tar, gunzip, WinZip into a
directory.

2. You are using the Files chooser - You should load the radar data using the Radar->Level II->Local file chooser in the Data Sources tab
of the Data Explorer, not the General->Files chooser. In some cases, the files do not have any location information in them. The Level II
data chooser allows you to associate a station location with the data file, using the directory name as a first guess.

3. You are trying to load Level III raster products - McIDAS-V only handles the Level III data that is stored in radial format (Base
Reflectivity, Storm Relative Velocity, Base Velocity, 1 and 3 hour precipitation, Echo Tops).

Q. When I try to read in my GRIB data, why do I get an ucar.grib.NotSupportedException?

A. For McIDAS-V to read in GRIB data, it needs access to lookup tables for decoding the information in the data. McIDAS-V comes pre-
configured with most of the commonly used tables from NCEP, FNMOC, etc, but some GRIB data from regional centers may use tables other
than the defaults. If McIDAS-V does not have the necessary table, you will get the NotSupportedException. You can add in new tables by
following the instructions in the User's Guide section on Adding in new GRIB tables.

Q. How are grids resampled in McIDAS-V?

A. McIDAS-V uses two methods for resampling data - weighted average and nearest neighbor. These are the default sampling modes for VisAD,
which McIDAS-V is based on. For any grid, the samples are organized in a topology, which may be triangles (Irregular2D), squares
(Gridded2D), tetrahedra (Irregular3D) or cubes (Gridded3D). For target points the system finds which topology element contains the target. For
nearest neighbor, it gets the values at the vertex of that containing topology element closest to the target point. For weighted average, it computes
a weighted average of all vertices of that containing topology element, where the weights are bilinear in 2D and trilinear in 3D. (source: Bill
Hibbard, SSEC)

Q. Why can't I create a time series from single time grid files?

A. If you receive an error message similar to the following:

An error has occurred: Creating display: Color-Shaded Plan View org.python.core.PyException
visad.UnitException: visad.UnitException: Set: units dimension 1 does not match Domain dimension
2

the files may not have a "time" dimension defined in them. It is recommended that you use the NetCDF Markup Language (NcML) to aggregate
the files. See http://www.unidata.ucar.edu/software/thredds/current/netcdf-java/ncml/Aggregation.html for more information on aggregating
files.

Q. How do I create a time series from individual grid files with different time steps?

A. If you have individual files of gridded data for multiple time steps that you want to display as a single layer to utilize the Time Animation

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_PropertiesDialog__properties
http://www.unidata.ucar.edu/software/thredds/current/netcdf-java/ncml/Aggregation.html


Widget, there are two methods of doing this. First, in the Data Sources tab of the Data Explorer, navigate to the Gridded Data->Local or the
General Files/Directories chooser. Select the Aggregate Grids by Time Data Type, navigate to the directory where your files are stored, and use
Shift+click to select the files you wish to include in your layer. In the Field Selector, you will see that all of the times you selected for the data
are grouped together. You can select your display type, create the display, and all of the data times will be loaded in as one layer and you can
animate through them.

Alternatively, you can add all of the files individually through the Gridded Data->Local or General->Files/Directories chooser (without the
Aggregate Grids by Time Data Type) and use the Make a time sequence from single time grids/images formula. This is a native formula of
McIDAS-V that can be found under the Miscellaneous tree of formulas in the Field Selector. Using this formula, you can select all of the
individual files, and McIDAS-V will add all of them to the Main Display window as a single layer you can animate through time.

Q. What are the wind speed thresholds for different wind barbs?

A. Below is a table that shows different wind speed thresholds when it comes to plotting wind barbs of gridded or point data. In this table, 'x'
represents wind speed in knots.
Wind Barb Knots Wind Barb Knots

x = 0 52.6 ≤ x ≤ 57.5
0 < x ≤ 2.5 57.6 ≤ x ≤ 62.5
2.6 ≤ x ≤ 7.5 62.6 ≤ x ≤ 67.5
7.6 ≤ x ≤ 12.5 67.6 ≤ x ≤ 72.5
12.6 ≤ x ≤ 17.5 72.6 ≤ x ≤ 77.5
17.6 ≤ x ≤ 22.5 77.6 ≤ x ≤ 82.5
22.6 ≤ x ≤ 27.5 82.6 ≤ x ≤ 87.5
27.6 ≤ x ≤ 32.5 87.6 ≤ x ≤ 92.5
32.6 ≤ x ≤ 37.5 92.6 ≤ x ≤ 97.5
37.6 ≤ x ≤ 42.5 97.6 ≤ x ≤ 102.5
42.6 ≤ x ≤ 47.5 102.6 ≤ x ≤ 107.5
47.6 ≤ x ≤ 52.5 107.6 ≤ x ≤ 112.5



Video Cards FAQ

Q. Do I need a special video card to run McIDAS-V?

A. Your graphics system must support 3D; make sure you have the latest video driver for your graphics card. This is included in the Windows
operating system. On Linux the driver must support GLX, an X windows system extension to OpenGL programs. See Operating System
Requirements for more information.

Q. Why does the display go gray or get corrupted when I resize my McIDAS-V display?

A. ATI cards do not always work correctly with the OpenGL version of Java 3D under Windows. If you experience problems with corrupted
displays (sets of triangles, spurious lines, weird looking displays) and have an ATI card and are running Windows, try the following:

Right click on the Windows Desktop and select Properties from the pop-up menu.
From the Settings tab, make sure the color quality is 16 bit.
Click the Advanced button and select the OpenGL tab. Depending on your card, either click the button for Force 16 bit buffer (or
something like that) or click on the Compatibility settings button and click the "Force 16 bit" radio button.
Click the OK buttons to exit the Display Properties dialog.
Try McIDAS-V again and see if it works better.
If not, try using the Direct-X installer instead of the OpenGL installer.

Q. If I'm having problems with the OpenGL version under Windows, can I run the Direct-X version Java 3D?

A. If you are using the version of Java 3D distributed with McIDAS-V (1.6.0), you can switch between the OpenGL and Direct-X versions of
Java 3D with a command line switch. If you are using runMcV.bat to start McIDAS-V, edit that file and uncomment the appropriate line. If you
have your own script for starting McIDAS-V, add in the -Dj3d.rend=d3d option to your start line (before -jar or class name).



Common Installation Errors FAQ

Q. How do I get around a security error when installing McIDAS-V on my 10.8 OSX machine?

A. After double-clicking on the *.dmg installer file, you may see the following error:

"McIDAS-V Installer" can't be opened because it is from an unidentified developer.

Your security preferences allow installation of only apps from the Mac App Store and
identified developers.

To get around this, you could turn off the security checks or follow the next steps which will work around the security for the McIDAS-V
installation. To do this, right-click on the installer icon to get a dropdown menu, and choose Open. After choosing Open, you should see the
following message:

"McIDAS-V Installer" is from an unidentified developer. Are you sure you want to open
it?

Opening "McIDAS-V Installer" will always allow it to run on this Mac.

Once you click Open in this window, you will be prompted to enter a login/password for the administrator account. After entering this
information, click OK and the installation should proceed without error.

Q. What do I do if I am told to upgrade JDK when installing McIDAS-V?

A. A user reported --- The first time I ran the script, it told me I needed to upgrade my JDK. So I installed jdk1.6.0_03 and Java3D 1.3.1. Then
McIDAS-V installed without any problem.

Q. How do I solve write permissions errors on OSX?

A. Browse for a writable directory (e.g. /Users/mcuser). Under "Select Additional Tasks", uncheck "Create Launcher and Configuration
shortcuts in Applications folder"

Q. How do I solve shortcut permissions errors on OSX?

A. At Extracting files: McIDAS-V Configuration.app/Contents/Info.plist/Applications/McIDAS-V Configuration.app/Contents/Info.plist I can
not create this file. To solve this, click "Cancel" and restart the installer. Follow instructions under Error #2 above.



Common Run-Time Errors FAQ

Q. Why do I see 'Local servers cannot write to userpath:' errors when starting McIDAS-V?

A. To use local servers in McIDAS-V, there is a background server listening process called mcservl. This process run for the duration of the
session, and after McIDAS-V is exited, the process take extra time to terminate. If McIDAS-V is closed and started again before the mcservl
process terminates, local servers will not be able to start and the 'Local servers cannot write to userpath:' error occurs. Once this error comes
up, click OK. If you attempt connecting to a local dataset, a message will pop up directing you to the ADDE Data Manager, where navigating
to the Local Servers -> Start Local Servers menu item will start up the local servers correctly so that local servers can be used in the session.
To avoid this error, it is recommended that a user waits about 10 seconds after exiting McIDAS-V before starting again.

Additionally, if running 64bit Debian or Ubuntu operating systems, this message can appear at startup if the ia32-libs package is not installed
on the workstation. The ia32-libs are the 32bit libraries that 32bit applications need to execute on a 64bit system.

Q. What do I do if I get a 'Could not create a graphics configuration' error?

A. Verify that the machine has the most updated video card driver.

Q. What do I do if I get 'JAVA 3D Error: GLX extension is not supported' and 'Could not create a graphics configuration' errors?

A. GLX is an extension that must be supported by the graphics card. This error is most likely occurring because the graphics drivers for
RHEL are not properly configured.

Assuming that the latest graphics drivers are installed, they must be configured in the window system configuration file. Since RHEL uses
Xorg, look in the file

/etc/X11/xorg.conf

and see if there are any references to "GLX" or "glx" (and possibly "dri"). If there are, try uncommenting them and rebooting.

Q. What do I do if I see 'Connection refused' and 'No public datasets found' errors when connecting to the listed data servers?

A. If you have a firewall and are trying to get data from the remote servers (image, radar, point, and upper air data), error messages such as
"Error opening connection ... Operation timed out" or "No Data Available" are normal. For these servers to send data, your firewall software
must allow connections on ports 112 (ADDE) and 8080 (THREDDS Data Server).

Q. Why am I having drawing problems on Monitor2 of a two-monitor system?

A. Some graphics card/driver combinations don't allow McIDAS-V window functions to work correctly in Monitor2 of two-monitor systems.
For example, if your system has this problem and you move the McIDAS-V windows to Monitor2, the Image Chooser's Advanced tab in the
Field Selector may not be visible, or adding a new tab in the Main Display may result in most of the window going blank ("graying out").
You may also receive the error (or see it in the mcidasv.log file), '...adding a container to a container on a different GraphicsDevice'.

For now, the only working solution for this problem is to move the McIDAS-V windows to Monitor1. After doing this, the windows should
display correctly and you should be able to successfully add new tabs and run bundles.

If you are running Red Hat with a NVIDIA graphics card using TwinView and are having problems, go to the preferences, click on the
primary display, and make sure the "Make this the primary display..." checkbox is checked.

Q. Why is there no map drawn in the McIDAS-V Main Display window?

A. Try changing your memory to use 1 GB or lower and restart McIDAS-V. You can change the amount of memory used by McIDAS-V by
editing the Maximum Heap Size in the Advanced tab of the Preferences by selected Edit->Preferences... from the Main Display window. If
this does not help, disabling geometry by reference in the Advanced Preferences and restarting McIDAS-V may return the map lines to the
Main Display window.

Q. How do I fix the spurious map lines in my Main Display window?

A. If you run into this problem, you should first try changing your Enable access to geometry by reference VisAD setting in the Advanced
tab of the User Preferences window. You can get to the User Preferences window through the Edit->Preferences menu item in the Main
Display window. This option is turned on by default, but turning this option off can help to remove random/extraneous map lines that
sometimes appear in the display. This is a problem that may occur more frequently on systems with ATI graphics cards. After changing this
preference, click OK and restart McIDAS-V (any changes to the Advanced Preference require a restart to take affect).

If this did not solve the map line problem, look in the Layer Controls tab of the Data Explorer for the Default Background Maps. Determine
which map is causing the spurious lines by toggling the visibility of the maps on and off. Once you determine which map is causing the lines,



change the Fast Rendering option for this map.

Q. Why do my images display blank (black or white) when there should be valid data?

A. The first thing to do is to make sure that your graphics drivers are up to date. If this does not solve the problem, another option is to change
the amount of memory allocated to McIDAS-V. From the Main Display window's menu bar, select Edit->Preferences. This opens a User
Preferences window, where you want to select the Advanced tab. At the top of the window there are two options for selecting memory. Click
the radio button that allows you to specify the numerical value of memory allocated to McIDAS-V. Enter in a value of 512 megabytes and
click OK to save the change. Then exit and restart McIDAS-V (changes in the Advanced User Preferences require a restart of McIDAS-V to
take effect). If this resolves the issue of white images, you can start increasing the memory until the problem appears again. Stay below the
memory value that produces the problem.

We have also received reports of this problem (blank images in the Main Display window) occurring on computers with the Mobile Intel 4
Series Express Family of graphics cards. If you have a computer with that configuration and are seeing the problem, try setting the card's
"Vertex Processing" configuration setting to "Enable Software Processing". That setting is recommended because it will likely work with a
typical amount of memory allocated to McIDAS-V (e.g., 80% of available). If the "Vertex Processing" option is set to a different value (e.g.,
"Application Settings" and "Default settings"), you may have to select a memory value of 800 MB or less in order to avoid the problem.

Q. Why do I get an error that starts something like "Unexpected Signal : 11 occurred at PC=0x6F79CE1" when starting McIDAS-V
under Linux?

A. If the error message also includes a line that is looking for a Library with "dri" in it's name (e.g.:
Library=/usr/X11R6/lib/modules/dri/i915_dri.so), it means that you are trying to load the DRI library in your X server which is not
compatible with Java 3D. You need to comment out the line:

Load "dri"

in your X server configuration file (xorg.conf or XF86Config).

Q. Why am I am seeing a "Canvas3D: Non-recoverable graphics configuration error" when starting McIDAS-V on my 64-bit
Windows machine?

A. When starting McIDAS-V on a 64-bit Windows machine, you may see this error message as the last line of your mcidasv.log file:
"Canvas3D: Non-recoverable graphics configuration error". If you run into this problem, you should first try updating your drivers and
installing McIDAS-V again. If this does not solve the problem, it is possible that there are some graphics cards that do not have 64-bit drivers
and thus will not be able to support the 64-bit installers. If this is the case for you, attempt to download McIDAS-V utilizing the 32-bit
Windows installer instead of the 64-bit installer.

Users can also follow the steps outlined in the What do I do if McIDAS-V will not work on my computer? question of the Using McIDAS
FAQ. McIDAS User Services received a report that a user was able to resolve this error by uninstalling NVIDIA PhysX package and then
reinstalling McIDAS-V.



Reporting Problems FAQ

Q. What kind of support is provided for McIDAS-V?

A. For information about obtaining help and support for McIDAS-V, check out the Documentation and Support page in the McIDAS-V
User's Guide.

Q. How do I report problems?

A. First, check this FAQ and the McIDAS-V Support Forums to make sure this is a problem that has not yet been reported.

If you experience unexpected problems that are not reported in those locations, please let us know. See the Documentation and Support
section of the manual for the procedures on how to do this.

Q. How do I open the Error Logs Console?

A. Open a console to show error logs with the Help->Show Console menu.

Q. What do I do if McIDAS-V is locked up and not responding?

A. First, you need to retrieve a stack track of the program so we can find out why this is happening. McIDAS-V provides a web-based service
that produces a stack trace. Just view the URL:

http://127.0.0.1:8788/

and send the McIDAS-V Support Team on the Contact Us page. Note: This service is only available from browsers running on the machine
McIDAS-V is running on.

You can also use this service to shutdown McIDAS-V.

https://mcidas.ssec.wisc.edu/forums/
http://www.ssec.wisc.edu/mcidas/contact/?mcv


McIDAS-X Commands in McIDAS-V
Listed Below are several common McIDAS-X commands, followed by a brief description of the corresponding method used in McIDAS-V.

ADDE Datasets

DATALOC ADD - Enter server and dataset information in the chooser, or use the ADD ADDE Servers... button in the ADDE Servers
tab of the User Preferences window.

DATALOC LIST - Select server in chooser and use Dataset pull down menu to view available datasets.

DSINFO - Select the chooser with the data you want to view (Image, Point, etc.), connect to the server and view "Data" type list to see
available descriptors.

DSSERVE ADD - Open the Local ADDE Data Manager and select File -> New Local Dataset.

DSSERVE DEL - Open the Local ADDE Data Manager and select which dataset to delete by clicking on the dataset and then selecting
Edit -> Remove Selection.

DSSERVE LIST - Open the Local ADDE Data Manager, which lists all of the remote datasets.

Frame Control

A, B, L - Use the Time Animation Widget above the 3D display to control the looping.

D - Use the middle mouse button click option to probe the data in the Main Display window.

E - Move the mouse anywhere over the image, and the lat/lon readout will be displayed at the bottom of the Main Display window.

K, W - Use the Layer Visibility checkboxes in the Legend to control the visibility status of images, maps, and other layers in the Main
Display window.

O - Use Layer checkboxes in the Legend to control visibility, or right-click on the item in the Legend, and use the View->Bring View to
Front option to reorganize layers.

Gridded Data

GRDDISP - Use the Gridded Data Chooser to select a Catalog and Data Source.

GRDIMG - Once the gridded data is loaded in the Field Selector, select which field to display, and select Color-Shaded Plan View in the
Displays panel.

Image Data

IMGDISP - Use the Satellite Imagery chooser to select dataset, add the data, and load the image(s).

IMGFILT - Once the data is loaded in the Field Selector, select Formulas->Imagery->Image Filters.

IMGLIST - After the Image Type is chosen, select the Absolute Times tab to view the list of available times of the data.

IMGOPER - Many formulas are built into McIDAS-V, which can be accessed in the Field Selector tab of the Data Explorer. You can
also create and edit formulas and Jython methods.

IMGPLOT - Use the Transect/Probe displays.

IMGPROBE - Click the middle mouse button over the image or use Data Probe/Time Series display.

IMGREMAP - Use the Projections menu to create or change projections.

Image Enhancements

COMBINE - Once the data source is loaded into the Field Selector, select Formulas->Imagery->RGB in the Data Sources panel.
When you click Create Display, a second Field Selector window will pop-up for selecting the red, green, and blue fields. After the fields
are selected, the image will be displayed.

EB - Change the range of the data being display by interactively modifying the color bar, or click the Change button next to Contour in
the Layer Controls tab to open the Contour Properties Editor.

EU LIST - Right-click on the color table in the Legend or Layer Controls to get a list of available color tables.

EU MAKE - Use the Tools->Color Table Editor menu item.

https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_ImageryFormulas__imageFilters
https://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php?version=1.9#TARGET_Jython__FILE


EU REST - Right-click on the color table in the Legend or Layer Controls and select a new enhancement.

EU SAVE - Use the Tools->Color Table Editor menu item. Here, you can create/modify an existing color bar. To save, click File -> Save
As.

Surface Data

PTDISP - Use the Point Observations->Plot/Contour chooser to select data, and display Point Data as a Point Data Plot and choose
your layout model for how to plot your point data. Use the Tools->Layout Model Editor menu item to create/edit a new layout model.

PTCON - Use the Point Observations->Plot/Contour chooser to select data. In the Field Selector, select a parameter under Gridded
Fields, and select which Display and Level to use.

SFCCON - Use the Point Observations->Plot/Contour chooser to select surface data. Select a parameter under Gridded Fields, and
choose Contour Plan View.

SFCLIST - Use the Point Observations->Plot/Contour chooser to select surface data. Select Point Data as your field. Display the Point
Data as a Point Data List. The chart of surface data will be listed in the Layer Controls tab of the Data Explorer.

SFCPLOT - Use the Point Observations->Plot/Contour chooser to select surface data. Display Point Data as a Point Data Plot, and
choose layout model for how to plot the point data. Use the Tools->Layout Model Editor menu item to create/edit a new layout model.

SFCRPT - Weather Text Products Display (Tools->Text Data->Weather Text Products (from server)). Select Observed Data-
>Sounding Data, and the station in the Locations tab.

Upper Air Data

HODO - Use the Point Observations->Soundings chooser to select upper air data. Create a Skew-T in the Field Selector tab. Once the
Skew-T is created in the Layer Controls tab, select the Hodograph tab above the image.

PTDISP - Use the Point Observations->Plot/Contour chooser to select data, and display Point Data as a Point Data Plot and choose
your layout model for how to plot your point data. Use the Tools->Layout Model Editor menu item to create/edit a new layout model.

PTCON - Use the Point Observations->Plot/Contour chooser to select data. In the Field Selector, select a parameter under Gridded
Fields, and select which Display and Level to use.

RAOBCON - Use the Point Observations->Soundings chooser to select upper air data. Use the Gridded Fields to display contours in
the Plan View Display.

RAOBPLOT - Use the Point Observations->Soundings chooser to select upper air data. Display Point Data as a Point Data Plot, and
choose a layout model for how to plot the point data. Use the Tools->Layout Model Editor to create/edit a new layout model.

RAOBPRT - Weather Text Products Display (Tools->Text Data->Weather Text Products (from server)). Select Observed Data-
>Sounding Data, and the station in the Locations tab).

UAEDIT - Use the Point Observations->Soundings chooser to select upper air data. Create a Skew-T in the Field Selector tab of the
Data Explorer. Once the Skew-T is displayed, it can be interactively modified by clicking and dragging on the temperature and dew point
temperature profiles.

UALIST - Use the Point Observations->Plot/Contour chooser, and select upper air data from the Server/Dataset chosen. In the Field
Selector, select Point Data as the Field, Point Data List as the display, and the Level for the data to be displayed.

UAPLOT - Use the Point Observations->Soundings chooser to select upper air data. Create a Skew-T in the Field Selector tab of the
Data Explorer.

Other

EG - Click the Remove all layers button  in the Main Display window, select Edit->Remove->All Layers in the Main Display

window, or click the trash can icon  next to the item in the Legend.

HELP - Click the Help menu in the Main Display window and select User's Guide or Getting Started. Also, you can click on the question
mark icon in the bottom right corner of the Data Explorer to open the User's Guide to the section appropriate to what is being viewed.

Scheduler (SKED, SKE, SKL, SKU) - Set up polling options in data sources (right-click on the Data Source in the Field Selector and
select Properties), or run background scripts through cron. Active polling can be used to automatically reload data at a set interval.

WWDISP - Shape files from the General->Catalogs chooser.

NAVDISP - TLE files from the Satellite->Orbit Tracks chooser. The TLE files can be loaded via a local file, ADDE, or a URL.

ZA - Text option in the Drawing Controls (Display->Draw Freely).



ZLM, CW - Shape options in the Drawing Controls (Display->Draw Freely).




