
McIDAS-V Tutorial 
Importing Data from Text Files 

updated November 2023 (software version 1.9) 
 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 

SSEC's 50-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 

(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 

manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 

Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into 

McIDAS-V for viewing and analyzing hyperspectral satellite data. 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 

McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 

the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 

https://www.ssec.wisc.edu/mcidas/software/v/.   

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 

Forums - https://mcidas.ssec.wisc.edu/forums/. The forums also provide the opportunity to share information 

with other users. 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 

McIDAS-V.  If you can not start McIDAS-V on your machine, you should follow the instructions in the 

document entitled McIDAS-V Tutorial – Installation and Introduction.   

 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 

Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 

Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 

Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 

 

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).   

 

 

 

https://www.ssec.wisc.edu/mcidas/software/v/
https://www.ssec.wisc.edu/mcidas/software/v/
https://www.ssec.wisc.edu/mcidas/software/v/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
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Plotting Point Observations from a text file 

 

1. Remove all layers and data sources from the previous displays. 

 

2. If there is more than one tab, close the extra tabs by clicking the “X” in the right corner of the tabs. 

 

3. Add the data from the <local path>/Data/Generic/QI_METOPC_2023230_T1850Z file. 

 

a. In the Data Sources tab of the Data Explorer, open the General -> Files/Directories chooser. 

 

b. In the Data Type field, choose Text Point Data files. 

 

c. Navigate to the <local path>/Data/Generic/QI_METOPC_2023230_T1850Z file. 

 

d. Click Add Source. 

 

4. Define the field names and units. 

 

a. In the Point Data window, select Space for the Delimiter. 

 

b. Under Start line, click the down arrow once to skip over the header line. 

 

c. In the lower panel of the Point Data window, fill in the fields exactly as shown below. Note that the 

items in these fields are case-sensitive. Do not use the pull down menus, as the choices are very limited.  

In the table below, any values not listed (e.g. “type”, and “sat”) do not need to be defined. 

 

 

Value Name Unit/Date Format Missing Value Extra 

day Time yyyyMMdd 

HHmm 

 colspan=”2” 

hms     

lat Latitude degrees   

lon Longitude degrees   

pre Pressure hPa   

spd Speed m/s   

dir Direction degrees   
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d. Select Preferences -> Save Current. Enter PWinds for the Name and click OK. 

 

e. Click OK at the bottom of the Point Data window. 

 

5. Open the Layout Model Editor to define how the data is displayed. 

 

a. In the Main Display select the Tools -> Layout Model Editor menu item. 

 

b. In the Layout Model Editor, select the File -> New menu item to create a new layout model. 

 

 

c. In the New Layout Model window, enter a name of PWinds and click OK. 
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6. Add a windbarb to your layout model. 

 

a. In the left panel of the Layout Model Editor, click Windbarb. Left Click in the window to place the 

windbarb object. Left Click+Drag to move the windbarb to the center of the box.  

 

b. In the Display tab of the Properties Dialog 

– WindBarb Symbol window, click the 

down arrow  for U or windspeed 

parameter.   Select Current Fields -> 

QI_METOPC_2023230_T1850Z-> Speed. 

 

c. Click the down arrow  for V or direction 

parameter.  Select  

Current Fields -> 

QI_METOPC_2023230_T1850Z -> True 

Heading Angle – Direction. Click OK to 

close the Properties Dialog window. 

 

7. Add the pressure value to your layout model. 

 

a. In the left panel of the Layout Model Editor, click 123 Value. Left Click in the window to place the 

value object.  Drag the object to above the windbarb.  

 

b. In the Display tab of the Properties Dialog – Value Symbol window, click the down arrow  for 

Parameter.  Select Current Fields -> QI_METOPC_2023230_T1850Z -> Pressure -- Pressure. 

 

c. Under Unit, select hectoPascals 

 

d. Click on Foreground Color box and select yellow. Click OK. 

 

e. Click OK to close the Properties Dialog window. 

 

8. Save your new layout model. 

 

a. In the Layout Model Editor, select File -> Save. 

 

b. Close the Layout Model Editor window. 

 

9. Create the display. 

 

a. In the Fields panel of the Field Selector, select the Point Data field. 

 

b. Select the Point Data Plot display type. 

 

c. In the lower-right panel of the Field Selector, open the Layout Model tab.  Click the down arrows   

and select PWinds <local>.  Click Create Display.  The default display is a world projection with wind 

barbs and pressures plotted.  As you zoom in you will see more stations appear in the plot.   
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Displaying radar imagery from a text file 

 

10. Remove all layers and data sources from the previous displays.  Create a new tab, and close the tab from 

the previous example. 

 

11. To add the data source for the <local path>/Data/Generic/Radar/text/RADAR.ASCII file, in the Data 

Sources tab of the Data Explorer, open the General -> Flat files chooser.  In the Flat files chooser: 

 

 Click Open File icon next to File field and navigate to <local path>/Data/Generic/Radar/text/ 

RADAR.ASCII. 

 In the Dimensions section of the Properties panel, enter 1200 for Elements and 1198 for Lines. 

 In the Navigation section of this tab, ensure Files is selected. 

 Click the Open File icon for Latitude and navigate to <local path>/Data/Generic/Radar/text/ 

RADAR.LAT. 

 Click the Open File icon for Longitude and navigate to <local path>/Data/Generic/Radar/text/ 

RADAR.LON. 

 Change the Scale value to 100 and check the East positive box. 

 In the Format section, select ASCII. 

 Click Add Source. 
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12. Display the radar data. 

 

a. In the Fields panel of the Field Selector tab, click key icon  next to RADAR.ASCII to expand the 

field and select Flat data. 

 

b. In the Displays panel, select Image Display. 

 

c. Click Create Display. 

 

13. The default display is a world projection, but this data is only over Oklahoma in the south-central United 

States.  Change the projection of the Main Display to Oklahoma.  

 

a. In the Main Display, navigate to the Projections -> Predefined -> US -> States -> N-Z -> Oklahoma 

menu item. 

 

b. Zoom in on the data by using Shift+Left Click+Drag to create a bounding box around the data. 

 

14. Change the color bar to display the radar data using typical colors used for a base reflectivity display. 

 

a. In the Legend, Right Click on the gray scale color bar. 

 

b. Select Radar -> Base Reflectivity 16 Levels. 

 

 

Creating a Plugin 
 

15. Remove all layers and data sources from the previous displays.  Create a new, one-paneled map display and 

close any previously-existing displays. 

 

16. Add a new NWS CWA map. 

 

a. From the Main Display window, click on the blue Default Background Maps text in the Legend to get 

to the Layer Controls for the map lines. 

 

b. From the Layer Controls tab of the Data Explorer, select Edit -> Add Your Own Map. 

 

c. Click the Browse button next to Map file or URL. 

 

d. Under the Files of Type dropdown, select All Files. 

 

e. Select the <local path>/Data/Generic/MapLines/w_02oc18.zip file and click Open. 

 

f. For Name, enter NWS CWA. 

 

g. Click OK. 

 

17. Set McIDAS-V to default to drawing the NWS CWA maps in tabs made in the future. 
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a. In the Layer Controls tab of the Data Explorer, select File -> Default Maps -> Save as the Default 

Map Set. 

 

b. Create a new, one paneled-map display in the Main Display window, and the NWS CWA map will be 

drawn. 

 

18. Create a plugin that contains these map lines. 

 

a. From the Main Display Window, select Tools -> Plugins -> Create. 

 

b. From the Plugin Creator window, select File -> Add File. 

 

c. From the Open window, select the maps.xml file and click Open. 

 

d. From the Plugin Creator window, click the Browse button. 

 

e. From the Save window, navigate to the directory where you want to write the plugin, and enter a name 

such as nws_cwa_map_lines.  Click Save. 

 

f. From the Plugin Creator window, click Write Plugin. 

 

19. This plugin can now be passed around to other users.  To install the plugin, the user would: 

 

a. Select Tools -> Plugins -> Manage from the Main Display. 

 

b. From the Plugin Manager, select File -> Install Plugin From File. 

 

c. Select the nws_cwa_map_lines.jar plugin and click Open. 

 

d. Restart McIDAS-V. 

 

20. For now, we will remove these CWA map lines so they no longer appear in all new display panels. 

 

a. From the Layer Controls of the map lines, click the Remove The Map ( ) button next to NWS CWA. 

 

b. Select File -> Default Maps -> Save as the Default Map Set. 

 

c. Create a new tab, and the NWS CWA map lines will not be drawn. 
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Problem Sets 

 

The previous examples were intended to give you a general knowledge of how to load and display data. The 

problem sets below are intended to introduce you to new topics related to the data, as well as challenge your 

knowledge of McIDAS-V. We recommend that you attempt to complete each problem set before looking at the 

solutions, which are provided below the problem set. 

 

1. Using the data contained within <local path>/Data/Generic/Radar, create a map display tab containing 

two panels. Display a loop of radar reflectivity in the left panel, and radar velocities in the right panel. For 

the velocities, change the color bar to the Velocity_Example.xml color bar in the  

<local path>/Data/Generic/Radar/ColorTable directory. 

 

2. Using the data contained within <local path>/Data/Generic/Reports, create a new map display tab 

containing two panels. Display hail reports in the left panel and tornado reports in the right panel. Create a 

new layout model for displaying hail and tornado, making each of them a different shape, coloring the hail 

by size, and coloring the tornados by EF level. Once each is displayed, display all of the reports over the 24-

hour period at once, and change the Time Animation properties in a way that there is only one frame for the 

24 hours of data. 

 

3. Save your display as a *.mcvz bundle, including every data source in the bundle. Once your bundle is saved, 

exit McIDAS-V. Restart McIDAS-V and load in your *.mcvz bundle. 

 

 



Page 9 of 16 

McIDAS-V Tutorial – Importing Data from Text Files                                                             November 2023 – McIDAS-V version 1.9 

Problem Set #1 – Solution 

 

Using the data contained within <local path>/Data/Generic/Radar, create a map display tab containing two 

panels. Display a loop of radar reflectivity in the left panel, and radar velocities in the right panel. For the 

velocities, change the color bar to the Velocity_Example.xml color bar in the <local path>/Data/Generic/ 

Radar/ColorTable directory. 

 

1. Create a new 2 panel map display tab. 

 

a. In the Main Display window, select the File -> New Display Tab -> Map Display -> Two Panels 

menu item. 

 

b. Close the any previously existing tabs.  Remove all layers and data sources. 

 

2. Select a loop of radar reflectivity data to display in the left panel of the Main Display. 

 

a. In the Main Display window, Left Click on the left panel to activate it. 

 

b. Add the radar reflectivity data source.  

 

 In the Data Sources tab of the Data Explorer, go to the Radar -> Level II -> Local chooser. 

 Navigate to the <local path>/Data/Generic/Radar/Reflectivity directory. 

 Use Shift+Left Click to select all of the files listed (2011/05/22 22:24Z – 23:07Z). 

 Click Add Source. 

 

3. Display the radar reflectivity data. 

 

a. In the Fields panel of the Field Selector, select BaseReflectivity. 

 

b. In the Displays panel, select the Radar Sweep View in 2D display type. 

 

c. In the Times tab, select Use Default from the dropdown menu to display every time. 

 

d. Click Create Display. 

 

4. Select a loop of radar velocities to display in the right panel of the Main Display. 

 

a. In the Main Display window, Left Click on the right panel to activate it. 

 

b. Add the radar velocity data source. 

 

 In the Data Sources tab of the Data Explorer, go to the Radar -> Level II -> Local chooser. 

 Navigate to the <local path>/Data/Generic/Radar/Velocity directory. 

 Use Shift+Left Click to select all of the files listed (2011/05/22 22:24Z – 23:07Z). 

 Click Add Source. 

 

5. Display the radar velocity data. 

 

a. In the Fields panel of the Field Selector, select StormMeanVelocity. 
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b. In the Displays panel, select the Radar Sweep View in 2D display type. 

 

c. In the Times tab, select Use Default from the dropdown menu to display every time. 

 

d. Click Create Display. 

 

6. Change the color bar used for the radar velocity display to the Velocity_Example.xml color bar found in the 

<local path>/Data/Generic/Radar/ColorTable directory. 

 

a. In the Layer Controls tab of the Data Explorer for the radar velocity data in panel 2, click the 

Radial Velocity button next to Color Table and select Edit Color Table. 

 

b. In the Color Table Editor, select the File -> Import… menu item. 

 

c. In the Color table import window, navigate to  

<local path>/Data/Generic/Radar/ColorTable/Velocity_Example.xml. Click Open. 

 

d. Close the Color Table Editor window. 

 

7. Interrogate the displays and determine the location of the tornado from the radar reflectivity and velocity 

data. 

 

 

Problem Set #2 – Solution 

 

Using the data contained within <local path>/Data/Generic/Reports, create a new map display tab containing 

two panels. Display hail reports in the left panel and tornado reports in the right panel. Create a new layout 

model for displaying hail and tornado reports, making each of them a different shape, coloring the hail by size, 

and coloring the tornados by EF level. Once each is displayed, display all of the reports over the 24-hour period 

at once, and change the Time Animation properties in a way that there is only one frame for the 24 hours of 

data. 

 

1. Create a new 2 panel map display tab. 

 

a. In the Main Display window, select the File -> New Display Tab -> Map Display -> Two Panels 

menu item. 

 

2. In the left panel of the Main Display, add in hail reports from 2011/05/22. 

 

a. In the Main Display window, Left Click on the left panel of the newly created tab to activate it. 

 

b. Add the hail data source. 

 

 In the Data Sources tab of the Data Explorer, go to the General -> Files/Directories chooser. 

 Navigate to the <local path>/Data/Generic/Reports/hail.csv file. 

 Click Add Source. 

 

3. Create a new layout model to display the hail data. 
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a. In the Main Display window, select the Tools -> Layout Model Editor menu item. 

 

b. In the Layout Model Editor window, select the File -> New menu item. 

 

c. In the New Layout Model window, enter in a name of Hail in the Layout Model Name field. 

Click OK. 

 

d. In the Layout Model Editor, Left Click on Shape on the left side of the window to select the item, 

and Left Click in the middle of the panel in the window to place the object. 

 

 In the Display tab of the Properties Dialog window, change the Shape to Filled Square and 

change Scale Size By to 0.4. 

 In the Color By tab, click the  button to the right of Map Value of field, and select Current 

Fields -> hail.csv -> Hail. 

 Change the Data Range to values of 0 and 4.5 to match up with the size of hail reported 

during the timeframe. 

 Click OK to close the Properties Dialog window. 

 

e. In the Layout Model Editor window, select the File -> Save menu item, and close the window. 

 

4. Display the hail data. 

 

a. In the Field Selector tab of the Data Explorer, select the Point Data field in the Fields panel. 

 

b. In the Displays panel, select Point Data Plot. 

 

c. In the Layout Model tab, click the  to the right of None, and select Hail <local>. 

 

d. Click Create Display. 

 

5. Change how the hail data is displayed to show all hail reports over the 24 hour period at once and only 

have one time step. 

 

a. In the Layer Controls tab of the Data Explorer for the hail data in Panel 1, select the Layout tab 

and uncheck the Declutter checkbox to display all of the data at each time step. 

 

b. In the Times tab, change the Show option to Multiple. This will plot all of the hail reports at once, 

regardless of the time they occurred. 

 

c. To remove all of the unnecessary time steps, in the Main Display window, click the  button in 

the Time Animation widget to get to the Time Animation Properties window. 

 

d. In the Define Animation Times tab, select Define your own list of times, and change the Interval 

field to 1 day and click OK. 
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6. Add in tornado reports from 2011/05/22 to the right panel of the Main Display. 

 

a. In the Main Display window, Left Click on the right panel to activate it. 

 

b. Add the tornado data source. 

 

 In the Data Sources tab of the Data Explorer, select the General -> Files/Directories 

chooser. 

 Navigate to the <local path>/Data/Generic/Reports/tornados.csv file. 

 Click Add Source. 

 

7. Create a new layout model to display the tornado data. 

 

a. In the Main Display window, select the Layout Model Editor menu item. 

 

b. In the Layout Model Editor window, select the File -> New menu item. 

 

c. In the New Layout Model window, enter in a name of Tornado in the Layout Model Name field. 

Click OK. 

 

d. In the Layout Model Editor, Left Click on Shape on the left side of the window to select the item, 

and Left Click in the middle of the panel to place the object. 

 

 In the Display tab of the Properties Dialog window, change the Shape to Filled Triangle. 

 In the Color By tab, click the  button to the right of Map Value of field, and select Current 

Fields -> tornados.csv -> EF. 

 Change the Data Range to values of 0 and 5 to match up with the EF values of tornados 

reported during the timeframe. 

 Click OK to close the Properties Dialog window. 

 

e. In the Layout Model Editor window, select the File -> Save menu item, and close the window. 

 

8. Display the tornado data. 

 

a. In the Field Selector tab of the Data Explorer, select the Point Data field in the Fields panel. 

 

b. In the Displays panel, select Point Data Plot. 

 

c. In the Layout Model tab, click the  to the right of None, and select Tornado <local>. 

 

d. Click Create Display. 

 

9. Repeat the same process used in step 5 to change how the tornado data is displayed to show all tornado 

reports over the 24 hour period at once and only have one time step. 

 

10. Zoom in over the region where the tornado was visible using the radar data to see if there are any tornado 

or wind reports reported. 
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Problem # 3 – Solution 

 

Save your display as a *.mcvz bundle, including every data source with the bundle. Once your bundle is saved, 

exit McIDAS-V. Restart McIDAS-V and load in your *.mcvz bundle. 

 

1. Save your display as a zipped bundle. 

 
a.    In the Main Display window, select the File -> Save Bundle… menu item. 

 
b. In the Save window, select a file name and directory. 

 
c.    In the Files of Type field, select McIDAS-V Zipped Data Bundles (*.mcvz). This needs to be saved 

as a zipped data bundle because we want to include the data. 

 
d. Click Save. 

 
e. In the Save Data window, select Save All Displayed Data at the top to include all data (radar, tornado 

and hail data) with the bundle and click OK. 

 
2. Once the saving of the bundle has completed, exit McIDAS-V. 

 

3. Restart McIDAS-V. 

 

4. Load in the bundle that you just saved. 

 

a.    In the Main Display window, select the File -> Open File… menu item. 

 

b. In the Open File window, navigate to the bundle that you saved in step 1, select the bundle and click 

Open.  Select Replace Session if prompted.  If prompted, choose to remove all layers and data, and to 

write the local data to a temporary directory. 

 

c.   This bundle should load in the data loaded into the session at the time the bundle was saved, as well as 

the displays and the configuration of the windows (number of tabs and panels).   A bundle can contain 

any data that can be displayed with McIDAS-V.   See the table below for a list of all data types that 

McIDAS-V can display. 
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Below is a list of supported data types, formats, and the method to access them in McIDAS-V. 

 

Data Type Description Supported Formats Access Method 

Gridded 

  

  

  

Numerical weather 

prediction models, 

climate analysis, gridded 

oceanographic datasets, 

NCEP/NCAR 

Reanalysis 

netCDF local files, HTTP, TDS Servers 

GRIB (versions 1&2) local files, TDS Servers 

Vis5D local files, HTTP 

GEMPAK local files, TDS Servers 

Satellite 

Imagery 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

Geostationary and polar 

orbiter satellite imagery, 

derived satellite products 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

ADDE ADDE servers, local & remote 

McIDAS AREA local files, local & remote ADDE 

AIRS local files 

GINI local files, TDS servers 

AMSR-E Level 1b local ADDE 

AMSR-E Level 2a local ADDE 

AMSR-E Rain Product local ADDE 

EUMETCast LRIT local ADDE 

Meteosat OpenMTP local ADDE 

Meteosat Second Generation  

(MSG) Level 1b 

local ADDE 

Metop AVHRR Level 1b local ADDE 

MODIS L1b MOD02  local ADDE 

MODIS L2 MOD04  local ADDE 

MODIS L2 MOD06  local ADDE 

MODIS L2 MOD07  local ADDE 

MODIS L2 MOD28  local ADDE 

MODIS L2 MOD35   

MODIS L2 MODR local ADDE 

MSG HRIT FD and HRV local ADDE 

MTSAT HRIT local ADDE 

NOAA AVHRR Level 1b local ADDE 

SSMI (TeraScan netCDF) local ADDE 

TRMM (TeraScan netCDF) local ADDE 

Himawari-8 (*.DAT) * local ADDE 

HimawariCast* local ADDE 

INSAT-3D Imager * local ADDE 

INSAT-3D Sounder * local ADDE 

GOES ABI and SCMI * local ADDE 

  GOES GLM local files, remote ADDE 

  TROPOMI (netCDF) local files 

  VIIRS SDR M-Band local ADDE, local files  

  VIIRS SDR I-Band local ADDE, local files 

  VIIRS SDR Day/Night Band local ADDE, local files 

  VIIRS EDR M-Band local ADDE, local files 

  VIIRS EDR I-Band local ADDE, local files 



Page 15 of 16 

McIDAS-V Tutorial – Importing Data from Text Files                                                             November 2023 – McIDAS-V version 1.9 

 

Data Type Description Supported Formats Access Method 

Radar Radar images Level II local files or TDS (bzip2 

compressed or uncompressed) 

 Level III/TDWR ADDE Servers, local files, or TDS 

 Universal Format (UF) local files 

 DORADE local files 

Orbit Tracks Orbit tracks of GEO 

(geostationary) and LEO 

(Low Earth Orbit) 

satellites 

TLE (Two-Line Element) local files, ADDE, URL 

Point 

Observational 

  

  

  

  

  

Surface observations 

(METAR and 

SYNOP), earthquake 

observations 

  

ADDE ADDE servers 

netCDF (Unidata, 

AWIPS/MADIS formats) 

local files 

Text (ASCII, CSV), Excel 

spreadsheet 

local files 

Global balloon 

soundings (RAOB) 

  

  

ADDE ADDE servers 

netCDF (Unidata, 

AWIPS/MADIS formats) 

local files 

CMA text format local files 

Trajectory 

  

Aircraft observations 

  

netCDF (RAF convention) local files 

Text (ASCII, CSV) local files 

GIS 

  

Data typically used in 

Geographic Information 

Systems (GIS) 

ESRI Shapefile local files, HTTP 

USGS DEM local files 

QuickTime 

  

QuickTime movies 

(without extensions) 

QuickTime local files, HTTP 

    

Flat Files Flat (2-dimensional) 

data 

Binary, ASCII, standard images 

(JPEG, GIF, etc.) 

local files; Flat files chooser 

 
* The Himawari-8, HimawariCast, INSAT-3D, VIIRS, and ABI/SCMI local servers are currently supported on 

Linux and macOS platforms 
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Zooming, Panning, and Rotating Controls 

 

Zooming Panning Rotating 

 Mouse  

Shift-Left Drag: Select a region 

by pressing the Shift key and 

dragging the left mouse button. 

Shift-Right Drag: Hold Shift key 

and drag the right mouse button. 

Moving up zooms in, moving 

down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 

mouse to pan. 

Right Mouse Drag: Drag right 

mouse to rotate. 

 Scroll Wheel  

Scroll Wheel-Up: Zoom Out. 

Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-

Up/Down: Rotate 

clockwise/counter clockwise. 

Shift-Scroll Wheel-Up/Down: 

Rotate forward/backward 

clockwise. 

 Arrow Keys  

Shift-Up: Zoom In. 

Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 

Control-Down arrow: Pan Up. 

Control-Right arrow: Pan Left. 

Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 

around vertical axis. 

Up/Down arrow: Rotate around 

horizontal axis. 

Shift-Left/Right arrow: Rotate 

Clockwise/Counterclockwise. 

 

 


