
McIDAS-V Tutorial 
Displaying Level II Radar Imagery 

updated November 2023 (software version 1.9) 
 

 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 

SSEC's 50-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 

(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 

manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 

Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into 

McIDAS-V for viewing and analyzing hyperspectral satellite data. 

 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 

McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 

the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 

https://www.ssec.wisc.edu/mcidas/software/v/. 

 

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 

Forums - https://mcidas.ssec.wisc.edu/forums/. The forums also provide the opportunity to share information 

with other users. 

 

In this McIDAS-V Tutorial, some exercises will be explained using local data files included in pre-loaded data 

bundles. If you have access to your own real-time ADDE servers, you may also use those, but be aware that 

different server configurations may make the explanations in this document not quite applicable to all data that 

you may load. 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 

McIDAS-V. If you cannot start McIDAS-V on your machine, you should follow the instructions in the 

document entitled McIDAS-V Tutorial – Installation and Introduction. 

 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 

Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 

Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 

Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 

 

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag). 

 

https://www.ssec.wisc.edu/mcidas/software/v/
https://www.ssec.wisc.edu/mcidas/software/v/
https://www.ssec.wisc.edu/mcidas/software/v/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
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Displaying Level II radar images: 2D and 3D reflectivity swaths 

 
The Radar Sweep View in 2D display creates a 2-dimensional display of 3-dimensional radar data at individual 

elevation angles. While only data from only one elevation angle can be displayed at once, you can cycle through 

different elevation angles to help to determine the 3-dimensional characteristics of the data. 

 

The Radar Sweep View in 3D display creates a 3-dimensional display of radar data at individual elevation 

angles. While only data from only one elevation angle can be displayed at once, you can cycle through different 

elevation angles to inspect the 3-dimensional characteristics of the data. This display appears to be identical to 

the Radar Sweep View in 2D display until the image is rotated, giving a perspective of altitude of the data. 

 

1. From the Data Explorer, navigate to the Radar -> Level II -> Local chooser. 

 

2. Navigate to the <local path>/Data/Radar directory.  Use Shift+Left-Click to select all of the KNKX* files. 

 

3. Verify that I’m Feeling Lucky is selected from the Station dropdown. 

 

4. Click Add Source. 

 

5. Open a two panel map display and change the color of the outline around the active panel.  

 

a. In the Main Display, select File -> New Display Tab -> Map Display -> Two Panels menu item. 

 

b. By default, the right panel is highlighted by a blue box, which means this is where the data will be 

displayed. Click the left panel, and you should see the blue box outline the panel display, indicating it is 

the active panel.  Any displays created will be added to the active panel. 

 

c. To change the outline color, select Edit -> Preferences.  Under the Display Window tab, there is a Color 

Scheme section on the right side.  To the right of Selected Panel, click the blue box to bring up the Set 

Selected Panel Border Color window.  Select a new color from the swatches and click OK.  Click OK 

to close the User Preferences window.  Switch between panels to refresh the box to the selected color. 

 

6. Display the reflectivity data using the Radar Sweep View in 2D display type in the left panel. 

 

a. Select the left panel of the Main Display, and return to the Field Selector tab of the Data Explorer. 

 

b. Under Fields, select Reflectivity.  The available displays will list under Displays.  Choose the Radar 

Displays -> Radar Sweep View in 2D display type.   

 

c. Click Create Display. 

 

7. Display the reflectivity data using the Radar Sweep View in 3D display type in the right panel. 

 

a. Select the right panel of the Main Display, and return to the Field Selector. 

 

b. Under Fields, select Reflectivity. The available displays will list under Displays. Choose the Radar 

Displays -> Radar Sweep View in 3D display type. 

 

c. Click Create Display.   
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8. There is no visible difference between the two layers until the view is rotated away from the top. Right 

Click+Drag or use the navigation toolbar in the left side of the Main Display to rotate the display. Turn 

looping on and off as you navigate through the 3D reflectivity image. 

 

9. A default for multi-panel displays is shared views, which means that as one panel’s navigation changes, they 

all move in sync.  To turn this feature off, go to a panel and uncheck Projections -> Share Views. 

 

Displaying Level II radar images: RHI 

 
The RHI (Range-Height Indicator) display is utilized to observe the 3-dimensional characteristics of radar data 

at various elevation angles. Every elevation angle included with the data will be used to create this display. This 

display creates a chart that has distance as the x-axis, and altitude as the y-axis. The distance component of the 

display is derived from the transect line, which has one endpoint at the location of the radar, and another at a 

user-defined latitude/longitude location. 
 

 
 

10. Display the reflectivity data using the RHI  display type in the left panel. 

 

a. In the Main Display, select the left panel, turn the looping off, and return to the Field Selector.     

 

b. Under Fields, select Reflectivity.  The available displays will list under Displays. Select the Radar 

Displays -> RHI display type.  Click Create Display. 

 

c. Rotate to the Top Viewpoint by clicking on the  button on the left toolbar.   

 

d. Left Click+Drag on the square at the end of the line in the Main Display to change the position of the 

RHI line.  The 2D display in the Layer Controls will automatically update as the RHI line moves. 
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e. Right Click+Drag in the left panel of the Main Display to visualize the vertical component of the RHI 

display. 

 

11. Rotate the reflectivity azimuth in both the Main Display and the Display tab of the Layer Controls. 

 

a. In the Settings tab of the Layer Controls for RHI, click Start next to Autorotate RHI. This will rotate 

the reflectivity azimuth in both the Main Display window and in the Display tab of the Layer Controls. 

 

b. When you are done, go back to the Settings tab of the Layer Controls and click Stop next to Autorotate 

RHI. 

 

12. Remove the “RHI” display from the panel on the left. 

 

a. Float the Legend for the panel on the left by navigating to the View -> Displays ->Float Legend menu 

item in the Main Display window. 

 

b. In the Display Legend window, remove the top Level II Radar Data (KNKX) listed under Radar 

Displays by clicking on the trash can icon to the right of it. 

 

c. Close the Display Legend window by clicking on the ‘x’ in the upper corner of the window. 

 

 

Displaying Level II radar images: Radar Cross Section 

 
The Radar Cross Section display is very similar to the RHI display. This display type is useful for observing 

the 3-dimensional characteristics of radar data at various elevation angles. Every elevation angle included with 

the data will be used to create this display. This display creates a chart that has distance as the x-axis, and 

altitude as the y-axis. The distance component of the display is derived from the transect line. Each endpoint of 

this transect line is at a user-defined latitude/longitude location, so neither endpoint is necessarily designated as 

the location of the radar. 

 

13. In the same tab used in the last example, select the left panel to activate it and return to the Field Selector. 

 

14. Display the reflectivity data using the Radar Cross Section display type. 

 

a. Under Fields, select Reflectivity.  The available displays will list under Displays.  Select the Radar 

Displays -> Radar Cross Section display type.  

 

b. Click Create Display. 

 

15. In the Main Display, Left Click+Drag the endpoints of the cross section to reposition them. You can also 

drag the entire cross section line by left clicking + dragging the triangle in the middle of the line. Use Right 

Click+Drag to navigate through the display in the 3D. Note that the display is duplicated in the Layer 

Controls tab of the Data Explorer. 
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Displaying Level II radar images: Radar Sweep as Topography 
 

The Radar Sweep as Topography display is a unique display type that helps to better visualize 2-dimensional 

radar data. This display type derives a 3-dimensional display from 2-dimensional data, making the display have 

various high and low vertical components based upon the numerical value of the parameter you are displaying. 

Only one elevation angle of radar data is used to create this display. 

16. Open a new tab by clicking on the  button in the Main Toolbar. 

 

17. Close any previously existing tabs. 

 

18. Display the reflectivity data at the 0.5 degree elevation angle using the Radar Sweep as Topography 

display type. 

 

a. In the Field Selector tab of the Data Explorer, open the Reflectivity tree in the Fields panel to see the 

individual elevation angles. 

 

b. Select the top Reflectivity Elevation Angle .5 field. The available displays will list under Displays. 

Select the Radar Sweep as Topography display type. 

 

c. Click Create Display. 

 

19. Right Click+Drag in the Main Display to observe the 3D features of the display. 

 

 

Displaying Level II radar images: CAPPI 

 
The CAPPI (Constant Altitude Plan Position Indicator) display is used to visualize the 2-dimensional 

characteristics of radar data at various altitudes. Every elevation angle included with the data will be used to 

create this display. Dependent on the altitude you select to display, you may see various rings of data. These 

rings indicate the radar display created from different elevation angles at the user-defined altitude. 

20. Open a new tab by clicking on the  button in the Main Toolbar. 

 

21. Close any previously existing tabs. 

 

22. Display the reflectivity data using the CAPPI display type. 

 

a. In the Field Selector tab of the Data Explorer, under the Fields panel, select Reflectivity. The available 

displays will list under Displays. Select the Radar Displays -> CAPPI display type.  

 

b. Click Create Display. 

 

23. In the Layer Controls tab, change the Levels menu item to change the vertical level displayed in the Main 

Display. You can also click the Cycle checkbox to animate through the levels in the vertical. 

 

The Display Mode can be changed to Mesh or Points.  This can make it easier to see any display that may 

otherwise be hidden underneath the radar display. 
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Displaying Level II radar images: Volume Scan 

 

The Volume Scan display is used to visualize the 3-dimensional characteristics of radar data in all directions 

from the location of the radar. Every elevation angle included with the data will be used to create this display. 

This is similar to the Radar Sweep View in 3D display, with the exception that this display plots data for every 

elevation angle at once. In order to be able to visualize data from various elevation angles at once, the data is 

displayed as points instead of as a solid surface. 

24. Open a new tab by clicking on the  button in the Main Toolbar. 

 

25. Close any previously existing tabs. 

 

26. Display the reflectivity data using the Volume Scan display type. 

 

a. In the Field Selector tab of the Data Explorer, under the Fields panel, select Reflectivity. The available 

displays will list under Displays. Select the Radar Displays -> Volume Scan display type. 

 

b. Select only one image time by selecting the Use Selected menu item in the Times tab of the Field 

Selector, and choose one time. 

 

c. Click Create Display. 

 

27. Right Click+Drag in the Main Display to observe the 3D view of all radar elevation angles at once. 

 

28. In the Layer Controls, enable the checkbox next to Clip Displayed Range and click Change.  In the Change 

Visible Range window, set the From value to 35 and click OK.  Notice how the display has been updated to 

only show reflectivity values of 35 and greater.  This feature allows the user to easily identify regions of 

higher reflectivity. 

 

 

Displaying Level II radar images: Radar Isosurface 
 

The Radar Isosurface display is used to visualize 3-dimensional characteristics of radar data in all directions 

from the location of the radar. Every elevation angle included with the data will be used to create this display. 

Instead of plotting data at all numerical values, a solid surface of only one user-defined data value will be 

displayed. One example use of this display would be selecting a high reflectivity value that may be indicative of 

hail, which can help to possibly identify the hail core of a thunderstorm. 

29. Open a new tab by clicking on the  button in the Main Toolbar. 

 

30. Close any previously existing tabs. 

 

31. Display the reflectivity data using the Radar Isosurface display type. 

 

a. In the Field Selector tab of the Data Explorer, under the Fields panel, select Reflectivity. The available 

displays will list under Displays. Select the Radar Displays -> Radar Isosurface display type. 

 

b. Select every image time by selecting the Use Selected menu item in the Times tab of the Field Selector, 

and choose every time. 
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c. Click Create Display. 

 

32. Add range rings to the display by selecting the Display -> Add Range Rings menu item in the Main 

Display. 

 

30. Change the format of the range rings. 

 

a. Click on Range Rings in the Legend of the Main Display window to take you to the Layer Controls for 

the range rings. Navigate to the Settings tab. Any changes in this tab will be automatically applied to the 

display. 

 

b. Change the Range Ring Spacing to 100, Color to white, and Line Width to 2. 

 

c. Change the Radial Spacing to 60, Color to white, and Line Width to 2. 

 

d. Change the Labels Color to white and Line Width to 2. 

 

Note that several of these menu items are linked by default.  Because of this, changing the color and line 

width of the Range Rings applied these settings to the Radials and Labels as well. 

 

33. Animate the display by pressing Play in the Time Animation Control widget. Right Click+Drag in the Main 

Display to observe the 3D characteristics of the Radar Isosurface display. 

 
34. In the Layer Controls tab for the Radar Isosurface display, change the Isosurface Value to 30 dBz.  This 

will change the display to show only reflectivity values of 30 dBz. 

 

 

Displaying Realtime Level II Radar Data 

 
The previous examples were intended to give you experience displaying archive radar.  The following example 

works through loading and displaying realtime data. 

 

35. Remove all layers and data sources from the session. 

 

36. Open a new tab by clicking on the  button in the Main Toolbar. 

 

37. Close any previously existing tabs. 

 

38. Load a loop of remote radar data into the Field Selector. 

 

a. From the Data Explorer, navigate to the Radar -> Level II -> Remote chooser. 

 

b. Verify that the default catalog of https://thredds.ucar.edu/thredds/radarServer/catalog.xml is listed. 

 

c. If the Collection dropdown menu isn’t active, click Connect next to Catalog. 

 

d. In the Collection dropdown menu, verify that NEXRAD Level II Radar from IDD is selected. 
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e. Left-Click on a station currently experiencing precipitation.  Note that you can zoom in on the map using 

the navigation controls below the map or with Left-Click+Drag. 

 

f. In the Relative tab, enter a value of 5 into the Number of times field. 

 

g. Click Add Source. 

 

39. Display reflectivity data. 

 

a. In the Field Selector tab of the Data Explorer, select Reflectivity under the Fields panel. 

 

b. In the Displays panel, select Radar Displays -> Radar Sweep View in 2D. 

 

c. Click Create Display. 

 

40. Investigate the display using similar functionalities used earlier. 
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Problem Sets 

 
The previous examples were intended to give you a general knowledge of how to load and display radar data. 

The problem sets below are intended to introduce you to new topics related to the data, as well as challenge 

your knowledge of McIDAS-V. We recommend that you attempt to complete each problem set before looking 

at the solutions, which are provided below the problem set. 

 

1. Load the KDDC bundle into McIDAS-V. This bundle contains radar data over Dodge City, Kansas from 

2007, when an EF-5 tornado occurred. Create a three panel display that will help identify the location of the 

tornado. In the first panel, create a Radar Sweep View in 2D display of Reflectivity. In the second panel, 

create a Radar Sweep View in 2D display of Radial Velocity. Finally, in the third panel, create a Radar 

Sweep View in 2D display of Spectrum Width. Add county outlines to the map backgrounds in all three 

panels. Change the enhancement of the Radial Velocity to Radar -> Base Radial Velocity. Change the 

Spectrum Width data range to 0 – 20. Add a color bar to the top of each panel. Change the name of the tab 

to ‘KDDX Radar Displays’. Change the name of each panel to represent the field that is being displayed 

(e.g. Reflectivity). Attempt locating the tornado by interrogating the displays. Probe the data with the 

middle mouse button. 

 

2. Create a Data Probe/Time Series display of reflectivity data. Hint: To help position the data probe, first 

create a Radar Sweep View in 2D display. 
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Problem Set #1 – Solution 

 
Load the KDDC bundle into McIDAS-V. This bundle contains radar data over Dodge City, Kansas from 2007, when 

an EF-5 tornado occurred. Create a three panel display that will help identify the location of the tornado. In the first 

panel, create a Radar Sweep View in 2D display of Reflectivity. In the second panel, create a Radar Sweep View in 

2D display of Radial Velocity. Finally, in the third panel, create a Radar Sweep View in 2D display of Spectrum 

Width. Add county outlines to the map backgrounds in all three panels. Change the enhancement of the Radial 

Velocity to Radar -> Base Radial Velocity. Change the Spectrum Width data range to 0 – 20. Add a color bar to the 

top of each panel. Change the name of the tab to ‘KDDX Radar Displays’. Change the name of each panel to 

represent the field that is being displayed (e.g. Reflectivity). Attempt locating the tornado by interrogating the 

displays. Probe the data with the middle mouse button. 

 

1. Load in the <local path>/Data/Radar/KDDC.mcvz bundle through the File -> Open File menu item in the 

Main Display. In the Open bundle window, select Replace session. This will add the data to the Field Selector. 

 

2. Create a three panel display via the File -> New Display Tab -> Map Display -> Three Panels menu item in the 

Main Display.  Close any previously existing tabs. 

 

3. Click the first panel on the left to make this panel active. Select the Reflectivity field and the Radar Sweep View 

in 2D display. Click Create Display. 

 

4. Click in the middle panel to make this panel active. Select the Radial Velocity field and the Radar Sweep View 

in 2D display. Click Create Display. 

 

5. Click on the third panel to make this panel active. Select the Spectrum Width field and the Radar Sweep View in 

2D display. Click Create Display. 

 

6. In the Layer Controls tab, go to the Default Background Maps controls for each panel. Check the box next to 

U.S. County Outlines for each panel to add county map outlines to each panel. 

 

7. Add a color bar to each panel by individually going to the Layer Controls tab for each field. In the menus of the 

Layer Controls, select Edit -> Properties. In the Properties window, go to the Color Scale tab, click the Visible 

checkbox. Select the Top Position. Change the font size to 20, and the text to Bold. Click Apply and OK. 

 

8. In the Layer Controls for Radial Velocity, under Color Table, select Radar -> Base Radial Velocity. 

 

9. In the Layer Controls tab for Spectrum Width, change the range to 0 – 20. Do this by clicking on the button to 

the right of Color Table, and selecting Change Range…. In the From field, enter 0. In the To field, enter a 

value of 20. Click OK to close the Change Range window. 

 

10. Double-click on the untitled tab to change the name of the tab from ‘untitled’ to ‘KDDC Radar Displays’. This 

opens a McIDAS-V – Rename Tab window. Type ‘KDDC Radar Displays’ and click OK. 

 

11. Change the name of each panel individually by going through the View -> Properties menu item. In the Main 

tab of the Properties window, change the Name of the first panel to ‘Reflectivity’. Use the same method to 

change the name of the second panel to ‘Radial Velocity’, and the third panel to ‘Spectrum Width’.  You may 

need to increase the width of your window to see the panel names.  

 

12. Interrogate the data in the three panels and attempt locating the position of the tornado. Play through the loop 

using the Time Animation Controls. 
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Problem Set #2 – Solution 

 
Create a Data Probe/Time Series display of reflectivity data. Hint: To help position the data probe, first create a 

Radar Sweep View in 2D display. 

 

1. Remove all layers via the Edit -> Remove -> All Layers menu item in the Main Display. 

 

2. Create a new, one panel tab via the File -> New Display Tab -> Map Display -> One Panel menu item in 

the Main Display. 

 

3. Close any previously existing tabs. 

 

4. In the Field Selector tab, select the Reflectivity field and the Radar Sweep View in 2D display type. Click 

Create Display. 

 

5. In the Field Selector tab, select the Reflectivity field and the Data Probe/Time Series display type. Click 

Create Display.  This will place a square probe in the Main Display overtop of the Radar Sweep View 

display. A time series at this probe location will be plotted in the Layer Controls tab of the Data Explorer. 

 

6. Play through the loop of data in the Main Display, and position the probe at an interesting location with 

respect to the reflectivity. As you move the data probe via Left Click+Drag, the Data Probe/Time Series 

display will automatically change. 

 

7. To get a valid range for the y-axis reflectivity values in the chart, after positioning the data probe over an 

interesting area, double-click on the DDC Reflectivity Parameter below the chart to open the Properties 

window.  Next to Range, enter a value of 0 for Min, 80 for Max, and click OK. 
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Zooming, Panning, and Rotating Controls 

 

Zooming Panning Rotating 

 Mouse  

Shift-Left Drag: Select a region 

by pressing the Shift key and 

dragging the left mouse button. 

Shift-Right Drag: Hold Shift key 

and drag the right mouse button. 

Moving up zooms in, moving 

down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 

mouse to pan. 

Right Mouse Drag: Drag right 

mouse to rotate. 

 Scroll Wheel  

Scroll Wheel-Up: Zoom Out. 

Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-

Up/Down: Rotate 

clockwise/counter clockwise. 

Shift-Scroll Wheel-Up/Down: 

Rotate forward/backward 

clockwise. 

 Arrow Keys  

Shift-Up: Zoom In. 

Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 

Control-Down arrow: Pan Up. 

Control-Right arrow: Pan Left. 

Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 

around vertical axis. 

Up/Down arrow: Rotate 

around horizontal axis. 

Shift-Left/Right arrow: Rotate 

Clockwise/Counterclockwise. 

 


