Instructions on how to open & import EDFacts data files
Using Excel 2016 /0ffice 365 or Excel 2013 /prior versions

Excel allows you to directly open a comma-separated values (.csv) or text (.txt) files however, Excel may
apply a format for the data that drops leading zeroes (as shown below), change the date format, and display
phone numbers and other data with special formatting incorrectly. This guide will walk you through the
process to use Excel’s power query to control the import of EDFacts data.

Example of an EDFacts .csv file opened in Excel

ccd_sea_029_1718_ w_1a_083118.csv - Excel

AutoSave (@ of) R

File Home Insert Pagelayout Formulas Data Review View Developer Add-ins Help CUSTOM O Search
Al - S SCHOOL_YEAR
A B T D E F G H I J K L M N (0]

1 [scHooL YFipsT  STATENANST SEA_NAMI STATE_AG MSTREET1 MSTREET2MSTREET3MCITY  MSTATE  MZIP MZIP4  LSTREET1 LSTREET2
2 Lo17-2018 1 ALABAMA AL Alabama S 1 PO Box 302101 Montgome AL 36130 2101 50 North Ripley Street
3 |2017-2018 2 ALASKA  AK Alaska Deg 1 P.0. Box 110500 Juneau  AK 99811 500 801 W. 10th Street Su
4 |2017-2018 4 ARIZONA AZ Arizona De 1 1535 W. JEFFERSON STREET  PHOENIX AZ 85007 3280 1535 W. Jefferson Str
5 |2017-2018 5 ARKANSAS AR ARKANSAS 1 FOUR CAP ROOM 304A LITTLE RO' AR 72201 FOUR CAP ROOM 304
6 |2017-2018 6 CALIFORN CA California 1 1430 N Street Sacrament CA 95814 5901 1430 N Street

7 |2017-2018 8 COLORAD(CO Colorado [ 1 201 EAST COLFAX AVENUE DENVER  CO 80203 1799 201 EAST COLFAX AVE
8 |2017-2018 9 CONNECT CT Connectict 1 PO Box 2219 Hartford CT 6145 2219 450 Columbus Boulev

Excel 2016 or Office 365

If you prefer, the Excel legacy import wizards can be used by clicking on File > Options > Data and
choosing the wizards you’d like to use. When using the legacy wizards, follow the instructions for
importing data using Excel 2013/prior versions.

Excel Options

General

Formulas

Proofing

Save

Language

Ease of Access
Advanced

Customize Ribbon
Quick Access Toolbar
Add-ins

Trust Center

[gc Change options related to data import and data analysis.

Data options

Make changes to the default layout of PivotTables: | Edit Default Layout.

Disable undo for large PivotTable refresh operations to reduce refresh time

Disable undo for PivotTables with at least this number of data source rows (in thousands):

[ prefer the Excel Data Model when creating PivotTables, QueryTables and Data Connections ©

Disable undo for large Data Model operations

Disable undo for Data Model operations when the model is at least this large (in MB)
Enable Data Analysis add-ins: Power Pivot, Power View and 3D Maps
[ Disable automatic grouping of Date/Time columns in PivotTables

Show legacy data import wizards

From Access (Legacy) From OData Data Feed (Legacy)

om Web (Legacy) rom XML Data Import (Legacy)

om Text (Legacy)

From SQL Server (Legacy)

From Data Connection Wizard (Legacy)

8 B

300 -

To use Excel Power Query to import a .csv or .txt file to a new workbook, follow these steps:

1. Open Excel and navigate to the Data tab; in the Get & Transform Data section, click on the Get

Data icon.

Figure 1: Data tab contents
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2. Select the file type of the file to be imported. From Get Data, click From File > From Text/CSV.

Figure 2: Data import options
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[% From Database ¥ [‘E} From Text/CSV

™
[?= From Azure > | [@®>] From XML B Taon.

= Import data from a text,
[ comma-separated value or
, From Online Services FromJSON | formatted text (space delimited)
file,
[‘ﬂ’ From Other Sources ~ * % From Folder

fgﬁ Legacy Wizards 4 EE From SharePoint Folder

% Combine Queries »

B2 Launch Power Query Editor.
[® Data Source Settings..
[E] auery Options

3. Select the file to be imported; note that the file contents are displayed in the right side of the window if
the preview option is selected.

Figure 3: File Explorer pop up window with file preview option circled
Organize v New folder - ®
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2017-2018,01,ALABAMA, AL ,Alabam
a State Department of
Fducation_01_Grade 1.American

o 0 0 0 o o @
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File name: | ccd_sea_052_1718.1_1a_083118.csv ~ | [TextFites ¢.pmitxtitesy) ~

i o

4. From the Get & Transform feature, choose Transform Data to adjust the data type for each column.

— The default settings for “Data Type Detection” use the first row for column headers and assigns the
data type (as text, number, integer, etc.) based on the first 200 rows in the file.

Figure 4: Get & Transform window

o X

ccd_sea_052_1718_|_1a_083118.csv
File Origin Delimiter Data Type Detection
1252: Western European (Windows) ~ | | Comma ~ | | Based on first 200 rows - 2
SCHOOL YEAR  FIPST  STATENAME ST SEA_NAME STATE_AGENCY_NO  GRADE RACE_ETHNICITY
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  American Indian or Alaska
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  American Indian or Alaskal
2017-2018 1 ALBAMA AL Alabama State Department of Education 1 Grade1 | Asian
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  asian
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade1 | Black or African American
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  Blackor African American
2017-2018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  Hispanic/Latino
2017-2018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  Hispanic/Latino
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  Native Hawaiian o Other P
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  Native Hawaiian o Other P
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  NotSpecfied
2017-2018 1 ALABAMA AL Alabama State Department of Education 1 Gradel | Twoormore races
2017-2018 1 ALABAMA AL Alabama State Department of Education 1 Grade1 | Twoor more races
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  white
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade1  white
2017-2018 1 ALABAMA AL Alabama State Department of Education 1 Grade10 | American Indian or Alaska |
2017-2018 1 ALABAMA AL Alabama State Department of Education 1 Grade10  American Indian or Alaska |
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade10  Asian
20172018 1 ALABAMA AL Alabama State Department of Education 1 Grade10  Asian
2017-2018 1 ALABAMA AL Alabama State Department of Education 1| Grade 10 | Black or African American
< >

toad [~] | Transform Data Cancel
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5.

Data in the file will be displayed in the Power Query Editor.

Columns FIPST and State Agency No have a data type integer in the example below and will be

changed to text because they contain leading zeros.

Figure 5: Power Query Editor

In the Applied Steps side bar, “Changed Type” will be applied by default.
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1 ALABAMA AL Alabama State Department of Education 1 Grade10 .
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PREVIEW DOWNLOADED AT 10:31 AM

Delete the “Changed Type” step (click on the ¥ next to the step) and choose the columns to change.

Hold the shift key and use your left mouse button to select highlight a continuous block of

columns, or hold the control key and use your left mouse button to select multiple, non-
continuous columns in the data set.

Figure 6: Selecting columns to set the data type.
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7. From the Transform tab, choose the appropriate Data Type from the drop list.

— In this example, Student Count was set to a Whole Number.

Figure 7: Choose the Data Type
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8. Complete the import by click

Add Column
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View
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Figure 8: Close & Load

< ;j Close & Load

A

L Close & Load To...

s

- Discard & Close
EX

P Options and settings »
@ :

~||A8 RACE_ETHNICITY

American Indian or Alaska Native
American indian or Alaska Native

Asian

Asian

Black or African American
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White
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9. Alternatively, choose Close & Load to...

— Load to a table: A pop up box allows data to be loaded to a “Table,” which produces the same
result as Close & Load. Data can also be loaded to a “PivotTable” or “PivotChart,” or a data

connection can be created.

— Create a connection: If “Create Connection” is chosen, the data does not load but is accessible

~||A8 sex
Female
Male
Female
Male
Female
Male
Female
Male
Female
Male
Not specified
Female
Male
Female
Male
Female
Male

Female

~||#2; STUDENT COUNT - | AB. TOTAL INDICATOR

241 Category Set A - By Race/Ethnicity; Sex; Grade
256 Category Set A - By Race/Ethnicity; Sex; Grade
395 Category Set A - By Race/Ethnicity; Sex; Grade
397 Category Set A - By Race/Ethnicity; Sex; Grade
8924 Category Set A - By Race/Ethnicity; Sex; Grade
9491 Category Set A - By Race/Ethnicity; Sex; Grade
2454 Category Set A - By Race/Ethnicity; Sex; Grade
2593 Category Set A - By Race/Ethnicity; Sex; Grade
24 Category Set A - By Race/Ethnicity; Sex; Grade
327, Category Set A - By Race/Ethnicity; Sex; Grade

0 Category Set A - By Race/Ethnicity; Sex; Grade
744 Category Set A - By Race/Ethnicity; Sex; Grade
826 Category Set A - By Race/Ethnicity; Sex; Grade
14374 Category Set A- By Race/Ethnicity; Sex; Grade
15648 Category Set A - By Race/Ethnicity; Sex; Grade
283 Category Set A - By Race/Ethnicity; Sex; Grade
291 Category Set A - By Race/Ethnicity; Sex; Grade

374 Category Set A~ By Race/Ethnicity; Sex; Grade

ing on Home or File > Close & Load.

through the Query Editor and can be used in other Excel Queries.

— Tip: The default setting for power pivot adds the table to Excel’s Data Model.

Figure 9: Options for Close & Load to...
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Properties...

Select how you want to view this data in your workbook.

? X
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Cancel
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10. Data will load to a table in the workbook.

— The import query appears in the side bar on the right and shows the total row count for the file.

— If you close the side bar and want to see it again, select Data > Queries and Connections.

Figure 10: Data imported to a Table

A B C D E

il scHooL_vear Bl ripst B sTaTENAME B s7 B sea_name [- B
2 20172018 01 ALABAMA AL Alabama State Department of Education 01

3 |2017-2018 02 ALASKA |a Alaska Department of Education and Early Development 01

4 |2017-2018 04 ARIZONA AZ  Arizona Department of Education 01

5 2017-2018 05 ARKANSAS AR ARKANSAS DEPARTMENT OF EDUCATION 01

6 20172018 06 CALIFORNIA CA California Department of Education 01

7 2017-2018 08 COLORADO €O Colorado Department of Education o1

8 2017-2018 09 CONNECTICUT CT  Connecticut State Department of Education o1

9 2017-2018 10 DELAWARE DE  Delaware Department of Education 01

10 |2017-2018 1 DISTRICT OF COLUMBIA DC  Office of the State Superintendent of Education (OSSE) 01
11/2017-2018 12 FLORIDA FL  FLORIDA DEPARTMENT OF EDUCATION 01

12 2017-2018 13 GEORGIA GA  Georgia Department of Education 01

13 |2017-2018 15 HAWAII HI  Hawaii Department of Education 01

14 2017-2018 16 IDAHO D Idaho State Department of Education 01

15 |2017-2018 17 ILLINOIS IL  Illinois State Board of Education 01

16 2017-2018 18 INDIANA IN Indiana Department of Education oL

FS029_SEA | FS052_SEA ‘ FS059_SEA ‘ Sheet1 | @ < »

=) P Display settings

Queries & Conn... ~ X

Queries | Connections

3 queries

M ccd_sea_029_1718_w_1a_083118
56 rows loaded.

[ ccd_sea_052_1718_|_1a_083118
14,152 rows loaded.

M ccd_sea_059_1718_|_1a_083118
1,379 rows loaded.

< >
H =@ [ - 1

+ 100%

11. Columns can be added to the table and formulas entered in those columns. A formula in a table column

can use the structured reference for the column name, such as [@FIPST], or a range like B:B.

Figure 11: Data imported to a Table

=[@STATENAME]&" - FIPST "&[@FIPST]

A B C D
1
2 = ALABAMA - FIPST 01 ALABAMA
3 2017-2018 ALASKA - FIPST 02 02 ALASKA
4 2017-2018 ARIZONA - FIPST 04 04 ARIZONA
5 2017-2018 ARKANSAS - FIPST 05 05 ARKANSAS
6 2017-2018 CALIFORNIA - FIPST 06 06 CALIFORNIA
7 2017-2018 COLORADO - FIPST 08 08 COLORADO
8 2017-2018 CONNECTICUT - FIPST 09 09 CONNECTICUT
9 2017-2018 DELAWARE - FIPST 10 10 DELAWARE

12. Save the file as an Excel workbook to retain the data connections and table format.

Figure 12: Save File As
Save As
@ Recent

Save As

Save as Adobe
PDF

Other locations.

E@ This PC

CCD data import

Excel Workbook (*.xsx)

Excel Workbook (*.xisx)
Excel Maero-Enabled Workbook (*xism)
Excel Binary Workbook (*.xIsb)

Excel §7-2003 Workbook (*xls)

CSV UTF-8 (Comma delimited) (*.csv)
XML Data (*xmi)

single File Web Page (*mht, *mhtmi)
Web Page (*htm, *html)

Excel Template (*xItx)

Excel Macro-Enabled Template (*xitm)
Excel 97-2003 Template (*xt)

Text (Tab delimited) (*:txt)

Unicode Text (*xt)

XML Spreadsheet 2003 (“xml)

[Z save
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Excel 2013

Excel 2013 and earlier versions use a simple and straightforward process for opening and importing text
files. When transferring files from .csv format to .xlsx format, some of the values displayed as ranges are
read as a date if the file is opened directly into Excel. To prevent this, save the flat file (.csv) before
opening it. Once the file is saved, follow the steps below to import the data into Excel.

1. In the Data tab, click From Text in the Get External Data section of the tool bar.

Figure 13: Data tab contents

Bookl - Microsoft Excel

I R I
m Home Insert Page Layout Farmulas Data Review View Agrabat
L D D 3 o ions. g FaTE ]7 W Clear El mm = B T LA -""."_'i ’51
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@ @ B EHRE! K" HER T, e BE B B= =P i W 8
From From From Frof er Existing Refresh. f\l Sort Filter ( Textto Remove Data Consolidate What-If Group Ungroup Subtofal
Access Web  Text  Sources=  Connections | All- J# Advanced | Columns Duplicates Validation ~ Analysis ~ - ~
Get External Data Cannedions Sart & Filter Data Tools Outline
A1 - 5
A B & D E F G H 1 J K L M N 0 P

2. From the pop-up file explorer window, select Text Files (*.prn, *.txt or *.csv) from the lower right
hand side drop-down; click Open.

Figure 14: Select Data file

(3] import Text File | ==
57 N e
1% » Libraries » Documents » - Segrch Document
O EIT D ¢ | 2] szaren 0 2|
Organize » Mew folder =+ H @
[&] Microsoft Excel Documents library Aurange by: Folidr =
Workspaces Includes: 2 locations -
|E Mame =]
I Favorites |
4 Downloads .. SharePoint Drafts lir
=
£ Recent Places B . oo Select & file to preview.
B Desktop . OneMote Notebooks
NEE
. Public Docume Ij My Shapes
. My Received Files
= Libraries My Note?mk Coentent
[ Documents I My -
1 Music - el L
File name: - [Tax‘t Files (*.prn;™ bt ™. csv) VI
Tools = | Open I I Cancel
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3. The settings Delimited and Start import at row 1 are selected by default; click Next.
Figure 15: Text Import Wizard Step 1

Text Import Wizard - Step 1 of 3 2

The Text Wizard has determined that your data is Delimited.
If this is correct, choose Next, or choose the data type that best describes your data.
Original data type
Choose the file type that best desaribes your data:
@ Debmited - Characters such as commas or tabs separate each field,
() Fixed width - Fields are aligned in columns with spaces bebween sach field.

]

Startimportatrow: 1 1=-| File origin: 437 : OBEM United States

Preview of file Ci\Users\Mekssa, Wilks\Downloads\math-achievement-ea-sy2012-13.csv,

id 1213", "ALL MTHOOpctprof 1213", "MAM MTHOOnumvalid 1213", "MAM MTHOOpctpd »
1l'lla._sl-'"au.npsu)-gw'uﬁsg"'uzsn'u?o__?g‘l-'lr'?ssllrlrei—.|l53-.|-so_35—'1l1325|l' |
L WEE, W% WCIZEO, v4e, EE", “2E", PE0-T3", V4ELT, VES®, 5T, RT0-78%, v2357", »
W mge mpge mgzgm mggn migaze magw mIjge wEIv wilae wEZ_aaw maga4nm mage
ga3", m2gn "CEBQ™, "406", 97", "1010", "83", "1£8", "8S-89", "108", "B5-35", "3325] ~

[concd ][ cieo | [oa @] ensh |

4. Select Comma for the delimiter type; Quote (*‘) for the Qualifier; click Next.
— Note: Tab is the default selection when opened. It can either be unchecked or left as is.

Figure 16: Text Import Wizard Step 2
Text Import Wizard - Step 2 of 3 |9 "

This screen lets you set the delimiters your data contains. You can see how your text is affected in the preview

i
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Data preview
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[ Concel ][ <gok ][ mext> |[ Eosn |
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5. For every column, even those with numeric data, change the data format from General to Text: click
on Text and highlight each column by clicking on it. Once all the columns are changed to text format,

click Finish.
Figure 17: Text Import Wizard Step 3
’Text Import Wizard - Step 3 of 3 liléj
This screen lets you select each column and set the Data Format.
Column data format

‘General converts numeric values to numbers, date values to dates, and all
remaining values to text.

MDY B ”gdvanced... ]
| Do not import column (skip)

~) Date:

Data preview

L BXL IexL =
umvalid 1213 RALL MIHOOpctprei 1213 MAM MIHOOnumvalid 1213 BES

Ea €]

[rg
-
T =3

L0

[ concd ] [ <iosk |

6. The file may also be saved as a .csv or .txt and reopened without having to repeat this process. The
file can also be saved as an Excel workbook by choosing Save As and selecting an appropriate Excel
file type.



