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Intro to QGIS

Introduction: Geographic Information Systems (GIS) is a tool used to display, create, and analyze spatial information to
help solve real world problems. It combines the graphics that make up a map with data tables of associated attributes.
QGIS is a GIS platform that is available as a free web-download. This tutorial guides you through the functionality of QGIS
using fictitious data of the status of tree health on Brock University’s campus. Your task is to identify trees in critical
condition that must be removed from the roadsides on campus to prevent road blocks or accidents.

Requirements:
e QGIS2.x

e A web browser (i.e. Google Chrome)

Part 1: Introducing the QGIS Interface

1. Obtain files to be used for this tutorial from www.brocku.ca/maplibrary/Instruction/QGIS_Data.zip .

2. When prompted click Save As and save these files in your personal file folder (i.e. X:Drive) or on an external source
(i.e. a USB).

3. Unzip thefile.

Run QGIS (Start > All Programs > QGIS Brighton > QGIS Desktop 2.6.1) or the latest version.

5. Click Project [Menu Bar] > Save Navigate to your personal file folder and save the project with a name.

e

The QGIS interface is made up of toolbars, menu bars, a data view, and a layers pane (see below).
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6. The tool bar is used to change the zoom level & pan, and to identify objects.
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7. The ‘Add Data Options’ allows adding various data types such as vector data and raster data.
8. The Layers Pane is where layer files display once they are added to the QGIS map document.
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Part 2: Adding Data

1.

10.

11.

12.

Set the projection of the Data View. Project menu > Project Properties > CRS > select Enable ‘on the fly’ CRS
transformation

Type NAD83 / UTM zone 17N into the Filter box and select this same option that appears in the ‘Coordinate
Reference System’ window at the bottom. Click OK.

In order to add data in QGIS be aware of what data types you are adding, i.e. vector or raster data, or data packaged
as an Esri geodatabase. There are separate buttons for various data.

Click the Add Vector button :

In the ‘Add vector layer’ window under ‘Source type’ select File.

For ‘Dataset’ browse to the folder where you saved the files for this tutorial. In the dropdown menu beside where
you type the file name change this option from ‘All Files (*)’ to ‘ESRI Shapefiles (*.shp, *.SHP)’. Add the buildings,
contours, roads, & water shapefiles by clicking the first file, holding down shift and clicking the last file, then click
Open. In the ‘Add vector layer’ window click Open again.

. N
«{; Add vector layer (B
Source type
Directory Database Protocol
Encoding | System -
Source
tion\HELP GUIDES\MOMN-WEB\Intro_QGIS'\Data\buildings.shp I
Open Cancel Help I
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NOTE: when the layers appear in the ‘Data View’ they may be zoomed out and appear only as a dot. To zoom into
the extent of the data, right click one of the layer names in the ‘Layers Pane’ and click ‘Zoom to Layer’.

Layers can be renamed by right clicking the layer name in the ‘Layers Pane’ and selecting Rename.
To change the symbology of a layer, right click the layer name and select Properties.

The ‘Layer Properties’ window will ) Loy Properses _Wtc: | oA N o

W Layer rendering

Layer transparency ¥; 0

appear; change the colour and size of the

Layer blending mode Normal ~ | Feature blending mode Normal -

feature within the ‘Style’ tab. Once €
BR Fields

& single Symbol |~

Unit Milimeter -
Transparency 0% (J———
Color ]

Saved styles -

selection is made, click OK.

Symbology of a layer can be set to
represent a categorization of the data.

For example, distinguish the different
“Types” of buildings on campus. /

Simple fil corners diagonal  dotted green land wiater wine

In the Layer Properties Style window for the buildings click the dropdown arrow next to ‘Single Symbol’ and select
Categorized.

In the ‘Column’ dropdown menu select Type, and then click classify. This classifies each of the different building
types with unique colour symbology. Click OK.
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Part 3: Adding Point Data from a table
In addition to adding shapefiles to the map project, point files from a data table can be created with corresponding
coordinates.

Click the Add Delimited Text Layer button.
Under ‘File Name’ click Browse. Select the Brock_trees file from the QGIS_Data folder and click Open. The rest of
the window will automatically fill with the appropriate information.

3. Before clicking OK in the ‘Create Layer from a Delimited Text File’ window, select the CSV (Comma Separated
Values) toggle beside ‘File Format’. Click OK.

4. The ‘Coordinate Reference System Selector’ window will appear. In the ‘Filter’ box, type: NAD83 / UTM zone 17N.

5. The filtered results will appear under ‘Coordinate reference systems of the world’. Select the corresponding search
result and click OK.

6. Points will appear in the Data View, each point represents a tree. In order to continue with our analysis, we must
first save these points in a shapefile (.shp) format. Right click the newly created Brock_trees points layer and select
Save As...

7. Inthe ‘Save vector layer as’ window, ensure that the ‘Format’ is an ESRI Shapefile. Browse to where you would like
to save the shapefile [QGIS_Data] and create a file name (i.e. Trees) and click Save.

8. Under ‘Encoding’ verify Add saved file to map is checked and click OK.

9. New points for the trees will appear in the Data View. To keep the Layers Pane organized it is recommended to
remove the Brock_trees CSV file from the map by right clicking the layer name and selecting Remove. Click OK when
prompted.

10. SAVE!

Part 4: Buffering & Selecting by Location Query
Brock University would like to remove trees that are deemed to be

in “poor” condition and are within a 20 metre radius of the roads on £ Buffer(s) . L2 e
campus; to avoid potential road blocks or accidents. To do this, we Input vector layer
must first create a 20m buffer around the roads. roads -
Use only selected features
1. Click ‘Vector’ from the top menu bar. Select Geoprocessing RELEIEE S > -
Tools > Buffer(s). Fill in the ‘Buffer(s)’ window to reflect the ¢ Buffer dstance 2
. ) Buffer distance field
image at right. —

2. Inthe ‘Output shapefile’, browse to your own local storage files

Dissolve buffer results

and give a name to the buffer [road_buffer_20m], and Save. Output shapefile
Back in the ‘Buffer(s)’ window click OK to run the buffer tool. C:fUsers/aschmucker/Road_buffer_20m.shp
Once the buffer is finished processing click Close. | Add result to canuas

3. To see all the features more clearly in the Data View, make the 0 0% | oK cose | |l

e

buffer layer transparent. This is done in the same window where

the layers’ symbology is altered [HINT: Properties > Style > Layer Transparency]. Change the transparency to 50%.
Click OK.
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Now we want to select the trees located only within the road buffer.

Click the ‘Vector’ menu and select Research Tools > Select by
location. Fill in the ‘Select by location” window to match the
image on the right and click OK [NOTE: the files names may
vary as you may have used different naming conventions].
Once it is finished processing, click Close.

The selected trees will be displayed in yellow in the Data
View. Save this selection as a shapefile. Right click trees file
in the Layers Pane and click Save As... Ensure the Format is
ESRI Shapefile. Click Browse and select your data folder
[QGIS_Data], and name the new shapefile [trees_buffer] click
Save. Back at the ‘Save vector layer as...” window, select Save
only selected features and Add saved file to map, then click
OK.

OPTIONAL: Selecting the trees within 20m of the roads can also
be done by performing what is known as a Clip. Click the
‘Vector’ menu and select Geoprocessing Tools > Clip. Fill in the
‘Clip’ window to match the image, and SAVE. After processing,
click Close.

Remove the Trees layer from the Layers Pane (HINT: Right
Click> Remove). Now only trees within the 20m road buffer are
visible.

SAVE!

Part 5: Select by Attribute

1.

To identify the trees in poor condition to be removed, right
click the new tree layer that was created in the previous step
[trees_buffer] and select Open Attribute Table.

Click the Select by expression button.

In the ‘Function List’ expand ‘Fields and Values’ and double
click CanopyCond. Notice this appears in the expression box.
Under ‘Operators’ click the equal (=) sign button.

Under the ‘Field Values’ window click the all unique button.
Double click Critical.

Press the space bar and in all caps type OR. Double click
CanopyCond again equals (=) button, then under ‘Field
Values’ double click Poor.

Click Select, then Close.
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I Qutput preview: @

'Critical' OR "CanopyCond™ = 'Poor'

LI



mailto:maplib@brocku.ca

Bl'@Ck MAP, DATA & GIS LIBRARY

University maplib@brocku.ca

QGISIntro 5

8. Still in the attribute table, from the Show All Features button, select Show Selected Features. This shows only the
trees that met the query criteria. Close the attribute table.

16 17 [v] 17 |QUPA Pin oak Quercus palustris 11.5 7.5
17 18 1] 13 | QUPA Pin oak Quercus palustris 1405 7.5
18 19 1] 19 | QUPA Pin oak Quercus palustris 11.5 75
5| 0 0 20 |QUPA Pin oak Quercus palustris 11.5 7.5
a0 | 21 0 21|qQuPa Pin oak Quercus palustris 1.5 7.5
21 | 2 0 27| QUPA Pin oak Quercus palusiris 115 7.5 =]
22 23 1] 23 |QUPA Pin oak Quercus palustris 11.5 7.5
| | )
b d Show All Features _ =]

¥ Show Selected Features
. Bt Un Map

b d Show Edited and New Features
Column Filter 4
L d Advanced Filter (Expression) Ctrl+F

9. Right click the trees_buffer layer and click Save As...

10. In the ‘Save As..." window ensure the file format is an ESRI Shapefile. Browse to the QGIS_Data folder you created
for this tutorial, name the new shapefile tree_removal, click Save. Back in the ‘Save vector layer as...” window,
ensure that Add saved file to map and Save only selected features are selected then click OK.

11. In the Layers Pane, remove the trees_buffer and the road_buffer.
12. Change the symbol for the tree_removal layer so it is more visible. [right click > Properties> Style]

13. SAVE!

This newest tree layer represents the trees that are hazards and will be removed by the tree removal crew. We can
now put together and print a map for the crew to use out in the field. The steps below describe this process.

Part 6: Printing A Map
1. Select the ‘Project’ menu > New Print Composer and give the map a name, for example “Tree Removal — Brock

University Campus, St. Catharines, ON” Click OK.

2. Inthe Print Composer window that appears, select the ‘Layout’ menu and click Add Map. The map will not appear
right away. Draw a box at a preferred location on the page using the crosshairs cursor by clicking on the blank page
and dragging the cursor.

3. Inthe ‘Layout’ menu add map elements such as:

e Add Arrow [click on map and draw the arrow, ending in the north (up) direction].

e Add Scalebar [click on the map where the horizontal scale bar is to be].

e Add Legend [click and form a rectangle where the legend is to be]. NOTE: remove unwanted items from the
Legend. With the Legend selected, go to the ‘Item Properties’ tab, and uncheck Auto update; manually
update the Legend.

e Add Label [click and form a rectangle where the text is to be. In the ‘Label’ box under Item Properties,
enter the desired text. Click on font under ‘Appearance’ to change the font size and shape. Adjust the size
of the box if the wording doesn’t fit].


mailto:maplib@brocku.ca

Br@CK MAP, DATA & GIS LIBRARY

University maplib@brocku.ca

QGISIntro 6

4. Inthe ‘Item properties’ tab adjust the specifics of a layout element — T — —

such as scalebar, legend, etc. _ - - —
P AL PR RS /8- -
B com smun.ﬂ\dasgenevahun

5. To add a neat line click the Add ellipse button > ‘Add =
Rectangle’, and draw a box around the map image. T [ ) oo

6. Inthe ‘Item properties’ under ‘Shape’, beside the word Style click ﬁ EE -
Change... Click Simple fill, then from the colour options, select By Lkl mep e

¥ Extents

Transparent fill (the border colour should default to black). Click OK.
7. To save the final map project click Composer > Save Project.
8. Export options are available in various formats using the buttons in

Xmin | §41767,021
Ymin | 4774853.913
Xmax | 64315.021

Ymax | 4775879.913

Set to map canvas extent

the image below: o =

O Margnaround feature [10% 5]
4
.

9. Print or add the map into another document, such as Word or PowerPoint.

10. Below is an example of a map created using this QGIS tutorial.

Tree Removal Map - Brock University Campus, St. Catharines, ON

Legend

A Trees for removal

Buildings

[ Academic

Il Maintenance

I Public

[T Residence

[ Restaurant

[ Sculpture

=

> Roads

7] water
Contours

Author: Amber Schmucker
Date: March 31, 2015
Projection: NAD 1983 UTM
Zone 17N
Source: Brock University
MDG Library
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