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Quantitative Mapping Using Census Data

This tutorial includes all necessary steps to create a thematic map using numeric census tract data — from data
acquisition; excel file formatting; preparing a boundary shape file; to the final product of designing a choropleth map.
STEP ONE: Download census data from CHASS

1. Navigate to the University of Toronto CHASS Site http://datacentre.chass.utoronto.ca/census/ “Canadian Census

Analyzer”
2. Under Census Profile Tables > by Census Geography (select Census Tract)
3. Select 2016.
4. Step 1: Specify Census Geography for retrieval
a. Under the heading Locate census geography, click the checkbox beside the letter ‘s’.

b. Check the box beside St. Catharines — Niagara (Ont.)

| = Census Geography: (1 selected)

® Locate census geography (CMAs/CAs with CTs) in the datab:

by Name | by Province
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3 items found: Selected items:
Sarnia (Ont.) ¢ St Catharines - Niagara (Ont.)
Sault Ste. Marie (Ont.)
¥ St Catharines - Niagara (Ont )

5. Step 2: Specify Census Profile variables for retrieval
a. Housing Profile, select the following:
i. Average monthly shelter costs for rented dwellings ($)(v3950)
b. Education Profile, select the following:
i. Total — Highest certificate, diploma or degree for the population aged 15 years and over in
private household — 25% sample data (v4920)

ii. University certificate, diploma or degree at bachelor level or above (v4929)

Selected items:

4| Average monthly shelter costs for rented dwellings ($) (v3950)

¢ Total - Highest certificate, diploma or degree for the population aged 15 years and over in private households - 25% sample data (v4920)
¢ University certificate, diploma or degree at bachelor level or above (v4929)

6. Scroll down to Step 3: specify the output details and submit query

a. Select Census Tract Name
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7. Scroll down to Select the output format:
a. Select MS Excel ready
8. Click Submit query.

Select the output format:

[Screen output
Text
HTIML
Comma-Separated Values (CSV) for spreadsheet
SAS
SPSS
Download to a file
Comma-Separated Values (CSV) file for spreadsheet
dBase (DBF) file

Submit Query. This will open a new tab or window in the browser.

Submit Query

The CSV file is automatically downloaded to your My Downloads.
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9. Run File Explorer and copy/paste the CSV to a more appropriate storage location (i.e. OneDrive).

10. Open the file (default name is “census.csv”) in MS Excel.

A B (€ D E F G H J K L M N o} p Q R
|2016 Censll s Profiles Files / Profile of Census Tracts

CoLo GEO UID

CoLL Census Tract name

coLz Housing - Total Sex / Total - Tenant househaolds in non-farm, non-reserve private dwellings - 25% sample data / Average monthly shelter costs for rented dwellings ($)

CcoL3 Education - Total Sex / Total - Highest certificate, diploma or degree for the population aged 15 years and over in private households - 25% sample data

CcoL4 Education - Total Sex / Total - Highest certificate, diploma or degree for the population aged 15 years and over in private households - 25% sample data / Postsecondary certificate

COLo CcoL1 coLz coLz coLa

5350000 0 901 337885 56680
5350001 1 927 3825 670
5390002 2 1064 5585 1740
5390003 3.01 806 3930 465

STEP TWO: Preparing an Excel File

The Excel file must be cleaned up before it can be used in ArcGIS.

1. Using the descriptions for each “COL” (column), enter a truncated field name in the cells just above the data
(e.g. using row 10 in the above screenshot). Field names must begin with a letter, contain only letters, numbers
and underscore characters and be limited to 64 characters long. DO NOT INCLUDE SPACES OR SPECIAL
CHARACTERS.



36680
670
1740
463
1695

g : COLO CoL1 coL2 COL3 coL4
10 |CTUID Ctname AvgRent TotalPoplSov BachelorDegree higher
1 J 5390000 0 901 337885
12 | 5390001 1 927 3825
13 | 5390002 2 1064 5585
14| 5330003.01 3.01 B06 3930
15| 3350003.02 3.02 995 6475
16 5390004.01 4.01 807 3480

1. Select rows 1 through 9 (in this example) and right-click > Delete.

1105
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2. Go to File > Save as and save the CSV to your project directory. ArcGIS Pro works with Excel files in various

formats.

3. Close Excel completely.
STEP THREE: Downloading Census Tract Boundary Files

1. Run Google Chrome and navigate to Scholars GeoPortal

http://geo.scholarsportal.info/#r/details/ uri@=7492657555SDLI 2016 Census CBF Eng Nat ct

2. Add the Census Tract Cartographic Boundary File to the viewer.

3. Zoom to Niagara.

4. Click the Download tab then select Download by area of interest > Select a pre-defined area > Census

Metropolitan Area (CMA) then click anywhere over Niagara.

]
v
Choose an area of interest:
> Select a pre-defined area R Draw an area ?
Select an area type and click the map.
Census Metropolitan Areas (| + | X bt duth-ServiceR s

Choose output options:

Choose an output file format (vector data only)
Shapefile - (.shp) E )

Choose an output coordinate system (vector data only)
Same As Input ?

Campden

Comers

Victoria Avenug/ _

Select datasets to include: Smithville|

oty Mire RY
¥| (= Cartographic Boundary Files (CBF), 2016 Census - Census Tracts Tw
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http://geo.scholarsportal.info/#r/details/_uri@=749265755$DLI_2016_Census_CBF_Eng_Nat_ct
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Click Download.

Under My download list, click the ZIP file to download.

Using File Explorer (MY COMPUTER), navigate to My Downloads and copy/paste the zip file to your local storage

device (i.e. OneDrive).
Right-click the zip file and select Extract All.

Close File Explorer. Close Google Chrome.

STEP FOUR: ArcGIS Pro — Adding data

1.

2
3.
4

Run ArcGIS Pro.
Create a new project > Blank
Provide a name for the project and browse to an appropriate storage location.

Click OK.

ArcGIS Pro creates a project file that includes all maps, tools, styles, etc. associated with your mapping project.

5. From the Insert tab, click New Map. Do not click the little down arrow. Catalog
. . . Project | Portal | Favorites | Histo
6. To open the catalog window click View > Catalog Pane e -
7. Right-click Folders > Add Folder Connection & Maps
8. Browse to the folder holding the unzipped shapefile and the census data file. = ;°:':°fef
SELECT ONLY THE FOLDER. This step creates a shortcut to the folder holding b @ Styles
b + Folders
the data f”es- b @ Locato +*  Add Folder Connection
9. From the Map tab, click Add Data. Do not click the little down arrow.
10. Under Project, click folders to see the shortcut created in the step above.
Add Data X
(_—J' TJ D » Project » Folders » » ||| Search Project
Organize * MNew ltem ~ T Em
4 Project Mame Type Date
\ i Databases B CensusMapping Folder Connection  11/21/2(
| » Folders QuantitativeMapping_ArcGIS_Pro Folder Connection  11/21/2(
El Portal \
o My Content
- Folder shortcut
e Groups
All Portal
B Living Atlas

4 [ Computer

Desktop

Name Default
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11. Double-click the folder shortcut and navigate to the CSV.
12. Select the file and click OK. The table appears under the heading Standalone Tables.
13. Click Add Data again and navigate to the shapefile downloaded in a previous step. Select the shapefile and click

OK to add it to the map.

r

l4 = Project MName Type Date
=l Databases :j DLI_2016_Census_CBF_Eng_Mat_ct.lyr Layer 11721
+ Folders | [E] DLI_2016_Census_CBF_Eng_Nat_ctshp  Shapefile 11/21
l4 & Portal
{j' My Content

14. Select the shapefile and click OK to open it.
STEP FIVE: Changing the Projection of the Map View

The map zooms to the extent of the shapefile; that is, the Niagara CMA. The default projection makes the map look

rotated. We will set the coordinate system for the map frame next.

1. From the Contents panel on the left, under Drawing Order, double click Map.
2. Click Coordinate Systems.
3. Inthe Search box, enter UTM. Hit Enter on the keyboard.
4. Double-click Projected coordinate system.
5. Double-click UTM then NAD 1983.
6. Scroll down and select NAD 1983 UTM Zone 17N. Click OK.
Map Properties: Map X
General Select the Coordinate System to view the available options.
Bxtent Current XY Dretails Current
Metadata
ST NAD 1983 UTM Zone 17N ‘ <MNone> ‘
Transf ti
enstemmanen XY Coordinate Systems Available | UtM x - | T &
lNumination
Labels (@ NAD 1983 UTM Zone 13N &
@ NAD 1983 UTM Zone 14N
@ NAD 1983 UTM Zone 15N
@ NAD 1983 UTM Zone 16N
|@ MAD 1983 UTM Zone 17N
e . hd

STEP SIX: Preparing the Attributes

This step involves joining the census data table to the census tract boundary file based on a common column.
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6.

8.
9.
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In the Contents pane, right-click the census tract boundary layer name (i.e.DLI_2016_Census_CBF_Eng_NAT_ct)
and click Attribute Table. Each census tract is linked with a row of attributes. Notice the column CTUID. This
column matches a column of data we downloaded with the census data (i.e. GeoUID).

In the Contents pane, right-click the standalone table census$ and click open. The first column in our census
data represents CTUID as well. We will perform a join based on CTUID (census tract unique identifier). But first
we need to create a new field that will populate the CTUID in the same data format as the census data.

In the Table view, click the table header named DLI_2016_Census_CBF_Eng_Nat_ct

Just below the table header are options for working with the table. Click the Add button to add a new field. The
view switches to the table fields view.

Enter a new field name “CT_UID”. This name must be unique from other field names.

Double-click the Data Type cell and select Double.

Under Number Format click the ellipsis button and choose Category Numeric with 2 decimal places. Click OK.
From the Fields tab at the top of the screen, click Save.

Reopen the attribute table for the census tract layer. Notice the new field added to the far right of the table.

10. Right-click the new field name CT_UID and select Calculate Field.

11. The goal is to populate the new field with the appropriately formatted CT UID. From the Fields section, double-

click CTUID. The expression is automatically populated as follows:

Geoprocessing i x

® Calculate Field

Parameters | Ervironments

Input Table

DLI_2016_Census_CBF_Eng_Nat_ct -

Field Name

CTUID3 -

Expression Type

Python 3 -
(1) Expression

Fields ? Helpers ?

FID .conjugate()
Shape .denominator{)
CTUID imag()

CTNAME .numerator()
PRUID real()

PRNAME .as_integer_ratio()
CMAUID fromhex()
CMAPLIN hexll

Insert Yalues Tl * o+ - =

CTUID3 =

Code Block

12. Click Run at the bottom right. The CT UID attribute field now matches the data type of the census data CT UID.



STEP SEVEN: Joining by attributes

1. Inthe Contents pane, right-click the census tract boundary layer name and select Joins & Relates then select
Add Join. The Add join tool pane is activated to the right of the map view.
2. Inthis example the software intuitively matches the fields from Geoprocessing v
the shapefile and census attributes. Confirm that the Input Join © Ll =
. ) . . . RIS @
Field reflects the new field added in the previous section. Parameters | Ervironmerts :
Layer Name or Table View
3. Click Run at the bottom right of the geoprocessing pane. DLI_2016_Census_CBF_Eng_Nat_ct -
. ) . . 1. Input Join Field
4. Toview the result, activate the table associated with the census CT UD -
Join Tabl
data (DLI_2016_Census_CBF_Eng_Nat_ct). It should be docked o -
below the map view. Output Join Field
CTUID -
5. Scroll to the right to see the joined attributes (AvgRent, Keep Al Target Features
TotalPopl150v, BachelorDegree_higher).
EE census$ LI 2016 Census CBF Eng Nat ¢t X
Field: EAdd @Dele‘ce ECalculate Selection: 1E§°‘ Switch =
A CTMAME  PRUID PRMNAME CMAUID  CMAPUID  CMANAME CMATYPE = Shape_leng  Shape_Area CT_UID CTUID Ctname AvgRent TotalPoplSov  BachelorDegree_higher
I 0209.03 35 Ontario 539 35539 St. Catharines - Miag... B 7597.968192 |2856803.66933 |5390209.03 '5390209.03 209.03 857 3935 525
0206.04 35 Ontario 539 35539 St. Catharines - Miag... B 7957.912248 |2397743.35313 |5390209.04 | 5390209.04 209.04 860 2735 3985
0209.05 35 Ontario 539 35539 5t. Catharines - Niag... B 7095.201324 |2941721.83784 |5390209.05 5390209.05 209.05 1112 5305 935
0200.06 35 Ontario 539 35539 St Catharines - Miag... B 5324.22562 |1828627.72906 |5390209.06  5390209.06 209.06 953 2620 765
0300.00 35 Ontario 539 35539 St. Catharines - Miag... B 16608.25258 9463463.34451 5390300 5390300 300 836 1165 100
0 35 Ontario 539 35539 St. Catharines - Miag... B 10843.172162 | 53424733.84527 5390301 5390301 30 888 4025 370
STEP EIGHT: Creating a choropleth map
A choropleth map applies a graduated colour scheme based on certain attributes. The first map we will make reflects
the average rent.
1. Click the census tract boundary layer (DLI_2016_Census_CBF _Eng Nat ct) agery  Share  View | Appearance | |
. . [%2] Masking -
to activate it. 7 asng
= T Display Filters
i Symbology - ype
2. Click the Appearance tab at the top of the screen. =  Import =
a-_________________|
3. Click the Symbology dropdown and select Graduated Colors. Symbolize your layer using one symbol
. . . Single Symbol
4. Beside Field, select AvgRent from the dropdown list. % A T
5. A default colour scheme is applied to the map where darker colours Symbolize your layer by category
Unique Values
represent hl her vaIues Draw categories using unique values of one
p g : or multiple fields.
6. From the Appearance tab, Effects group, Layer Blend options, select Symbolize your layer by quantity
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Darken > Mulitply. (This option is only available in Pro version 2.8 or

higher)

Graduated Colors
Draw quantities using graduated colors,
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ElMap x ~ | Symbology - DLI_2016_Census_CBF_Eng_Nat_ct =X
1d¢ A
\ " PBBY 4

Primary symbology

Graduated Colors
Ransomville

Batmer-Rd Field avgrent .

~0na Park Normalization | <None>
Method Natural Breaks (Jenks)
Grimsby

10319 Escarpment

Classes 5

Color scheme I | G

Classes | Histogram | Scales

portRd % More +

any LLHODIA

: 1
2 Symbol - Uppervalue = Label

<0 <0
West Lincoln

La Saile Nashville +| < 862 <862

< 9% <996
& Niagara

Peninsula | F=E23T: 1237

EREO0

North
Tonawanda
Tonawanda

v | =< 1735 21735
Winslow

Warner

Brighton M
Webber Rd

Kenmore

PY S31IIN

PY WIRYIM

Dunnville

Byng

West ¢

Port Maitland \\5 /
/

. Lackawanni

A lot of census data must be represented as a percentage. This is known as ‘normalization’. For example, the variable
downloaded earlier that represents highest level of schooling as bachelor’s degree or higher must be mapped as a

percentage of the population 15 and over. Follow these steps to map a normalized value.

7. Right-click the census tract layer (DLI_2016_Census_CBF_Eng_Nat_ct) and select Copy.

8. Inthe Contents panel, below Drawing Order, right-click the word Map and select Paste. You now have 2 layers
representing the census data.

9. Click the topmost layer to activate it. The symbology pane should still be activated to the right of the map view.

10. Change the Field option to BachelorDegree_Higher (population with bachelor degree or higher).

11. Beside Normalization, select Pop15o0v (total population 15 years of age and older).

12. Select a new colour scheme and see the map reflect your changes.

To enhance our understanding of the map we will adjust the legend values to reflect percentages (by default the
number represents a fraction.

13. From the Symbology pane, click the advanced symbol options button “E’El
14. Under Format Labels, beside Category, select Percentage.
15. Under Percentage, select Number represents a fraction. Adjust it to show as a percentage.
16. Change the number of decimal places to 1.

September 20, 2021
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Symbology - DLI_2016_Census_CBF_Eng_Nat_ct ~ *
AL
2% 56 g
AN
Advanced symbol options
v Format labels
Category |Percentage = F ] DL'_Z:” E_C'EI'ELIS_CEF_EHQ_NHI_CI:
Percentage bachelor_or_higher / totpopl5ov
() Number already represents a percentage.
on "o pereente [ ] «86%
umber represents a fraction. Adjust it to show as a percentage.
Rounding I:l 213.6%
(® Decimal places 2 s - =18.9%
O Significant digits - <77.4%
Alignment - A0
@) Left
() Right 12 =
[] Show thousands separators
I:‘ Pad with zeros
[] Show plus sign
» Sample size
» Data exclusion
» Feature level masking
. ~  Symbology - DLI_2016_Census_CBF_Eng_Nat_ct >3 X
S
\ Au —
; PBBY 4 =
Primary symbology
|Graduated Colors ¥
Field |bachelor_or_higher v
T'ﬁ:ﬁ:{' Normalization |totpop150v M
Reservation
Method [Natural Breaks Uenks) .
Classes | 5 v
Color scheme | L N
Niagara "'\\
Peninsula Classes | Histogram | Scales
) \
o More v

Symbol = Uppervalue = Label
] <] = o.086402 <8.6%
[ | < 013638 <13.6%
| %l < 0.189189 <18.9%

] B " <27.4%

=

v = 04 240%
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STEP NINE: Layout & Printing
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1. From the Insert tab, select Layout > Landscape > Letter
2. From the Insert tab > Map Frames, select Map Frame > select the map frame and draw a box on the map to
define the extent of the map.
5 ,"E;v'i' NASA NGA, USGS, Province of Cntano, &n Canada, Esm -y
’,’ Garmin, SafeGragh, FAO, METI/NASA, UISGS EPA NPS, NRCan,
/,’ Parks Canada
3. To change the scale of the map (zoom/pan), right-click the map and select ACTIVATE. You can now zoom and
pan. Alternately, enter a specific scale at the bottom left of the layout view
4. To stop the activation, click the red X = at the top right of the map view.
5. Toresize an element (l.e. the map window), select it, grab and drag the handles.

September 20, 2021
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6. To add other map elements, go to the Map Surrounds group from the INSERT tab and add a north arrow, scale

hoesis |l B

Morth  Scale Legend Chart Table Additional
Arrow~ Bar~ Frame~= Frame Surrounds~

Map Surrounds
bar, and legend. P

7. To add a title or other text, click the text tool in the Graphics and Text group on the INSERT tab.

A
Burl %
Population with Bachelors Degree 5, “al
or Higher as a percentage of \ [e]
A\
the population 15 and over
@ Niag a
) = h
T
~ .
«| Schooling
| Bachelor Degree
) ety | [ <86% P
[ =13.6%
Nisgara e 0 =18.9%
Peninsula B <27.4%
34 B =40%
£
e
V‘O.d
Buffalo
o2
dm ‘ﬁ-l!.-.‘
‘J
N o
? 110 2.0 A Pravince of Ontario, Esn Canana"hr(bf;ﬂi Garmin, FAQ, METI/NASA, USGS, EPA NPS, NRCarehued
L Ihmﬂa; Lt ’/, Parks Canada, Es, NASA NGA, USGS

8. Don’t forget to save your work!

9. To share your map with others, click the SHARE tab > Export Layout (provides a PDF, JPEG or TIFF)

Share

&0 B

Print Export Capture To
Layout Layout Chpboard

Output
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