3 Ipv6 Routing

Download as pdf or txt
Download as pdf or txt
You are on page 1of 27

IPv6 Routing Protocols

ISP Workshops

Last updated 23 August 2013 1


Initial IPv6 Configuration
for Cisco IOS

2
IPv6 Configuration on Cisco IOS
p  To
enable IPv6 the following global
commands are required:
Router(config)# ipv6 unicast-routing
n  Also enable IPv6 CEF (not on by default):
Router(config)# ipv6 cef
n  Also disable IPv6 Source Routing (enabled by
default):
Router(config)# no ipv6 source-routing

3
IPv6 Configuration
p  To configure a global or unique-local IPv6 address
the following interface command should be
entered:

Router(config-if)# ipv6 address X:X..X:X/prefix

p  To configure an EUI-64 based IPv6 address the


following interface command should be entered:

Router(config-if)# ipv6 address X:X::/prefix eui-64

n  EUI-64 is not helpful on a router and is not recommended


4
IPv6 Configuration
p  If no global IPv6 address is required on an
interface, yet it needs to carry IPv6 traffic:
n  Enable IPv6 on that interface using:
Router(config-if)# ipv6 enable
n  Which will result in a link-local IPv6 address being
constructed automatically
n  FE80:: is concatenated with the Interface ID to give:
p  FE80::interface-id
p  Configuring an IPv6 address (whether global or
unique-local) will also result in a link-local IPv6
address being created

5
IPv6 Configuration
Router1# conf t
Router1(config)# ipv6 unicast-routing
Router1(config)# ipv6 cef
Router1(config)# int fast 0/0
Router1(config-int)# ipv6 enable
Router1(config-int)# ^Z

Router1#sh ipv6 interface fast 0/0


FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::A8B9:C0FF:FE00:F11D
No global unicast address is configured
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF00:F11D
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled 6
IPv6 Configuration – EUI64
Router1#sh ipv6 interface fast 0/0
FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::A8B9:C0FF:FE00:F11D
Global unicast address(es):
2001:DB8::A8B9:C0FF:FE00:F11D, subnet is 2001:DB8::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF00:F11D
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
ND advertised reachable time is 0 milliseconds
ND advertised retransmit interval is 0 milliseconds
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds 7
Hosts use stateless autoconfig for addresses.
IPv6 Configuration – Static
Router1#sh ipv6 int fast 0/0
FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::A8B9:C0FF:FE00:F11D
Global unicast address(es):
2001:DB8::2, subnet is 2001:DB8::/64
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF08:2
FF02::1:FF00:F11D
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
ND advertised reachable time is 0 milliseconds
ND advertised retransmit interval is 0 milliseconds
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds 8
Hosts use stateless autoconfig for addresses.
IPv6 Interface Configuration
Duplicate Address Detection
p  If a point-to-point interface (e.g. POS, HSSI,
Serial) is looped:
n  Router sees its address by Solicited Node Multicast
n  Duplicate Address Detection kicks in:

Aug 23 09:18:41.263: %IPV6_ND-6-DUPLICATE_INFO: DAD attempt detected


for 2001:DB8:0:3:: on Serial1/1

n  Interface automatically disabled for IPv6 traffic (IPv4


traffic is unaffected)
n  This has impact for backbone links (IPv6 traffic takes
alternative path) and external peering links (IPv6
peering down, IPv4 peering okay)
p  Workaround?
n  Monitoring! 9
Routing Protocols

10
Static Routing
p  Syntax is:
n  ipv6 route ipv6-prefix/prefix-length {ipv6-address |
interface-type interface-number} [administrative-
distance]
p  Static Route

ipv6 route 2001:DB8::/64 2001:DB8:0:ABCD::1 150

n  Routes packets for network 2001:db8::/64 to a


networking device at 2001:DB8:0:ABCD::1 with an
administrative distance of 150

11
Default Routing Example

IPv6
Internet Router2
:e
:a Ethernet0
LAN1:
2001:db8:2:1::/64 Router1
:a Ethernet1
LAN2:
2001:db8:2:2::/64
ipv6 unicast-routing
!
interface Ethernet0
ipv6 address 2001:db8:2:1::a/64
!
interface Ethernet1
ipv6 address 2001:db8:2:2::a/64
! Default Route
ipv6 route ::/0 2001:db8:2:1::e to Router2 12
Dynamic Routing Protocols in IPv6
p  Dynamic Routing in IPv6 is unchanged from IPv4:
n  IPv6 has 2 types of routing protocols: IGP and EGP
n  IPv6 still uses the longest-prefix match routing
algorithm
p  IGP
n  RIPng (RFC 2080)
n  Cisco EIGRP for IPv6
n  OSPFv3 (RFC 5340)
n  Integrated IS-ISv6 (RFC 5308)
p  EGP
n  MP-BGP4 (RFC 4760 and RFC 2545)

13
Configuring Routing Protocols
p  Dynamic routing protocols require router-id
n  Router-id is a 32 bit integer
n  IOS auto-generates these from loopback interface
address if configured, else highest IPv4 address on the
router
n  Most ISPs will deploy IPv6 dual stack – so router-id will
be automatically created
p  Early adopters choosing to deploy IPv6 in the
total absence of any IPv4 addressing need to be
aware:
n  Router-id needs to be manually configured:
ipv6 router ospf 100
router-id 10.1.1.4

14
RIPng
p  For the ISP industry, simply don’t go here
p  ISPs do not use RIP in any form unless
there is absolutely no alternative
n  And there usually is
p  RIPngwas used in the early days of the
IPv6 test network
n  Sensible routing protocols such as OSPF and
BGP rapidly replaced RIPng when they became
available

15
EIGRP for IPv6
p  Cisco EIGRP has had IPv6 protocol support added
n  Just another protocol module (IP, IPX, AppleTalk) with
three new TLVs:
p  IPv6_REQUEST_TYPE (0X0401)
p  IPv6_METRIC_TYPE (0X0402)
p  IPv6_EXTERIOR_TYPE (0X0403)
n  Router-ID is still 32-bit, protocol is still 88
p  Uses similar CLI to existing IPv4 protocol support
p  Easy deployment path for existing IPv4 EIGRP
users
p  In Cisco IOS Release 12.4 onwards

16
EIGRP for IPv6
p  Some differences:
n  Hellos are sourced from the link-local address and
destined to FF02::A (all EIGRP routers). This means that
neighbors do not have to share the same global prefix
(with the exception of explicitly specified neighbours
where traffic is unicasted).
n  Automatic summarisation is disabled by default for IPv6
(unlike IPv4)
n  No split-horizon in the case of EIGRP for IPv6 (because
IPv6 supports multiple prefixes per interface)

17
EIGRP for IPv6—Configuration &
Display
Router 2
Ethernet0 = 2001:db8:2:1:245:21ff:fe00:feed

LAN1: 2001:db8:2:1::/64 Router2#


ipv6 router eigrp 100
Ethernet0 router-id 1.1.1.1

Router 1 interface Ethernet0


ipv6 address 2001:db8:2:1::/64 eui-64
Ethernet1 ipv6 enable
ipv6 eigrp 100
LAN2: 2001:db8:2:2::/64
Router1#show ipv6 eigrp neighbor
IPv6-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 FE80::245:21ff:fe00:feed E0 14 00:01:43 1 4500 0 1

Router1#show ipv6 eigrp topology all-links


IPv6-EIGRP Topology Table for AS(100)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 2001:db8:2:1::/64, 1 successors, FD is 28160, serno 1
via Connected, Ethernet0
Neighbour Identified
via FE80::245:21ff:fe00:feed (30720/28160), Ethernet0 by Link-Local Address
18
OSPFv3 overview
p  OSPFv3 is OSPF for IPv6 (RFC 5340)
p  Based on OSPFv2, with enhancements
p  Distributes IPv6 prefixes
p  Runs directly over IPv6
p  Ships-in-the-night with OSPFv2

19
Differences from OSPFv2
p  Runs over a link, not a subnet
n  Multiple instances per link
p  Topology not IPv6 specific
n  Router ID
n  Link ID

p  Standard authentication mechanisms


p  Uses link local addresses
p  Generalized flooding scope
p  Two new LSA types

20
OSPFv3 configuration example

Router1# Area 0
interface Ethernet0
ipv6 address 2001:db8:1:1::1/64 Router2
ipv6 ospf 1 area 0
LAN1: 2001:db8:1:1::/64
interface Ethernet1 Eth0
ipv6 address 2001:db8:2:2::2/64
ipv6 ospf 1 area 1 Router1
Eth1
ipv6 router ospf 1
router-id 1.1.1.1 LAN2: 2001:db8:2:2::/64

NB: Router-id only required in


Area 1
absence of any ipv4 configuration

21
ISIS Standards History
p  ISO 10589 specifies the OSI IS-IS routing
protocol for CLNS traffic
p  RFC 1195 added IPv4 support
n  Also known as Integrated IS-IS (I/IS-IS)
n  I/IS-IS runs on top of the Data Link Layer
p  RFC5308 adds IPv6 address family support
p  RFC5120 defines Multi-Topology concept
n  Permits IPv4 and IPv6 topologies which are not identical
n  Permits roll out of IPv6 without impacting IPv4
operations

22
Cisco IOS IS-IS dual stack
configuration
Router1#
interface ethernet 1
ip address 10.1.1.1 255.255.255.0
ipv6 address 2001:db8:1::a/64
LAN1: 2001:db8:1::a/64 ip router isis
ipv6 router isis
Ethernet 1
interface ethernet 2
Router1 ip address 10.2.1.1 255.255.255.0
Ethernet 2 ipv6 address 2001:db8:2::a/64
ip router isis
LAN2: 2001:db8:2::a/64 ipv6 router isis

router isis
net 42.0001.0000.0000.072c.00
metric-style wide
Dual IPv4/IPv6 configuration.
Redistributing both IPv6 static routes
and IPv4 static routes. 23
Multi-Protocol BGP for IPv6 –
RFC2545
p  IPv6 specific extensions
n  Scoped addresses: Next-hop contains a global
IPv6 address and/or potentially a link-local
address
n  NEXT_HOP and NLRI are expressed as IPv6
addresses and prefix
n  Address Family Information (AFI) = 2 (IPv6)
p  Sub-AFI = 1 (NLRI is used for unicast)
p  Sub-AFI = 2 (NLRI is used for multicast RPF check)

p  Sub-AFI = 3 (NLRI is used for both unicast and


multicast RPF check)
p  Sub-AFI = 4 (label)
24
A Simple MP-BGP Session
Router1 Router2
AS 65001 AS 65002
2001:db8:2:1::f 2001:db8:2:1::1

Router1#
interface Ethernet0
ipv6 address 2001:db8:2:1::f/64
!
router bgp 65001
bgp router-id 10.10.10.1
no bgp default ipv4-unicast
neighbor 2001:db8:2:1::1 remote-as 65002
address-family ipv6
neighbor 2001:db8:2:1::1 activate
neighbor 2001:db8:2:1::1 prefix-list bgp65002in in
neighbor 2001:db8:2:1::1 prefix-list bgp65002out out
exit-address-family
25
Routing Protocols for IPv6
Summary
p  Support for IPv6 in the major routing
protocols
p  More details for OSPF, ISIS and BGP in
separate presentations

26
IPv6 Routing Protocols
ISP Workshops

27

You might also like

pFad - Phonifier reborn

Pfad - The Proxy pFad of © 2024 Garber Painting. All rights reserved.

Note: This service is not intended for secure transactions such as banking, social media, email, or purchasing. Use at your own risk. We assume no liability whatsoever for broken pages.


Alternative Proxies:

Alternative Proxy

pFad Proxy

pFad v3 Proxy

pFad v4 Proxy