Faza 2
Faza 2
Faza 2
hostname Hub
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 5
exit
crypto isakmp key cisco95 address 0.0.0.0 0.0.0.0
crypto ipsec transform-set VPN esp-aes 256 esp-sha-hmac
mode transport
crypto ipsec profile dmvpn
set transform-set VPN
exit
interface Tunnel1
ip address 172.16.1.1 255.255.255.0
no ip redirects
no ip next-hop-self eigrp 10
no ip split-horizon eigrp 10
ip mtu 1400
ip nhrp authentication test
ip nhrp map multicast dynamic
ip nhrp network-id 1
ip tcp adjust-mss 1360
tunnel source f0/0
tunnel mode gre multipoint
tunnel key 10
tunnel protection ipsec profile dmvpn
exit
interface f0/0
ip address 200.1.0.1 255.255.255.0
no shut
exit
interface f0/1
ip address 192.168.1.1 255.255.255.0
no shut
exit
router eigrp 10
network 172.16.1.0 0.0.0.255
network 192.168.1.0 0.0.0.255
no auto-summary
exit
router ospf 1
network 200.1.0.0 0.0.0.255 area 0
exit
exit
Spoke1
Conf t
hostname Spoke1
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 5
exit
crypto isakmp key cisco95 address 0.0.0.0 0.0.0.0
crypto ipsec transform-set VPN esp-aes 256 esp-sha-hmac
mode transport
crypto ipsec profile dmvpn
set transform-set VPN
exit
interface Tunnel1
ip address 172.16.1.2 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication test
ip nhrp map multicast dynamic
ip nhrp map 172.16.1.1 200.1.0.1
ip nhrp map multicast 200.1.0.1
ip nhrp network-id 1
ip nhrp nhs 172.16.1.1
delay 1000
ip tcp adjust-mss 1360
tunnel source f0/0
tunnel mode gre multipoint
tunnel key 10
tunnel protection ipsec profile dmvpn
exit
interface f0/0
ip address 200.2.0.1 255.255.255.0
no shut
exit
interface f0/1
ip address 192.168.2.1 255.255.255.0
no shut
exit
router eigrp 10
network 172.16.1.0 0.0.0.255
network 192.168.2.0 0.0.0.255
no auto-summary
exit
router ospf 1
network 200.2.0.0 0.0.0.255 area 0
exit
exit
Spoke2
Conf t
hostname Spoke2
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 5
exit
crypto isakmp key cisco95 address 0.0.0.0 0.0.0.0
crypto ipsec transform-set VPN esp-aes 256 esp-sha-hmac
mode transport
crypto ipsec profile dmvpn
set transform-set VPN
exit
interface Tunnel1
ip address 172.16.1.3 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication test
ip nhrp map multicast dynamic
ip nhrp map 172.16.1.1 200.1.0.1
ip nhrp map multicast 200.1.0.1
ip nhrp network-id 1
ip nhrp nhs 172.16.1.1
delay 1000
ip tcp adjust-mss 1360
tunnel source f0/0
tunnel mode gre multipoint
tunnel key 10
tunnel protection ipsec profile dmvpn
exit
interface f0/0
ip address 200.3.0.1 255.255.255.0
no shut
exit
interface f0/1
ip address 192.168.3.1 255.255.255.0
no shut
exit
router eigrp 10
network 172.16.1.0 0.0.0.255
network 192.168.3.0 0.0.0.255
no auto-summary
exit
router ospf 1
network 200.3.0.0 0.0.0.255 area 0
exit
exit
Spoke3
Conf t
hostname Spoke3
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 5
exit
crypto isakmp key cisco95 address 0.0.0.0 0.0.0.0
crypto ipsec transform-set VPN esp-aes 256 esp-sha-hmac
mode transport
crypto ipsec profile dmvpn
set transform-set VPN
exit
interface Tunnel1
ip address 172.16.1.4 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication test
ip nhrp map multicast dynamic
ip nhrp map 172.16.1.1 200.1.0.1
ip nhrp map multicast 200.1.0.1
ip nhrp network-id 1
ip nhrp nhs 172.16.1.1
delay 1000
ip tcp adjust-mss 1360
tunnel source f0/0
tunnel mode gre multipoint
tunnel key 10
tunnel protection ipsec profile dmvpn
exit
interface f0/0
ip address 200.4.0.1 255.255.255.0
no shut
exit
interface f0/1
ip address 192.168.4.1 255.255.255.0
no shut
exit
router eigrp 10
network 172.16.1.0 0.0.0.255
network 192.168.4.0 0.0.0.255
no auto-summary
exit
router ospf 1
network 200.4.0.0 0.0.0.255 area 0
exit
exit
ISP
conf t
hostname ISP
interf f0/0
ip address 200.1.0.2 255.255.255.0
no shut
exit
interf f0/1
ip address 200.2.0.2 255.255.255.0
no shut
exit
interf f1/0
ip address 200.3.0.2 255.255.255.0
no shut
exit
interf f2/0
ip address 200.4.0.2 255.255.255.0
no shut
exit
router ospf 1
network 200.1.0.0 0.0.0.255 area 0
network 200.2.0.0 0.0.0.255 area 0
network 200.3.0.0 0.0.0.255 area 0
network 200.4.0.0 0.0.0.255 area 0
exit
exit
ip 192.168.1.2 255.255.255.0 192.168.1.1
ip 192.168.2.2 255.255.255.0 192.168.2.1
ip 192.168.3.2 255.255.255.0 192.168.3.1
ip 192.168.4.2 255.255.255.0 192.168.4.1