OSPF Virtual Link and Special Areas

Download as pdf or txt
Download as pdf or txt
You are on page 1of 11

/* Step-1: Assign IP Address of all interfaces and configure OSPF, Static, RIP */

R1#configure terminal
R1(config)#interface serial 2/0
R1(config-if)#ip address 192.168.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 2/1


R1(config-if)#ip address 192.168.1.5 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 1/1


R1(config-if)#ip address 192.168.1.9 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 1/2


R1(config-if)#ip address 192.168.1.13 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 1/3


R1(config-if)#ip address 192.168.1.17 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 1/0
R1(config-if)#ip address 192.168.1.21 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

/* Configure OSPF */
R1(config)#router ospf 1
R1(config-router)#net
R1(config-router)#network 192.168.1.0 0.0.0.3 area 0
R1(config-router)#network 192.168.4.0 0.0.0.3 area 0
R1(config-router)#network 192.168.8.0 0.0.0.3 area 0
R1(config-router)#network 192.168.12.0 0.0.0.3 area 0
R1(config-router)#network 192.168.16.0 0.0.0.3 area 0
R1(config-router)#network 192.168.20.0 0.0.0.3 area 0
R1(config-router)#^Z
R1#wr

/* Configure default-Static Route */


R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 1.1.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#ip route 0.0.0.0 0.0.0.0 1.1.1.2

R2#configure terminal
R2(config)#interface serial 1/0
R2(config-if)#ip address 192.168.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial 1/1


R2(config-if)#ip address 10.1.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

/* Configure OSPF */
R2(config)#router ospf 1
R2(config-router)#net
R2(config-router)#network 192.168.1.0 0.0.0.3 area 0
R2(config-router)#network 10.1.1.0 0.0.0.255 area 1
R2(config-router)#^Z
R2#wr

R3#configure terminal
R3(config)#interface serial 1/2
R3(config-if)#ip address 10.1.1.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
/* Configure OSPF */
R3(config)#router ospf 1
R3(config-router)#network 10.1.1.0 0.0.0.255 area 1
R3(config-router)#^z
R3#wr

R4#configure terminal
R4(config)#interface loopback 0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#exit

R4(config)#interface serial 1/0


R4(config-if)#ip address 192.168.1.6 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit

R4(config)#interface serial 1/1


R4(config-if)#ip address 10.1.2.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit

/* Step-2: Configure OSPF */


R4(config)#router ospf 1
R4(config-router)#net
R4(config-router)#network 192.168.1.4 0.0.0.3 area 0
R4(config-router)#network 10.1.2.0 0.0.0.255 area 2
R4(config-router)#exit

R5#configure terminal
R5(config)#interface loopback 0
R5(config-if)#ip address 5.5.5.5 255.255.255.255
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface serial 1/2


R5(config-if)#ip address 10.1.2.2 255.255.255.252
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface serial 1/0


R5(config-if)#ip address 10.1.3.1 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit

/* Configure OSPF */
R5(config)#router ospf 1
R5(config-router)#network 10.1.2.0 0.0.0.255 area 2
R5(config-router)#network 10.1.3.0 0.0.0.255 area 3
R5(config-router)#exit

R6(config)#interface serial 1/3


R6(config-if)#ip address 10.1.3.2 255.255.255.0
R6(config-if)#no shutdown
R6(config-if)#exit

/* Configure OSPF */
R6(config)#router ospf 1
R6(config-router)#network 10.1.3.0 0.0.0.255 area 3
R6(config-router)#^Z
R6#wr

R7#configure terminal
R7(config)#interface serial 1/1
R7(config-if)#ip address 192.168.1.10 255.255.255.252
R7(config-if)#no shutdown
R7(config-if)#exit

R7(config)#interface serial 1/0


R7(config-if)#ip address 10.1.4.1 255.255.255.0
R7(config-if)#no shutdown
R7(config-if)#exit

/* Configure OSPF */
R7(config)#router ospf 1
R7(config-router)#network 192.168.1.8 0.0.0.3 area 0
R7(config-router)#network 10.1.4.0 0.0.0.255 area 4
R7(config-router)#^Z
R7#wr

/* Assign IP Address of all interfaces */


R8#configure terminal
R8(config)#interface serial 1/0
R8(config-if)#ip address 10.1.4.2 255.255.255.0
R8(config-if)#no shutdown
R8(config-if)#exit

/* Configure OSPF */
R8(config)#router ospf 1
R8(config-router)#network 10.1.4.0 0.0.0.255 area 4
R8(config-router)#^Z
R8#wr
R9#configure terminal
R9(config)#interface serial 1/0
R9(config-if)#ip address 192.168.1.14 255.255.255.252
R9(config-if)#no shutdown
R9(config-if)#exit

R9(config)#interface serial 1/1


R9(config-if)#ip address 10.1.5.1 255.255.255.0
R9(config-if)#no shutdown
R9(config-if)#exit

/* Configure OSPF */
R9(config)#router ospf 1
R9(config-router)#network 192.168.1.12 0.0.0.3 area 0
R9(config-router)#network 10.1.5.0 0.0.0.255 area 5
R9(config-router)#^Z
R9#wr

R10#configure terminal
R10(config)#interface serial 1/2
R10(config-if)#ip address 10.1.5.2 255.255.255.0
R10(config-if)#no shutdown
R10(config-if)#exit

/* Configure OSPF */
R10(config)#router ospf 1
R10(config-router)#network 10.1.5.0 0.0.0.255 area 5
R10(config-router)#^Z
R10#wr

R11#configure terminal
R11(config)#interface serial 1/0
R11(config-if)#no shutdown
R11(config-if)#exit

R11(config-if)#ip address 10.1.6.1 255.255.255.0


R11(config-if)#no shutdown
R11(config-if)#exit

/* Configure OSPF */
R11(config)#router ospf 1
R11(config-router)#network 192.168.1.16 0.0.0.3 area 0
R11(config-router)#network 10.1.6.0 0.0.0.255 area 6
R11(config-router)#^Z
R11#wr
R12#configure terminal
R12(config)#interface serial 1/2
R12(config-if)#ip address 10.1.6.2 255.255.255.0
R12(config-if)#no shutdown
R12(config-if)#exit

R12(config)#interface fastEthernet 0/0


R12(config-if)#ip address 172.22.1.1 255.255.255.0
R12(config-if)#no shutdown
R12(config-if)#exit

/* Configure OSPF */
R12(config)#router ospf 1
R12(config-router)#network 10.1.6.0 0.0.0.255 area 6
R12(config-router)#ex
R12(config-router)#exit

/* Configure RIP */
R12(config)#router rip
R12(config-router)#version 2
R12(config-router)#no auto-summary
R12(config-router)#network 172.22.1.0
R12(config-router)#^Z
R12#wr

R13(config)#interface fastEthernet 0/1


R13(config-if)#ip address 172.22.1.2 255.255.255.0
R13(config-if)#no shutdown
R13(config-if)#exit

/* Configure RIP */
R13(config)#router rip
R13(config-router)#version 2
R13(config-router)#no auto-summary
R13(config-router)#network 172.22.1.0
R13(config-router)#^Z
R13#wr

R14#configure terminal
R14(config)#interface serial 1/0
R14(config-if)#ip address 192.168.1.22 255.255.255.252
R14(config-if)#no shutdown
R14(config-if)#exit

R14(config)#interface serial 1/1


R14(config-if)#ip address 10.1.7.1 255.255.255.0
R14(config-if)#no shutdown
R14(config-if)#exit

/* Configure OSPF */
R14(config)#router ospf 1
R14(config-router)#network 192.168.1.20 0.0.0.3 area 0
R14(config-router)#network 10.1.7.0 0.0.0.255 area 7
R14(config-router)#^Z
R14#wr

R15#configure terminal
R15(config)#interface serial 1/2
R15(config-if)#no shutdown
R15(config-if)#exit

R15(config)#interface fastEthernet 0/0


R15(config-if)#ip address 172.22.2.1 255.255.255.0
R15(config-if)#no shutdown
R15(config-if)#exit

/* Configure OSPF */
R15(config)#router ospf 1
R15(config-router)#network 10.1.7.0 0.0.0.255 area 7
R15(config-router)#exit

/* Configure RIP */
R15(config)#router rip
R15(config-router)#version 2
R15(config-router)#no auto-summary
R15(config-router)#network 172.22.2.0
R15(config-router)#^Z
R15#wr

R16#configure terminal
R16(config)#interface fastEthernet 0/0
R16(config-if)#ip address 172.22.2.2 255.255.255.0
R16(config-if)#no shutdown
R16(config-if)#exit

/* Configure RIP */
R16(config)#router rip
R16(config-router)#version 2
R16(config-router)#no auto-summary
R16(config-router)#network 172.22.2.0
R16(config-router)#^Z
R16#wr

R17(config)#interface fastEthernet 0/1


R17(config-if)#ip address 1.1.1.2 255.255.255.252
R17(config-if)#no shutdown
R17(config-if)#exit

R17(config)#interface loopback 0
R17(config-if)#ip address 17.17.17.17 255.255.255.0

/* Configure Static Route */


R17(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.1
R17(config)#exit
R17#wr

/* Step-2: Vitrual Link configuration on router R4 & R5 */


R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#area 2 virtual-link 5.5.5.5
R4(config-router)#^z
R4#wr

R5(config)#router ospf 1
R5(config-router)#router-id 5.5.5.5
R5(config-router)#area 2 virtual-link 4.4.4.4
R5(config-router)#^Z
R5#wr

/* Step-3: Redistribute Static, RIP to OSPF domain and vice-versa at Router R1 */


>>> Redistribute Static into OSPF router R1 >>>
R1(config)#router ospf 1
R1(config-router)#redistribute static subnets

>>> Redistribute RIP into OSPF and vice versa at router R12 >>>
R12(config)#router ospf 1
R12(config-router)#redistribute rip subnets
R12(config-router)#exit

R12(config)#router rip
R12(config-router)#redistribute ospf 1 metric 5
R12(config-router)#^Z
R12#wr

>>> Redistribute RIP into OSPF and vice-versa at Router R15 >>>
R15(config)#router ospf 1
R15(config-router)#redistribute rip subnets
R15(config-router)#exit

R15(config)#router rip
R15(config-router)#redistribute ospf 1 metric 5
R15(config-router)#exit
/* Step-4: STUB Area configuration on router R7 & R8 */
R7(config)#router ospf 1
R7(config-router)#area 4 stub

R8(config)#router ospf 1
R8(config-router)#area 4 stub

/* Step-5: Totally STUB Area configuration on router R9 & R10 */


R9(config)#router ospf 1
R9(config-router)#area 5 stub no-summary

R10(config)#router ospf 1
R10(config-router)#area 5 stub no-summary
/* Step-6: NSSA (Not-So-Stubby-Area) configuration on router R11 & R12 */
R11(config)#router ospf 1
R11(config-router)#area 6 nssa default-information-originate

R12(config)#router ospf 1
R12(config-router)#area 6 nssa
/* Step-7: Totally NSSA configuration on router R14 & R15 */
R14(config)#router ospf 1
R14(config-router)#area 7 nssa no-summary

R15(config)#router ospf 1
R15(config-router)#area 7 nssa no-summary

You might also like

pFad - Phonifier reborn

Pfad - The Proxy pFad of © 2024 Garber Painting. All rights reserved.

Note: This service is not intended for secure transactions such as banking, social media, email, or purchasing. Use at your own risk. We assume no liability whatsoever for broken pages.


Alternative Proxies:

Alternative Proxy

pFad Proxy

pFad v3 Proxy

pFad v4 Proxy