Correction TP Routage
Correction TP Routage
Correction TP Routage
Module : TCP/IP
R1
Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface fastEthernet 0/0
R1(config-if)# ip address 192.168.1.2 255.255.255.0
R1(config-if)#exit
R1(config)#no ip routing
R1(config)#ip default-gateway 192.168.1.1
R1(config)#exit
R1#write
R2
Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface fastEthernet 0/0
R2(config-if)# ip address 192.168.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 0/0
R2(config-if)# ip address 192.168.12.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
Anne : 2012-2013
R2(config)#router rip
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.12.0
R2(config)#exit
R2#write
R3
Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#interface fastEthernet 0/0
R3(config-if)# ip address 192.168.2.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface serial0/0
R3(config-if)# ip address 192.168.12.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#network 192.168.2.0
R3(config-router)#network 192.168.12.0
R3(config)#exit
R3#write
R4
Router>enable
Router#configure terminal
Router(config)#hostname R4
R2
Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.12.0
R2(config)#exit
R2#write
R3
Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config-router)#network 192.168.2.0
R3(config-router)#network 192.168.12.0
R3(config)#exit
R3#write
R4
Router>enable
Router#configure terminal
Router(config)#hostname R4
Configuration OSPF
R1
Router>en
Router#configure terminal
Router(conf)#hostname R1
R1(conf)#no ip routing
R1(conf)#ip default-gateway 192.168.1.1
R1(conf)#interface FastEthernet0/0
R1(conf-if)#ip address 192.168.1.2 255.255.255.0
R1(conf-if)#no shutdown
R1(conf-if)#end
R1#wr
R2
Router>en
Router#configure terminal
Router(conf)#hostname R2
R2(conf)#interface FastEthernet0/0
R2(conf-if)#ip address 192.168.1.1 255.255.255.0
R2(conf-if)#no shutdown
R2(conf-if)#exit
R2(conf)#interface Serial0/0
R2(conf-if)#ip address 192.168.12.1 255.255.255.0
R2(conf-if)#no shutdown
R2(conf-if)#exit
R2(config-router)#router ospf 1
R2(config-router)#network 192.168.1.0 0.0.0.255 area 0
R2(config-router)#network 192.168.12.0 0.0.0.255 area 0
R2(config-router)#end
R2#wr
R3
Router>en
Router#configure terminal
Router(conf)#hostname R3
R3(conf)#interface FastEthernet0/0
R3(conf-if)#ip address 192.168.2.1 255.255.255.0
R3(conf-if)#no shutdown
R3(conf-if)#exit
R3(conf)#interface Serial0/0
R3(conf-if)#ip address 192.168.12.2 255.255.255.0
R3(conf-if)#no shutdown
R3(conf-if)#exit
R3(config)#router ospf 1
R3(config-router)#network 192.168.2.0 0.0.0.255 area 0
R3(config-router)#network 192.168.12.0 0.0.0.255 area0
R3(config-router)#end
R3#wr
R4
Router>en
Router#configure terminal
Router(conf)#hostname R4
R4(conf)#no ip routing
R4(conf)#ip default-gateway 192.168.2.1
R4(conf)#interface FastEthernet0/0
R3(conf-if)# ip address 192.168.2.2 255.255.255.0
R4(conf-if)#no shutdown
R4(conf-if)#end
R4#wr
R1
Router>en
Router#configure terminal
Router(conf)#hostname R1
R1(conf)#no ip routing
R1(conf)#ip default-gateway 192.168.1.1
R1(conf)#interface FastEthernet0/0
R1(conf-if)#ip address 192.168.1.2 255.255.255.0
R1(conf-if)#no shutdown
R1(conf-if)#end
R1#wr
R2
Router>en
Router#configure terminal
Router(conf)#hostname R2
R2(conf)#interface FastEthernet0/0
R3
Router>en
Router#configure terminal
Router(conf)#hostname R3
R3(conf)#interface FastEthernet0/0
R3(conf-if)#ip address 192.168.2.1 255.255.255.0
R3(conf-if)#no shutdown
R3(conf-if)#exit
R3(conf)#interface Serial0/0
R3(conf-if)#ip address 192.168.12.2 255.255.255.0
R3(conf-if)#no shutdown
R3(conf-if)#exit
R3(conf)#interface Serial0/1
R3(conf-if)#ip address 192.168.24.1 255.255.255.0
R3(conf-if)#no shutdown
R3(conf-if)#exit
R3(config)#router bgp 2
R3(config-router)#network 192.168.2.0
R3(config-router)#network 192.168.12.0
R3(config-router)#network 192.168.24.0
R3(config-router)#neighbor 192.168.12.1 remote-as 1
R3(config-router)#neighbor 192.168.24.2 remote-as 4
R3(config-router)#end
R3#wr
R4
Router>en
Router#configure terminal
Router(conf)#hostname R4
R4(conf)#no ip routing
R4(conf)#ip default-gateway 192.168.2.1
R4(conf)#interface FastEthernet0/0
R3(conf-if)# ip address 192.168.2.2 255.255.255.0
R4(conf-if)#no shutdown
R4(conf-if)#end
R4#wr
R5
Router>en
Router#configure terminal
Router(conf)#hostname R5
R5(conf)#no ip routing
R5(conf)#ip default-gateway 192.168.3.1
R5(conf)#interface FastEthernet0/0
R5(conf-if)#ip address 192.168.3.2 255.255.255.0
R5(conf-if)#no shutdown
R5(conf-if)#end
R5#wr
R6
Router>en
Router#configure terminal
Router(conf)#hostname R6
R6(conf-if)#interface FastEthernet0/0
R6(conf-if)#ip address 192.168.3.1 255.255.255.0
R6(conf-if)#no shutdown
R6(conf-if)#exit
R6(conf)#interface Serial0/0
R6(conf-if)#ip address 192.168.34.1 255.255.255.0
R6(conf-if)#no shutdown
R6(conf-if)#exit
R6(conf)#interface Serial0/1
R6(conf-if)#ip address 192.168.13.2 255.255.255.0
R6(conf-if)#no shutdown
R6(conf-if)#exit
R6(conf)#router bgp 3
R6(conf-router)#network 192.168.3.0
R6(conf-router)#network 192.168.13.0
R6(conf-router)#network 192.168.34.0
R6(conf-router)#neighbor 192.168.13.1 remote-as 1
R6(conf-router)#neighbor 192.168.34.2 remote-as 4
R6(conf-router)#end
R6#wr
R7
Router>en
Router#configure terminal
Router(conf)#hostname R7
R7(conf)#interface FastEthernet0/0
R7(conf-if)#ip address 192.168.4.1 255.255.255.0
R7(conf-if)#no shutdown
R7(conf-if)#exit
R7(conf)#interface Serial0/0
R7(conf-if)# ip address 192.168.34.2 255.255.255.0
R7(conf-if)#no shutdown
R7(conf-if)#exit
R7(conf)#interface Serial0/1
R7(conf-if)# ip address 192.168.24.2 255.255.255.0
R7(conf-if)#no shutdown
R7(conf-if)#exit
R7(conf)#router bgp 4
R7(conf-router)#network 192.168.4.0
R7(conf-router)#network 192.168.24.0
R7(conf-router)#network 192.168.34.0
R7(conf-router)#neighbor 192.168.24.1 remote-as 2
R7(conf-router)#neighbor 192.168.34.1 remote-as 3
R7(conf-router)#end
R7#wr
R8
Router>en
Router#configure terminal
Router(conf)#hostname R8
R8(conf)#ip default-gateway 192.168.4.1
R8(conf)#interface FastEthernet0/0
R8(conf-if)#ip address 192.168.4.2 255.255.255.0
R8(conf-if)#no shutdown
R8(conf-if)#end
R8#wr