E. Lab Task 12

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 4

ISRA UNIVERSITY

Faculty of Engineering, Science &Technology


Department of Computer Science

Course Code Course Name Credit Hours


CSDC-214 Data Communication & Computer Networks 4(3 + 3)

Lab Task # 12
Student’s Name: ________________ Student’s ID: _____________

Date: _________ Teacher’s Sig: ____________

Title: To Use Cisco Router as DHCP Server

Objective: To deal with the Introduction and usage of different networking devices.

Exercises: To perform the following lab, We will configure DHCP in cisco router using packet
tracer simulator;

Step 1:Create the following topology,

Data Communication & Computer Networks, CSDC-214 1


Step 2:Configure router interface fastethernet0/0 and fastethernet

1/0 with ip address.

R1#config t
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown

R1(config-if)#exit
R1(config)#interface fastethernet 0/1
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

Step 3:Configure DHCP pool for the network 10 and 20,

In Router R1,Global Configuration mode,

R1(config)#service dhcp (may not work in this scenario, but do not worry and do other steps)

This command is to enable the dhcp server on a router. Routers in packet tracer won't accept this

Data Communication & Computer Networks, CSDC-214 2


command.By default dhcp will be running on router so skip 'service dhcp' command if you are
configuring dhcp in packet tracer,just create a network pool for the network it will work.Use this
in real time or other simulators like gns3.

R1(config)#ip dhcp pool 10network "where '10network' is the pool name we can use
whatever we
want.This command get us into the DHCP Configuration mode."

R1(dhcp-config)#network 10.0.0.0 255.0.0.0 "It defines the network range to be leased"

R1(dhcp-config)#dns-server 10.0.0.2 "Ip address for the dns server."

R1(dhcp-config)#default-router 10.0.0.1 "Default gateway for this network."

R1(dhcp-config)#exit

DHCP pool for 10 Network

R1(config)#ip dhcp pool 10network


R1(dhcp-config)#network 10.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 10.0.0.1
R1(dhcp-config)#exit

DHCP pool for 20 Network

R1(config)#ip dhcp pool 20network


R1(dhcp-config)#network 20.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 20.0.0.1
R1(dhcp-config)#exit
Range of ip address excluded from the pool it will not be leased to the clients.
R1(config)#ip dhcp excluded address 10.0.0.1 10.0.0.10
R1(config)#ip dhcp excluded address 10.0.0.35

Now, Click on any of the PC->Desktop->ip configuration->Choose DHCP.Now PC will get an


ip from DHCP server.

Data Communication & Computer Networks, CSDC-214 3


Data Communication & Computer Networks, CSDC-214 4

You might also like

pFad - Phonifier reborn

Pfad - The Proxy pFad of © 2024 Garber Painting. All rights reserved.

Note: This service is not intended for secure transactions such as banking, social media, email, or purchasing. Use at your own risk. We assume no liability whatsoever for broken pages.


Alternative Proxies:

Alternative Proxy

pFad Proxy

pFad v3 Proxy

pFad v4 Proxy