Route Lab

Download as pdf or txt
Download as pdf or txt
You are on page 1of 8

1.

Question

By increasing the first distant office, JS manufactures has extended their business. They configured
the remote office router (R3) from which they can reach all Corporate subnets. In order to raise
network stableness and lower the memory usage and broadband utilization to R3, JS manufactures
makes use of route summarization together with the EIGRP Stub Routing feature. Another network
engineer is responsible for the implementing of this solution. However, in the process of configuring
EIGRP stub routing connectivity with the remote network devices off of R3 has been missing.

Presently JS has configured EIGRP on all routers in the network R2, R3, and R4. Your duty is to find
and solve the connectivity failure problem with the remote office router R3. You should then configure
route summarization only to the distant office router R3 to complete the task after the problem has
been solved.

The success of pings from R4 to the R3 LAN interface proves that the fault has been corrected and the
R3 IP routing table only contains two 10.0.0.0 subnets.

Ans:

R3#configure terminal
R3(config)#router eigrp 123
R3(config-router)#no eigrp stub receive-only
R3(config-router)#eigrp stub
R3(config-router)#end

R4>enable
R4#configure terminal
R4(config)#interface s0/0
R4(config-if)#ip summary-address eigrp 123 10.2.0.0 255.255.0.0

Question: (Hope someone will contribute the detailed requirement of this sim!)

Some information I have gathered so far:

R2 is an ASBR for EIGRP 100 and OSPF AREA 24

R3 is an ASBR for EIGRP 100 and OSPF AREA 34

[note: so there are TWO separate areas on TWO separate ASBRS

thus you need to do redistribution on R2 and R3

R1 is ONLY in EIGRP 100, and is THE ONLY router you can ping from. R4 has a loopback interface that
must be pinged from R1.

R4 is running OSPF and has redundant link to EIGRP network over R3 router.

Notice: You should make a ping from R1 to 172.16.100.1 network to make sure everything is working
correctly.
Ans

First we need to find out 5 parameters (Bandwidth, Delay, Reliability, Load, MTU) of the s0/0/0
interface (the interface of R2 connected to R4) for redistribution :

R2#show interface s0/0/0

Write down these 5 parameters, notice that we have to divide the Delay by 10 because its metric unit
is tens of microsecond. For example, we get Bandwidth=1544 Kbit, Delay=20000 us, Reliability=255,
Load=1, MTU=1500 bytes then we would redistribute as follows:

R2#config terminal

R2(config)# router ospf 1

R2(config-router)# redistribute eigrp 100 metric-type 1 subnets

R2(config-router)#exit

R2(config-router)#router eigrp 100

R2(config-router)#redistribute ospf 1 metric 1544 2000 255 1 1500

(Notice: In fact, these parameters are just used for reference and we can use other parameters with
no problem. Also, a candidate said that the simulator didn’t accept the Bandwidth of 1544; in that
case, we can use a lower value, like 128.

If the delay is 20000us then we need to divide it by 10, that is 20000 / 10 = 2000)

For R3 we use the show interface fa0/0 to get 5 parameters too

R3#show interface fa0/0

For example we get Bandwidth=10000 Kbit, Delay=1000 us, Reliability=255, Load=1, MTU=1500
bytes

R3#config terminal

R3(config)#router ospf 1

R3(config-router)#redistribute eigrp 100 metric-type 1 subnets

R3(config)#exit

R3(config-router)#router eigrp 100

R3(config-router)#redistribute ospf 1 metric 10000 100 255 1 1500

Finally you should try to “show ip route” to see the 172.16.100.1 network (the network behind R4) in
the routing table of R1 and make a ping from R1 to this network.
3

Question

Company Acan has two links which can take it to the Internet. The company policy demands that you
use web traffic to be forwarded only to Frame Relay link if available and other traffic can go through
any links. No static or default routing is allowed.

All the HTTP traffic from the EIGRP Network should go through Frame Relay link if available and all the
other traffic should go through either link.
The only router you are able to administrate is the Border Router, from the EIGRP Network you may
only send HTTP traffic. As the other people mentioned, actually it is not a BGP lab. You are not able to
execute the command “router bgp 65001″

1) Access list that catches the HTTP traffic:


BorderRouter#access-list 101 permit tcp any any eq www

Note that the server was not directly connected to the Border Router. There were a lot of EIGRP
routes on it. In the real exam you do not know the exact IP address of the server in the EIGRP
network so we have to use the source as “any” to catch all the source addresses.

2) Route map that sets the next hop address to be ISP1 and permits the rest of the traffic:
BorderRouter(config)#route-map pbr permit 10
BorderRouter(config-route-map)#match ip address 101
BorderRouter(config-route-map)#set ip next-hop 10.1.101.1
BorderRouter(config-route-map)#exit
BorderRouter(config)#route-map pbr permit 20

(Notice: the route-map pbr permit 20 line allows other traffic than HTTP to be routed. Otherwise,
other traffic will be dropped)

3) Apply the route-map on the interface to the server in the EIGRP Network:
BorderRouter(config-route-map)#exit
BorderRouter(config)#int fa0/0
BorderRouter(config-if)#ip policy route-map pbr
BorderRouter(config-if)#exit
BorderRouter(config)#exit

4) There is a “Host for Testing”, click on this host to open a box in which there is a button named
“Generate HTTP traffic”. Click on this button to generate some packets for HTTP traffic. Jump back to
the BorderRouter and type the command “show route-map”.

BorderRouter#show route-map

4.

Question

OSPF is configured on routers Amani and Lynaic. Amani’s S0/0 interface and Lynaic’s S0/1 interface
are in Area 0. Lynaic’s Loopback0 interface is in Area 2.

Your task is to configure the following:


Portland’s S0/0 interface in Area 1
Amani’s S0/1 interface in Area 1
Use the appropriate mask such that ONLY Portland’s S0/0 and Amnani’s S0/1 could be in
Area 1.
Area 1 should not receive any external or inter-area routes (except the default route).

Ans

+ Configure Portland router as a stub:

Portland#configure terminal
Portland(config)#router ospf 1

Allow network 192.168.4.4/30 to join Area 1, notice that you have to convert subnet mask into
wildcard mask:

Portland(config-router)#network 192.168.4.4 0.0.0.3 area 1

Configure Portland as a stub:

Portland(config-router)#area 1 stub

Portland(config-router)#end
Portland#copy running-config startup-config

+ Configure Amani router as a “totally stub”:

Amani#configure terminal
Amani(config)#router ospf 1
Amani(config-router)#network 192.168.4.4 0.0.0.3 area 1

Make area 1 become a totally stubby area, notice that we can only use this command on ABR router:

Amani(config-router)#area 1 stub no-summary

Amani(config-router)#end
Amani#copy running-config startup-config

Question

Acme is a small export company that has an existing enterprise network that is running IPv6 OSPFv3.
Currently OSPF is configured on all routers. However, R4′s loopback address (FEC0:4:4) cannot be
seen in R1′s IPv6 routing table. You are tasked with identifying the cause of this fault and
implementing the needed corrective actions that uses OSPF features and does no change the current
area assignments. You will know that you have corrected the fault when R4′s loopback address
(FEC0:4:4) can be seen in the routing table of R1.
Special Note: To gain the maximum number of points you must remove all incorrect or unneeded
configuration statements related to this issue.

To troubleshoot the problem, first issue the show running-config on all of 4 routers. Pay more
attention to the outputs of routers R2 and R3

The output of the “show running-config” command of R2:

The output of the “show running-config” command of R3:

We knew that all areas in an Open Shortest Path First (OSPF) autonomous system must be physically
connected to the backbone area (Area 0). In some cases, where this is not possible,we can use a
virtual link to connect to the backbone through a non-backbone area. The area through which you
configure the virtual link is known as a transit area. In this case, the area 11 will become the transit
area. Therefore, routers R2 and R3 must be configured with the area
virtual-link command.

+ Configure virtual link on R2 (from the first output above, we learned that the OSPF process ID of R2
is 1):

R2>enable
R2#configure terminal
R2(config)#ipv6 router ospf 1
R2(config-rtr)#area 11 virtual-link 3.3.3.3

(Notice that we have to use neighbor router-id 3.3.3.3, not R2′s router-id 2.2.2.2)

+ Configure virtual link on R3 (from the second output above, we learned that the OSPF process ID of
R3 is 1 and we have to disable the wrong configuration of “area 54 virtual-link 4.4.4.4″):

R3>enable
R3#configure terminal
R3(config)#ipv6 router ospf 1
R3(config-rtr)#no area 54 virtual-link 4.4.4.4
R3(config-rtr)#area 11 virtual-link 2.2.2.2

We should check the configuration on R4:

R4>enable
R4#show running-config

You will see a wrongly configured virtual-link command. To get full mark we have to disable this
command:

R4#configure terminal
R4(config)#ipv6 router ospf 1
R4(config-rtr)#no area 54 virtual-link 3.3.3.3

After finishing the configuration don’t forget to ping between R1 and R4 to make sure they work well!

Now all the configuration was done. It is weird that we can’t ping the IPv6 loopback interface of R4
(with the ping or ping ipv6 command) but we can check by using the command show ipv6 route on
R1

The copying running-config startup-config command will not work but don’t worry, just skip it.

Notice: If you issue the command “show running-config” on R1, you will see these two lines:

passive-interface default
no passive-interface fa0/0 (fa0/0 is the interface connecting with R2)

These two lines make all the interfaces of R1 become passive interfaces except interface fa0/0. They
are correctly configured so don’t try to disable them.

You might also like

pFad - Phonifier reborn

Pfad - The Proxy pFad of © 2024 Garber Painting. All rights reserved.

Note: This service is not intended for secure transactions such as banking, social media, email, or purchasing. Use at your own risk. We assume no liability whatsoever for broken pages.


Alternative Proxies:

Alternative Proxy

pFad Proxy

pFad v3 Proxy

pFad v4 Proxy